]> granicus.if.org Git - zziplib/blob - zziplib.spec
reference to ogre3d
[zziplib] / zziplib.spec
1 %define lib   lib010
2 Summary:      ZZipLib - libZ-based ZIP-access Library
3 Name:         zziplib
4 Version:      0.13.53
5 Release:      1
6 License:      LGPL
7 Group:        Development/Libraries
8 URL:          http://zziplib.sf.net
9 Vendor:       Guido Draheim <guidod@gmx.de>
10 Source0:      http://prdownloads.sf.net/%{name}/%{name}-%{version}.tar.bz2
11 BuildRoot:    /var/tmp/%{name}-%{version}-%{release}
12
13 Distribution: Original
14 Packager:     Guido Draheim <guidod@gmx.de>
15 Requires:      zlib
16 BuildRequires: zlib-devel
17 BuildRequires: SDL-devel
18
19 #Begin3
20 # Author1:        too@iki.fi (Tomi Ollila)
21 # Author2:        guidod@gmx.de (Guido Draheim)
22 # Maintained-by:  guidod@gmx.de (Guido Draheim)
23 # Primary-Site:   zziplib.sf.net
24 # Keywords:       zip zlib inflate archive gamedata
25 # Platforms:      zlib posix
26 # Copying-Policy: Lesser GPL Version 2
27 #End
28
29 %package %lib
30 Summary:      ZZipLib - Documentation Files
31 Group:        Development/Libraries
32 Provides:     zziplib = %version
33 Provides:     libzzip0 = %version
34 Provides:     libzzip-0.so.10
35
36 %package doc
37 Summary:      ZZipLib - Documentation Files
38 Group:        Development/Libraries
39 BuildRequires: python
40 BuildRequires: xmlto
41
42 %package devel
43 Summary:      ZZipLib - Development Files
44 Group:        Development/Libraries
45 Requires:     zziplib-%lib = %version
46 # Requires: pkgconfig (not yet)
47
48 %package SDL_rwops-devel
49 Summary:      ZZipLib - Development Files for SDL_rwops
50 Group:        Development/Libraries
51 Requires:     zziplib-%lib = %version
52 Requires:     pkgconfig
53
54 %description
55  : zziplib provides read access to zipped files in a zip-archive,
56  : using compression based solely on free algorithms provided by zlib.
57
58 %description %lib
59  : zziplib provides read access to zipped files in a zip-archive,
60  : using compression based solely on free algorithms provided by zlib.
61  zziplib provides an additional API to transparently access files
62  being either real files or zipped files with the same filepath argument.
63  This is handy to package many files being shared data into a single
64  zip file - as it is sometimes used with gamedata or script repositories.
65  The library itself is fully multithreaded, and it is namespace clean
66  using the zzip_ prefix for its exports and declarations.
67
68 %description doc
69  : zziplib provides read access to zipped files in a zip-archive,
70  : using compression based solely on free algorithms provided by zlib.
71  these are the (html) docs, mostly generated actually.
72
73 %description devel
74  : zziplib provides read access to zipped files in a zip-archive,
75  : using compression based solely on free algorithms provided by zlib.
76  these are the header files needed to develop programs using zziplib.
77  there are test binaries to hint usage of the library in user programs.
78
79 %description SDL_rwops-devel
80  : zziplib provides read access to zipped files in a zip-archive,
81  : using compression based solely on free algorithms provided by zlib.
82  these are example headers and implementation along with a pkgconfig
83  script that allows to easily use zziplib through SDL_rwops calls.
84
85 %prep
86 #'
87 %setup
88 # fixing relink problems during install too
89 # LDFLAGS="-L%buildroot%_libdir" \
90 #
91
92 CFLAGS="$RPM_OPT_FLAGS" \
93 sh configure --prefix=%{_prefix} \
94              --with-docdir=%{_docdir} \
95              --mandir=%{_mandir} \
96              --bindir=%{_bindir} \
97              --libdir=%{_libdir} \
98              --enable-sdl  TIMEOUT=9
99 %__make zzip64-setup
100
101 %build
102 %__make %{?jobs:-j%jobs}
103 %__make check
104 %__make test-sdl
105 %__make %{?jobs:-j%jobs} zzip64-build
106 %__make %{?jobs:-j%jobs} doc
107
108 %install
109 %__rm -rf %{buildroot}
110 %__make zzip64-install DESTDIR=%{buildroot}
111 %__make install DESTDIR=%{buildroot}
112 %__make zzip32-postinstall DESTDIR=%{buildroot}
113 %__make zzip-postinstall
114 %__make install-doc DESTDIR=%{buildroot}
115 %__make install-mans DESTDIR=%{buildroot}
116 %__make install-sdl DESTDIR=%{buildroot}
117
118 %clean
119 %__rm -rf %{buildroot}
120
121 %files %lib
122       %defattr(-,root,root)
123       %{_libdir}/lib*.so.*
124
125 %post %lib
126 /sbin/ldconfig || true
127 %postun %lib
128 /sbin/ldconfig || true
129
130 %files doc
131       %defattr(-,root,root)
132       %{_datadir}/doc/*
133 %dir  %{_datadir}/omf/%{name}
134       %{_datadir}/omf/%{name}/*
135 %post doc
136 test ! -f %_bindir/scrollkeeper-update || %_bindir/scrollkeeper-update
137 %postun doc
138 test ! -f %_bindir/scrollkeeper-update || %_bindir/scrollkeeper-update
139
140 %files devel
141       %defattr(-,root,root)
142       %{_bindir}/*
143 %dir  %{_includedir}/zzip
144       %{_includedir}/zzip/*
145       %{_includedir}/*.h
146       %{_libdir}/lib*.so
147       %{_libdir}/lib*.a
148       %{_libdir}/lib*.la
149       %{_libdir}/pkgconfig/zzip*
150       %{_datadir}/aclocal/%{name}*.m4
151       %{_mandir}/man3/*
152
153 %files SDL_rwops-devel
154       %defattr(-,root,root)
155       %{_libdir}/pkgconfig/SDL*zzip*
156 %dir  %{_includedir}/SDL_rwops_zzip
157       %{_includedir}/SDL_rwops_zzip/*
158