]> granicus.if.org Git - sysstat/blob - sysstat-12.1.6.spec
sar/sadc: Add stable identifier support for disks statistics
[sysstat] / sysstat-12.1.6.spec
1 Summary:        SAR, SADF, MPSTAT, IOSTAT, TAPESTAT, PIDSTAT and CIFSIOSTAT for Linux
2 Name:           sysstat
3 Version:        12.1.6
4 Release:        1
5 License:        GPL
6 Group:          Applications/System
7 Source0:        %{name}-%{version}.tar.gz
8 URL:            http://pagesperso-orange.fr/sebastien.godard/
9 Packager:       Sebastien Godard <sysstat _at_ orange.fr>
10 BuildRoot:      %{_tmppath}/%{name}-%{version}-root-%(id -u -n)
11 Requires:       gettext
12
13 %description
14 The sysstat package contains the sar, sadf, mpstat, iostat, tapestat,
15 pidstat, cifsiostat and sa tools for Linux.
16 The sar command collects and reports system activity information.
17 The information collected by sar can be saved in a file in a binary
18 format for future inspection. The statistics reported by sar concern
19 I/O transfer rates, paging activity, process-related activities,
20 interrupts, network activity, memory and swap space utilization, CPU
21 utilization, kernel activities and TTY statistics, among others. Both
22 UP and SMP machines are fully supported.
23 The sadf command may  be used to display data collected by sar in
24 various formats (CSV, XML, etc.) and to draw graphs (SVG).
25 The iostat command reports CPU utilization and I/O statistics for disks.
26 The tapestat command reports statistics for tapes connected to the system.
27 The mpstat command reports global and per-processor statistics.
28 The pidstat command reports statistics for Linux tasks (processes).
29 The cifsiostat command reports I/O statistics for CIFS filesystems.
30
31 %define debug_package %{nil}
32
33 %prep
34 %setup
35
36 %build
37 # To include cron installation, add options --enable-install-cron and --enable-copy-only
38 ./configure --prefix=%{_prefix} \
39         --disable-file-attr \
40         sa_lib_dir=%{_libdir}/sa \
41         --mandir=%{_mandir} \
42         DESTDIR=$RPM_BUILD_ROOT
43 make
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT/var/log/sa
48
49 make install
50
51 mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
52 install -m 755  sysstat $RPM_BUILD_ROOT/etc/rc.d/init.d/sysstat
53 mkdir -p $RPM_BUILD_ROOT/etc/sysconfig
54 install -m 644 sysstat.sysconfig $RPM_BUILD_ROOT/etc/sysconfig/sysstat
55 install -m 644 sysstat.ioconf $RPM_BUILD_ROOT/etc/sysconfig/sysstat.ioconf
56 mkdir -p $RPM_BUILD_ROOT/etc/cron.d
57 install -m 644 cron/sysstat.crond.sample $RPM_BUILD_ROOT/etc/cron.d/sysstat
58 mkdir -p $RPM_BUILD_ROOT/etc/rc2.d
59 cd $RPM_BUILD_ROOT/etc/rc2.d && ln -sf ../init.d/sysstat S01sysstat
60 mkdir -p $RPM_BUILD_ROOT/etc/rc3.d
61 cd $RPM_BUILD_ROOT/etc/rc3.d && ln -sf ../init.d/sysstat S01sysstat
62 mkdir -p $RPM_BUILD_ROOT/etc/rc5.d
63 cd $RPM_BUILD_ROOT/etc/rc5.d && ln -sf ../init.d/sysstat S01sysstat
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc %{_datadir}/doc/sysstat-%{version}/*
71 %attr(755,root,root) %{_bindir}/*
72 %attr(755,root,root) %{_libdir}/sa/*
73 %attr(644,root,root) %{_mandir}/man*/*
74 %attr(644,root,root) %{_datadir}/locale/*/LC_MESSAGES/sysstat.mo
75 %attr(755,root,root) %dir /var/log/sa
76 %attr(755,root,root) /etc/rc.d/init.d/sysstat
77 %attr(644,root,root) /etc/sysconfig/sysstat
78 %attr(644,root,root) /etc/sysconfig/sysstat.ioconf
79 /etc/rc2.d/S01sysstat
80 /etc/rc3.d/S01sysstat
81 /etc/rc5.d/S01sysstat
82 %config(noreplace) %attr(0644,root,root) /etc/cron.d/sysstat
83