]> granicus.if.org Git - strace/blob - strace.spec
2007-01-11 Roland McGrath <roland@redhat.com>
[strace] / strace.spec
1 Summary: Tracks and displays system calls associated with a running process.
2 Name: strace
3 Version: 4.5.15
4 Release: 1%{?dist}
5 License: BSD
6 Group: Development/Debuggers
7 URL: http://sourceforge.net/projects/strace/
8 Source0: http://dl.sourceforge.net/strace/%{name}-%{version}.tar.bz2
9 BuildRoot: %{_tmppath}/%{name}-root
10
11 %define strace64_arches ppc64
12
13 %description
14 The strace program intercepts and records the system calls called and
15 received by a running process.  Strace can print a record of each
16 system call, its arguments and its return value.  Strace is useful for
17 diagnosing problems and debugging, as well as for instructional
18 purposes.
19
20 Install strace if you need a tool to track the system calls made and
21 received by a process.
22
23 %ifarch %{strace64_arches}
24 %package -n strace64
25 Summary: Tracks and displays system calls associated with a running process.
26 Group: Development/Debuggers
27
28 %description -n strace64
29 The strace program intercepts and records the system calls called and
30 received by a running process.  Strace can print a record of each
31 system call, its arguments and its return value.  Strace is useful for
32 diagnosing problems and debugging, as well as for instructional
33 purposes.
34
35 Install strace if you need a tool to track the system calls made and
36 received by a process.
37
38 This package provides the `strace64' program to trace 64-bit processes.
39 The `strace' program in the `strace' package is for 32-bit processes.
40 %endif
41
42 %prep
43 %setup -q
44
45 %build
46 %configure
47 make
48
49 %install
50 rm -rf %{buildroot}
51 mkdir -p %{buildroot}%{_mandir}/man1
52 mkdir -p %{buildroot}%{_bindir}
53 %makeinstall man1dir=%{buildroot}%{_mandir}/man1
54
55 # remove unpackaged files from the buildroot
56 rm -f %{buildroot}%{_bindir}/strace-graph
57
58 %ifarch %{strace64_arches}
59 ln %{buildroot}%{_bindir}/strace %{buildroot}%{_bindir}/strace64
60 %endif
61
62 %clean
63 rm -rf %{buildroot}
64
65 %files
66 %defattr(-,root,root)
67 %{_bindir}/strace
68 %{_mandir}/man1/*
69
70 %ifarch %{strace64_arches}
71 %files -n strace64
72 %defattr(-,root,root)
73 %{_bindir}/strace64
74 %endif
75
76
77 %changelog
78 * Thu Jan 11 2007 Roland McGrath <roland@redhat.com> - 4.5.15-1
79 - biarch fixes (#179740, #192193, #171626, #173050, #218433, #218043)
80 - fix -ff -o behavior (#204950, #218435, #193808, #219423)
81 - better quotactl printing (#118696)
82 - *at, inotify*, pselect6, ppoll and unshare syscalls (#178633, #191275)
83 - glibc-2.5 build fixes (#209856)
84 - memory corruption fixes (#200621
85 - fix race in child setup under -f (#180293)
86 - show ipc key values in hex (#198179, #192182)
87 - disallow -c with -ff (#187847)
88 - Resolves: RHBZ #179740, RHBZ #192193, RHBZ #204950, RHBZ #218435
89 - Resolves: RHBZ #193808, RHBZ #219423, RHBZ #171626, RHBZ #173050
90 - Resolves: RHBZ #218433, RHBZ #218043, RHBZ #118696, RHBZ #178633
91 - Resolves: RHBZ #191275, RHBZ #209856, RHBZ #200621, RHBZ #180293
92 - Resolves: RHBZ #198179, RHBZ #198182, RHBZ #187847
93
94 * Mon Nov 20 2006 Jakub Jelinek <jakub@redhat.com> - 4.5.14-4
95 - Fix ia64 syscall decoding (#206768)
96 - Fix build with glibc-2.4.90-33 and up on all arches but ia64
97 - Fix build against 2.6.18+ headers
98
99 * Tue Aug 22 2006 Roland McGrath <roland@redhat.com> - 4.5.14-3
100 - Fix bogus decoding of syscalls >= 300 (#201462, #202620).
101
102 * Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-2
103 - rebuild
104
105 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.2
106 - bump again for long double bug on ppc{,64}
107
108 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.1
109 - rebuilt for new gcc4.1 snapshot and glibc changes
110
111 * Mon Jan 16 2006 Roland McGrath <roland@redhat.com> - 4.5.14-1
112 - Fix biarch decoding of socket syscalls (#174354).
113 - Fix biarch -e support (#173986).
114 - Accept numeric syscalls in -e (#174798).
115 - Fix ipc syscall decoding (#164755).
116 - Improve msgrcv printing (#164757).
117 - Man page updates (#165375).
118 - Improve mount syscall printing (#165377).
119 - Correct printing of restarting syscalls (#165469).
120
121 * Wed Aug  3 2005 Roland McGrath <roland@redhat.com> - 4.5.13-1
122 - Fix setsockopt decoding on 64-bit (#162449).
123 - Fix typos in socket option name strings (#161578).
124 - Display more IPV6 socket options by name (#162450).
125 - Don't display inappropriate syscalls for -e trace=file (#159340).
126 - New selector type -e trace=desc for file-descriptor using calls (#159400).
127 - Fix 32-bit old_mmap syscall decoding on x86-64 (#162467, #164215).
128 - Fix errors detaching from multithreaded process on interrupt (#161919).
129 - Note 4.5.12 fix for crash handling bad signal numbers (#162739).
130
131 * Wed Jun  8 2005 Roland McGrath <roland@redhat.com> - 4.5.12-1
132 - Fix known syscall recognition for IA32 processes on x86-64 (#158934).
133 - Fix bad output for ptrace on x86-64 (#159787).
134 - Fix potential buffer overruns (#151570, #159196).
135 - Make some diagnostics more consistent (#159308).
136 - Update PowerPC system calls.
137 - Better printing for Linux aio system calls.
138 - Don't truncate statfs64 fields to 32 bits in output (#158243).
139 - Cosmetic code cleanups (#159688).
140
141 * Tue Mar 22 2005 Roland McGrath <roland@redhat.com> - 4.5.11-1
142 - Build tweaks.
143 - Note 4.5.10 select fix (#151570).
144
145 * Mon Mar 14 2005 Roland McGrath <roland@redhat.com> - 4.5.10-1
146 - Fix select handling on nonstandard fd_set sizes.
147 - Don't print errors for null file name pointers.
148 - Fix initial execve output with -i (#143365).
149
150 * Fri Feb  4 2005 Roland McGrath <roland@redhat.com> - 4.5.9-2
151 - update ia64 syscall list (#146245)
152 - fix x86_64 syscall argument extraction for 32-bit processes (#146093)
153 - fix -e signal=NAME parsing (#143362)
154 - fix x86_64 exit_group syscall handling
155 - improve socket ioctl printing (#138223)
156 - code cleanups (#143369, #143370)
157 - improve mount flags printing (#141932)
158 - support symbolic printing of x86_64 arch_prctl parameters (#142667)
159 - fix potential crash in getxattr printing
160
161 * Tue Oct 19 2004 Roland McGrath <roland@redhat.com> - 4.5.8-1
162 - fix multithreaded exit handling (#132150, #135254)
163 - fix ioctl name matching (#129808)
164 - print RTC_* ioctl structure contents (#58606)
165 - grok epoll_* syscalls (#134463)
166 - grok new RLIMIT_* values (#133594)
167 - print struct cmsghdr contents for sendmsg (#131689)
168 - fix clock_* and timer_* argument output (#131420)
169
170 * Tue Aug 31 2004 Roland McGrath <roland@redhat.com> - 4.5.7-2
171 - new upstream version, misc fixes and updates (#128091, #129166, #128391, #129378, #130965, #131177)
172
173 * Mon Jul 12 2004 Roland McGrath <roland@redhat.com> 4.5.6-1
174 - new upstream version, updates ioctl lists (#127398), fixes quotactl (#127393), more ioctl decoding (#126917)
175
176 * Sun Jun 27 2004 Roland McGrath <roland@redhat.com> 4.5.5-1
177 - new upstream version, fixes x86-64 biarch support (#126547)
178
179 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> 4.5.4-2
180 - rebuilt
181
182 * Thu Jun  3 2004 Roland McGrath <roland@redhat.com> 4.5.4-0.FC1
183 - rebuilt for FC1 update
184
185 * Thu Jun  3 2004 Roland McGrath <roland@redhat.com> 4.5.4-1
186 - new upstream version, more ioctls (#122257), minor fixes
187
188 * Fri Apr 16 2004 Roland McGrath <roland@redhat.com> 4.5.3-1
189 - new upstream version, mq_* calls (#120701), -p vs NPTL (#120462), more fixes (#118694, #120541, #118685)
190
191 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 4.5.2-1.1
192 - rebuilt
193
194 * Mon Mar  1 2004 Roland McGrath <roland@redhat.com> 4.5.2-1
195 - new upstream version, sched_* calls (#116990), show core flag (#112117)
196
197 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
198 - rebuilt
199
200 * Thu Nov 13 2003 Roland McGrath <roland@redhat.com> 4.5.1-1
201 - new upstream version, more fixes (#108012, #105366, #105359, #105358)
202
203 * Tue Sep 30 2003 Roland McGrath <roland@redhat.com> 4.5-3
204 - revert bogus s390 fix
205
206 * Thu Sep 25 2003 Roland McGrath <roland@redhat.com> 4.5-1.2.1AS
207 - rebuilt for 2.1AS erratum
208
209 * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-2
210 - rebuilt
211
212 * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-1
213 - new upstream version, more fixes (#101499, #104365)
214
215 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-2
216 - rebuilt
217
218 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-1
219 - new upstream version, groks more new system calls, PF_INET6 sockets
220
221 * Mon Jun 10 2003 Roland McGrath <roland@redhat.com> 4.4.98-1
222 - new upstream version, more fixes (#90754, #91085)
223
224 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
225 - rebuilt
226
227 * Sun Mar 30 2003 Roland McGrath <roland@redhat.com> 4.4.96-1
228 - new upstream version, handles yet more 2.5 syscalls, x86_64 & ia64 fixes
229
230 * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com> 4.4.95-2
231 - rebuilt
232
233 * Mon Feb 24 2003 Roland McGrath <roland@redhat.com> 4.4.95-1
234 - new upstream version, fixed getresuid/getresgid (#84959)
235
236 * Wed Feb 19 2003 Roland McGrath <roland@redhat.com> 4.4.94-1
237 - new upstream version, new option -E to set environment variables (#82392)
238
239 * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.4.93-2
240 - rebuilt
241
242 * Tue Jan 21 2003 Roland McGrath <roland@redhat.com> 4.4.93-1
243 - new upstream version, fixes ppc and s390 bugs, adds missing ptrace requests
244
245 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.91-1
246 - new upstream version, fixes -f on x86-64
247
248 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.90-1
249 - new upstream version, fixes all known bugs modulo ia64 and s390 issues
250
251 * Fri Jan 03 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.4-11
252 - add further s390 patch from IBM
253
254 * Wed Nov 27 2002 Tim Powers <timp@redhat.com> 4.4-10
255 - remove unpackaged files from the buildroot
256
257 * Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.4-9.1
258 - Added latest s390(x) patch.
259
260 * Fri Sep 06 2002 Karsten Hopp <karsten@redhat.de> 4.4-9
261 - preliminary x86_64 support with an ugly patch to help
262   debugging. Needs cleanup!
263
264 * Mon Sep  2 2002 Jakub Jelinek <jakub@redhat.com> 4.4-8
265 - newer version of the clone fixing patch (Roland McGrath)
266 - aio syscalls for i386/ia64/ppc (Ben LaHaise)
267
268 * Wed Aug 28 2002 Jakub Jelinek <jakub@redhat.com> 4.4-7
269 - fix strace -f (Roland McGrath, #68994)
270 - handle ?et_thread_area, SA_RESTORER (Ulrich Drepper)
271
272 * Fri Jun 21 2002 Jakub Jelinek <jakub@redhat.com> 4.4-6
273 - handle futexes, *xattr, sendfile64, etc. (Ulrich Drepper)
274 - handle modify_ldt (#66894)
275
276 * Thu May 23 2002 Tim Powers <timp@redhat.com>
277 - automated rebuild
278
279 * Tue Apr 16 2002 Jakub Jelinek <jakub@redhat.com> 4.4-4
280 - fix for the last patch by Jeff Law (#62591)
281
282 * Mon Mar  4 2002 Preston Brown <pbrown@redhat.com> 4.4-3
283 - integrate patch from Jeff Law to eliminate hang tracing threads
284
285 * Sat Feb 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
286 - minor update from debian tar-ball
287
288 * Wed Jan 02 2002 Florian La Roche <Florian.LaRoche@redhat.de>
289 - update to 4.4
290
291 * Sun Jul 22 2001 Florian La Roche <Florian.LaRoche@redhat.de>
292 - disable s390 patches, they are already included
293
294 * Wed Jul 18 2001 Preston Brown <pbrown@redhat.com> 4.3-1
295 - new upstream version.  Seems to have integrated most new syscalls
296 - tracing threaded programs is now functional.
297
298 * Mon Jun 11 2001 Than Ngo <than@redhat.com>
299 - port s390 patches from IBM
300
301 * Wed May 16 2001 Nalin Dahyabhai <nalin@redhat.com>
302 - modify new syscall patch to allocate enough heap space in setgroups32()
303
304 * Wed Feb 14 2001 Jakub Jelinek <jakub@redhat.com>
305 - #include <time.h> in addition to <sys/time.h>
306
307 * Fri Jan 26 2001 Karsten Hopp <karsten@redhat.com>
308 - clean up conflicting patches. This happened only
309   when building on S390
310
311 * Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
312 - update to CVS, reintegrate ia64 support
313
314 * Sat Dec  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
315 - Get S/390 support into the normal package
316
317 * Sat Nov 18 2000 Florian La Roche <Florian.LaRoche@redhat.de>
318 - added S/390 patch from IBM, adapting it to not conflict with
319   IA64 patch
320
321 * Sat Aug 19 2000 Jakub Jelinek <jakub@redhat.com>
322 - doh, actually apply the 2.4 syscalls patch
323 - make it compile with 2.4.0-test7-pre4+ headers, add
324   getdents64 and fcntl64
325
326 * Thu Aug  3 2000 Jakub Jelinek <jakub@redhat.com>
327 - add a bunch of new 2.4 syscalls (#14036)
328
329 * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
330 - automatic rebuild
331 - excludearch ia64
332
333 * Fri Jun  2 2000 Matt Wilson <msw@redhat.com>
334 - use buildinstall for FHS
335
336 * Wed May 24 2000 Jakub Jelinek <jakub@redhat.com>
337 - make things compile on sparc
338 - fix sigreturn on sparc
339
340 * Fri Mar 31 2000 Bill Nottingham <notting@redhat.com>
341 - fix stat64 misdef (#10485)
342
343 * Tue Mar 21 2000 Michael K. Johnson <johnsonm@redhat.com>
344 - added ia64 patch
345
346 * Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
347 - man pages are compressed
348 - version 4.2 (why are we keeping all these patches around?)
349
350 * Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
351 - update to 4.1 (with sparc socketcall patch).
352
353 * Fri Nov 12 1999 Jakub Jelinek <jakub@redhat.com>
354 - fix socketcall on sparc.
355
356 * Thu Sep 02 1999 Cristian Gafton <gafton@redhat.com>
357 - fix KERN_SECURELVL compile problem
358
359 * Tue Aug 31 1999 Cristian Gafton <gafton@redhat.com>
360 - added alpha patch from HJLu to fix the osf_sigprocmask interpretation
361
362 * Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
363 - update to 3.99.1.
364
365 * Wed Jun  2 1999 Jeff Johnson <jbj@redhat.com>
366 - add (the other :-) jj's sparc patch.
367
368 * Wed May 26 1999 Jeff Johnson <jbj@redhat.com>
369 - upgrade to 3.99 in order to
370 -    add new 2.2.x open flags (#2955).
371 -    add new 2.2.x syscalls (#2866).
372 - strace 3.1 patches carried along for now.
373
374 * Sun May 16 1999 Jeff Johnson <jbj@redhat.com>
375 - don't rely on (broken!) rpm %patch (#2735)
376
377 * Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
378 - strip binary
379
380 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
381 - auto rebuild in the new build environment (release 16)
382
383 * Tue Feb  9 1999 Jeff Johnson <jbj@redhat.com>
384 - vfork est arrive!
385
386 * Tue Feb  9 1999 Christopher Blizzard <blizzard@redhat.com>
387 - Add patch to follow clone() syscalls, too.
388
389 * Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
390 - patch to build alpha/sparc with glibc 2.1.
391
392 * Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
393 - patch to build on ARM
394
395 * Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
396 - fix typo (printf, not tprintf).
397
398 * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
399 - fix compile problem on sparc.
400
401 * Tue Aug 18 1998 Cristian Gafton <gafton@redhat.com>
402 - buildroot
403
404 * Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
405 - added the umoven patch from James Youngman <jay@gnu.org>
406 - fixed build problems on newer glibc releases
407
408 * Mon Jun 08 1998 Prospector System <bugs@redhat.com>
409 - translations modified for de, fr, tr