]> granicus.if.org Git - strace/blob - strace.spec
2004-08-31 Roland McGrath <roland@redhat.com>
[strace] / strace.spec
1 Summary: Tracks and displays system calls associated with a running process.
2 Name: strace
3 Version: 4.5.7
4 Release: 2
5 License: BSD
6 Group: Development/Debuggers
7 URL: http://sourceforge.net/projects/strace/
8 Source0: %{name}-%{version}.tar.bz2
9 BuildRoot: %{_tmppath}/%{name}-root
10
11 %define strace64_arches ppc64
12
13 %description
14 The strace program intercepts and records the system calls called and
15 received by a running process.  Strace can print a record of each
16 system call, its arguments and its return value.  Strace is useful for
17 diagnosing problems and debugging, as well as for instructional
18 purposes.
19
20 Install strace if you need a tool to track the system calls made and
21 received by a process.
22
23 %ifarch %{strace64_arches}
24 %package -n strace64
25 Summary: Tracks and displays system calls associated with a running process.
26 Group: Development/Debuggers
27
28 %description -n strace64
29 The strace program intercepts and records the system calls called and
30 received by a running process.  Strace can print a record of each
31 system call, its arguments and its return value.  Strace is useful for
32 diagnosing problems and debugging, as well as for instructional
33 purposes.
34
35 Install strace if you need a tool to track the system calls made and
36 received by a process.
37
38 This package provides the `strace64' program to trace 64-bit processes.
39 The `strace' program in the `strace' package is for 32-bit processes.
40 %endif
41
42 %prep
43 %setup -q
44
45 %build
46 %configure
47 make
48
49 %install
50 rm -rf %{buildroot}
51 mkdir -p %{buildroot}%{_mandir}/man1
52 mkdir -p %{buildroot}%{_bindir}
53 %makeinstall man1dir=%{buildroot}%{_mandir}/man1
54
55 # remove unpackaged files from the buildroot
56 rm -f %{buildroot}%{_bindir}/strace-graph
57
58 %ifarch %{strace64_arches}
59 ln %{buildroot}%{_bindir}/strace %{buildroot}%{_bindir}/strace64
60 %endif
61
62 %clean
63 rm -rf %{buildroot}
64
65 %files
66 %defattr(-,root,root)
67 %{_bindir}/strace
68 %{_mandir}/man1/*
69
70 %ifarch %{strace64_arches}
71 %files -n strace64
72 %defattr(-,root,root)
73 %{_bindir}/strace64
74 %endif
75
76
77 %changelog
78 * Tue Aug 31 2004 Roland McGrath <roland@redhat.com> - 4.5.7-2
79 - new upstream version, misc fixes and updates (#128091, #129166, #128391, #129378, #130965, #131177)
80
81 * Mon Jul 12 2004 Roland McGrath <roland@redhat.com> 4.5.6-1
82 - new upstream version, updates ioctl lists (#127398), fixes quotactl (#127393), more ioctl decoding (#126917)
83
84 * Sun Jun 27 2004 Roland McGrath <roland@redhat.com> 4.5.5-1
85 - new upstream version, fixes x86-64 biarch support (#126547)
86
87 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> 4.5.4-2
88 - rebuilt
89
90 * Thu Jun  3 2004 Roland McGrath <roland@redhat.com> 4.5.4-0.FC1
91 - rebuilt for FC1 update
92
93 * Thu Jun  3 2004 Roland McGrath <roland@redhat.com> 4.5.4-1
94 - new upstream version, more ioctls (#122257), minor fixes
95
96 * Fri Apr 16 2004 Roland McGrath <roland@redhat.com> 4.5.3-1
97 - new upstream version, mq_* calls (#120701), -p vs NPTL (#120462), more fixes (#118694, #120541, #118685)
98
99 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 4.5.2-1.1
100 - rebuilt
101
102 * Mon Mar  1 2004 Roland McGrath <roland@redhat.com> 4.5.2-1
103 - new upstream version, sched_* calls (#116990), show core flag (#112117)
104
105 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
106 - rebuilt
107
108 * Thu Nov 13 2003 Roland McGrath <roland@redhat.com> 4.5.1-1
109 - new upstream version, more fixes (#108012, #105366, #105359, #105358)
110
111 * Tue Sep 30 2003 Roland McGrath <roland@redhat.com> 4.5-3
112 - revert bogus s390 fix
113
114 * Thu Sep 25 2003 Roland McGrath <roland@redhat.com> 4.5-1.2.1AS
115 - rebuilt for 2.1AS erratum
116
117 * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-2
118 - rebuilt
119
120 * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-1
121 - new upstream version, more fixes (#101499, #104365)
122
123 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-2
124 - rebuilt
125
126 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-1
127 - new upstream version, groks more new system calls, PF_INET6 sockets
128
129 * Mon Jun 10 2003 Roland McGrath <roland@redhat.com> 4.4.98-1
130 - new upstream version, more fixes (#90754, #91085)
131
132 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
133 - rebuilt
134
135 * Sun Mar 30 2003 Roland McGrath <roland@redhat.com> 4.4.96-1
136 - new upstream version, handles yet more 2.5 syscalls, x86_64 & ia64 fixes
137
138 * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com> 4.4.95-2
139 - rebuilt
140
141 * Mon Feb 24 2003 Roland McGrath <roland@redhat.com> 4.4.95-1
142 - new upstream version, fixed getresuid/getresgid (#84959)
143
144 * Wed Feb 19 2003 Roland McGrath <roland@redhat.com> 4.4.94-1
145 - new upstream version, new option -E to set environment variables (#82392)
146
147 * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.4.93-2
148 - rebuilt
149
150 * Tue Jan 21 2003 Roland McGrath <roland@redhat.com> 4.4.93-1
151 - new upstream version, fixes ppc and s390 bugs, adds missing ptrace requests
152
153 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.91-1
154 - new upstream version, fixes -f on x86-64
155
156 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.90-1
157 - new upstream version, fixes all known bugs modulo ia64 and s390 issues
158
159 * Fri Jan 03 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.4-11
160 - add further s390 patch from IBM
161
162 * Wed Nov 27 2002 Tim Powers <timp@redhat.com> 4.4-10
163 - remove unpackaged files from the buildroot
164
165 * Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.4-9.1
166 - Added latest s390(x) patch.
167
168 * Fri Sep 06 2002 Karsten Hopp <karsten@redhat.de> 4.4-9
169 - preliminary x86_64 support with an ugly patch to help
170   debugging. Needs cleanup!
171
172 * Mon Sep  2 2002 Jakub Jelinek <jakub@redhat.com> 4.4-8
173 - newer version of the clone fixing patch (Roland McGrath)
174 - aio syscalls for i386/ia64/ppc (Ben LaHaise)
175
176 * Wed Aug 28 2002 Jakub Jelinek <jakub@redhat.com> 4.4-7
177 - fix strace -f (Roland McGrath, #68994)
178 - handle ?et_thread_area, SA_RESTORER (Ulrich Drepper)
179
180 * Fri Jun 21 2002 Jakub Jelinek <jakub@redhat.com> 4.4-6
181 - handle futexes, *xattr, sendfile64, etc. (Ulrich Drepper)
182 - handle modify_ldt (#66894)
183
184 * Thu May 23 2002 Tim Powers <timp@redhat.com>
185 - automated rebuild
186
187 * Tue Apr 16 2002 Jakub Jelinek <jakub@redhat.com> 4.4-4
188 - fix for the last patch by Jeff Law (#62591)
189
190 * Mon Mar  4 2002 Preston Brown <pbrown@redhat.com> 4.4-3
191 - integrate patch from Jeff Law to eliminate hang tracing threads
192
193 * Sat Feb 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
194 - minor update from debian tar-ball
195
196 * Wed Jan 02 2002 Florian La Roche <Florian.LaRoche@redhat.de>
197 - update to 4.4
198
199 * Sun Jul 22 2001 Florian La Roche <Florian.LaRoche@redhat.de>
200 - disable s390 patches, they are already included
201
202 * Wed Jul 18 2001 Preston Brown <pbrown@redhat.com> 4.3-1
203 - new upstream version.  Seems to have integrated most new syscalls
204 - tracing threaded programs is now functional.
205
206 * Mon Jun 11 2001 Than Ngo <than@redhat.com>
207 - port s390 patches from IBM
208
209 * Wed May 16 2001 Nalin Dahyabhai <nalin@redhat.com>
210 - modify new syscall patch to allocate enough heap space in setgroups32()
211
212 * Wed Feb 14 2001 Jakub Jelinek <jakub@redhat.com>
213 - #include <time.h> in addition to <sys/time.h>
214
215 * Fri Jan 26 2001 Karsten Hopp <karsten@redhat.com>
216 - clean up conflicting patches. This happened only
217   when building on S390
218
219 * Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
220 - update to CVS, reintegrate ia64 support
221
222 * Sat Dec  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
223 - Get S/390 support into the normal package
224
225 * Sat Nov 18 2000 Florian La Roche <Florian.LaRoche@redhat.de>
226 - added S/390 patch from IBM, adapting it to not conflict with
227   IA64 patch
228
229 * Sat Aug 19 2000 Jakub Jelinek <jakub@redhat.com>
230 - doh, actually apply the 2.4 syscalls patch
231 - make it compile with 2.4.0-test7-pre4+ headers, add
232   getdents64 and fcntl64
233
234 * Thu Aug  3 2000 Jakub Jelinek <jakub@redhat.com>
235 - add a bunch of new 2.4 syscalls (#14036)
236
237 * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
238 - automatic rebuild
239 - excludearch ia64
240
241 * Fri Jun  2 2000 Matt Wilson <msw@redhat.com>
242 - use buildinstall for FHS
243
244 * Wed May 24 2000 Jakub Jelinek <jakub@redhat.com>
245 - make things compile on sparc
246 - fix sigreturn on sparc
247
248 * Fri Mar 31 2000 Bill Nottingham <notting@redhat.com>
249 - fix stat64 misdef (#10485)
250
251 * Tue Mar 21 2000 Michael K. Johnson <johnsonm@redhat.com>
252 - added ia64 patch
253
254 * Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
255 - man pages are compressed
256 - version 4.2 (why are we keeping all these patches around?)
257
258 * Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
259 - update to 4.1 (with sparc socketcall patch).
260
261 * Fri Nov 12 1999 Jakub Jelinek <jakub@redhat.com>
262 - fix socketcall on sparc.
263
264 * Thu Sep 02 1999 Cristian Gafton <gafton@redhat.com>
265 - fix KERN_SECURELVL compile problem
266
267 * Tue Aug 31 1999 Cristian Gafton <gafton@redhat.com>
268 - added alpha patch from HJLu to fix the osf_sigprocmask interpretation
269
270 * Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
271 - update to 3.99.1.
272
273 * Wed Jun  2 1999 Jeff Johnson <jbj@redhat.com>
274 - add (the other :-) jj's sparc patch.
275
276 * Wed May 26 1999 Jeff Johnson <jbj@redhat.com>
277 - upgrade to 3.99 in order to
278 -    add new 2.2.x open flags (#2955).
279 -    add new 2.2.x syscalls (#2866).
280 - strace 3.1 patches carried along for now.
281
282 * Sun May 16 1999 Jeff Johnson <jbj@redhat.com>
283 - don't rely on (broken!) rpm %patch (#2735)
284
285 * Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
286 - strip binary
287
288 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
289 - auto rebuild in the new build environment (release 16)
290
291 * Tue Feb  9 1999 Jeff Johnson <jbj@redhat.com>
292 - vfork est arrive!
293
294 * Tue Feb  9 1999 Christopher Blizzard <blizzard@redhat.com>
295 - Add patch to follow clone() syscalls, too.
296
297 * Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
298 - patch to build alpha/sparc with glibc 2.1.
299
300 * Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
301 - patch to build on ARM
302
303 * Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
304 - fix typo (printf, not tprintf).
305
306 * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
307 - fix compile problem on sparc.
308
309 * Tue Aug 18 1998 Cristian Gafton <gafton@redhat.com>
310 - buildroot
311
312 * Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
313 - added the umoven patch from James Youngman <jay@gnu.org>
314 - fixed build problems on newer glibc releases
315
316 * Mon Jun 08 1998 Prospector System <bugs@redhat.com>
317 - translations modified for de, fr, tr