]> granicus.if.org Git - strace/blob - strace.spec
add log entry!
[strace] / strace.spec
1 Summary: Tracks and displays system calls associated with a running process.
2 Name: strace
3 Version: 4.5
4 Release: 1
5 License: BSD
6 Group: Development/Debuggers
7 URL: http://sourceforge.net/projects/strace/
8 Source0: %{name}-%{version}.tar.bz2
9 BuildRoot: %{_tmppath}/%{name}-root
10
11 %define strace64_arches ppc64
12
13 %description
14 The strace program intercepts and records the system calls called and
15 received by a running process.  Strace can print a record of each
16 system call, its arguments and its return value.  Strace is useful for
17 diagnosing problems and debugging, as well as for instructional
18 purposes.
19
20 Install strace if you need a tool to track the system calls made and
21 received by a process.
22
23 %ifarch %{strace64_arches}
24 %package -n strace64
25 Summary: Tracks and displays system calls associated with a running process.
26 Group: Development/Debuggers
27
28 %description -n strace64
29 The strace program intercepts and records the system calls called and
30 received by a running process.  Strace can print a record of each
31 system call, its arguments and its return value.  Strace is useful for
32 diagnosing problems and debugging, as well as for instructional
33 purposes.
34
35 Install strace if you need a tool to track the system calls made and
36 received by a process.
37
38 This package provides the `strace64' program to trace 64-bit processes.
39 The `strace' program in the `strace' package is for 32-bit processes.
40 %endif
41
42 %prep
43 %setup -q
44
45 %build
46 %configure
47 make
48
49 %install
50 rm -rf %{buildroot}
51 mkdir -p %{buildroot}%{_mandir}/man1
52 mkdir -p %{buildroot}%{_bindir}
53 %makeinstall man1dir=%{buildroot}%{_mandir}/man1
54
55 # remove unpackaged files from the buildroot
56 rm -f %{buildroot}%{_bindir}/strace-graph
57
58 %ifarch %{strace64_arches}
59 ln %{buildroot}%{_bindir}/strace %{buildroot}%{_bindir}/strace64
60 %endif
61
62 %clean
63 rm -rf %{buildroot}
64
65 %files
66 %defattr(-,root,root)
67 %{_bindir}/strace
68 %{_mandir}/man1/*
69
70 %ifarch %{strace64_arches}
71 %files -n strace64
72 %defattr(-,root,root)
73 %{_bindir}/strace64
74 %endif
75
76
77 %changelog
78 * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-1
79 - new upstream version, more fixes (#101499, #104365)
80
81 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-2
82 - rebuilt
83
84 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-1
85 - new upstream version, groks more new system calls, PF_INET6 sockets
86
87 * Mon Jun 10 2003 Roland McGrath <roland@redhat.com> 4.4.98-1
88 - new upstream version, more fixes (#90754, #91085)
89
90 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
91 - rebuilt
92
93 * Sun Mar 30 2003 Roland McGrath <roland@redhat.com> 4.4.96-1
94 - new upstream version, handles yet more 2.5 syscalls, x86_64 & ia64 fixes
95
96 * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com> 4.4.95-2
97 - rebuilt
98
99 * Mon Feb 24 2003 Roland McGrath <roland@redhat.com> 4.4.95-1
100 - new upstream version, fixed getresuid/getresgid (#84959)
101
102 * Wed Feb 19 2003 Roland McGrath <roland@redhat.com> 4.4.94-1
103 - new upstream version, new option -E to set environment variables (#82392)
104
105 * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.4.93-2
106 - rebuilt
107
108 * Tue Jan 21 2003 Roland McGrath <roland@redhat.com> 4.4.93-1
109 - new upstream version, fixes ppc and s390 bugs, adds missing ptrace requests
110
111 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.91-1
112 - new upstream version, fixes -f on x86-64
113
114 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.90-1
115 - new upstream version, fixes all known bugs modulo ia64 and s390 issues
116
117 * Fri Jan 03 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.4-11
118 - add further s390 patch from IBM
119
120 * Wed Nov 27 2002 Tim Powers <timp@redhat.com> 4.4-10
121 - remove unpackaged files from the buildroot
122
123 * Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.4-9.1
124 - Added latest s390(x) patch.
125
126 * Fri Sep 06 2002 Karsten Hopp <karsten@redhat.de> 4.4-9
127 - preliminary x86_64 support with an ugly patch to help
128   debugging. Needs cleanup!
129
130 * Mon Sep  2 2002 Jakub Jelinek <jakub@redhat.com> 4.4-8
131 - newer version of the clone fixing patch (Roland McGrath)
132 - aio syscalls for i386/ia64/ppc (Ben LaHaise)
133
134 * Wed Aug 28 2002 Jakub Jelinek <jakub@redhat.com> 4.4-7
135 - fix strace -f (Roland McGrath, #68994)
136 - handle ?et_thread_area, SA_RESTORER (Ulrich Drepper)
137
138 * Fri Jun 21 2002 Jakub Jelinek <jakub@redhat.com> 4.4-6
139 - handle futexes, *xattr, sendfile64, etc. (Ulrich Drepper)
140 - handle modify_ldt (#66894)
141
142 * Thu May 23 2002 Tim Powers <timp@redhat.com>
143 - automated rebuild
144
145 * Tue Apr 16 2002 Jakub Jelinek <jakub@redhat.com> 4.4-4
146 - fix for the last patch by Jeff Law (#62591)
147
148 * Mon Mar  4 2002 Preston Brown <pbrown@redhat.com> 4.4-3
149 - integrate patch from Jeff Law to eliminate hang tracing threads
150
151 * Sat Feb 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
152 - minor update from debian tar-ball
153
154 * Wed Jan 02 2002 Florian La Roche <Florian.LaRoche@redhat.de>
155 - update to 4.4
156
157 * Sun Jul 22 2001 Florian La Roche <Florian.LaRoche@redhat.de>
158 - disable s390 patches, they are already included
159
160 * Wed Jul 18 2001 Preston Brown <pbrown@redhat.com> 4.3-1
161 - new upstream version.  Seems to have integrated most new syscalls
162 - tracing threaded programs is now functional.
163
164 * Mon Jun 11 2001 Than Ngo <than@redhat.com>
165 - port s390 patches from IBM
166
167 * Wed May 16 2001 Nalin Dahyabhai <nalin@redhat.com>
168 - modify new syscall patch to allocate enough heap space in setgroups32()
169
170 * Wed Feb 14 2001 Jakub Jelinek <jakub@redhat.com>
171 - #include <time.h> in addition to <sys/time.h>
172
173 * Fri Jan 26 2001 Karsten Hopp <karsten@redhat.com>
174 - clean up conflicting patches. This happened only
175   when building on S390
176
177 * Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
178 - update to CVS, reintegrate ia64 support
179
180 * Sat Dec  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
181 - Get S/390 support into the normal package
182
183 * Sat Nov 18 2000 Florian La Roche <Florian.LaRoche@redhat.de>
184 - added S/390 patch from IBM, adapting it to not conflict with
185   IA64 patch
186
187 * Sat Aug 19 2000 Jakub Jelinek <jakub@redhat.com>
188 - doh, actually apply the 2.4 syscalls patch
189 - make it compile with 2.4.0-test7-pre4+ headers, add
190   getdents64 and fcntl64
191
192 * Thu Aug  3 2000 Jakub Jelinek <jakub@redhat.com>
193 - add a bunch of new 2.4 syscalls (#14036)
194
195 * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
196 - automatic rebuild
197 - excludearch ia64
198
199 * Fri Jun  2 2000 Matt Wilson <msw@redhat.com>
200 - use buildinstall for FHS
201
202 * Wed May 24 2000 Jakub Jelinek <jakub@redhat.com>
203 - make things compile on sparc
204 - fix sigreturn on sparc
205
206 * Fri Mar 31 2000 Bill Nottingham <notting@redhat.com>
207 - fix stat64 misdef (#10485)
208
209 * Tue Mar 21 2000 Michael K. Johnson <johnsonm@redhat.com>
210 - added ia64 patch
211
212 * Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
213 - man pages are compressed
214 - version 4.2 (why are we keeping all these patches around?)
215
216 * Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
217 - update to 4.1 (with sparc socketcall patch).
218
219 * Fri Nov 12 1999 Jakub Jelinek <jakub@redhat.com>
220 - fix socketcall on sparc.
221
222 * Thu Sep 02 1999 Cristian Gafton <gafton@redhat.com>
223 - fix KERN_SECURELVL compile problem
224
225 * Tue Aug 31 1999 Cristian Gafton <gafton@redhat.com>
226 - added alpha patch from HJLu to fix the osf_sigprocmask interpretation
227
228 * Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
229 - update to 3.99.1.
230
231 * Wed Jun  2 1999 Jeff Johnson <jbj@redhat.com>
232 - add (the other :-) jj's sparc patch.
233
234 * Wed May 26 1999 Jeff Johnson <jbj@redhat.com>
235 - upgrade to 3.99 in order to
236 -    add new 2.2.x open flags (#2955).
237 -    add new 2.2.x syscalls (#2866).
238 - strace 3.1 patches carried along for now.
239
240 * Sun May 16 1999 Jeff Johnson <jbj@redhat.com>
241 - don't rely on (broken!) rpm %patch (#2735)
242
243 * Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
244 - strip binary
245
246 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
247 - auto rebuild in the new build environment (release 16)
248
249 * Tue Feb  9 1999 Jeff Johnson <jbj@redhat.com>
250 - vfork est arrive!
251
252 * Tue Feb  9 1999 Christopher Blizzard <blizzard@redhat.com>
253 - Add patch to follow clone() syscalls, too.
254
255 * Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
256 - patch to build alpha/sparc with glibc 2.1.
257
258 * Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
259 - patch to build on ARM
260
261 * Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
262 - fix typo (printf, not tprintf).
263
264 * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
265 - fix compile problem on sparc.
266
267 * Tue Aug 18 1998 Cristian Gafton <gafton@redhat.com>
268 - buildroot
269
270 * Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
271 - added the umoven patch from James Youngman <jay@gnu.org>
272 - fixed build problems on newer glibc releases
273
274 * Mon Jun 08 1998 Prospector System <bugs@redhat.com>
275 - translations modified for de, fr, tr