]> granicus.if.org Git - strace/blob - strace.spec
Sync strace.spec and debian/ with packages
[strace] / strace.spec
1 Summary: Tracks and displays system calls associated with a running process
2 Name: strace
3 Version: 4.10
4 Release: 3%{?dist}
5 License: BSD
6 Group: Development/Debuggers
7 URL: http://sourceforge.net/projects/strace/
8 Source: http://downloads.sourceforge.net/strace/%{name}-%{version}.tar.xz
9 BuildRequires: libacl-devel, time
10 %define strace64_arches ppc64 sparc64
11
12 %description
13 The strace program intercepts and records the system calls called and
14 received by a running process.  Strace can print a record of each
15 system call, its arguments and its return value.  Strace is useful for
16 diagnosing problems and debugging, as well as for instructional
17 purposes.
18
19 Install strace if you need a tool to track the system calls made and
20 received by a process.
21
22 %ifarch %{strace64_arches}
23 %package -n strace64
24 Summary: Tracks and displays system calls associated with a running process.
25 Group: Development/Debuggers
26
27 %description -n strace64
28 The strace program intercepts and records the system calls called and
29 received by a running process.  Strace can print a record of each
30 system call, its arguments and its return value.  Strace is useful for
31 diagnosing problems and debugging, as well as for instructional
32 purposes.
33
34 Install strace if you need a tool to track the system calls made and
35 received by a process.
36
37 This package provides the `strace64' program to trace 64-bit processes.
38 The `strace' program in the `strace' package is for 32-bit processes.
39 %endif
40
41 %prep
42 %setup -q
43
44 %build
45 %configure
46 make %{?_smp_mflags}
47
48 %install
49 make DESTDIR=%{buildroot} install
50
51 # remove unpackaged files from the buildroot
52 rm -f %{buildroot}%{_bindir}/strace-graph
53
54 %define copy64 ln
55 %if 0%{?rhel}
56 %if 0%{?rhel} < 6
57 %endif
58 %define copy64 cp -p
59 %endif
60
61 %ifarch %{strace64_arches}
62 %{copy64} %{buildroot}%{_bindir}/strace %{buildroot}%{_bindir}/strace64
63 %endif
64
65 %check
66 make -k check VERBOSE=1
67
68 %files
69 %doc CREDITS ChangeLog ChangeLog-CVS COPYING NEWS README
70 %{_bindir}/strace
71 %{_bindir}/strace-log-merge
72 %{_mandir}/man1/*
73
74 %ifarch %{strace64_arches}
75 %files -n strace64
76 %{_bindir}/strace64
77 %endif
78
79 %changelog
80 * Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.10-3
81 - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
82
83 * Mon May 11 2015 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 4.10-2
84 - Backport set of upstream patches to get it buildable on AArch64
85
86 * Fri Mar 06 2015 Dmitry V. Levin <ldv@altlinux.org> - 4.10-1
87 - New upstream release:
88   + enhanced ioctl decoding (#902788).
89
90 * Mon Nov 03 2014 Lubomir Rintel <lkundrak@v3.sk> - 4.9-3
91 - Regenerate ioctl entries with proper kernel headers
92
93 * Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.9-2
94 - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
95
96 * Fri Aug 15 2014 Dmitry V. Levin <ldv@altlinux.org> - 4.9-1
97 - New upstream release:
98   + fixed build when <sys/ptrace.h> and <linux/ptrace.h> conflict (#993384);
99   + updated CLOCK_* constants (#1088455);
100   + enabled ppc64le support (#1122323);
101   + fixed attach to a process on ppc64le (#1129569).
102
103 * Fri Jul 25 2014 Dan HorĂ¡k <dan[at]danny.cz> - 4.8-5
104 - update for ppc64
105
106 * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.8-4
107 - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
108
109 * Fri Dec  6 2013 Peter Robinson <pbrobinson@fedoraproject.org> 4.8-3
110 - Fix FTBFS
111
112 * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.8-2
113 - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
114
115 * Mon Jun 03 2013 Dmitry V. Levin <ldv@altlinux.org> - 4.8-1
116 - New upstream release:
117   + fixed ERESTARTNOINTR leaking to userspace on ancient kernels (#659382);
118   + fixed decoding of *xattr syscalls (#885233);
119   + fixed handling of files with 64-bit inode numbers by 32-bit strace (#912790);
120   + added aarch64 support (#969858).
121
122 * Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.7-3
123 - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
124
125 * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.7-2
126 - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
127
128 * Wed May 02 2012 Dmitry V. Levin <ldv@altlinux.org> 4.7-1
129 - New upstream release.
130   + implemented proper handling of real SIGTRAPs (#162774).
131
132 * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.6-2
133 - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
134
135 * Mon Mar 14 2011 Dmitry V. Levin <ldv@altlinux.org> - 4.6-1
136 - New upstream release.
137   + fixed a corner case in waitpid handling (#663547).
138
139 * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.20-2
140 - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
141
142 * Tue Apr 13 2010 Roland McGrath <roland@redhat.com> - 4.5.20-1
143 - New upstream release, work mostly by Andreas Schwab and Dmitry V. Levin.
144   + fixed potential stack buffer overflow in select decoder (#556678);
145   + fixed FTBFS (#539044).
146
147 * Wed Oct 21 2009 Roland McGrath <roland@redhat.com> - 4.5.19-1
148 - New upstream release, work mostly by Dmitry V. Levin <ldv@altlinux.org>
149   + exit/kill strace with traced process exitcode/signal (#105371);
150   + fixed build on ARM EABI (#507576);
151   + fixed display of 32-bit argv array on 64-bit architectures (#519480);
152   + fixed display of 32-bit fcntl(F_SETLK) on 64-bit architectures (#471169);
153   + fixed several bugs in strings decoder, including potential heap
154     memory corruption (#470529, #478324, #511035).
155
156 * Thu Aug 28 2008 Roland McGrath <roland@redhat.com> - 4.5.18-1
157 - build fix for newer kernel headers (#457291)
158 - fix CLONE_VFORK handling (#455078)
159 - Support new Linux/PPC system call subpage_prot and PROT_SAO flag.
160 - In sigaction system call, display sa_flags value along with SIG_DFL/SIG_IGN.
161
162 * Mon Jul 21 2008 Roland McGrath <roland@redhat.com> - 4.5.17-1
163 - handle O_CLOEXEC, MSG_CMSG_CLOEXEC (#365781)
164 - fix biarch stat64 decoding (#222275)
165 - fix spurious "..." in printing of environment strings (#358241)
166 - improve prctl decoding (#364401)
167 - fix hang wait on exited child with exited child (#354261)
168 - fix biarch fork/vfork (-f) tracing (#447475)
169 - fix biarch printing of negative argument kill (#430585)
170 - fix biarch decoding of error return values (#447587)
171 - fix -f tracing of CLONE_VFORK (#455078)
172 - fix ia64 register clobberation in -f tracing (#453438)
173 - print SO_NODEFER, SA_RESETHAND instead of SA_NOMASK, SA_ONESHOT (#455821)
174 - fix futex argument decoding (#448628, #448629)
175
176 * Fri Aug  3 2007 Roland McGrath <roland@redhat.com> - 4.5.16-1
177 - fix multithread issues (#240962, #240961, #247907)
178 - fix spurious SIGSTOP on early interrupt (#240986)
179 - fix utime for biarch (#247185)
180 - fix -u error message (#247170)
181 - better futex syscall printing (##241467)
182 - fix argv/envp printing with small -s settings, and for biarch
183 - new syscalls: getcpu, eventfd, timerfd, signalfd, epoll_pwait,
184   move_pages, utimensat
185
186 * Tue Jan 16 2007 Roland McGrath <roland@redhat.com> - 4.5.15-1
187 - biarch fixes (#179740, #192193, #171626, #173050, #218433, #218043)
188 - fix -ff -o behavior (#204950, #218435, #193808, #219423)
189 - better quotactl printing (#118696)
190 - *at, inotify*, pselect6, ppoll and unshare syscalls (#178633, #191275)
191 - glibc-2.5 build fixes (#209856)
192 - memory corruption fixes (#200621
193 - fix race in child setup under -f (#180293)
194 - show ipc key values in hex (#198179, #192182)
195 - disallow -c with -ff (#187847)
196 - Resolves: RHBZ #179740, RHBZ #192193, RHBZ #204950, RHBZ #218435
197 - Resolves: RHBZ #193808, RHBZ #219423, RHBZ #171626, RHBZ #173050
198 - Resolves: RHBZ #218433, RHBZ #218043, RHBZ #118696, RHBZ #178633
199 - Resolves: RHBZ #191275, RHBZ #209856, RHBZ #200621, RHBZ #180293
200 - Resolves: RHBZ #198179, RHBZ #198182, RHBZ #187847
201
202 * Mon Nov 20 2006 Jakub Jelinek <jakub@redhat.com> - 4.5.14-4
203 - Fix ia64 syscall decoding (#206768)
204 - Fix build with glibc-2.4.90-33 and up on all arches but ia64
205 - Fix build against 2.6.18+ headers
206
207 * Tue Aug 22 2006 Roland McGrath <roland@redhat.com> - 4.5.14-3
208 - Fix bogus decoding of syscalls >= 300 (#201462, #202620).
209
210 * Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-2
211 - rebuild
212
213 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.2
214 - bump again for long double bug on ppc{,64}
215
216 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.1
217 - rebuilt for new gcc4.1 snapshot and glibc changes
218
219 * Mon Jan 16 2006 Roland McGrath <roland@redhat.com> - 4.5.14-1
220 - Fix biarch decoding of socket syscalls (#174354).
221 - Fix biarch -e support (#173986).
222 - Accept numeric syscalls in -e (#174798).
223 - Fix ipc syscall decoding (#164755).
224 - Improve msgrcv printing (#164757).
225 - Man page updates (#165375).
226 - Improve mount syscall printing (#165377).
227 - Correct printing of restarting syscalls (#165469).
228
229 * Wed Aug  3 2005 Roland McGrath <roland@redhat.com> - 4.5.13-1
230 - Fix setsockopt decoding on 64-bit (#162449).
231 - Fix typos in socket option name strings (#161578).
232 - Display more IPV6 socket options by name (#162450).
233 - Don't display inappropriate syscalls for -e trace=file (#159340).
234 - New selector type -e trace=desc for file-descriptor using calls (#159400).
235 - Fix 32-bit old_mmap syscall decoding on x86-64 (#162467, #164215).
236 - Fix errors detaching from multithreaded process on interrupt (#161919).
237 - Note 4.5.12 fix for crash handling bad signal numbers (#162739).
238
239 * Wed Jun  8 2005 Roland McGrath <roland@redhat.com> - 4.5.12-1
240 - Fix known syscall recognition for IA32 processes on x86-64 (#158934).
241 - Fix bad output for ptrace on x86-64 (#159787).
242 - Fix potential buffer overruns (#151570, #159196).
243 - Make some diagnostics more consistent (#159308).
244 - Update PowerPC system calls.
245 - Better printing for Linux aio system calls.
246 - Don't truncate statfs64 fields to 32 bits in output (#158243).
247 - Cosmetic code cleanups (#159688).
248
249 * Tue Mar 22 2005 Roland McGrath <roland@redhat.com> - 4.5.11-1
250 - Build tweaks.
251 - Note 4.5.10 select fix (#151570).
252
253 * Mon Mar 14 2005 Roland McGrath <roland@redhat.com> - 4.5.10-1
254 - Fix select handling on nonstandard fd_set sizes.
255 - Don't print errors for null file name pointers.
256 - Fix initial execve output with -i (#143365).
257
258 * Fri Feb  4 2005 Roland McGrath <roland@redhat.com> - 4.5.9-2
259 - update ia64 syscall list (#146245)
260 - fix x86_64 syscall argument extraction for 32-bit processes (#146093)
261 - fix -e signal=NAME parsing (#143362)
262 - fix x86_64 exit_group syscall handling
263 - improve socket ioctl printing (#138223)
264 - code cleanups (#143369, #143370)
265 - improve mount flags printing (#141932)
266 - support symbolic printing of x86_64 arch_prctl parameters (#142667)
267 - fix potential crash in getxattr printing
268
269 * Tue Oct 19 2004 Roland McGrath <roland@redhat.com> - 4.5.8-1
270 - fix multithreaded exit handling (#132150, #135254)
271 - fix ioctl name matching (#129808)
272 - print RTC_* ioctl structure contents (#58606)
273 - grok epoll_* syscalls (#134463)
274 - grok new RLIMIT_* values (#133594)
275 - print struct cmsghdr contents for sendmsg (#131689)
276 - fix clock_* and timer_* argument output (#131420)
277
278 * Tue Aug 31 2004 Roland McGrath <roland@redhat.com> - 4.5.7-2
279 - new upstream version, misc fixes and updates (#128091, #129166, #128391, #129378, #130965, #131177)
280
281 * Mon Jul 12 2004 Roland McGrath <roland@redhat.com> 4.5.6-1
282 - new upstream version, updates ioctl lists (#127398), fixes quotactl (#127393), more ioctl decoding (#126917)
283
284 * Sun Jun 27 2004 Roland McGrath <roland@redhat.com> 4.5.5-1
285 - new upstream version, fixes x86-64 biarch support (#126547)
286
287 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> 4.5.4-2
288 - rebuilt
289
290 * Thu Jun  3 2004 Roland McGrath <roland@redhat.com> 4.5.4-0.FC1
291 - rebuilt for FC1 update
292
293 * Thu Jun  3 2004 Roland McGrath <roland@redhat.com> 4.5.4-1
294 - new upstream version, more ioctls (#122257), minor fixes
295
296 * Fri Apr 16 2004 Roland McGrath <roland@redhat.com> 4.5.3-1
297 - new upstream version, mq_* calls (#120701), -p vs NPTL (#120462), more fixes (#118694, #120541, #118685)
298
299 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 4.5.2-1.1
300 - rebuilt
301
302 * Mon Mar  1 2004 Roland McGrath <roland@redhat.com> 4.5.2-1
303 - new upstream version, sched_* calls (#116990), show core flag (#112117)
304
305 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
306 - rebuilt
307
308 * Thu Nov 13 2003 Roland McGrath <roland@redhat.com> 4.5.1-1
309 - new upstream version, more fixes (#108012, #105366, #105359, #105358)
310
311 * Tue Sep 30 2003 Roland McGrath <roland@redhat.com> 4.5-3
312 - revert bogus s390 fix
313
314 * Thu Sep 25 2003 Roland McGrath <roland@redhat.com> 4.5-1.2.1AS
315 - rebuilt for 2.1AS erratum
316
317 * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-2
318 - rebuilt
319
320 * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-1
321 - new upstream version, more fixes (#101499, #104365)
322
323 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-2
324 - rebuilt
325
326 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-1
327 - new upstream version, groks more new system calls, PF_INET6 sockets
328
329 * Tue Jun 10 2003 Roland McGrath <roland@redhat.com> 4.4.98-1
330 - new upstream version, more fixes (#90754, #91085)
331
332 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
333 - rebuilt
334
335 * Sun Mar 30 2003 Roland McGrath <roland@redhat.com> 4.4.96-1
336 - new upstream version, handles yet more 2.5 syscalls, x86_64 & ia64 fixes
337
338 * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com> 4.4.95-2
339 - rebuilt
340
341 * Mon Feb 24 2003 Roland McGrath <roland@redhat.com> 4.4.95-1
342 - new upstream version, fixed getresuid/getresgid (#84959)
343
344 * Wed Feb 19 2003 Roland McGrath <roland@redhat.com> 4.4.94-1
345 - new upstream version, new option -E to set environment variables (#82392)
346
347 * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.4.93-2
348 - rebuilt
349
350 * Tue Jan 21 2003 Roland McGrath <roland@redhat.com> 4.4.93-1
351 - new upstream version, fixes ppc and s390 bugs, adds missing ptrace requests
352
353 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.91-1
354 - new upstream version, fixes -f on x86-64
355
356 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.90-1
357 - new upstream version, fixes all known bugs modulo ia64 and s390 issues
358
359 * Fri Jan 03 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.4-11
360 - add further s390 patch from IBM
361
362 * Wed Nov 27 2002 Tim Powers <timp@redhat.com> 4.4-10
363 - remove unpackaged files from the buildroot
364
365 * Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.4-9.1
366 - Added latest s390(x) patch.
367
368 * Fri Sep 06 2002 Karsten Hopp <karsten@redhat.de> 4.4-9
369 - preliminary x86_64 support with an ugly patch to help
370   debugging. Needs cleanup!
371
372 * Mon Sep  2 2002 Jakub Jelinek <jakub@redhat.com> 4.4-8
373 - newer version of the clone fixing patch (Roland McGrath)
374 - aio syscalls for i386/ia64/ppc (Ben LaHaise)
375
376 * Wed Aug 28 2002 Jakub Jelinek <jakub@redhat.com> 4.4-7
377 - fix strace -f (Roland McGrath, #68994)
378 - handle ?et_thread_area, SA_RESTORER (Ulrich Drepper)
379
380 * Fri Jun 21 2002 Jakub Jelinek <jakub@redhat.com> 4.4-6
381 - handle futexes, *xattr, sendfile64, etc. (Ulrich Drepper)
382 - handle modify_ldt (#66894)
383
384 * Thu May 23 2002 Tim Powers <timp@redhat.com>
385 - automated rebuild
386
387 * Tue Apr 16 2002 Jakub Jelinek <jakub@redhat.com> 4.4-4
388 - fix for the last patch by Jeff Law (#62591)
389
390 * Mon Mar  4 2002 Preston Brown <pbrown@redhat.com> 4.4-3
391 - integrate patch from Jeff Law to eliminate hang tracing threads
392
393 * Sat Feb 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
394 - minor update from debian tar-ball
395
396 * Wed Jan 02 2002 Florian La Roche <Florian.LaRoche@redhat.de>
397 - update to 4.4
398
399 * Sun Jul 22 2001 Florian La Roche <Florian.LaRoche@redhat.de>
400 - disable s390 patches, they are already included
401
402 * Wed Jul 18 2001 Preston Brown <pbrown@redhat.com> 4.3-1
403 - new upstream version.  Seems to have integrated most new syscalls
404 - tracing threaded programs is now functional.
405
406 * Mon Jun 11 2001 Than Ngo <than@redhat.com>
407 - port s390 patches from IBM
408
409 * Wed May 16 2001 Nalin Dahyabhai <nalin@redhat.com>
410 - modify new syscall patch to allocate enough heap space in setgroups32()
411
412 * Wed Feb 14 2001 Jakub Jelinek <jakub@redhat.com>
413 - #include <time.h> in addition to <sys/time.h>
414
415 * Fri Jan 26 2001 Karsten Hopp <karsten@redhat.com>
416 - clean up conflicting patches. This happened only
417   when building on S390
418
419 * Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
420 - update to CVS, reintegrate ia64 support
421
422 * Fri Dec  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
423 - Get S/390 support into the normal package
424
425 * Sat Nov 18 2000 Florian La Roche <Florian.LaRoche@redhat.de>
426 - added S/390 patch from IBM, adapting it to not conflict with
427   IA64 patch
428
429 * Sat Aug 19 2000 Jakub Jelinek <jakub@redhat.com>
430 - doh, actually apply the 2.4 syscalls patch
431 - make it compile with 2.4.0-test7-pre4+ headers, add
432   getdents64 and fcntl64
433
434 * Thu Aug  3 2000 Jakub Jelinek <jakub@redhat.com>
435 - add a bunch of new 2.4 syscalls (#14036)
436
437 * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
438 - automatic rebuild
439 - excludearch ia64
440
441 * Fri Jun  2 2000 Matt Wilson <msw@redhat.com>
442 - use buildinstall for FHS
443
444 * Wed May 24 2000 Jakub Jelinek <jakub@redhat.com>
445 - make things compile on sparc
446 - fix sigreturn on sparc
447
448 * Fri Mar 31 2000 Bill Nottingham <notting@redhat.com>
449 - fix stat64 misdef (#10485)
450
451 * Tue Mar 21 2000 Michael K. Johnson <johnsonm@redhat.com>
452 - added ia64 patch
453
454 * Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
455 - man pages are compressed
456 - version 4.2 (why are we keeping all these patches around?)
457
458 * Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
459 - update to 4.1 (with sparc socketcall patch).
460
461 * Fri Nov 12 1999 Jakub Jelinek <jakub@redhat.com>
462 - fix socketcall on sparc.
463
464 * Thu Sep 02 1999 Cristian Gafton <gafton@redhat.com>
465 - fix KERN_SECURELVL compile problem
466
467 * Tue Aug 31 1999 Cristian Gafton <gafton@redhat.com>
468 - added alpha patch from HJLu to fix the osf_sigprocmask interpretation
469
470 * Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
471 - update to 3.99.1.
472
473 * Wed Jun  2 1999 Jeff Johnson <jbj@redhat.com>
474 - add (the other :-) jj's sparc patch.
475
476 * Wed May 26 1999 Jeff Johnson <jbj@redhat.com>
477 - upgrade to 3.99 in order to
478 -    add new 2.2.x open flags (#2955).
479 -    add new 2.2.x syscalls (#2866).
480 - strace 3.1 patches carried along for now.
481
482 * Sun May 16 1999 Jeff Johnson <jbj@redhat.com>
483 - don't rely on (broken!) rpm %%patch (#2735)
484
485 * Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
486 - strip binary
487
488 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
489 - auto rebuild in the new build environment (release 16)
490
491 * Tue Feb  9 1999 Jeff Johnson <jbj@redhat.com>
492 - vfork est arrive!
493
494 * Tue Feb  9 1999 Christopher Blizzard <blizzard@redhat.com>
495 - Add patch to follow clone() syscalls, too.
496
497 * Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
498 - patch to build alpha/sparc with glibc 2.1.
499
500 * Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
501 - patch to build on ARM
502
503 * Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
504 - fix typo (printf, not tprintf).
505
506 * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
507 - fix compile problem on sparc.
508
509 * Tue Aug 18 1998 Cristian Gafton <gafton@redhat.com>
510 - buildroot
511
512 * Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
513 - added the umoven patch from James Youngman <jay@gnu.org>
514 - fixed build problems on newer glibc releases
515
516 * Mon Jun 08 1998 Prospector System <bugs@redhat.com>
517 - translations modified for de, fr, tr