]> granicus.if.org Git - strace/blob - strace.spec
2007-02-18 Roland McGrath <roland@redhat.com>
[strace] / strace.spec
1 Summary: Tracks and displays system calls associated with a running process
2 Name: strace
3 Version: 4.5.15
4 Release: 1%{?dist}
5 License: BSD
6 Group: Development/Debuggers
7 URL: http://sourceforge.net/projects/strace/
8 Source0: http://dl.sourceforge.net/strace/%{name}-%{version}.tar.bz2
9 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
10
11 %define strace64_arches ppc64
12
13 %description
14 The strace program intercepts and records the system calls called and
15 received by a running process.  Strace can print a record of each
16 system call, its arguments and its return value.  Strace is useful for
17 diagnosing problems and debugging, as well as for instructional
18 purposes.
19
20 Install strace if you need a tool to track the system calls made and
21 received by a process.
22
23 %ifarch %{strace64_arches}
24 %package -n strace64
25 Summary: Tracks and displays system calls associated with a running process.
26 Group: Development/Debuggers
27
28 %description -n strace64
29 The strace program intercepts and records the system calls called and
30 received by a running process.  Strace can print a record of each
31 system call, its arguments and its return value.  Strace is useful for
32 diagnosing problems and debugging, as well as for instructional
33 purposes.
34
35 Install strace if you need a tool to track the system calls made and
36 received by a process.
37
38 This package provides the `strace64' program to trace 64-bit processes.
39 The `strace' program in the `strace' package is for 32-bit processes.
40 %endif
41
42 %prep
43 %setup -q
44
45 %build
46 %configure
47 make
48
49 %install
50 rm -rf %{buildroot}
51 make DESTDIR=%{buildroot} install
52
53 # remove unpackaged files from the buildroot
54 rm -f %{buildroot}%{_bindir}/strace-graph
55
56 %ifarch %{strace64_arches}
57 ln %{buildroot}%{_bindir}/strace %{buildroot}%{_bindir}/strace64
58 %endif
59
60 %clean
61 rm -rf %{buildroot}
62
63 %files
64 %defattr(-,root,root)
65 %doc CREDITS ChangeLog COPYRIGHT NEWS PORTING README
66 %{_bindir}/strace
67 %{_mandir}/man1/*
68
69 %ifarch %{strace64_arches}
70 %files -n strace64
71 %defattr(-,root,root)
72 %{_bindir}/strace64
73 %endif
74
75
76 %changelog
77 * Tue Jan 16 2007 Roland McGrath <roland@redhat.com> - 4.5.15-1
78 - biarch fixes (#179740, #192193, #171626, #173050, #218433, #218043)
79 - fix -ff -o behavior (#204950, #218435, #193808, #219423)
80 - better quotactl printing (#118696)
81 - *at, inotify*, pselect6, ppoll and unshare syscalls (#178633, #191275)
82 - glibc-2.5 build fixes (#209856)
83 - memory corruption fixes (#200621
84 - fix race in child setup under -f (#180293)
85 - show ipc key values in hex (#198179, #192182)
86 - disallow -c with -ff (#187847)
87 - Resolves: RHBZ #179740, RHBZ #192193, RHBZ #204950, RHBZ #218435
88 - Resolves: RHBZ #193808, RHBZ #219423, RHBZ #171626, RHBZ #173050
89 - Resolves: RHBZ #218433, RHBZ #218043, RHBZ #118696, RHBZ #178633
90 - Resolves: RHBZ #191275, RHBZ #209856, RHBZ #200621, RHBZ #180293
91 - Resolves: RHBZ #198179, RHBZ #198182, RHBZ #187847
92
93 * Mon Nov 20 2006 Jakub Jelinek <jakub@redhat.com> - 4.5.14-4
94 - Fix ia64 syscall decoding (#206768)
95 - Fix build with glibc-2.4.90-33 and up on all arches but ia64
96 - Fix build against 2.6.18+ headers
97
98 * Tue Aug 22 2006 Roland McGrath <roland@redhat.com> - 4.5.14-3
99 - Fix bogus decoding of syscalls >= 300 (#201462, #202620).
100
101 * Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-2
102 - rebuild
103
104 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.2
105 - bump again for long double bug on ppc{,64}
106
107 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.1
108 - rebuilt for new gcc4.1 snapshot and glibc changes
109
110 * Mon Jan 16 2006 Roland McGrath <roland@redhat.com> - 4.5.14-1
111 - Fix biarch decoding of socket syscalls (#174354).
112 - Fix biarch -e support (#173986).
113 - Accept numeric syscalls in -e (#174798).
114 - Fix ipc syscall decoding (#164755).
115 - Improve msgrcv printing (#164757).
116 - Man page updates (#165375).
117 - Improve mount syscall printing (#165377).
118 - Correct printing of restarting syscalls (#165469).
119
120 * Wed Aug  3 2005 Roland McGrath <roland@redhat.com> - 4.5.13-1
121 - Fix setsockopt decoding on 64-bit (#162449).
122 - Fix typos in socket option name strings (#161578).
123 - Display more IPV6 socket options by name (#162450).
124 - Don't display inappropriate syscalls for -e trace=file (#159340).
125 - New selector type -e trace=desc for file-descriptor using calls (#159400).
126 - Fix 32-bit old_mmap syscall decoding on x86-64 (#162467, #164215).
127 - Fix errors detaching from multithreaded process on interrupt (#161919).
128 - Note 4.5.12 fix for crash handling bad signal numbers (#162739).
129
130 * Wed Jun  8 2005 Roland McGrath <roland@redhat.com> - 4.5.12-1
131 - Fix known syscall recognition for IA32 processes on x86-64 (#158934).
132 - Fix bad output for ptrace on x86-64 (#159787).
133 - Fix potential buffer overruns (#151570, #159196).
134 - Make some diagnostics more consistent (#159308).
135 - Update PowerPC system calls.
136 - Better printing for Linux aio system calls.
137 - Don't truncate statfs64 fields to 32 bits in output (#158243).
138 - Cosmetic code cleanups (#159688).
139
140 * Tue Mar 22 2005 Roland McGrath <roland@redhat.com> - 4.5.11-1
141 - Build tweaks.
142 - Note 4.5.10 select fix (#151570).
143
144 * Mon Mar 14 2005 Roland McGrath <roland@redhat.com> - 4.5.10-1
145 - Fix select handling on nonstandard fd_set sizes.
146 - Don't print errors for null file name pointers.
147 - Fix initial execve output with -i (#143365).
148
149 * Fri Feb  4 2005 Roland McGrath <roland@redhat.com> - 4.5.9-2
150 - update ia64 syscall list (#146245)
151 - fix x86_64 syscall argument extraction for 32-bit processes (#146093)
152 - fix -e signal=NAME parsing (#143362)
153 - fix x86_64 exit_group syscall handling
154 - improve socket ioctl printing (#138223)
155 - code cleanups (#143369, #143370)
156 - improve mount flags printing (#141932)
157 - support symbolic printing of x86_64 arch_prctl parameters (#142667)
158 - fix potential crash in getxattr printing
159
160 * Tue Oct 19 2004 Roland McGrath <roland@redhat.com> - 4.5.8-1
161 - fix multithreaded exit handling (#132150, #135254)
162 - fix ioctl name matching (#129808)
163 - print RTC_* ioctl structure contents (#58606)
164 - grok epoll_* syscalls (#134463)
165 - grok new RLIMIT_* values (#133594)
166 - print struct cmsghdr contents for sendmsg (#131689)
167 - fix clock_* and timer_* argument output (#131420)
168
169 * Tue Aug 31 2004 Roland McGrath <roland@redhat.com> - 4.5.7-2
170 - new upstream version, misc fixes and updates (#128091, #129166, #128391, #129378, #130965, #131177)
171
172 * Mon Jul 12 2004 Roland McGrath <roland@redhat.com> 4.5.6-1
173 - new upstream version, updates ioctl lists (#127398), fixes quotactl (#127393), more ioctl decoding (#126917)
174
175 * Sun Jun 27 2004 Roland McGrath <roland@redhat.com> 4.5.5-1
176 - new upstream version, fixes x86-64 biarch support (#126547)
177
178 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> 4.5.4-2
179 - rebuilt
180
181 * Thu Jun  3 2004 Roland McGrath <roland@redhat.com> 4.5.4-0.FC1
182 - rebuilt for FC1 update
183
184 * Thu Jun  3 2004 Roland McGrath <roland@redhat.com> 4.5.4-1
185 - new upstream version, more ioctls (#122257), minor fixes
186
187 * Fri Apr 16 2004 Roland McGrath <roland@redhat.com> 4.5.3-1
188 - new upstream version, mq_* calls (#120701), -p vs NPTL (#120462), more fixes (#118694, #120541, #118685)
189
190 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 4.5.2-1.1
191 - rebuilt
192
193 * Mon Mar  1 2004 Roland McGrath <roland@redhat.com> 4.5.2-1
194 - new upstream version, sched_* calls (#116990), show core flag (#112117)
195
196 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
197 - rebuilt
198
199 * Thu Nov 13 2003 Roland McGrath <roland@redhat.com> 4.5.1-1
200 - new upstream version, more fixes (#108012, #105366, #105359, #105358)
201
202 * Tue Sep 30 2003 Roland McGrath <roland@redhat.com> 4.5-3
203 - revert bogus s390 fix
204
205 * Thu Sep 25 2003 Roland McGrath <roland@redhat.com> 4.5-1.2.1AS
206 - rebuilt for 2.1AS erratum
207
208 * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-2
209 - rebuilt
210
211 * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-1
212 - new upstream version, more fixes (#101499, #104365)
213
214 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-2
215 - rebuilt
216
217 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-1
218 - new upstream version, groks more new system calls, PF_INET6 sockets
219
220 * Mon Jun 10 2003 Roland McGrath <roland@redhat.com> 4.4.98-1
221 - new upstream version, more fixes (#90754, #91085)
222
223 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
224 - rebuilt
225
226 * Sun Mar 30 2003 Roland McGrath <roland@redhat.com> 4.4.96-1
227 - new upstream version, handles yet more 2.5 syscalls, x86_64 & ia64 fixes
228
229 * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com> 4.4.95-2
230 - rebuilt
231
232 * Mon Feb 24 2003 Roland McGrath <roland@redhat.com> 4.4.95-1
233 - new upstream version, fixed getresuid/getresgid (#84959)
234
235 * Wed Feb 19 2003 Roland McGrath <roland@redhat.com> 4.4.94-1
236 - new upstream version, new option -E to set environment variables (#82392)
237
238 * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.4.93-2
239 - rebuilt
240
241 * Tue Jan 21 2003 Roland McGrath <roland@redhat.com> 4.4.93-1
242 - new upstream version, fixes ppc and s390 bugs, adds missing ptrace requests
243
244 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.91-1
245 - new upstream version, fixes -f on x86-64
246
247 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.90-1
248 - new upstream version, fixes all known bugs modulo ia64 and s390 issues
249
250 * Fri Jan 03 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.4-11
251 - add further s390 patch from IBM
252
253 * Wed Nov 27 2002 Tim Powers <timp@redhat.com> 4.4-10
254 - remove unpackaged files from the buildroot
255
256 * Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.4-9.1
257 - Added latest s390(x) patch.
258
259 * Fri Sep 06 2002 Karsten Hopp <karsten@redhat.de> 4.4-9
260 - preliminary x86_64 support with an ugly patch to help
261   debugging. Needs cleanup!
262
263 * Mon Sep  2 2002 Jakub Jelinek <jakub@redhat.com> 4.4-8
264 - newer version of the clone fixing patch (Roland McGrath)
265 - aio syscalls for i386/ia64/ppc (Ben LaHaise)
266
267 * Wed Aug 28 2002 Jakub Jelinek <jakub@redhat.com> 4.4-7
268 - fix strace -f (Roland McGrath, #68994)
269 - handle ?et_thread_area, SA_RESTORER (Ulrich Drepper)
270
271 * Fri Jun 21 2002 Jakub Jelinek <jakub@redhat.com> 4.4-6
272 - handle futexes, *xattr, sendfile64, etc. (Ulrich Drepper)
273 - handle modify_ldt (#66894)
274
275 * Thu May 23 2002 Tim Powers <timp@redhat.com>
276 - automated rebuild
277
278 * Tue Apr 16 2002 Jakub Jelinek <jakub@redhat.com> 4.4-4
279 - fix for the last patch by Jeff Law (#62591)
280
281 * Mon Mar  4 2002 Preston Brown <pbrown@redhat.com> 4.4-3
282 - integrate patch from Jeff Law to eliminate hang tracing threads
283
284 * Sat Feb 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
285 - minor update from debian tar-ball
286
287 * Wed Jan 02 2002 Florian La Roche <Florian.LaRoche@redhat.de>
288 - update to 4.4
289
290 * Sun Jul 22 2001 Florian La Roche <Florian.LaRoche@redhat.de>
291 - disable s390 patches, they are already included
292
293 * Wed Jul 18 2001 Preston Brown <pbrown@redhat.com> 4.3-1
294 - new upstream version.  Seems to have integrated most new syscalls
295 - tracing threaded programs is now functional.
296
297 * Mon Jun 11 2001 Than Ngo <than@redhat.com>
298 - port s390 patches from IBM
299
300 * Wed May 16 2001 Nalin Dahyabhai <nalin@redhat.com>
301 - modify new syscall patch to allocate enough heap space in setgroups32()
302
303 * Wed Feb 14 2001 Jakub Jelinek <jakub@redhat.com>
304 - #include <time.h> in addition to <sys/time.h>
305
306 * Fri Jan 26 2001 Karsten Hopp <karsten@redhat.com>
307 - clean up conflicting patches. This happened only
308   when building on S390
309
310 * Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
311 - update to CVS, reintegrate ia64 support
312
313 * Sat Dec  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
314 - Get S/390 support into the normal package
315
316 * Sat Nov 18 2000 Florian La Roche <Florian.LaRoche@redhat.de>
317 - added S/390 patch from IBM, adapting it to not conflict with
318   IA64 patch
319
320 * Sat Aug 19 2000 Jakub Jelinek <jakub@redhat.com>
321 - doh, actually apply the 2.4 syscalls patch
322 - make it compile with 2.4.0-test7-pre4+ headers, add
323   getdents64 and fcntl64
324
325 * Thu Aug  3 2000 Jakub Jelinek <jakub@redhat.com>
326 - add a bunch of new 2.4 syscalls (#14036)
327
328 * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
329 - automatic rebuild
330 - excludearch ia64
331
332 * Fri Jun  2 2000 Matt Wilson <msw@redhat.com>
333 - use buildinstall for FHS
334
335 * Wed May 24 2000 Jakub Jelinek <jakub@redhat.com>
336 - make things compile on sparc
337 - fix sigreturn on sparc
338
339 * Fri Mar 31 2000 Bill Nottingham <notting@redhat.com>
340 - fix stat64 misdef (#10485)
341
342 * Tue Mar 21 2000 Michael K. Johnson <johnsonm@redhat.com>
343 - added ia64 patch
344
345 * Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
346 - man pages are compressed
347 - version 4.2 (why are we keeping all these patches around?)
348
349 * Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
350 - update to 4.1 (with sparc socketcall patch).
351
352 * Fri Nov 12 1999 Jakub Jelinek <jakub@redhat.com>
353 - fix socketcall on sparc.
354
355 * Thu Sep 02 1999 Cristian Gafton <gafton@redhat.com>
356 - fix KERN_SECURELVL compile problem
357
358 * Tue Aug 31 1999 Cristian Gafton <gafton@redhat.com>
359 - added alpha patch from HJLu to fix the osf_sigprocmask interpretation
360
361 * Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
362 - update to 3.99.1.
363
364 * Wed Jun  2 1999 Jeff Johnson <jbj@redhat.com>
365 - add (the other :-) jj's sparc patch.
366
367 * Wed May 26 1999 Jeff Johnson <jbj@redhat.com>
368 - upgrade to 3.99 in order to
369 -    add new 2.2.x open flags (#2955).
370 -    add new 2.2.x syscalls (#2866).
371 - strace 3.1 patches carried along for now.
372
373 * Sun May 16 1999 Jeff Johnson <jbj@redhat.com>
374 - don't rely on (broken!) rpm %%patch (#2735)
375
376 * Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
377 - strip binary
378
379 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
380 - auto rebuild in the new build environment (release 16)
381
382 * Tue Feb  9 1999 Jeff Johnson <jbj@redhat.com>
383 - vfork est arrive!
384
385 * Tue Feb  9 1999 Christopher Blizzard <blizzard@redhat.com>
386 - Add patch to follow clone() syscalls, too.
387
388 * Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
389 - patch to build alpha/sparc with glibc 2.1.
390
391 * Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
392 - patch to build on ARM
393
394 * Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
395 - fix typo (printf, not tprintf).
396
397 * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
398 - fix compile problem on sparc.
399
400 * Tue Aug 18 1998 Cristian Gafton <gafton@redhat.com>
401 - buildroot
402
403 * Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
404 - added the umoven patch from James Youngman <jay@gnu.org>
405 - fixed build problems on newer glibc releases
406
407 * Mon Jun 08 1998 Prospector System <bugs@redhat.com>
408 - translations modified for de, fr, tr