]> granicus.if.org Git - strace/blob - strace.spec
2003-03-30 Roland McGrath <roland@redhat.com>
[strace] / strace.spec
1 Summary: Tracks and displays system calls associated with a running process.
2 Name: strace
3 Version: 4.4.95
4 Release: 1
5 License: BSD
6 Group: Development/Debuggers
7 URL: http://sourceforge.net/projects/strace/
8 Source0: %{name}-%{version}.tar.bz2
9 BuildRoot: %{_tmppath}/%{name}-root
10
11 %description
12 The strace program intercepts and records the system calls called and
13 received by a running process.  Strace can print a record of each
14 system call, its arguments and its return value.  Strace is useful for
15 diagnosing problems and debugging, as well as for instructional
16 purposes.
17
18 Install strace if you need a tool to track the system calls made and
19 received by a process.
20
21 %prep
22 %setup -q
23
24 %build
25 %configure
26 make
27
28 %install
29 rm -rf %{buildroot}
30 mkdir -p %{buildroot}%{_mandir}/man1
31 mkdir -p %{buildroot}%{_bindir}
32 %makeinstall man1dir=%{buildroot}%{_mandir}/man1
33
34 # remove unpackaged files from the buildroot
35 rm -f %{buildroot}%{_bindir}/strace-graph
36
37 %clean
38 rm -rf %{buildroot}
39
40 %files
41 %defattr(-,root,root)
42 %{_bindir}/strace
43 %{_mandir}/man1/*
44
45 %changelog
46 * Mon Feb 24 2003 Roland McGrath <roland@redhat.com> 4.4.95-1
47 - new upstream version, fixed getresuid/getresgid (#84959)
48
49 * Wed Feb 19 2003 Roland McGrath <roland@redhat.com> 4.4.94-1
50 - new upstream version, new option -E to set environment variables (#82392)
51
52 * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.4.93-2
53 - rebuilt
54
55 * Tue Jan 21 2003 Roland McGrath <roland@redhat.com> 4.4.93-1
56 - new upstream version, fixes ppc and s390 bugs, adds missing ptrace requests
57
58 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.91-1
59 - new upstream version, fixes -f on x86-64
60
61 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.90-1
62 - new upstream version, fixes all known bugs modulo ia64 and s390 issues
63
64 * Fri Jan 03 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.4-11
65 - add further s390 patch from IBM
66
67 * Wed Nov 27 2002 Tim Powers <timp@redhat.com> 4.4-10
68 - remove unpackaged files from the buildroot
69
70 * Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.4-9.1
71 - Added latest s390(x) patch.
72
73 * Fri Sep 06 2002 Karsten Hopp <karsten@redhat.de> 4.4-9
74 - preliminary x86_64 support with an ugly patch to help
75   debugging. Needs cleanup!
76
77 * Mon Sep  2 2002 Jakub Jelinek <jakub@redhat.com> 4.4-8
78 - newer version of the clone fixing patch (Roland McGrath)
79 - aio syscalls for i386/ia64/ppc (Ben LaHaise)
80
81 * Wed Aug 28 2002 Jakub Jelinek <jakub@redhat.com> 4.4-7
82 - fix strace -f (Roland McGrath, #68994)
83 - handle ?et_thread_area, SA_RESTORER (Ulrich Drepper)
84
85 * Fri Jun 21 2002 Jakub Jelinek <jakub@redhat.com> 4.4-6
86 - handle futexes, *xattr, sendfile64, etc. (Ulrich Drepper)
87 - handle modify_ldt (#66894)
88
89 * Thu May 23 2002 Tim Powers <timp@redhat.com>
90 - automated rebuild
91
92 * Tue Apr 16 2002 Jakub Jelinek <jakub@redhat.com> 4.4-4
93 - fix for the last patch by Jeff Law (#62591)
94
95 * Mon Mar  4 2002 Preston Brown <pbrown@redhat.com> 4.4-3
96 - integrate patch from Jeff Law to eliminate hang tracing threads
97
98 * Sat Feb 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
99 - minor update from debian tar-ball
100
101 * Wed Jan 02 2002 Florian La Roche <Florian.LaRoche@redhat.de>
102 - update to 4.4
103
104 * Sun Jul 22 2001 Florian La Roche <Florian.LaRoche@redhat.de>
105 - disable s390 patches, they are already included
106
107 * Wed Jul 18 2001 Preston Brown <pbrown@redhat.com> 4.3-1
108 - new upstream version.  Seems to have integrated most new syscalls
109 - tracing threaded programs is now functional.
110
111 * Mon Jun 11 2001 Than Ngo <than@redhat.com>
112 - port s390 patches from IBM
113
114 * Wed May 16 2001 Nalin Dahyabhai <nalin@redhat.com>
115 - modify new syscall patch to allocate enough heap space in setgroups32()
116
117 * Wed Feb 14 2001 Jakub Jelinek <jakub@redhat.com>
118 - #include <time.h> in addition to <sys/time.h>
119
120 * Fri Jan 26 2001 Karsten Hopp <karsten@redhat.com>
121 - clean up conflicting patches. This happened only
122   when building on S390
123
124 * Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
125 - update to CVS, reintegrate ia64 support
126
127 * Sat Dec  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
128 - Get S/390 support into the normal package
129
130 * Sat Nov 18 2000 Florian La Roche <Florian.LaRoche@redhat.de>
131 - added S/390 patch from IBM, adapting it to not conflict with
132   IA64 patch
133
134 * Sat Aug 19 2000 Jakub Jelinek <jakub@redhat.com>
135 - doh, actually apply the 2.4 syscalls patch
136 - make it compile with 2.4.0-test7-pre4+ headers, add
137   getdents64 and fcntl64
138
139 * Thu Aug  3 2000 Jakub Jelinek <jakub@redhat.com>
140 - add a bunch of new 2.4 syscalls (#14036)
141
142 * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
143 - automatic rebuild
144 - excludearch ia64
145
146 * Fri Jun  2 2000 Matt Wilson <msw@redhat.com>
147 - use buildinstall for FHS
148
149 * Wed May 24 2000 Jakub Jelinek <jakub@redhat.com>
150 - make things compile on sparc
151 - fix sigreturn on sparc
152
153 * Fri Mar 31 2000 Bill Nottingham <notting@redhat.com>
154 - fix stat64 misdef (#10485)
155
156 * Tue Mar 21 2000 Michael K. Johnson <johnsonm@redhat.com>
157 - added ia64 patch
158
159 * Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
160 - man pages are compressed
161 - version 4.2 (why are we keeping all these patches around?)
162
163 * Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
164 - update to 4.1 (with sparc socketcall patch).
165
166 * Fri Nov 12 1999 Jakub Jelinek <jakub@redhat.com>
167 - fix socketcall on sparc.
168
169 * Thu Sep 02 1999 Cristian Gafton <gafton@redhat.com>
170 - fix KERN_SECURELVL compile problem
171
172 * Tue Aug 31 1999 Cristian Gafton <gafton@redhat.com>
173 - added alpha patch from HJLu to fix the osf_sigprocmask interpretation
174
175 * Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
176 - update to 3.99.1.
177
178 * Wed Jun  2 1999 Jeff Johnson <jbj@redhat.com>
179 - add (the other :-) jj's sparc patch.
180
181 * Wed May 26 1999 Jeff Johnson <jbj@redhat.com>
182 - upgrade to 3.99 in order to
183 -    add new 2.2.x open flags (#2955).
184 -    add new 2.2.x syscalls (#2866).
185 - strace 3.1 patches carried along for now.
186
187 * Sun May 16 1999 Jeff Johnson <jbj@redhat.com>
188 - don't rely on (broken!) rpm %patch (#2735)
189
190 * Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
191 - strip binary
192
193 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
194 - auto rebuild in the new build environment (release 16)
195
196 * Tue Feb  9 1999 Jeff Johnson <jbj@redhat.com>
197 - vfork est arrive!
198
199 * Tue Feb  9 1999 Christopher Blizzard <blizzard@redhat.com>
200 - Add patch to follow clone() syscalls, too.
201
202 * Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
203 - patch to build alpha/sparc with glibc 2.1.
204
205 * Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
206 - patch to build on ARM
207
208 * Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
209 - fix typo (printf, not tprintf).
210
211 * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
212 - fix compile problem on sparc.
213
214 * Tue Aug 18 1998 Cristian Gafton <gafton@redhat.com>
215 - buildroot
216
217 * Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
218 - added the umoven patch from James Youngman <jay@gnu.org>
219 - fixed build problems on newer glibc releases
220
221 * Mon Jun 08 1998 Prospector System <bugs@redhat.com>
222 - translations modified for de, fr, tr