]> granicus.if.org Git - strace/blob - strace.spec
.
[strace] / strace.spec
1 Summary: Tracks and displays system calls associated with a running process.
2 Name: strace
3 Version: 4.5.8
4 Release: 1
5 License: BSD
6 Group: Development/Debuggers
7 URL: http://sourceforge.net/projects/strace/
8 Source0: %{name}-%{version}.tar.bz2
9 BuildRoot: %{_tmppath}/%{name}-root
10
11 %define strace64_arches ppc64
12
13 %description
14 The strace program intercepts and records the system calls called and
15 received by a running process.  Strace can print a record of each
16 system call, its arguments and its return value.  Strace is useful for
17 diagnosing problems and debugging, as well as for instructional
18 purposes.
19
20 Install strace if you need a tool to track the system calls made and
21 received by a process.
22
23 %ifarch %{strace64_arches}
24 %package -n strace64
25 Summary: Tracks and displays system calls associated with a running process.
26 Group: Development/Debuggers
27
28 %description -n strace64
29 The strace program intercepts and records the system calls called and
30 received by a running process.  Strace can print a record of each
31 system call, its arguments and its return value.  Strace is useful for
32 diagnosing problems and debugging, as well as for instructional
33 purposes.
34
35 Install strace if you need a tool to track the system calls made and
36 received by a process.
37
38 This package provides the `strace64' program to trace 64-bit processes.
39 The `strace' program in the `strace' package is for 32-bit processes.
40 %endif
41
42 %prep
43 %setup -q
44
45 %build
46 %configure
47 make
48
49 %install
50 rm -rf %{buildroot}
51 mkdir -p %{buildroot}%{_mandir}/man1
52 mkdir -p %{buildroot}%{_bindir}
53 %makeinstall man1dir=%{buildroot}%{_mandir}/man1
54
55 # remove unpackaged files from the buildroot
56 rm -f %{buildroot}%{_bindir}/strace-graph
57
58 %ifarch %{strace64_arches}
59 ln %{buildroot}%{_bindir}/strace %{buildroot}%{_bindir}/strace64
60 %endif
61
62 %clean
63 rm -rf %{buildroot}
64
65 %files
66 %defattr(-,root,root)
67 %{_bindir}/strace
68 %{_mandir}/man1/*
69
70 %ifarch %{strace64_arches}
71 %files -n strace64
72 %defattr(-,root,root)
73 %{_bindir}/strace64
74 %endif
75
76
77 %changelog
78 * Tue Oct 19 2004 Roland McGrath <roland@redhat.com> - 4.5.8-1
79 - fix multithreaded exit handling (#132150, #135254)
80 - fix ioctl name matching (#129808)
81 - print RTC_* ioctl structure contents (#58606)
82 - grok epoll_* syscalls (#134463)
83 - grok new RLIMIT_* values (#133594)
84 - print struct cmsghdr contents for sendmsg (#131689)
85 - fix clock_* and timer_* argument output (#131420)
86
87 * Tue Aug 31 2004 Roland McGrath <roland@redhat.com> - 4.5.7-2
88 - new upstream version, misc fixes and updates (#128091, #129166, #128391, #129378, #130965, #131177)
89
90 * Mon Jul 12 2004 Roland McGrath <roland@redhat.com> 4.5.6-1
91 - new upstream version, updates ioctl lists (#127398), fixes quotactl (#127393), more ioctl decoding (#126917)
92
93 * Sun Jun 27 2004 Roland McGrath <roland@redhat.com> 4.5.5-1
94 - new upstream version, fixes x86-64 biarch support (#126547)
95
96 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> 4.5.4-2
97 - rebuilt
98
99 * Thu Jun  3 2004 Roland McGrath <roland@redhat.com> 4.5.4-0.FC1
100 - rebuilt for FC1 update
101
102 * Thu Jun  3 2004 Roland McGrath <roland@redhat.com> 4.5.4-1
103 - new upstream version, more ioctls (#122257), minor fixes
104
105 * Fri Apr 16 2004 Roland McGrath <roland@redhat.com> 4.5.3-1
106 - new upstream version, mq_* calls (#120701), -p vs NPTL (#120462), more fixes (#118694, #120541, #118685)
107
108 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 4.5.2-1.1
109 - rebuilt
110
111 * Mon Mar  1 2004 Roland McGrath <roland@redhat.com> 4.5.2-1
112 - new upstream version, sched_* calls (#116990), show core flag (#112117)
113
114 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
115 - rebuilt
116
117 * Thu Nov 13 2003 Roland McGrath <roland@redhat.com> 4.5.1-1
118 - new upstream version, more fixes (#108012, #105366, #105359, #105358)
119
120 * Tue Sep 30 2003 Roland McGrath <roland@redhat.com> 4.5-3
121 - revert bogus s390 fix
122
123 * Thu Sep 25 2003 Roland McGrath <roland@redhat.com> 4.5-1.2.1AS
124 - rebuilt for 2.1AS erratum
125
126 * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-2
127 - rebuilt
128
129 * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-1
130 - new upstream version, more fixes (#101499, #104365)
131
132 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-2
133 - rebuilt
134
135 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-1
136 - new upstream version, groks more new system calls, PF_INET6 sockets
137
138 * Mon Jun 10 2003 Roland McGrath <roland@redhat.com> 4.4.98-1
139 - new upstream version, more fixes (#90754, #91085)
140
141 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
142 - rebuilt
143
144 * Sun Mar 30 2003 Roland McGrath <roland@redhat.com> 4.4.96-1
145 - new upstream version, handles yet more 2.5 syscalls, x86_64 & ia64 fixes
146
147 * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com> 4.4.95-2
148 - rebuilt
149
150 * Mon Feb 24 2003 Roland McGrath <roland@redhat.com> 4.4.95-1
151 - new upstream version, fixed getresuid/getresgid (#84959)
152
153 * Wed Feb 19 2003 Roland McGrath <roland@redhat.com> 4.4.94-1
154 - new upstream version, new option -E to set environment variables (#82392)
155
156 * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.4.93-2
157 - rebuilt
158
159 * Tue Jan 21 2003 Roland McGrath <roland@redhat.com> 4.4.93-1
160 - new upstream version, fixes ppc and s390 bugs, adds missing ptrace requests
161
162 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.91-1
163 - new upstream version, fixes -f on x86-64
164
165 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.90-1
166 - new upstream version, fixes all known bugs modulo ia64 and s390 issues
167
168 * Fri Jan 03 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.4-11
169 - add further s390 patch from IBM
170
171 * Wed Nov 27 2002 Tim Powers <timp@redhat.com> 4.4-10
172 - remove unpackaged files from the buildroot
173
174 * Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.4-9.1
175 - Added latest s390(x) patch.
176
177 * Fri Sep 06 2002 Karsten Hopp <karsten@redhat.de> 4.4-9
178 - preliminary x86_64 support with an ugly patch to help
179   debugging. Needs cleanup!
180
181 * Mon Sep  2 2002 Jakub Jelinek <jakub@redhat.com> 4.4-8
182 - newer version of the clone fixing patch (Roland McGrath)
183 - aio syscalls for i386/ia64/ppc (Ben LaHaise)
184
185 * Wed Aug 28 2002 Jakub Jelinek <jakub@redhat.com> 4.4-7
186 - fix strace -f (Roland McGrath, #68994)
187 - handle ?et_thread_area, SA_RESTORER (Ulrich Drepper)
188
189 * Fri Jun 21 2002 Jakub Jelinek <jakub@redhat.com> 4.4-6
190 - handle futexes, *xattr, sendfile64, etc. (Ulrich Drepper)
191 - handle modify_ldt (#66894)
192
193 * Thu May 23 2002 Tim Powers <timp@redhat.com>
194 - automated rebuild
195
196 * Tue Apr 16 2002 Jakub Jelinek <jakub@redhat.com> 4.4-4
197 - fix for the last patch by Jeff Law (#62591)
198
199 * Mon Mar  4 2002 Preston Brown <pbrown@redhat.com> 4.4-3
200 - integrate patch from Jeff Law to eliminate hang tracing threads
201
202 * Sat Feb 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
203 - minor update from debian tar-ball
204
205 * Wed Jan 02 2002 Florian La Roche <Florian.LaRoche@redhat.de>
206 - update to 4.4
207
208 * Sun Jul 22 2001 Florian La Roche <Florian.LaRoche@redhat.de>
209 - disable s390 patches, they are already included
210
211 * Wed Jul 18 2001 Preston Brown <pbrown@redhat.com> 4.3-1
212 - new upstream version.  Seems to have integrated most new syscalls
213 - tracing threaded programs is now functional.
214
215 * Mon Jun 11 2001 Than Ngo <than@redhat.com>
216 - port s390 patches from IBM
217
218 * Wed May 16 2001 Nalin Dahyabhai <nalin@redhat.com>
219 - modify new syscall patch to allocate enough heap space in setgroups32()
220
221 * Wed Feb 14 2001 Jakub Jelinek <jakub@redhat.com>
222 - #include <time.h> in addition to <sys/time.h>
223
224 * Fri Jan 26 2001 Karsten Hopp <karsten@redhat.com>
225 - clean up conflicting patches. This happened only
226   when building on S390
227
228 * Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
229 - update to CVS, reintegrate ia64 support
230
231 * Sat Dec  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
232 - Get S/390 support into the normal package
233
234 * Sat Nov 18 2000 Florian La Roche <Florian.LaRoche@redhat.de>
235 - added S/390 patch from IBM, adapting it to not conflict with
236   IA64 patch
237
238 * Sat Aug 19 2000 Jakub Jelinek <jakub@redhat.com>
239 - doh, actually apply the 2.4 syscalls patch
240 - make it compile with 2.4.0-test7-pre4+ headers, add
241   getdents64 and fcntl64
242
243 * Thu Aug  3 2000 Jakub Jelinek <jakub@redhat.com>
244 - add a bunch of new 2.4 syscalls (#14036)
245
246 * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
247 - automatic rebuild
248 - excludearch ia64
249
250 * Fri Jun  2 2000 Matt Wilson <msw@redhat.com>
251 - use buildinstall for FHS
252
253 * Wed May 24 2000 Jakub Jelinek <jakub@redhat.com>
254 - make things compile on sparc
255 - fix sigreturn on sparc
256
257 * Fri Mar 31 2000 Bill Nottingham <notting@redhat.com>
258 - fix stat64 misdef (#10485)
259
260 * Tue Mar 21 2000 Michael K. Johnson <johnsonm@redhat.com>
261 - added ia64 patch
262
263 * Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
264 - man pages are compressed
265 - version 4.2 (why are we keeping all these patches around?)
266
267 * Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
268 - update to 4.1 (with sparc socketcall patch).
269
270 * Fri Nov 12 1999 Jakub Jelinek <jakub@redhat.com>
271 - fix socketcall on sparc.
272
273 * Thu Sep 02 1999 Cristian Gafton <gafton@redhat.com>
274 - fix KERN_SECURELVL compile problem
275
276 * Tue Aug 31 1999 Cristian Gafton <gafton@redhat.com>
277 - added alpha patch from HJLu to fix the osf_sigprocmask interpretation
278
279 * Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
280 - update to 3.99.1.
281
282 * Wed Jun  2 1999 Jeff Johnson <jbj@redhat.com>
283 - add (the other :-) jj's sparc patch.
284
285 * Wed May 26 1999 Jeff Johnson <jbj@redhat.com>
286 - upgrade to 3.99 in order to
287 -    add new 2.2.x open flags (#2955).
288 -    add new 2.2.x syscalls (#2866).
289 - strace 3.1 patches carried along for now.
290
291 * Sun May 16 1999 Jeff Johnson <jbj@redhat.com>
292 - don't rely on (broken!) rpm %patch (#2735)
293
294 * Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
295 - strip binary
296
297 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
298 - auto rebuild in the new build environment (release 16)
299
300 * Tue Feb  9 1999 Jeff Johnson <jbj@redhat.com>
301 - vfork est arrive!
302
303 * Tue Feb  9 1999 Christopher Blizzard <blizzard@redhat.com>
304 - Add patch to follow clone() syscalls, too.
305
306 * Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
307 - patch to build alpha/sparc with glibc 2.1.
308
309 * Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
310 - patch to build on ARM
311
312 * Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
313 - fix typo (printf, not tprintf).
314
315 * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
316 - fix compile problem on sparc.
317
318 * Tue Aug 18 1998 Cristian Gafton <gafton@redhat.com>
319 - buildroot
320
321 * Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
322 - added the umoven patch from James Youngman <jay@gnu.org>
323 - fixed build problems on newer glibc releases
324
325 * Mon Jun 08 1998 Prospector System <bugs@redhat.com>
326 - translations modified for de, fr, tr