]> granicus.if.org Git - strace/blob - strace.spec
process.c: move get*uid and set*uid parsers to a separate file
[strace] / strace.spec
1 Summary: Tracks and displays system calls associated with a running process
2 Name: strace
3 Version: 4.9
4 Release: 1%{?dist}
5 License: BSD
6 Group: Development/Debuggers
7 URL: http://sourceforge.net/projects/strace/
8 Source: http://downloads.sourceforge.net/strace/%{name}-%{version}.tar.xz
9
10 BuildRequires: libacl-devel, libaio-devel, time
11
12 %define strace64_arches ppc64 sparc64
13
14 %description
15 The strace program intercepts and records the system calls called and
16 received by a running process.  Strace can print a record of each
17 system call, its arguments and its return value.  Strace is useful for
18 diagnosing problems and debugging, as well as for instructional
19 purposes.
20
21 Install strace if you need a tool to track the system calls made and
22 received by a process.
23
24 %ifarch %{strace64_arches}
25 %package -n strace64
26 Summary: Tracks and displays system calls associated with a running process.
27 Group: Development/Debuggers
28
29 %description -n strace64
30 The strace program intercepts and records the system calls called and
31 received by a running process.  Strace can print a record of each
32 system call, its arguments and its return value.  Strace is useful for
33 diagnosing problems and debugging, as well as for instructional
34 purposes.
35
36 Install strace if you need a tool to track the system calls made and
37 received by a process.
38
39 This package provides the `strace64' program to trace 64-bit processes.
40 The `strace' program in the `strace' package is for 32-bit processes.
41 %endif
42
43 %prep
44 %setup -q
45
46 %build
47 %configure
48 make %{?_smp_mflags}
49
50 %install
51 make DESTDIR=%{buildroot} install
52
53 # remove unpackaged files from the buildroot
54 rm -f %{buildroot}%{_bindir}/strace-graph
55
56 %define copy64 ln
57 %if 0%{?rhel}
58 %if 0%{?rhel} < 6
59 %endif
60 %define copy64 cp -p
61 %endif
62
63 %ifarch %{strace64_arches}
64 %{copy64} %{buildroot}%{_bindir}/strace %{buildroot}%{_bindir}/strace64
65 %endif
66
67 %check
68 make -k check VERBOSE=1
69
70 %files
71 %doc CREDITS ChangeLog ChangeLog-CVS COPYING NEWS README
72 %{_bindir}/strace
73 %{_bindir}/strace-log-merge
74 %{_mandir}/man1/*
75
76 %ifarch %{strace64_arches}
77 %files -n strace64
78 %{_bindir}/strace64
79 %endif
80
81 %changelog
82 * Fri Aug 15 2014 Dmitry V. Levin <ldv@altlinux.org> - 4.9-1
83 - New upstream release:
84   + fixed build when <sys/ptrace.h> and <linux/ptrace.h> conflict (#993384);
85   + updated CLOCK_* constants (#1088455);
86   + enabled ppc64le support (#1122323);
87   + fixed attach to a process on ppc64le (#1129569).
88
89 * Fri Jul 25 2014 Dan HorĂ¡k <dan[at]danny.cz> - 4.8-5
90 - update for ppc64
91
92 * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.8-4
93 - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
94
95 * Fri Dec  6 2013 Peter Robinson <pbrobinson@fedoraproject.org> 4.8-3
96 - Fix FTBFS
97
98 * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.8-2
99 - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
100
101 * Mon Jun 03 2013 Dmitry V. Levin <ldv@altlinux.org> - 4.8-1
102 - New upstream release:
103   + fixed ERESTARTNOINTR leaking to userspace on ancient kernels (#659382);
104   + fixed decoding of *xattr syscalls (#885233);
105   + fixed handling of files with 64-bit inode numbers by 32-bit strace (#912790);
106   + added aarch64 support (#969858).
107
108 * Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.7-3
109 - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
110
111 * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.7-2
112 - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
113
114 * Wed May 02 2012 Dmitry V. Levin <ldv@altlinux.org> 4.7-1
115 - New upstream release.
116   + implemented proper handling of real SIGTRAPs (#162774).
117
118 * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.6-2
119 - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
120
121 * Mon Mar 14 2011 Dmitry V. Levin <ldv@altlinux.org> - 4.6-1
122 - New upstream release.
123   + fixed a corner case in waitpid handling (#663547).
124
125 * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.20-2
126 - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
127
128 * Tue Apr 13 2010 Roland McGrath <roland@redhat.com> - 4.5.20-1
129 - New upstream release, work mostly by Andreas Schwab and Dmitry V. Levin.
130   + fixed potential stack buffer overflow in select decoder (#556678);
131   + fixed FTBFS (#539044).
132
133 * Wed Oct 21 2009 Roland McGrath <roland@redhat.com> - 4.5.19-1
134 - New upstream release, work mostly by Dmitry V. Levin <ldv@altlinux.org>
135   + exit/kill strace with traced process exitcode/signal (#105371);
136   + fixed build on ARM EABI (#507576);
137   + fixed display of 32-bit argv array on 64-bit architectures (#519480);
138   + fixed display of 32-bit fcntl(F_SETLK) on 64-bit architectures (#471169);
139   + fixed several bugs in strings decoder, including potential heap
140     memory corruption (#470529, #478324, #511035).
141
142 * Thu Aug 28 2008 Roland McGrath <roland@redhat.com> - 4.5.18-1
143 - build fix for newer kernel headers (#457291)
144 - fix CLONE_VFORK handling (#455078)
145 - Support new Linux/PPC system call subpage_prot and PROT_SAO flag.
146 - In sigaction system call, display sa_flags value along with SIG_DFL/SIG_IGN.
147
148 * Mon Jul 21 2008 Roland McGrath <roland@redhat.com> - 4.5.17-1
149 - handle O_CLOEXEC, MSG_CMSG_CLOEXEC (#365781)
150 - fix biarch stat64 decoding (#222275)
151 - fix spurious "..." in printing of environment strings (#358241)
152 - improve prctl decoding (#364401)
153 - fix hang wait on exited child with exited child (#354261)
154 - fix biarch fork/vfork (-f) tracing (#447475)
155 - fix biarch printing of negative argument kill (#430585)
156 - fix biarch decoding of error return values (#447587)
157 - fix -f tracing of CLONE_VFORK (#455078)
158 - fix ia64 register clobberation in -f tracing (#453438)
159 - print SO_NODEFER, SA_RESETHAND instead of SA_NOMASK, SA_ONESHOT (#455821)
160 - fix futex argument decoding (#448628, #448629)
161
162 * Fri Aug  3 2007 Roland McGrath <roland@redhat.com> - 4.5.16-1
163 - fix multithread issues (#240962, #240961, #247907)
164 - fix spurious SIGSTOP on early interrupt (#240986)
165 - fix utime for biarch (#247185)
166 - fix -u error message (#247170)
167 - better futex syscall printing (##241467)
168 - fix argv/envp printing with small -s settings, and for biarch
169 - new syscalls: getcpu, eventfd, timerfd, signalfd, epoll_pwait,
170   move_pages, utimensat
171
172 * Tue Jan 16 2007 Roland McGrath <roland@redhat.com> - 4.5.15-1
173 - biarch fixes (#179740, #192193, #171626, #173050, #218433, #218043)
174 - fix -ff -o behavior (#204950, #218435, #193808, #219423)
175 - better quotactl printing (#118696)
176 - *at, inotify*, pselect6, ppoll and unshare syscalls (#178633, #191275)
177 - glibc-2.5 build fixes (#209856)
178 - memory corruption fixes (#200621
179 - fix race in child setup under -f (#180293)
180 - show ipc key values in hex (#198179, #192182)
181 - disallow -c with -ff (#187847)
182 - Resolves: RHBZ #179740, RHBZ #192193, RHBZ #204950, RHBZ #218435
183 - Resolves: RHBZ #193808, RHBZ #219423, RHBZ #171626, RHBZ #173050
184 - Resolves: RHBZ #218433, RHBZ #218043, RHBZ #118696, RHBZ #178633
185 - Resolves: RHBZ #191275, RHBZ #209856, RHBZ #200621, RHBZ #180293
186 - Resolves: RHBZ #198179, RHBZ #198182, RHBZ #187847
187
188 * Mon Nov 20 2006 Jakub Jelinek <jakub@redhat.com> - 4.5.14-4
189 - Fix ia64 syscall decoding (#206768)
190 - Fix build with glibc-2.4.90-33 and up on all arches but ia64
191 - Fix build against 2.6.18+ headers
192
193 * Tue Aug 22 2006 Roland McGrath <roland@redhat.com> - 4.5.14-3
194 - Fix bogus decoding of syscalls >= 300 (#201462, #202620).
195
196 * Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-2
197 - rebuild
198
199 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.2
200 - bump again for long double bug on ppc{,64}
201
202 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.1
203 - rebuilt for new gcc4.1 snapshot and glibc changes
204
205 * Mon Jan 16 2006 Roland McGrath <roland@redhat.com> - 4.5.14-1
206 - Fix biarch decoding of socket syscalls (#174354).
207 - Fix biarch -e support (#173986).
208 - Accept numeric syscalls in -e (#174798).
209 - Fix ipc syscall decoding (#164755).
210 - Improve msgrcv printing (#164757).
211 - Man page updates (#165375).
212 - Improve mount syscall printing (#165377).
213 - Correct printing of restarting syscalls (#165469).
214
215 * Wed Aug  3 2005 Roland McGrath <roland@redhat.com> - 4.5.13-1
216 - Fix setsockopt decoding on 64-bit (#162449).
217 - Fix typos in socket option name strings (#161578).
218 - Display more IPV6 socket options by name (#162450).
219 - Don't display inappropriate syscalls for -e trace=file (#159340).
220 - New selector type -e trace=desc for file-descriptor using calls (#159400).
221 - Fix 32-bit old_mmap syscall decoding on x86-64 (#162467, #164215).
222 - Fix errors detaching from multithreaded process on interrupt (#161919).
223 - Note 4.5.12 fix for crash handling bad signal numbers (#162739).
224
225 * Wed Jun  8 2005 Roland McGrath <roland@redhat.com> - 4.5.12-1
226 - Fix known syscall recognition for IA32 processes on x86-64 (#158934).
227 - Fix bad output for ptrace on x86-64 (#159787).
228 - Fix potential buffer overruns (#151570, #159196).
229 - Make some diagnostics more consistent (#159308).
230 - Update PowerPC system calls.
231 - Better printing for Linux aio system calls.
232 - Don't truncate statfs64 fields to 32 bits in output (#158243).
233 - Cosmetic code cleanups (#159688).
234
235 * Tue Mar 22 2005 Roland McGrath <roland@redhat.com> - 4.5.11-1
236 - Build tweaks.
237 - Note 4.5.10 select fix (#151570).
238
239 * Mon Mar 14 2005 Roland McGrath <roland@redhat.com> - 4.5.10-1
240 - Fix select handling on nonstandard fd_set sizes.
241 - Don't print errors for null file name pointers.
242 - Fix initial execve output with -i (#143365).
243
244 * Fri Feb  4 2005 Roland McGrath <roland@redhat.com> - 4.5.9-2
245 - update ia64 syscall list (#146245)
246 - fix x86_64 syscall argument extraction for 32-bit processes (#146093)
247 - fix -e signal=NAME parsing (#143362)
248 - fix x86_64 exit_group syscall handling
249 - improve socket ioctl printing (#138223)
250 - code cleanups (#143369, #143370)
251 - improve mount flags printing (#141932)
252 - support symbolic printing of x86_64 arch_prctl parameters (#142667)
253 - fix potential crash in getxattr printing
254
255 * Tue Oct 19 2004 Roland McGrath <roland@redhat.com> - 4.5.8-1
256 - fix multithreaded exit handling (#132150, #135254)
257 - fix ioctl name matching (#129808)
258 - print RTC_* ioctl structure contents (#58606)
259 - grok epoll_* syscalls (#134463)
260 - grok new RLIMIT_* values (#133594)
261 - print struct cmsghdr contents for sendmsg (#131689)
262 - fix clock_* and timer_* argument output (#131420)
263
264 * Tue Aug 31 2004 Roland McGrath <roland@redhat.com> - 4.5.7-2
265 - new upstream version, misc fixes and updates (#128091, #129166, #128391, #129378, #130965, #131177)
266
267 * Mon Jul 12 2004 Roland McGrath <roland@redhat.com> 4.5.6-1
268 - new upstream version, updates ioctl lists (#127398), fixes quotactl (#127393), more ioctl decoding (#126917)
269
270 * Sun Jun 27 2004 Roland McGrath <roland@redhat.com> 4.5.5-1
271 - new upstream version, fixes x86-64 biarch support (#126547)
272
273 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> 4.5.4-2
274 - rebuilt
275
276 * Thu Jun  3 2004 Roland McGrath <roland@redhat.com> 4.5.4-0.FC1
277 - rebuilt for FC1 update
278
279 * Thu Jun  3 2004 Roland McGrath <roland@redhat.com> 4.5.4-1
280 - new upstream version, more ioctls (#122257), minor fixes
281
282 * Fri Apr 16 2004 Roland McGrath <roland@redhat.com> 4.5.3-1
283 - new upstream version, mq_* calls (#120701), -p vs NPTL (#120462), more fixes (#118694, #120541, #118685)
284
285 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 4.5.2-1.1
286 - rebuilt
287
288 * Mon Mar  1 2004 Roland McGrath <roland@redhat.com> 4.5.2-1
289 - new upstream version, sched_* calls (#116990), show core flag (#112117)
290
291 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
292 - rebuilt
293
294 * Thu Nov 13 2003 Roland McGrath <roland@redhat.com> 4.5.1-1
295 - new upstream version, more fixes (#108012, #105366, #105359, #105358)
296
297 * Tue Sep 30 2003 Roland McGrath <roland@redhat.com> 4.5-3
298 - revert bogus s390 fix
299
300 * Thu Sep 25 2003 Roland McGrath <roland@redhat.com> 4.5-1.2.1AS
301 - rebuilt for 2.1AS erratum
302
303 * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-2
304 - rebuilt
305
306 * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-1
307 - new upstream version, more fixes (#101499, #104365)
308
309 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-2
310 - rebuilt
311
312 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-1
313 - new upstream version, groks more new system calls, PF_INET6 sockets
314
315 * Tue Jun 10 2003 Roland McGrath <roland@redhat.com> 4.4.98-1
316 - new upstream version, more fixes (#90754, #91085)
317
318 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
319 - rebuilt
320
321 * Sun Mar 30 2003 Roland McGrath <roland@redhat.com> 4.4.96-1
322 - new upstream version, handles yet more 2.5 syscalls, x86_64 & ia64 fixes
323
324 * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com> 4.4.95-2
325 - rebuilt
326
327 * Mon Feb 24 2003 Roland McGrath <roland@redhat.com> 4.4.95-1
328 - new upstream version, fixed getresuid/getresgid (#84959)
329
330 * Wed Feb 19 2003 Roland McGrath <roland@redhat.com> 4.4.94-1
331 - new upstream version, new option -E to set environment variables (#82392)
332
333 * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.4.93-2
334 - rebuilt
335
336 * Tue Jan 21 2003 Roland McGrath <roland@redhat.com> 4.4.93-1
337 - new upstream version, fixes ppc and s390 bugs, adds missing ptrace requests
338
339 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.91-1
340 - new upstream version, fixes -f on x86-64
341
342 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.90-1
343 - new upstream version, fixes all known bugs modulo ia64 and s390 issues
344
345 * Fri Jan 03 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.4-11
346 - add further s390 patch from IBM
347
348 * Wed Nov 27 2002 Tim Powers <timp@redhat.com> 4.4-10
349 - remove unpackaged files from the buildroot
350
351 * Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.4-9.1
352 - Added latest s390(x) patch.
353
354 * Fri Sep 06 2002 Karsten Hopp <karsten@redhat.de> 4.4-9
355 - preliminary x86_64 support with an ugly patch to help
356   debugging. Needs cleanup!
357
358 * Mon Sep  2 2002 Jakub Jelinek <jakub@redhat.com> 4.4-8
359 - newer version of the clone fixing patch (Roland McGrath)
360 - aio syscalls for i386/ia64/ppc (Ben LaHaise)
361
362 * Wed Aug 28 2002 Jakub Jelinek <jakub@redhat.com> 4.4-7
363 - fix strace -f (Roland McGrath, #68994)
364 - handle ?et_thread_area, SA_RESTORER (Ulrich Drepper)
365
366 * Fri Jun 21 2002 Jakub Jelinek <jakub@redhat.com> 4.4-6
367 - handle futexes, *xattr, sendfile64, etc. (Ulrich Drepper)
368 - handle modify_ldt (#66894)
369
370 * Thu May 23 2002 Tim Powers <timp@redhat.com>
371 - automated rebuild
372
373 * Tue Apr 16 2002 Jakub Jelinek <jakub@redhat.com> 4.4-4
374 - fix for the last patch by Jeff Law (#62591)
375
376 * Mon Mar  4 2002 Preston Brown <pbrown@redhat.com> 4.4-3
377 - integrate patch from Jeff Law to eliminate hang tracing threads
378
379 * Sat Feb 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
380 - minor update from debian tar-ball
381
382 * Wed Jan 02 2002 Florian La Roche <Florian.LaRoche@redhat.de>
383 - update to 4.4
384
385 * Sun Jul 22 2001 Florian La Roche <Florian.LaRoche@redhat.de>
386 - disable s390 patches, they are already included
387
388 * Wed Jul 18 2001 Preston Brown <pbrown@redhat.com> 4.3-1
389 - new upstream version.  Seems to have integrated most new syscalls
390 - tracing threaded programs is now functional.
391
392 * Mon Jun 11 2001 Than Ngo <than@redhat.com>
393 - port s390 patches from IBM
394
395 * Wed May 16 2001 Nalin Dahyabhai <nalin@redhat.com>
396 - modify new syscall patch to allocate enough heap space in setgroups32()
397
398 * Wed Feb 14 2001 Jakub Jelinek <jakub@redhat.com>
399 - #include <time.h> in addition to <sys/time.h>
400
401 * Fri Jan 26 2001 Karsten Hopp <karsten@redhat.com>
402 - clean up conflicting patches. This happened only
403   when building on S390
404
405 * Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
406 - update to CVS, reintegrate ia64 support
407
408 * Fri Dec  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
409 - Get S/390 support into the normal package
410
411 * Sat Nov 18 2000 Florian La Roche <Florian.LaRoche@redhat.de>
412 - added S/390 patch from IBM, adapting it to not conflict with
413   IA64 patch
414
415 * Sat Aug 19 2000 Jakub Jelinek <jakub@redhat.com>
416 - doh, actually apply the 2.4 syscalls patch
417 - make it compile with 2.4.0-test7-pre4+ headers, add
418   getdents64 and fcntl64
419
420 * Thu Aug  3 2000 Jakub Jelinek <jakub@redhat.com>
421 - add a bunch of new 2.4 syscalls (#14036)
422
423 * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
424 - automatic rebuild
425 - excludearch ia64
426
427 * Fri Jun  2 2000 Matt Wilson <msw@redhat.com>
428 - use buildinstall for FHS
429
430 * Wed May 24 2000 Jakub Jelinek <jakub@redhat.com>
431 - make things compile on sparc
432 - fix sigreturn on sparc
433
434 * Fri Mar 31 2000 Bill Nottingham <notting@redhat.com>
435 - fix stat64 misdef (#10485)
436
437 * Tue Mar 21 2000 Michael K. Johnson <johnsonm@redhat.com>
438 - added ia64 patch
439
440 * Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
441 - man pages are compressed
442 - version 4.2 (why are we keeping all these patches around?)
443
444 * Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
445 - update to 4.1 (with sparc socketcall patch).
446
447 * Fri Nov 12 1999 Jakub Jelinek <jakub@redhat.com>
448 - fix socketcall on sparc.
449
450 * Thu Sep 02 1999 Cristian Gafton <gafton@redhat.com>
451 - fix KERN_SECURELVL compile problem
452
453 * Tue Aug 31 1999 Cristian Gafton <gafton@redhat.com>
454 - added alpha patch from HJLu to fix the osf_sigprocmask interpretation
455
456 * Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
457 - update to 3.99.1.
458
459 * Wed Jun  2 1999 Jeff Johnson <jbj@redhat.com>
460 - add (the other :-) jj's sparc patch.
461
462 * Wed May 26 1999 Jeff Johnson <jbj@redhat.com>
463 - upgrade to 3.99 in order to
464 -    add new 2.2.x open flags (#2955).
465 -    add new 2.2.x syscalls (#2866).
466 - strace 3.1 patches carried along for now.
467
468 * Sun May 16 1999 Jeff Johnson <jbj@redhat.com>
469 - don't rely on (broken!) rpm %%patch (#2735)
470
471 * Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
472 - strip binary
473
474 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
475 - auto rebuild in the new build environment (release 16)
476
477 * Tue Feb  9 1999 Jeff Johnson <jbj@redhat.com>
478 - vfork est arrive!
479
480 * Tue Feb  9 1999 Christopher Blizzard <blizzard@redhat.com>
481 - Add patch to follow clone() syscalls, too.
482
483 * Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
484 - patch to build alpha/sparc with glibc 2.1.
485
486 * Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
487 - patch to build on ARM
488
489 * Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
490 - fix typo (printf, not tprintf).
491
492 * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
493 - fix compile problem on sparc.
494
495 * Tue Aug 18 1998 Cristian Gafton <gafton@redhat.com>
496 - buildroot
497
498 * Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
499 - added the umoven patch from James Youngman <jay@gnu.org>
500 - fixed build problems on newer glibc releases
501
502 * Mon Jun 08 1998 Prospector System <bugs@redhat.com>
503 - translations modified for de, fr, tr