]> granicus.if.org Git - strace/blob - strace.spec
2004-07-12 Dmitry V. Levin <ldv@altlinux.org>
[strace] / strace.spec
1 Summary: Tracks and displays system calls associated with a running process.
2 Name: strace
3 Version: 4.5.6
4 Release: 1
5 License: BSD
6 Group: Development/Debuggers
7 URL: http://sourceforge.net/projects/strace/
8 Source0: %{name}-%{version}.tar.bz2
9 BuildRoot: %{_tmppath}/%{name}-root
10
11 %define strace64_arches ppc64
12
13 %description
14 The strace program intercepts and records the system calls called and
15 received by a running process.  Strace can print a record of each
16 system call, its arguments and its return value.  Strace is useful for
17 diagnosing problems and debugging, as well as for instructional
18 purposes.
19
20 Install strace if you need a tool to track the system calls made and
21 received by a process.
22
23 %ifarch %{strace64_arches}
24 %package -n strace64
25 Summary: Tracks and displays system calls associated with a running process.
26 Group: Development/Debuggers
27
28 %description -n strace64
29 The strace program intercepts and records the system calls called and
30 received by a running process.  Strace can print a record of each
31 system call, its arguments and its return value.  Strace is useful for
32 diagnosing problems and debugging, as well as for instructional
33 purposes.
34
35 Install strace if you need a tool to track the system calls made and
36 received by a process.
37
38 This package provides the `strace64' program to trace 64-bit processes.
39 The `strace' program in the `strace' package is for 32-bit processes.
40 %endif
41
42 %prep
43 %setup -q
44
45 %build
46 %configure
47 make
48
49 %install
50 rm -rf %{buildroot}
51 mkdir -p %{buildroot}%{_mandir}/man1
52 mkdir -p %{buildroot}%{_bindir}
53 %makeinstall man1dir=%{buildroot}%{_mandir}/man1
54
55 # remove unpackaged files from the buildroot
56 rm -f %{buildroot}%{_bindir}/strace-graph
57
58 %ifarch %{strace64_arches}
59 ln %{buildroot}%{_bindir}/strace %{buildroot}%{_bindir}/strace64
60 %endif
61
62 %clean
63 rm -rf %{buildroot}
64
65 %files
66 %defattr(-,root,root)
67 %{_bindir}/strace
68 %{_mandir}/man1/*
69
70 %ifarch %{strace64_arches}
71 %files -n strace64
72 %defattr(-,root,root)
73 %{_bindir}/strace64
74 %endif
75
76
77 %changelog
78 * Mon Jul 12 2004 Roland McGrath <roland@redhat.com> 4.5.6-1
79 - new upstream version, updates ioctl lists (#127398), fixes quotactl (#127393), more ioctl decoding (#126917)
80
81 * Sun Jun 27 2004 Roland McGrath <roland@redhat.com> 4.5.5-1
82 - new upstream version, fixes x86-64 biarch support (#126547)
83
84 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> 4.5.4-2
85 - rebuilt
86
87 * Thu Jun  3 2004 Roland McGrath <roland@redhat.com> 4.5.4-0.FC1
88 - rebuilt for FC1 update
89
90 * Thu Jun  3 2004 Roland McGrath <roland@redhat.com> 4.5.4-1
91 - new upstream version, more ioctls (#122257), minor fixes
92
93 * Fri Apr 16 2004 Roland McGrath <roland@redhat.com> 4.5.3-1
94 - new upstream version, mq_* calls (#120701), -p vs NPTL (#120462), more fixes (#118694, #120541, #118685)
95
96 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 4.5.2-1.1
97 - rebuilt
98
99 * Mon Mar  1 2004 Roland McGrath <roland@redhat.com> 4.5.2-1
100 - new upstream version, sched_* calls (#116990), show core flag (#112117)
101
102 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
103 - rebuilt
104
105 * Thu Nov 13 2003 Roland McGrath <roland@redhat.com> 4.5.1-1
106 - new upstream version, more fixes (#108012, #105366, #105359, #105358)
107
108 * Tue Sep 30 2003 Roland McGrath <roland@redhat.com> 4.5-3
109 - revert bogus s390 fix
110
111 * Thu Sep 25 2003 Roland McGrath <roland@redhat.com> 4.5-1.2.1AS
112 - rebuilt for 2.1AS erratum
113
114 * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-2
115 - rebuilt
116
117 * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-1
118 - new upstream version, more fixes (#101499, #104365)
119
120 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-2
121 - rebuilt
122
123 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-1
124 - new upstream version, groks more new system calls, PF_INET6 sockets
125
126 * Mon Jun 10 2003 Roland McGrath <roland@redhat.com> 4.4.98-1
127 - new upstream version, more fixes (#90754, #91085)
128
129 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
130 - rebuilt
131
132 * Sun Mar 30 2003 Roland McGrath <roland@redhat.com> 4.4.96-1
133 - new upstream version, handles yet more 2.5 syscalls, x86_64 & ia64 fixes
134
135 * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com> 4.4.95-2
136 - rebuilt
137
138 * Mon Feb 24 2003 Roland McGrath <roland@redhat.com> 4.4.95-1
139 - new upstream version, fixed getresuid/getresgid (#84959)
140
141 * Wed Feb 19 2003 Roland McGrath <roland@redhat.com> 4.4.94-1
142 - new upstream version, new option -E to set environment variables (#82392)
143
144 * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.4.93-2
145 - rebuilt
146
147 * Tue Jan 21 2003 Roland McGrath <roland@redhat.com> 4.4.93-1
148 - new upstream version, fixes ppc and s390 bugs, adds missing ptrace requests
149
150 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.91-1
151 - new upstream version, fixes -f on x86-64
152
153 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.90-1
154 - new upstream version, fixes all known bugs modulo ia64 and s390 issues
155
156 * Fri Jan 03 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.4-11
157 - add further s390 patch from IBM
158
159 * Wed Nov 27 2002 Tim Powers <timp@redhat.com> 4.4-10
160 - remove unpackaged files from the buildroot
161
162 * Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.4-9.1
163 - Added latest s390(x) patch.
164
165 * Fri Sep 06 2002 Karsten Hopp <karsten@redhat.de> 4.4-9
166 - preliminary x86_64 support with an ugly patch to help
167   debugging. Needs cleanup!
168
169 * Mon Sep  2 2002 Jakub Jelinek <jakub@redhat.com> 4.4-8
170 - newer version of the clone fixing patch (Roland McGrath)
171 - aio syscalls for i386/ia64/ppc (Ben LaHaise)
172
173 * Wed Aug 28 2002 Jakub Jelinek <jakub@redhat.com> 4.4-7
174 - fix strace -f (Roland McGrath, #68994)
175 - handle ?et_thread_area, SA_RESTORER (Ulrich Drepper)
176
177 * Fri Jun 21 2002 Jakub Jelinek <jakub@redhat.com> 4.4-6
178 - handle futexes, *xattr, sendfile64, etc. (Ulrich Drepper)
179 - handle modify_ldt (#66894)
180
181 * Thu May 23 2002 Tim Powers <timp@redhat.com>
182 - automated rebuild
183
184 * Tue Apr 16 2002 Jakub Jelinek <jakub@redhat.com> 4.4-4
185 - fix for the last patch by Jeff Law (#62591)
186
187 * Mon Mar  4 2002 Preston Brown <pbrown@redhat.com> 4.4-3
188 - integrate patch from Jeff Law to eliminate hang tracing threads
189
190 * Sat Feb 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
191 - minor update from debian tar-ball
192
193 * Wed Jan 02 2002 Florian La Roche <Florian.LaRoche@redhat.de>
194 - update to 4.4
195
196 * Sun Jul 22 2001 Florian La Roche <Florian.LaRoche@redhat.de>
197 - disable s390 patches, they are already included
198
199 * Wed Jul 18 2001 Preston Brown <pbrown@redhat.com> 4.3-1
200 - new upstream version.  Seems to have integrated most new syscalls
201 - tracing threaded programs is now functional.
202
203 * Mon Jun 11 2001 Than Ngo <than@redhat.com>
204 - port s390 patches from IBM
205
206 * Wed May 16 2001 Nalin Dahyabhai <nalin@redhat.com>
207 - modify new syscall patch to allocate enough heap space in setgroups32()
208
209 * Wed Feb 14 2001 Jakub Jelinek <jakub@redhat.com>
210 - #include <time.h> in addition to <sys/time.h>
211
212 * Fri Jan 26 2001 Karsten Hopp <karsten@redhat.com>
213 - clean up conflicting patches. This happened only
214   when building on S390
215
216 * Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
217 - update to CVS, reintegrate ia64 support
218
219 * Sat Dec  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
220 - Get S/390 support into the normal package
221
222 * Sat Nov 18 2000 Florian La Roche <Florian.LaRoche@redhat.de>
223 - added S/390 patch from IBM, adapting it to not conflict with
224   IA64 patch
225
226 * Sat Aug 19 2000 Jakub Jelinek <jakub@redhat.com>
227 - doh, actually apply the 2.4 syscalls patch
228 - make it compile with 2.4.0-test7-pre4+ headers, add
229   getdents64 and fcntl64
230
231 * Thu Aug  3 2000 Jakub Jelinek <jakub@redhat.com>
232 - add a bunch of new 2.4 syscalls (#14036)
233
234 * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
235 - automatic rebuild
236 - excludearch ia64
237
238 * Fri Jun  2 2000 Matt Wilson <msw@redhat.com>
239 - use buildinstall for FHS
240
241 * Wed May 24 2000 Jakub Jelinek <jakub@redhat.com>
242 - make things compile on sparc
243 - fix sigreturn on sparc
244
245 * Fri Mar 31 2000 Bill Nottingham <notting@redhat.com>
246 - fix stat64 misdef (#10485)
247
248 * Tue Mar 21 2000 Michael K. Johnson <johnsonm@redhat.com>
249 - added ia64 patch
250
251 * Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
252 - man pages are compressed
253 - version 4.2 (why are we keeping all these patches around?)
254
255 * Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
256 - update to 4.1 (with sparc socketcall patch).
257
258 * Fri Nov 12 1999 Jakub Jelinek <jakub@redhat.com>
259 - fix socketcall on sparc.
260
261 * Thu Sep 02 1999 Cristian Gafton <gafton@redhat.com>
262 - fix KERN_SECURELVL compile problem
263
264 * Tue Aug 31 1999 Cristian Gafton <gafton@redhat.com>
265 - added alpha patch from HJLu to fix the osf_sigprocmask interpretation
266
267 * Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
268 - update to 3.99.1.
269
270 * Wed Jun  2 1999 Jeff Johnson <jbj@redhat.com>
271 - add (the other :-) jj's sparc patch.
272
273 * Wed May 26 1999 Jeff Johnson <jbj@redhat.com>
274 - upgrade to 3.99 in order to
275 -    add new 2.2.x open flags (#2955).
276 -    add new 2.2.x syscalls (#2866).
277 - strace 3.1 patches carried along for now.
278
279 * Sun May 16 1999 Jeff Johnson <jbj@redhat.com>
280 - don't rely on (broken!) rpm %patch (#2735)
281
282 * Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
283 - strip binary
284
285 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
286 - auto rebuild in the new build environment (release 16)
287
288 * Tue Feb  9 1999 Jeff Johnson <jbj@redhat.com>
289 - vfork est arrive!
290
291 * Tue Feb  9 1999 Christopher Blizzard <blizzard@redhat.com>
292 - Add patch to follow clone() syscalls, too.
293
294 * Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
295 - patch to build alpha/sparc with glibc 2.1.
296
297 * Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
298 - patch to build on ARM
299
300 * Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
301 - fix typo (printf, not tprintf).
302
303 * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
304 - fix compile problem on sparc.
305
306 * Tue Aug 18 1998 Cristian Gafton <gafton@redhat.com>
307 - buildroot
308
309 * Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
310 - added the umoven patch from James Youngman <jay@gnu.org>
311 - fixed build problems on newer glibc releases
312
313 * Mon Jun 08 1998 Prospector System <bugs@redhat.com>
314 - translations modified for de, fr, tr