]> granicus.if.org Git - strace/blob - strace.spec
.
[strace] / strace.spec
1 Summary: Tracks and displays system calls associated with a running process.
2 Name: strace
3 Version: 4.5.9
4 Release: 2
5 License: BSD
6 Group: Development/Debuggers
7 URL: http://sourceforge.net/projects/strace/
8 Source0: %{name}-%{version}.tar.bz2
9 BuildRoot: %{_tmppath}/%{name}-root
10
11 %define strace64_arches ppc64
12
13 %description
14 The strace program intercepts and records the system calls called and
15 received by a running process.  Strace can print a record of each
16 system call, its arguments and its return value.  Strace is useful for
17 diagnosing problems and debugging, as well as for instructional
18 purposes.
19
20 Install strace if you need a tool to track the system calls made and
21 received by a process.
22
23 %ifarch %{strace64_arches}
24 %package -n strace64
25 Summary: Tracks and displays system calls associated with a running process.
26 Group: Development/Debuggers
27
28 %description -n strace64
29 The strace program intercepts and records the system calls called and
30 received by a running process.  Strace can print a record of each
31 system call, its arguments and its return value.  Strace is useful for
32 diagnosing problems and debugging, as well as for instructional
33 purposes.
34
35 Install strace if you need a tool to track the system calls made and
36 received by a process.
37
38 This package provides the `strace64' program to trace 64-bit processes.
39 The `strace' program in the `strace' package is for 32-bit processes.
40 %endif
41
42 %prep
43 %setup -q
44
45 %build
46 %configure
47 make
48
49 %install
50 rm -rf %{buildroot}
51 mkdir -p %{buildroot}%{_mandir}/man1
52 mkdir -p %{buildroot}%{_bindir}
53 %makeinstall man1dir=%{buildroot}%{_mandir}/man1
54
55 # remove unpackaged files from the buildroot
56 rm -f %{buildroot}%{_bindir}/strace-graph
57
58 %ifarch %{strace64_arches}
59 ln %{buildroot}%{_bindir}/strace %{buildroot}%{_bindir}/strace64
60 %endif
61
62 %clean
63 rm -rf %{buildroot}
64
65 %files
66 %defattr(-,root,root)
67 %{_bindir}/strace
68 %{_mandir}/man1/*
69
70 %ifarch %{strace64_arches}
71 %files -n strace64
72 %defattr(-,root,root)
73 %{_bindir}/strace64
74 %endif
75
76
77 %changelog
78 * Fri Feb  4 2005 Roland McGrath <roland@redhat.com> - 4.5.9-2
79 - update ia64 syscall list (#146245)
80 - fix x86_64 syscall argument extraction for 32-bit processes (#146093)
81 - fix -e signal=NAME parsing (#143362)
82 - fix x86_64 exit_group syscall handling
83 - improve socket ioctl printing (#138223)
84 - code cleanups (#143369, #143370)
85 - improve mount flags printing (#141932)
86 - support symbolic printing of x86_64 arch_prctl parameters (#142667)
87 - fix potential crash in getxattr printing
88
89 * Tue Oct 19 2004 Roland McGrath <roland@redhat.com> - 4.5.8-1
90 - fix multithreaded exit handling (#132150, #135254)
91 - fix ioctl name matching (#129808)
92 - print RTC_* ioctl structure contents (#58606)
93 - grok epoll_* syscalls (#134463)
94 - grok new RLIMIT_* values (#133594)
95 - print struct cmsghdr contents for sendmsg (#131689)
96 - fix clock_* and timer_* argument output (#131420)
97
98 * Tue Aug 31 2004 Roland McGrath <roland@redhat.com> - 4.5.7-2
99 - new upstream version, misc fixes and updates (#128091, #129166, #128391, #129378, #130965, #131177)
100
101 * Mon Jul 12 2004 Roland McGrath <roland@redhat.com> 4.5.6-1
102 - new upstream version, updates ioctl lists (#127398), fixes quotactl (#127393), more ioctl decoding (#126917)
103
104 * Sun Jun 27 2004 Roland McGrath <roland@redhat.com> 4.5.5-1
105 - new upstream version, fixes x86-64 biarch support (#126547)
106
107 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> 4.5.4-2
108 - rebuilt
109
110 * Thu Jun  3 2004 Roland McGrath <roland@redhat.com> 4.5.4-0.FC1
111 - rebuilt for FC1 update
112
113 * Thu Jun  3 2004 Roland McGrath <roland@redhat.com> 4.5.4-1
114 - new upstream version, more ioctls (#122257), minor fixes
115
116 * Fri Apr 16 2004 Roland McGrath <roland@redhat.com> 4.5.3-1
117 - new upstream version, mq_* calls (#120701), -p vs NPTL (#120462), more fixes (#118694, #120541, #118685)
118
119 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 4.5.2-1.1
120 - rebuilt
121
122 * Mon Mar  1 2004 Roland McGrath <roland@redhat.com> 4.5.2-1
123 - new upstream version, sched_* calls (#116990), show core flag (#112117)
124
125 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
126 - rebuilt
127
128 * Thu Nov 13 2003 Roland McGrath <roland@redhat.com> 4.5.1-1
129 - new upstream version, more fixes (#108012, #105366, #105359, #105358)
130
131 * Tue Sep 30 2003 Roland McGrath <roland@redhat.com> 4.5-3
132 - revert bogus s390 fix
133
134 * Thu Sep 25 2003 Roland McGrath <roland@redhat.com> 4.5-1.2.1AS
135 - rebuilt for 2.1AS erratum
136
137 * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-2
138 - rebuilt
139
140 * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-1
141 - new upstream version, more fixes (#101499, #104365)
142
143 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-2
144 - rebuilt
145
146 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-1
147 - new upstream version, groks more new system calls, PF_INET6 sockets
148
149 * Mon Jun 10 2003 Roland McGrath <roland@redhat.com> 4.4.98-1
150 - new upstream version, more fixes (#90754, #91085)
151
152 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
153 - rebuilt
154
155 * Sun Mar 30 2003 Roland McGrath <roland@redhat.com> 4.4.96-1
156 - new upstream version, handles yet more 2.5 syscalls, x86_64 & ia64 fixes
157
158 * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com> 4.4.95-2
159 - rebuilt
160
161 * Mon Feb 24 2003 Roland McGrath <roland@redhat.com> 4.4.95-1
162 - new upstream version, fixed getresuid/getresgid (#84959)
163
164 * Wed Feb 19 2003 Roland McGrath <roland@redhat.com> 4.4.94-1
165 - new upstream version, new option -E to set environment variables (#82392)
166
167 * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.4.93-2
168 - rebuilt
169
170 * Tue Jan 21 2003 Roland McGrath <roland@redhat.com> 4.4.93-1
171 - new upstream version, fixes ppc and s390 bugs, adds missing ptrace requests
172
173 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.91-1
174 - new upstream version, fixes -f on x86-64
175
176 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.90-1
177 - new upstream version, fixes all known bugs modulo ia64 and s390 issues
178
179 * Fri Jan 03 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.4-11
180 - add further s390 patch from IBM
181
182 * Wed Nov 27 2002 Tim Powers <timp@redhat.com> 4.4-10
183 - remove unpackaged files from the buildroot
184
185 * Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.4-9.1
186 - Added latest s390(x) patch.
187
188 * Fri Sep 06 2002 Karsten Hopp <karsten@redhat.de> 4.4-9
189 - preliminary x86_64 support with an ugly patch to help
190   debugging. Needs cleanup!
191
192 * Mon Sep  2 2002 Jakub Jelinek <jakub@redhat.com> 4.4-8
193 - newer version of the clone fixing patch (Roland McGrath)
194 - aio syscalls for i386/ia64/ppc (Ben LaHaise)
195
196 * Wed Aug 28 2002 Jakub Jelinek <jakub@redhat.com> 4.4-7
197 - fix strace -f (Roland McGrath, #68994)
198 - handle ?et_thread_area, SA_RESTORER (Ulrich Drepper)
199
200 * Fri Jun 21 2002 Jakub Jelinek <jakub@redhat.com> 4.4-6
201 - handle futexes, *xattr, sendfile64, etc. (Ulrich Drepper)
202 - handle modify_ldt (#66894)
203
204 * Thu May 23 2002 Tim Powers <timp@redhat.com>
205 - automated rebuild
206
207 * Tue Apr 16 2002 Jakub Jelinek <jakub@redhat.com> 4.4-4
208 - fix for the last patch by Jeff Law (#62591)
209
210 * Mon Mar  4 2002 Preston Brown <pbrown@redhat.com> 4.4-3
211 - integrate patch from Jeff Law to eliminate hang tracing threads
212
213 * Sat Feb 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
214 - minor update from debian tar-ball
215
216 * Wed Jan 02 2002 Florian La Roche <Florian.LaRoche@redhat.de>
217 - update to 4.4
218
219 * Sun Jul 22 2001 Florian La Roche <Florian.LaRoche@redhat.de>
220 - disable s390 patches, they are already included
221
222 * Wed Jul 18 2001 Preston Brown <pbrown@redhat.com> 4.3-1
223 - new upstream version.  Seems to have integrated most new syscalls
224 - tracing threaded programs is now functional.
225
226 * Mon Jun 11 2001 Than Ngo <than@redhat.com>
227 - port s390 patches from IBM
228
229 * Wed May 16 2001 Nalin Dahyabhai <nalin@redhat.com>
230 - modify new syscall patch to allocate enough heap space in setgroups32()
231
232 * Wed Feb 14 2001 Jakub Jelinek <jakub@redhat.com>
233 - #include <time.h> in addition to <sys/time.h>
234
235 * Fri Jan 26 2001 Karsten Hopp <karsten@redhat.com>
236 - clean up conflicting patches. This happened only
237   when building on S390
238
239 * Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
240 - update to CVS, reintegrate ia64 support
241
242 * Sat Dec  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
243 - Get S/390 support into the normal package
244
245 * Sat Nov 18 2000 Florian La Roche <Florian.LaRoche@redhat.de>
246 - added S/390 patch from IBM, adapting it to not conflict with
247   IA64 patch
248
249 * Sat Aug 19 2000 Jakub Jelinek <jakub@redhat.com>
250 - doh, actually apply the 2.4 syscalls patch
251 - make it compile with 2.4.0-test7-pre4+ headers, add
252   getdents64 and fcntl64
253
254 * Thu Aug  3 2000 Jakub Jelinek <jakub@redhat.com>
255 - add a bunch of new 2.4 syscalls (#14036)
256
257 * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
258 - automatic rebuild
259 - excludearch ia64
260
261 * Fri Jun  2 2000 Matt Wilson <msw@redhat.com>
262 - use buildinstall for FHS
263
264 * Wed May 24 2000 Jakub Jelinek <jakub@redhat.com>
265 - make things compile on sparc
266 - fix sigreturn on sparc
267
268 * Fri Mar 31 2000 Bill Nottingham <notting@redhat.com>
269 - fix stat64 misdef (#10485)
270
271 * Tue Mar 21 2000 Michael K. Johnson <johnsonm@redhat.com>
272 - added ia64 patch
273
274 * Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
275 - man pages are compressed
276 - version 4.2 (why are we keeping all these patches around?)
277
278 * Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
279 - update to 4.1 (with sparc socketcall patch).
280
281 * Fri Nov 12 1999 Jakub Jelinek <jakub@redhat.com>
282 - fix socketcall on sparc.
283
284 * Thu Sep 02 1999 Cristian Gafton <gafton@redhat.com>
285 - fix KERN_SECURELVL compile problem
286
287 * Tue Aug 31 1999 Cristian Gafton <gafton@redhat.com>
288 - added alpha patch from HJLu to fix the osf_sigprocmask interpretation
289
290 * Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
291 - update to 3.99.1.
292
293 * Wed Jun  2 1999 Jeff Johnson <jbj@redhat.com>
294 - add (the other :-) jj's sparc patch.
295
296 * Wed May 26 1999 Jeff Johnson <jbj@redhat.com>
297 - upgrade to 3.99 in order to
298 -    add new 2.2.x open flags (#2955).
299 -    add new 2.2.x syscalls (#2866).
300 - strace 3.1 patches carried along for now.
301
302 * Sun May 16 1999 Jeff Johnson <jbj@redhat.com>
303 - don't rely on (broken!) rpm %patch (#2735)
304
305 * Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
306 - strip binary
307
308 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
309 - auto rebuild in the new build environment (release 16)
310
311 * Tue Feb  9 1999 Jeff Johnson <jbj@redhat.com>
312 - vfork est arrive!
313
314 * Tue Feb  9 1999 Christopher Blizzard <blizzard@redhat.com>
315 - Add patch to follow clone() syscalls, too.
316
317 * Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
318 - patch to build alpha/sparc with glibc 2.1.
319
320 * Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
321 - patch to build on ARM
322
323 * Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
324 - fix typo (printf, not tprintf).
325
326 * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
327 - fix compile problem on sparc.
328
329 * Tue Aug 18 1998 Cristian Gafton <gafton@redhat.com>
330 - buildroot
331
332 * Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
333 - added the umoven patch from James Youngman <jay@gnu.org>
334 - fixed build problems on newer glibc releases
335
336 * Mon Jun 08 1998 Prospector System <bugs@redhat.com>
337 - translations modified for de, fr, tr