]> granicus.if.org Git - strace/blob - strace.spec
2006-01-12 Roland McGrath <roland@redhat.com>
[strace] / strace.spec
1 Summary: Tracks and displays system calls associated with a running process.
2 Name: strace
3 Version: 4.5.13
4 Release: 1
5 License: BSD
6 Group: Development/Debuggers
7 URL: http://sourceforge.net/projects/strace/
8 Source0: %{name}-%{version}.tar.bz2
9 BuildRoot: %{_tmppath}/%{name}-root
10
11 %define strace64_arches ppc64
12
13 %description
14 The strace program intercepts and records the system calls called and
15 received by a running process.  Strace can print a record of each
16 system call, its arguments and its return value.  Strace is useful for
17 diagnosing problems and debugging, as well as for instructional
18 purposes.
19
20 Install strace if you need a tool to track the system calls made and
21 received by a process.
22
23 %ifarch %{strace64_arches}
24 %package -n strace64
25 Summary: Tracks and displays system calls associated with a running process.
26 Group: Development/Debuggers
27
28 %description -n strace64
29 The strace program intercepts and records the system calls called and
30 received by a running process.  Strace can print a record of each
31 system call, its arguments and its return value.  Strace is useful for
32 diagnosing problems and debugging, as well as for instructional
33 purposes.
34
35 Install strace if you need a tool to track the system calls made and
36 received by a process.
37
38 This package provides the `strace64' program to trace 64-bit processes.
39 The `strace' program in the `strace' package is for 32-bit processes.
40 %endif
41
42 %prep
43 %setup -q
44
45 %build
46 %configure
47 make
48
49 %install
50 rm -rf %{buildroot}
51 mkdir -p %{buildroot}%{_mandir}/man1
52 mkdir -p %{buildroot}%{_bindir}
53 %makeinstall man1dir=%{buildroot}%{_mandir}/man1
54
55 # remove unpackaged files from the buildroot
56 rm -f %{buildroot}%{_bindir}/strace-graph
57
58 %ifarch %{strace64_arches}
59 ln %{buildroot}%{_bindir}/strace %{buildroot}%{_bindir}/strace64
60 %endif
61
62 %clean
63 rm -rf %{buildroot}
64
65 %files
66 %defattr(-,root,root)
67 %{_bindir}/strace
68 %{_mandir}/man1/*
69
70 %ifarch %{strace64_arches}
71 %files -n strace64
72 %defattr(-,root,root)
73 %{_bindir}/strace64
74 %endif
75
76
77 %changelog
78 * Wed Aug  3 2005 Roland McGrath <roland@redhat.com> - 4.5.13-1
79 - Fix setsockopt decoding on 64-bit (#162449).
80 - Fix typos in socket option name strings (#161578).
81 - Display more IPV6 socket options by name (#162450).
82 - Don't display inappropriate syscalls for -e trace=file (#159340).
83 - New selector type -e trace=desc for file-descriptor using calls (#159400).
84 - Fix 32-bit old_mmap syscall decoding on x86-64 (#162467, #164215).
85 - Fix errors detaching from multithreaded process on interrupt (#161919).
86 - Note 4.5.12 fix for crash handling bad signal numbers (#162739).
87
88 * Wed Jun  8 2005 Roland McGrath <roland@redhat.com> - 4.5.12-1
89 - Fix known syscall recognition for IA32 processes on x86-64 (#158934).
90 - Fix bad output for ptrace on x86-64 (#159787).
91 - Fix potential buffer overruns (#151570, #159196).
92 - Make some diagnostics more consistent (#159308).
93 - Update PowerPC system calls.
94 - Better printing for Linux aio system calls.
95 - Don't truncate statfs64 fields to 32 bits in output (#158243).
96 - Cosmetic code cleanups (#159688).
97
98 * Tue Mar 22 2005 Roland McGrath <roland@redhat.com> - 4.5.11-1
99 - Build tweaks.
100 - Note 4.5.10 select fix (#151570).
101
102 * Mon Mar 14 2005 Roland McGrath <roland@redhat.com> - 4.5.10-1
103 - Fix select handling on nonstandard fd_set sizes.
104 - Don't print errors for null file name pointers.
105 - Fix initial execve output with -i (#143365).
106
107 * Fri Feb  4 2005 Roland McGrath <roland@redhat.com> - 4.5.9-2
108 - update ia64 syscall list (#146245)
109 - fix x86_64 syscall argument extraction for 32-bit processes (#146093)
110 - fix -e signal=NAME parsing (#143362)
111 - fix x86_64 exit_group syscall handling
112 - improve socket ioctl printing (#138223)
113 - code cleanups (#143369, #143370)
114 - improve mount flags printing (#141932)
115 - support symbolic printing of x86_64 arch_prctl parameters (#142667)
116 - fix potential crash in getxattr printing
117
118 * Tue Oct 19 2004 Roland McGrath <roland@redhat.com> - 4.5.8-1
119 - fix multithreaded exit handling (#132150, #135254)
120 - fix ioctl name matching (#129808)
121 - print RTC_* ioctl structure contents (#58606)
122 - grok epoll_* syscalls (#134463)
123 - grok new RLIMIT_* values (#133594)
124 - print struct cmsghdr contents for sendmsg (#131689)
125 - fix clock_* and timer_* argument output (#131420)
126
127 * Tue Aug 31 2004 Roland McGrath <roland@redhat.com> - 4.5.7-2
128 - new upstream version, misc fixes and updates (#128091, #129166, #128391, #129378, #130965, #131177)
129
130 * Mon Jul 12 2004 Roland McGrath <roland@redhat.com> 4.5.6-1
131 - new upstream version, updates ioctl lists (#127398), fixes quotactl (#127393), more ioctl decoding (#126917)
132
133 * Sun Jun 27 2004 Roland McGrath <roland@redhat.com> 4.5.5-1
134 - new upstream version, fixes x86-64 biarch support (#126547)
135
136 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> 4.5.4-2
137 - rebuilt
138
139 * Thu Jun  3 2004 Roland McGrath <roland@redhat.com> 4.5.4-0.FC1
140 - rebuilt for FC1 update
141
142 * Thu Jun  3 2004 Roland McGrath <roland@redhat.com> 4.5.4-1
143 - new upstream version, more ioctls (#122257), minor fixes
144
145 * Fri Apr 16 2004 Roland McGrath <roland@redhat.com> 4.5.3-1
146 - new upstream version, mq_* calls (#120701), -p vs NPTL (#120462), more fixes (#118694, #120541, #118685)
147
148 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 4.5.2-1.1
149 - rebuilt
150
151 * Mon Mar  1 2004 Roland McGrath <roland@redhat.com> 4.5.2-1
152 - new upstream version, sched_* calls (#116990), show core flag (#112117)
153
154 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
155 - rebuilt
156
157 * Thu Nov 13 2003 Roland McGrath <roland@redhat.com> 4.5.1-1
158 - new upstream version, more fixes (#108012, #105366, #105359, #105358)
159
160 * Tue Sep 30 2003 Roland McGrath <roland@redhat.com> 4.5-3
161 - revert bogus s390 fix
162
163 * Thu Sep 25 2003 Roland McGrath <roland@redhat.com> 4.5-1.2.1AS
164 - rebuilt for 2.1AS erratum
165
166 * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-2
167 - rebuilt
168
169 * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-1
170 - new upstream version, more fixes (#101499, #104365)
171
172 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-2
173 - rebuilt
174
175 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-1
176 - new upstream version, groks more new system calls, PF_INET6 sockets
177
178 * Mon Jun 10 2003 Roland McGrath <roland@redhat.com> 4.4.98-1
179 - new upstream version, more fixes (#90754, #91085)
180
181 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
182 - rebuilt
183
184 * Sun Mar 30 2003 Roland McGrath <roland@redhat.com> 4.4.96-1
185 - new upstream version, handles yet more 2.5 syscalls, x86_64 & ia64 fixes
186
187 * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com> 4.4.95-2
188 - rebuilt
189
190 * Mon Feb 24 2003 Roland McGrath <roland@redhat.com> 4.4.95-1
191 - new upstream version, fixed getresuid/getresgid (#84959)
192
193 * Wed Feb 19 2003 Roland McGrath <roland@redhat.com> 4.4.94-1
194 - new upstream version, new option -E to set environment variables (#82392)
195
196 * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.4.93-2
197 - rebuilt
198
199 * Tue Jan 21 2003 Roland McGrath <roland@redhat.com> 4.4.93-1
200 - new upstream version, fixes ppc and s390 bugs, adds missing ptrace requests
201
202 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.91-1
203 - new upstream version, fixes -f on x86-64
204
205 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.90-1
206 - new upstream version, fixes all known bugs modulo ia64 and s390 issues
207
208 * Fri Jan 03 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.4-11
209 - add further s390 patch from IBM
210
211 * Wed Nov 27 2002 Tim Powers <timp@redhat.com> 4.4-10
212 - remove unpackaged files from the buildroot
213
214 * Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.4-9.1
215 - Added latest s390(x) patch.
216
217 * Fri Sep 06 2002 Karsten Hopp <karsten@redhat.de> 4.4-9
218 - preliminary x86_64 support with an ugly patch to help
219   debugging. Needs cleanup!
220
221 * Mon Sep  2 2002 Jakub Jelinek <jakub@redhat.com> 4.4-8
222 - newer version of the clone fixing patch (Roland McGrath)
223 - aio syscalls for i386/ia64/ppc (Ben LaHaise)
224
225 * Wed Aug 28 2002 Jakub Jelinek <jakub@redhat.com> 4.4-7
226 - fix strace -f (Roland McGrath, #68994)
227 - handle ?et_thread_area, SA_RESTORER (Ulrich Drepper)
228
229 * Fri Jun 21 2002 Jakub Jelinek <jakub@redhat.com> 4.4-6
230 - handle futexes, *xattr, sendfile64, etc. (Ulrich Drepper)
231 - handle modify_ldt (#66894)
232
233 * Thu May 23 2002 Tim Powers <timp@redhat.com>
234 - automated rebuild
235
236 * Tue Apr 16 2002 Jakub Jelinek <jakub@redhat.com> 4.4-4
237 - fix for the last patch by Jeff Law (#62591)
238
239 * Mon Mar  4 2002 Preston Brown <pbrown@redhat.com> 4.4-3
240 - integrate patch from Jeff Law to eliminate hang tracing threads
241
242 * Sat Feb 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
243 - minor update from debian tar-ball
244
245 * Wed Jan 02 2002 Florian La Roche <Florian.LaRoche@redhat.de>
246 - update to 4.4
247
248 * Sun Jul 22 2001 Florian La Roche <Florian.LaRoche@redhat.de>
249 - disable s390 patches, they are already included
250
251 * Wed Jul 18 2001 Preston Brown <pbrown@redhat.com> 4.3-1
252 - new upstream version.  Seems to have integrated most new syscalls
253 - tracing threaded programs is now functional.
254
255 * Mon Jun 11 2001 Than Ngo <than@redhat.com>
256 - port s390 patches from IBM
257
258 * Wed May 16 2001 Nalin Dahyabhai <nalin@redhat.com>
259 - modify new syscall patch to allocate enough heap space in setgroups32()
260
261 * Wed Feb 14 2001 Jakub Jelinek <jakub@redhat.com>
262 - #include <time.h> in addition to <sys/time.h>
263
264 * Fri Jan 26 2001 Karsten Hopp <karsten@redhat.com>
265 - clean up conflicting patches. This happened only
266   when building on S390
267
268 * Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
269 - update to CVS, reintegrate ia64 support
270
271 * Sat Dec  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
272 - Get S/390 support into the normal package
273
274 * Sat Nov 18 2000 Florian La Roche <Florian.LaRoche@redhat.de>
275 - added S/390 patch from IBM, adapting it to not conflict with
276   IA64 patch
277
278 * Sat Aug 19 2000 Jakub Jelinek <jakub@redhat.com>
279 - doh, actually apply the 2.4 syscalls patch
280 - make it compile with 2.4.0-test7-pre4+ headers, add
281   getdents64 and fcntl64
282
283 * Thu Aug  3 2000 Jakub Jelinek <jakub@redhat.com>
284 - add a bunch of new 2.4 syscalls (#14036)
285
286 * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
287 - automatic rebuild
288 - excludearch ia64
289
290 * Fri Jun  2 2000 Matt Wilson <msw@redhat.com>
291 - use buildinstall for FHS
292
293 * Wed May 24 2000 Jakub Jelinek <jakub@redhat.com>
294 - make things compile on sparc
295 - fix sigreturn on sparc
296
297 * Fri Mar 31 2000 Bill Nottingham <notting@redhat.com>
298 - fix stat64 misdef (#10485)
299
300 * Tue Mar 21 2000 Michael K. Johnson <johnsonm@redhat.com>
301 - added ia64 patch
302
303 * Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
304 - man pages are compressed
305 - version 4.2 (why are we keeping all these patches around?)
306
307 * Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
308 - update to 4.1 (with sparc socketcall patch).
309
310 * Fri Nov 12 1999 Jakub Jelinek <jakub@redhat.com>
311 - fix socketcall on sparc.
312
313 * Thu Sep 02 1999 Cristian Gafton <gafton@redhat.com>
314 - fix KERN_SECURELVL compile problem
315
316 * Tue Aug 31 1999 Cristian Gafton <gafton@redhat.com>
317 - added alpha patch from HJLu to fix the osf_sigprocmask interpretation
318
319 * Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
320 - update to 3.99.1.
321
322 * Wed Jun  2 1999 Jeff Johnson <jbj@redhat.com>
323 - add (the other :-) jj's sparc patch.
324
325 * Wed May 26 1999 Jeff Johnson <jbj@redhat.com>
326 - upgrade to 3.99 in order to
327 -    add new 2.2.x open flags (#2955).
328 -    add new 2.2.x syscalls (#2866).
329 - strace 3.1 patches carried along for now.
330
331 * Sun May 16 1999 Jeff Johnson <jbj@redhat.com>
332 - don't rely on (broken!) rpm %patch (#2735)
333
334 * Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
335 - strip binary
336
337 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
338 - auto rebuild in the new build environment (release 16)
339
340 * Tue Feb  9 1999 Jeff Johnson <jbj@redhat.com>
341 - vfork est arrive!
342
343 * Tue Feb  9 1999 Christopher Blizzard <blizzard@redhat.com>
344 - Add patch to follow clone() syscalls, too.
345
346 * Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
347 - patch to build alpha/sparc with glibc 2.1.
348
349 * Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
350 - patch to build on ARM
351
352 * Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
353 - fix typo (printf, not tprintf).
354
355 * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
356 - fix compile problem on sparc.
357
358 * Tue Aug 18 1998 Cristian Gafton <gafton@redhat.com>
359 - buildroot
360
361 * Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
362 - added the umoven patch from James Youngman <jay@gnu.org>
363 - fixed build problems on newer glibc releases
364
365 * Mon Jun 08 1998 Prospector System <bugs@redhat.com>
366 - translations modified for de, fr, tr