]> granicus.if.org Git - strace/blob - strace.spec
6beab55da3a6b704d1ab3a6af628d92ea0cef30c
[strace] / strace.spec
1 Summary: Tracks and displays system calls associated with a running process.
2 Name: strace
3 Version: 4.5
4 Release: 1
5 License: BSD
6 Group: Development/Debuggers
7 URL: http://sourceforge.net/projects/strace/
8 Source0: %{name}-%{version}.tar.bz2
9 BuildRoot: %{_tmppath}/%{name}-root
10
11 %define strace64_arches ppc64
12
13 %description
14 The strace program intercepts and records the system calls called and
15 received by a running process.  Strace can print a record of each
16 system call, its arguments and its return value.  Strace is useful for
17 diagnosing problems and debugging, as well as for instructional
18 purposes.
19
20 Install strace if you need a tool to track the system calls made and
21 received by a process.
22
23 %ifarch %{strace64_arches}
24 %package -n strace64
25 Summary: Tracks and displays system calls associated with a running process.
26 Group: Development/Debuggers
27
28 %description -n strace64
29 The strace program intercepts and records the system calls called and
30 received by a running process.  Strace can print a record of each
31 system call, its arguments and its return value.  Strace is useful for
32 diagnosing problems and debugging, as well as for instructional
33 purposes.
34
35 Install strace if you need a tool to track the system calls made and
36 received by a process.
37
38 This package provides the `strace64' program to trace 64-bit processes.
39 The `strace' program in the `strace' package is for 32-bit processes.
40 %endif
41
42 %prep
43 %setup -q
44
45 %build
46 %configure
47 make
48
49 %install
50 rm -rf %{buildroot}
51 mkdir -p %{buildroot}%{_mandir}/man1
52 mkdir -p %{buildroot}%{_bindir}
53 %makeinstall man1dir=%{buildroot}%{_mandir}/man1
54
55 # remove unpackaged files from the buildroot
56 rm -f %{buildroot}%{_bindir}/strace-graph
57
58 %ifarch %{strace64_arches}
59 ln %{buildroot}%{_bindir}/strace %{buildroot}%{_bindir}/strace64
60 %endif
61
62 %clean
63 rm -rf %{buildroot}
64
65 %files
66 %defattr(-,root,root)
67 %{_bindir}/strace
68 %{_mandir}/man1/*
69
70 %ifarch %{strace64_arches}
71 %files -n strace64
72 %defattr(-,root,root)
73 %{_bindir}/strace64
74 %endif
75
76
77 %changelog
78 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-2
79 - rebuilt
80
81 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-1
82 - new upstream version, groks more new system calls, PF_INET6 sockets
83
84 * Mon Jun 10 2003 Roland McGrath <roland@redhat.com> 4.4.98-1
85 - new upstream version, more fixes (#90754, #91085)
86
87 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
88 - rebuilt
89
90 * Sun Mar 30 2003 Roland McGrath <roland@redhat.com> 4.4.96-1
91 - new upstream version, handles yet more 2.5 syscalls, x86_64 & ia64 fixes
92
93 * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com> 4.4.95-2
94 - rebuilt
95
96 * Mon Feb 24 2003 Roland McGrath <roland@redhat.com> 4.4.95-1
97 - new upstream version, fixed getresuid/getresgid (#84959)
98
99 * Wed Feb 19 2003 Roland McGrath <roland@redhat.com> 4.4.94-1
100 - new upstream version, new option -E to set environment variables (#82392)
101
102 * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.4.93-2
103 - rebuilt
104
105 * Tue Jan 21 2003 Roland McGrath <roland@redhat.com> 4.4.93-1
106 - new upstream version, fixes ppc and s390 bugs, adds missing ptrace requests
107
108 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.91-1
109 - new upstream version, fixes -f on x86-64
110
111 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.90-1
112 - new upstream version, fixes all known bugs modulo ia64 and s390 issues
113
114 * Fri Jan 03 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.4-11
115 - add further s390 patch from IBM
116
117 * Wed Nov 27 2002 Tim Powers <timp@redhat.com> 4.4-10
118 - remove unpackaged files from the buildroot
119
120 * Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.4-9.1
121 - Added latest s390(x) patch.
122
123 * Fri Sep 06 2002 Karsten Hopp <karsten@redhat.de> 4.4-9
124 - preliminary x86_64 support with an ugly patch to help
125   debugging. Needs cleanup!
126
127 * Mon Sep  2 2002 Jakub Jelinek <jakub@redhat.com> 4.4-8
128 - newer version of the clone fixing patch (Roland McGrath)
129 - aio syscalls for i386/ia64/ppc (Ben LaHaise)
130
131 * Wed Aug 28 2002 Jakub Jelinek <jakub@redhat.com> 4.4-7
132 - fix strace -f (Roland McGrath, #68994)
133 - handle ?et_thread_area, SA_RESTORER (Ulrich Drepper)
134
135 * Fri Jun 21 2002 Jakub Jelinek <jakub@redhat.com> 4.4-6
136 - handle futexes, *xattr, sendfile64, etc. (Ulrich Drepper)
137 - handle modify_ldt (#66894)
138
139 * Thu May 23 2002 Tim Powers <timp@redhat.com>
140 - automated rebuild
141
142 * Tue Apr 16 2002 Jakub Jelinek <jakub@redhat.com> 4.4-4
143 - fix for the last patch by Jeff Law (#62591)
144
145 * Mon Mar  4 2002 Preston Brown <pbrown@redhat.com> 4.4-3
146 - integrate patch from Jeff Law to eliminate hang tracing threads
147
148 * Sat Feb 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
149 - minor update from debian tar-ball
150
151 * Wed Jan 02 2002 Florian La Roche <Florian.LaRoche@redhat.de>
152 - update to 4.4
153
154 * Sun Jul 22 2001 Florian La Roche <Florian.LaRoche@redhat.de>
155 - disable s390 patches, they are already included
156
157 * Wed Jul 18 2001 Preston Brown <pbrown@redhat.com> 4.3-1
158 - new upstream version.  Seems to have integrated most new syscalls
159 - tracing threaded programs is now functional.
160
161 * Mon Jun 11 2001 Than Ngo <than@redhat.com>
162 - port s390 patches from IBM
163
164 * Wed May 16 2001 Nalin Dahyabhai <nalin@redhat.com>
165 - modify new syscall patch to allocate enough heap space in setgroups32()
166
167 * Wed Feb 14 2001 Jakub Jelinek <jakub@redhat.com>
168 - #include <time.h> in addition to <sys/time.h>
169
170 * Fri Jan 26 2001 Karsten Hopp <karsten@redhat.com>
171 - clean up conflicting patches. This happened only
172   when building on S390
173
174 * Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
175 - update to CVS, reintegrate ia64 support
176
177 * Sat Dec  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
178 - Get S/390 support into the normal package
179
180 * Sat Nov 18 2000 Florian La Roche <Florian.LaRoche@redhat.de>
181 - added S/390 patch from IBM, adapting it to not conflict with
182   IA64 patch
183
184 * Sat Aug 19 2000 Jakub Jelinek <jakub@redhat.com>
185 - doh, actually apply the 2.4 syscalls patch
186 - make it compile with 2.4.0-test7-pre4+ headers, add
187   getdents64 and fcntl64
188
189 * Thu Aug  3 2000 Jakub Jelinek <jakub@redhat.com>
190 - add a bunch of new 2.4 syscalls (#14036)
191
192 * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
193 - automatic rebuild
194 - excludearch ia64
195
196 * Fri Jun  2 2000 Matt Wilson <msw@redhat.com>
197 - use buildinstall for FHS
198
199 * Wed May 24 2000 Jakub Jelinek <jakub@redhat.com>
200 - make things compile on sparc
201 - fix sigreturn on sparc
202
203 * Fri Mar 31 2000 Bill Nottingham <notting@redhat.com>
204 - fix stat64 misdef (#10485)
205
206 * Tue Mar 21 2000 Michael K. Johnson <johnsonm@redhat.com>
207 - added ia64 patch
208
209 * Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
210 - man pages are compressed
211 - version 4.2 (why are we keeping all these patches around?)
212
213 * Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
214 - update to 4.1 (with sparc socketcall patch).
215
216 * Fri Nov 12 1999 Jakub Jelinek <jakub@redhat.com>
217 - fix socketcall on sparc.
218
219 * Thu Sep 02 1999 Cristian Gafton <gafton@redhat.com>
220 - fix KERN_SECURELVL compile problem
221
222 * Tue Aug 31 1999 Cristian Gafton <gafton@redhat.com>
223 - added alpha patch from HJLu to fix the osf_sigprocmask interpretation
224
225 * Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
226 - update to 3.99.1.
227
228 * Wed Jun  2 1999 Jeff Johnson <jbj@redhat.com>
229 - add (the other :-) jj's sparc patch.
230
231 * Wed May 26 1999 Jeff Johnson <jbj@redhat.com>
232 - upgrade to 3.99 in order to
233 -    add new 2.2.x open flags (#2955).
234 -    add new 2.2.x syscalls (#2866).
235 - strace 3.1 patches carried along for now.
236
237 * Sun May 16 1999 Jeff Johnson <jbj@redhat.com>
238 - don't rely on (broken!) rpm %patch (#2735)
239
240 * Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
241 - strip binary
242
243 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
244 - auto rebuild in the new build environment (release 16)
245
246 * Tue Feb  9 1999 Jeff Johnson <jbj@redhat.com>
247 - vfork est arrive!
248
249 * Tue Feb  9 1999 Christopher Blizzard <blizzard@redhat.com>
250 - Add patch to follow clone() syscalls, too.
251
252 * Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
253 - patch to build alpha/sparc with glibc 2.1.
254
255 * Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
256 - patch to build on ARM
257
258 * Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
259 - fix typo (printf, not tprintf).
260
261 * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
262 - fix compile problem on sparc.
263
264 * Tue Aug 18 1998 Cristian Gafton <gafton@redhat.com>
265 - buildroot
266
267 * Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
268 - added the umoven patch from James Youngman <jay@gnu.org>
269 - fixed build problems on newer glibc releases
270
271 * Mon Jun 08 1998 Prospector System <bugs@redhat.com>
272 - translations modified for de, fr, tr