]> granicus.if.org Git - strace/blob - strace.spec
2003-07-28 Daniel Jacobowitz <drow@mvista.com>
[strace] / strace.spec
1 Summary: Tracks and displays system calls associated with a running process.
2 Name: strace
3 Version: 4.4.99
4 Release: 1
5 License: BSD
6 Group: Development/Debuggers
7 URL: http://sourceforge.net/projects/strace/
8 Source0: %{name}-%{version}.tar.bz2
9 BuildRoot: %{_tmppath}/%{name}-root
10
11 %description
12 The strace program intercepts and records the system calls called and
13 received by a running process.  Strace can print a record of each
14 system call, its arguments and its return value.  Strace is useful for
15 diagnosing problems and debugging, as well as for instructional
16 purposes.
17
18 Install strace if you need a tool to track the system calls made and
19 received by a process.
20
21 %prep
22 %setup -q
23
24 %build
25 %configure
26 make
27
28 %install
29 rm -rf %{buildroot}
30 mkdir -p %{buildroot}%{_mandir}/man1
31 mkdir -p %{buildroot}%{_bindir}
32 %makeinstall man1dir=%{buildroot}%{_mandir}/man1
33
34 # remove unpackaged files from the buildroot
35 rm -f %{buildroot}%{_bindir}/strace-graph
36
37 %clean
38 rm -rf %{buildroot}
39
40 %files
41 %defattr(-,root,root)
42 %{_bindir}/strace
43 %{_mandir}/man1/*
44
45 %changelog
46 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-1
47 - new upstream version, groks more new system calls, PF_INET6 sockets
48
49 * Mon Jun 10 2003 Roland McGrath <roland@redhat.com> 4.4.98-1
50 - new upstream version, more fixes (#90754, #91085)
51
52 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
53 - rebuilt
54
55 * Sun Mar 30 2003 Roland McGrath <roland@redhat.com> 4.4.96-1
56 - new upstream version, handles yet more 2.5 syscalls, x86_64 & ia64 fixes
57
58 * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com> 4.4.95-2
59 - rebuilt
60
61 * Mon Feb 24 2003 Roland McGrath <roland@redhat.com> 4.4.95-1
62 - new upstream version, fixed getresuid/getresgid (#84959)
63
64 * Wed Feb 19 2003 Roland McGrath <roland@redhat.com> 4.4.94-1
65 - new upstream version, new option -E to set environment variables (#82392)
66
67 * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.4.93-2
68 - rebuilt
69
70 * Tue Jan 21 2003 Roland McGrath <roland@redhat.com> 4.4.93-1
71 - new upstream version, fixes ppc and s390 bugs, adds missing ptrace requests
72
73 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.91-1
74 - new upstream version, fixes -f on x86-64
75
76 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.90-1
77 - new upstream version, fixes all known bugs modulo ia64 and s390 issues
78
79 * Fri Jan 03 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.4-11
80 - add further s390 patch from IBM
81
82 * Wed Nov 27 2002 Tim Powers <timp@redhat.com> 4.4-10
83 - remove unpackaged files from the buildroot
84
85 * Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.4-9.1
86 - Added latest s390(x) patch.
87
88 * Fri Sep 06 2002 Karsten Hopp <karsten@redhat.de> 4.4-9
89 - preliminary x86_64 support with an ugly patch to help
90   debugging. Needs cleanup!
91
92 * Mon Sep  2 2002 Jakub Jelinek <jakub@redhat.com> 4.4-8
93 - newer version of the clone fixing patch (Roland McGrath)
94 - aio syscalls for i386/ia64/ppc (Ben LaHaise)
95
96 * Wed Aug 28 2002 Jakub Jelinek <jakub@redhat.com> 4.4-7
97 - fix strace -f (Roland McGrath, #68994)
98 - handle ?et_thread_area, SA_RESTORER (Ulrich Drepper)
99
100 * Fri Jun 21 2002 Jakub Jelinek <jakub@redhat.com> 4.4-6
101 - handle futexes, *xattr, sendfile64, etc. (Ulrich Drepper)
102 - handle modify_ldt (#66894)
103
104 * Thu May 23 2002 Tim Powers <timp@redhat.com>
105 - automated rebuild
106
107 * Tue Apr 16 2002 Jakub Jelinek <jakub@redhat.com> 4.4-4
108 - fix for the last patch by Jeff Law (#62591)
109
110 * Mon Mar  4 2002 Preston Brown <pbrown@redhat.com> 4.4-3
111 - integrate patch from Jeff Law to eliminate hang tracing threads
112
113 * Sat Feb 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
114 - minor update from debian tar-ball
115
116 * Wed Jan 02 2002 Florian La Roche <Florian.LaRoche@redhat.de>
117 - update to 4.4
118
119 * Sun Jul 22 2001 Florian La Roche <Florian.LaRoche@redhat.de>
120 - disable s390 patches, they are already included
121
122 * Wed Jul 18 2001 Preston Brown <pbrown@redhat.com> 4.3-1
123 - new upstream version.  Seems to have integrated most new syscalls
124 - tracing threaded programs is now functional.
125
126 * Mon Jun 11 2001 Than Ngo <than@redhat.com>
127 - port s390 patches from IBM
128
129 * Wed May 16 2001 Nalin Dahyabhai <nalin@redhat.com>
130 - modify new syscall patch to allocate enough heap space in setgroups32()
131
132 * Wed Feb 14 2001 Jakub Jelinek <jakub@redhat.com>
133 - #include <time.h> in addition to <sys/time.h>
134
135 * Fri Jan 26 2001 Karsten Hopp <karsten@redhat.com>
136 - clean up conflicting patches. This happened only
137   when building on S390
138
139 * Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
140 - update to CVS, reintegrate ia64 support
141
142 * Sat Dec  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
143 - Get S/390 support into the normal package
144
145 * Sat Nov 18 2000 Florian La Roche <Florian.LaRoche@redhat.de>
146 - added S/390 patch from IBM, adapting it to not conflict with
147   IA64 patch
148
149 * Sat Aug 19 2000 Jakub Jelinek <jakub@redhat.com>
150 - doh, actually apply the 2.4 syscalls patch
151 - make it compile with 2.4.0-test7-pre4+ headers, add
152   getdents64 and fcntl64
153
154 * Thu Aug  3 2000 Jakub Jelinek <jakub@redhat.com>
155 - add a bunch of new 2.4 syscalls (#14036)
156
157 * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
158 - automatic rebuild
159 - excludearch ia64
160
161 * Fri Jun  2 2000 Matt Wilson <msw@redhat.com>
162 - use buildinstall for FHS
163
164 * Wed May 24 2000 Jakub Jelinek <jakub@redhat.com>
165 - make things compile on sparc
166 - fix sigreturn on sparc
167
168 * Fri Mar 31 2000 Bill Nottingham <notting@redhat.com>
169 - fix stat64 misdef (#10485)
170
171 * Tue Mar 21 2000 Michael K. Johnson <johnsonm@redhat.com>
172 - added ia64 patch
173
174 * Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
175 - man pages are compressed
176 - version 4.2 (why are we keeping all these patches around?)
177
178 * Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
179 - update to 4.1 (with sparc socketcall patch).
180
181 * Fri Nov 12 1999 Jakub Jelinek <jakub@redhat.com>
182 - fix socketcall on sparc.
183
184 * Thu Sep 02 1999 Cristian Gafton <gafton@redhat.com>
185 - fix KERN_SECURELVL compile problem
186
187 * Tue Aug 31 1999 Cristian Gafton <gafton@redhat.com>
188 - added alpha patch from HJLu to fix the osf_sigprocmask interpretation
189
190 * Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
191 - update to 3.99.1.
192
193 * Wed Jun  2 1999 Jeff Johnson <jbj@redhat.com>
194 - add (the other :-) jj's sparc patch.
195
196 * Wed May 26 1999 Jeff Johnson <jbj@redhat.com>
197 - upgrade to 3.99 in order to
198 -    add new 2.2.x open flags (#2955).
199 -    add new 2.2.x syscalls (#2866).
200 - strace 3.1 patches carried along for now.
201
202 * Sun May 16 1999 Jeff Johnson <jbj@redhat.com>
203 - don't rely on (broken!) rpm %patch (#2735)
204
205 * Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
206 - strip binary
207
208 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
209 - auto rebuild in the new build environment (release 16)
210
211 * Tue Feb  9 1999 Jeff Johnson <jbj@redhat.com>
212 - vfork est arrive!
213
214 * Tue Feb  9 1999 Christopher Blizzard <blizzard@redhat.com>
215 - Add patch to follow clone() syscalls, too.
216
217 * Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
218 - patch to build alpha/sparc with glibc 2.1.
219
220 * Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
221 - patch to build on ARM
222
223 * Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
224 - fix typo (printf, not tprintf).
225
226 * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
227 - fix compile problem on sparc.
228
229 * Tue Aug 18 1998 Cristian Gafton <gafton@redhat.com>
230 - buildroot
231
232 * Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
233 - added the umoven patch from James Youngman <jay@gnu.org>
234 - fixed build problems on newer glibc releases
235
236 * Mon Jun 08 1998 Prospector System <bugs@redhat.com>
237 - translations modified for de, fr, tr