]> granicus.if.org Git - strace/blob - strace.spec
linux/ioctlent: unify them all
[strace] / strace.spec
1 Summary: Tracks and displays system calls associated with a running process
2 Name: strace
3 Version: 4.5.20
4 Release: 2%{?dist}
5 License: BSD
6 Group: Development/Debuggers
7 URL: http://sourceforge.net/projects/strace/
8 Source: http://downloads.sourceforge.net/strace/%{name}-%{version}.tar.xz
9 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
10
11 BuildRequires: libacl-devel, libaio-devel, time
12
13 %define strace64_arches ppc64 sparc64
14
15 %description
16 The strace program intercepts and records the system calls called and
17 received by a running process.  Strace can print a record of each
18 system call, its arguments and its return value.  Strace is useful for
19 diagnosing problems and debugging, as well as for instructional
20 purposes.
21
22 Install strace if you need a tool to track the system calls made and
23 received by a process.
24
25 %ifarch %{strace64_arches}
26 %package -n strace64
27 Summary: Tracks and displays system calls associated with a running process.
28 Group: Development/Debuggers
29
30 %description -n strace64
31 The strace program intercepts and records the system calls called and
32 received by a running process.  Strace can print a record of each
33 system call, its arguments and its return value.  Strace is useful for
34 diagnosing problems and debugging, as well as for instructional
35 purposes.
36
37 Install strace if you need a tool to track the system calls made and
38 received by a process.
39
40 This package provides the `strace64' program to trace 64-bit processes.
41 The `strace' program in the `strace' package is for 32-bit processes.
42 %endif
43
44 %prep
45 %setup -q
46
47 %build
48 %configure
49 make %{?_smp_mflags}
50
51 %install
52 rm -rf %{buildroot}
53 make DESTDIR=%{buildroot} install
54
55 # remove unpackaged files from the buildroot
56 rm -f %{buildroot}%{_bindir}/strace-graph
57
58 %define copy64 ln
59 %if 0%{?rhel}
60 %if 0%{?rhel} < 6
61 %endif
62 %define copy64 cp -p
63 %endif
64
65 %ifarch %{strace64_arches}
66 %{copy64} %{buildroot}%{_bindir}/strace %{buildroot}%{_bindir}/strace64
67 %endif
68
69 %check
70 make check
71
72 %clean
73 rm -rf %{buildroot}
74
75 %files
76 %defattr(-,root,root)
77 %doc CREDITS ChangeLog ChangeLog-CVS COPYRIGHT NEWS PORTING README
78 %{_bindir}/strace
79 %{_mandir}/man1/*
80
81 %ifarch %{strace64_arches}
82 %files -n strace64
83 %defattr(-,root,root)
84 %{_bindir}/strace64
85 %endif
86
87 %changelog
88 * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.20-2
89 - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
90
91 * Tue Apr 13 2010 Roland McGrath <roland@redhat.com> - 4.5.20-1
92 - New upstream release, work mostly by Andreas Schwab and Dmitry V. Levin.
93   + fixed potential stack buffer overflow in select decoder (#556678);
94   + fixed FTBFS (#539044).
95
96 * Wed Oct 21 2009 Roland McGrath <roland@redhat.com> - 4.5.19-1
97 - New upstream release, work mostly by Dmitry V. Levin <ldv@altlinux.org>
98   + exit/kill strace with traced process exitcode/signal (#105371);
99   + fixed build on ARM EABI (#507576);
100   + fixed display of 32-bit argv array on 64-bit architectures (#519480);
101   + fixed display of 32-bit fcntl(F_SETLK) on 64-bit architectures (#471169);
102   + fixed several bugs in strings decoder, including potential heap
103     memory corruption (#470529, #478324, #511035).
104
105 * Thu Aug 28 2008 Roland McGrath <roland@redhat.com> - 4.5.18-1
106 - build fix for newer kernel headers (#457291)
107 - fix CLONE_VFORK handling (#455078)
108 - Support new Linux/PPC system call subpage_prot and PROT_SAO flag.
109 - In sigaction system call, display sa_flags value along with SIG_DFL/SIG_IGN.
110
111 * Mon Jul 21 2008 Roland McGrath <roland@redhat.com> - 4.5.17-1
112 - handle O_CLOEXEC, MSG_CMSG_CLOEXEC (#365781)
113 - fix biarch stat64 decoding (#222275)
114 - fix spurious "..." in printing of environment strings (#358241)
115 - improve prctl decoding (#364401)
116 - fix hang wait on exited child with exited child (#354261)
117 - fix biarch fork/vfork (-f) tracing (#447475)
118 - fix biarch printing of negative argument kill (#430585)
119 - fix biarch decoding of error return values (#447587)
120 - fix -f tracing of CLONE_VFORK (#455078)
121 - fix ia64 register clobberation in -f tracing (#453438)
122 - print SO_NODEFER, SA_RESETHAND instead of SA_NOMASK, SA_ONESHOT (#455821)
123 - fix futex argument decoding (#448628, #448629)
124
125 * Fri Aug  3 2007 Roland McGrath <roland@redhat.com> - 4.5.16-1
126 - fix multithread issues (#240962, #240961, #247907)
127 - fix spurious SIGSTOP on early interrupt (#240986)
128 - fix utime for biarch (#247185)
129 - fix -u error message (#247170)
130 - better futex syscall printing (##241467)
131 - fix argv/envp printing with small -s settings, and for biarch
132 - new syscalls: getcpu, eventfd, timerfd, signalfd, epoll_pwait,
133   move_pages, utimensat
134
135 * Tue Jan 16 2007 Roland McGrath <roland@redhat.com> - 4.5.15-1
136 - biarch fixes (#179740, #192193, #171626, #173050, #218433, #218043)
137 - fix -ff -o behavior (#204950, #218435, #193808, #219423)
138 - better quotactl printing (#118696)
139 - *at, inotify*, pselect6, ppoll and unshare syscalls (#178633, #191275)
140 - glibc-2.5 build fixes (#209856)
141 - memory corruption fixes (#200621
142 - fix race in child setup under -f (#180293)
143 - show ipc key values in hex (#198179, #192182)
144 - disallow -c with -ff (#187847)
145 - Resolves: RHBZ #179740, RHBZ #192193, RHBZ #204950, RHBZ #218435
146 - Resolves: RHBZ #193808, RHBZ #219423, RHBZ #171626, RHBZ #173050
147 - Resolves: RHBZ #218433, RHBZ #218043, RHBZ #118696, RHBZ #178633
148 - Resolves: RHBZ #191275, RHBZ #209856, RHBZ #200621, RHBZ #180293
149 - Resolves: RHBZ #198179, RHBZ #198182, RHBZ #187847
150
151 * Mon Nov 20 2006 Jakub Jelinek <jakub@redhat.com> - 4.5.14-4
152 - Fix ia64 syscall decoding (#206768)
153 - Fix build with glibc-2.4.90-33 and up on all arches but ia64
154 - Fix build against 2.6.18+ headers
155
156 * Tue Aug 22 2006 Roland McGrath <roland@redhat.com> - 4.5.14-3
157 - Fix bogus decoding of syscalls >= 300 (#201462, #202620).
158
159 * Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-2
160 - rebuild
161
162 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.2
163 - bump again for long double bug on ppc{,64}
164
165 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.1
166 - rebuilt for new gcc4.1 snapshot and glibc changes
167
168 * Mon Jan 16 2006 Roland McGrath <roland@redhat.com> - 4.5.14-1
169 - Fix biarch decoding of socket syscalls (#174354).
170 - Fix biarch -e support (#173986).
171 - Accept numeric syscalls in -e (#174798).
172 - Fix ipc syscall decoding (#164755).
173 - Improve msgrcv printing (#164757).
174 - Man page updates (#165375).
175 - Improve mount syscall printing (#165377).
176 - Correct printing of restarting syscalls (#165469).
177
178 * Wed Aug  3 2005 Roland McGrath <roland@redhat.com> - 4.5.13-1
179 - Fix setsockopt decoding on 64-bit (#162449).
180 - Fix typos in socket option name strings (#161578).
181 - Display more IPV6 socket options by name (#162450).
182 - Don't display inappropriate syscalls for -e trace=file (#159340).
183 - New selector type -e trace=desc for file-descriptor using calls (#159400).
184 - Fix 32-bit old_mmap syscall decoding on x86-64 (#162467, #164215).
185 - Fix errors detaching from multithreaded process on interrupt (#161919).
186 - Note 4.5.12 fix for crash handling bad signal numbers (#162739).
187
188 * Wed Jun  8 2005 Roland McGrath <roland@redhat.com> - 4.5.12-1
189 - Fix known syscall recognition for IA32 processes on x86-64 (#158934).
190 - Fix bad output for ptrace on x86-64 (#159787).
191 - Fix potential buffer overruns (#151570, #159196).
192 - Make some diagnostics more consistent (#159308).
193 - Update PowerPC system calls.
194 - Better printing for Linux aio system calls.
195 - Don't truncate statfs64 fields to 32 bits in output (#158243).
196 - Cosmetic code cleanups (#159688).
197
198 * Tue Mar 22 2005 Roland McGrath <roland@redhat.com> - 4.5.11-1
199 - Build tweaks.
200 - Note 4.5.10 select fix (#151570).
201
202 * Mon Mar 14 2005 Roland McGrath <roland@redhat.com> - 4.5.10-1
203 - Fix select handling on nonstandard fd_set sizes.
204 - Don't print errors for null file name pointers.
205 - Fix initial execve output with -i (#143365).
206
207 * Fri Feb  4 2005 Roland McGrath <roland@redhat.com> - 4.5.9-2
208 - update ia64 syscall list (#146245)
209 - fix x86_64 syscall argument extraction for 32-bit processes (#146093)
210 - fix -e signal=NAME parsing (#143362)
211 - fix x86_64 exit_group syscall handling
212 - improve socket ioctl printing (#138223)
213 - code cleanups (#143369, #143370)
214 - improve mount flags printing (#141932)
215 - support symbolic printing of x86_64 arch_prctl parameters (#142667)
216 - fix potential crash in getxattr printing
217
218 * Tue Oct 19 2004 Roland McGrath <roland@redhat.com> - 4.5.8-1
219 - fix multithreaded exit handling (#132150, #135254)
220 - fix ioctl name matching (#129808)
221 - print RTC_* ioctl structure contents (#58606)
222 - grok epoll_* syscalls (#134463)
223 - grok new RLIMIT_* values (#133594)
224 - print struct cmsghdr contents for sendmsg (#131689)
225 - fix clock_* and timer_* argument output (#131420)
226
227 * Tue Aug 31 2004 Roland McGrath <roland@redhat.com> - 4.5.7-2
228 - new upstream version, misc fixes and updates (#128091, #129166, #128391, #129378, #130965, #131177)
229
230 * Mon Jul 12 2004 Roland McGrath <roland@redhat.com> 4.5.6-1
231 - new upstream version, updates ioctl lists (#127398), fixes quotactl (#127393), more ioctl decoding (#126917)
232
233 * Sun Jun 27 2004 Roland McGrath <roland@redhat.com> 4.5.5-1
234 - new upstream version, fixes x86-64 biarch support (#126547)
235
236 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> 4.5.4-2
237 - rebuilt
238
239 * Thu Jun  3 2004 Roland McGrath <roland@redhat.com> 4.5.4-0.FC1
240 - rebuilt for FC1 update
241
242 * Thu Jun  3 2004 Roland McGrath <roland@redhat.com> 4.5.4-1
243 - new upstream version, more ioctls (#122257), minor fixes
244
245 * Fri Apr 16 2004 Roland McGrath <roland@redhat.com> 4.5.3-1
246 - new upstream version, mq_* calls (#120701), -p vs NPTL (#120462), more fixes (#118694, #120541, #118685)
247
248 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 4.5.2-1.1
249 - rebuilt
250
251 * Mon Mar  1 2004 Roland McGrath <roland@redhat.com> 4.5.2-1
252 - new upstream version, sched_* calls (#116990), show core flag (#112117)
253
254 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
255 - rebuilt
256
257 * Thu Nov 13 2003 Roland McGrath <roland@redhat.com> 4.5.1-1
258 - new upstream version, more fixes (#108012, #105366, #105359, #105358)
259
260 * Tue Sep 30 2003 Roland McGrath <roland@redhat.com> 4.5-3
261 - revert bogus s390 fix
262
263 * Thu Sep 25 2003 Roland McGrath <roland@redhat.com> 4.5-1.2.1AS
264 - rebuilt for 2.1AS erratum
265
266 * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-2
267 - rebuilt
268
269 * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-1
270 - new upstream version, more fixes (#101499, #104365)
271
272 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-2
273 - rebuilt
274
275 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-1
276 - new upstream version, groks more new system calls, PF_INET6 sockets
277
278 * Mon Jun 10 2003 Roland McGrath <roland@redhat.com> 4.4.98-1
279 - new upstream version, more fixes (#90754, #91085)
280
281 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
282 - rebuilt
283
284 * Sun Mar 30 2003 Roland McGrath <roland@redhat.com> 4.4.96-1
285 - new upstream version, handles yet more 2.5 syscalls, x86_64 & ia64 fixes
286
287 * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com> 4.4.95-2
288 - rebuilt
289
290 * Mon Feb 24 2003 Roland McGrath <roland@redhat.com> 4.4.95-1
291 - new upstream version, fixed getresuid/getresgid (#84959)
292
293 * Wed Feb 19 2003 Roland McGrath <roland@redhat.com> 4.4.94-1
294 - new upstream version, new option -E to set environment variables (#82392)
295
296 * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.4.93-2
297 - rebuilt
298
299 * Tue Jan 21 2003 Roland McGrath <roland@redhat.com> 4.4.93-1
300 - new upstream version, fixes ppc and s390 bugs, adds missing ptrace requests
301
302 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.91-1
303 - new upstream version, fixes -f on x86-64
304
305 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.90-1
306 - new upstream version, fixes all known bugs modulo ia64 and s390 issues
307
308 * Fri Jan 03 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.4-11
309 - add further s390 patch from IBM
310
311 * Wed Nov 27 2002 Tim Powers <timp@redhat.com> 4.4-10
312 - remove unpackaged files from the buildroot
313
314 * Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.4-9.1
315 - Added latest s390(x) patch.
316
317 * Fri Sep 06 2002 Karsten Hopp <karsten@redhat.de> 4.4-9
318 - preliminary x86_64 support with an ugly patch to help
319   debugging. Needs cleanup!
320
321 * Mon Sep  2 2002 Jakub Jelinek <jakub@redhat.com> 4.4-8
322 - newer version of the clone fixing patch (Roland McGrath)
323 - aio syscalls for i386/ia64/ppc (Ben LaHaise)
324
325 * Wed Aug 28 2002 Jakub Jelinek <jakub@redhat.com> 4.4-7
326 - fix strace -f (Roland McGrath, #68994)
327 - handle ?et_thread_area, SA_RESTORER (Ulrich Drepper)
328
329 * Fri Jun 21 2002 Jakub Jelinek <jakub@redhat.com> 4.4-6
330 - handle futexes, *xattr, sendfile64, etc. (Ulrich Drepper)
331 - handle modify_ldt (#66894)
332
333 * Thu May 23 2002 Tim Powers <timp@redhat.com>
334 - automated rebuild
335
336 * Tue Apr 16 2002 Jakub Jelinek <jakub@redhat.com> 4.4-4
337 - fix for the last patch by Jeff Law (#62591)
338
339 * Mon Mar  4 2002 Preston Brown <pbrown@redhat.com> 4.4-3
340 - integrate patch from Jeff Law to eliminate hang tracing threads
341
342 * Sat Feb 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
343 - minor update from debian tar-ball
344
345 * Wed Jan 02 2002 Florian La Roche <Florian.LaRoche@redhat.de>
346 - update to 4.4
347
348 * Sun Jul 22 2001 Florian La Roche <Florian.LaRoche@redhat.de>
349 - disable s390 patches, they are already included
350
351 * Wed Jul 18 2001 Preston Brown <pbrown@redhat.com> 4.3-1
352 - new upstream version.  Seems to have integrated most new syscalls
353 - tracing threaded programs is now functional.
354
355 * Mon Jun 11 2001 Than Ngo <than@redhat.com>
356 - port s390 patches from IBM
357
358 * Wed May 16 2001 Nalin Dahyabhai <nalin@redhat.com>
359 - modify new syscall patch to allocate enough heap space in setgroups32()
360
361 * Wed Feb 14 2001 Jakub Jelinek <jakub@redhat.com>
362 - #include <time.h> in addition to <sys/time.h>
363
364 * Fri Jan 26 2001 Karsten Hopp <karsten@redhat.com>
365 - clean up conflicting patches. This happened only
366   when building on S390
367
368 * Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
369 - update to CVS, reintegrate ia64 support
370
371 * Sat Dec  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
372 - Get S/390 support into the normal package
373
374 * Sat Nov 18 2000 Florian La Roche <Florian.LaRoche@redhat.de>
375 - added S/390 patch from IBM, adapting it to not conflict with
376   IA64 patch
377
378 * Sat Aug 19 2000 Jakub Jelinek <jakub@redhat.com>
379 - doh, actually apply the 2.4 syscalls patch
380 - make it compile with 2.4.0-test7-pre4+ headers, add
381   getdents64 and fcntl64
382
383 * Thu Aug  3 2000 Jakub Jelinek <jakub@redhat.com>
384 - add a bunch of new 2.4 syscalls (#14036)
385
386 * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
387 - automatic rebuild
388 - excludearch ia64
389
390 * Fri Jun  2 2000 Matt Wilson <msw@redhat.com>
391 - use buildinstall for FHS
392
393 * Wed May 24 2000 Jakub Jelinek <jakub@redhat.com>
394 - make things compile on sparc
395 - fix sigreturn on sparc
396
397 * Fri Mar 31 2000 Bill Nottingham <notting@redhat.com>
398 - fix stat64 misdef (#10485)
399
400 * Tue Mar 21 2000 Michael K. Johnson <johnsonm@redhat.com>
401 - added ia64 patch
402
403 * Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
404 - man pages are compressed
405 - version 4.2 (why are we keeping all these patches around?)
406
407 * Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
408 - update to 4.1 (with sparc socketcall patch).
409
410 * Fri Nov 12 1999 Jakub Jelinek <jakub@redhat.com>
411 - fix socketcall on sparc.
412
413 * Thu Sep 02 1999 Cristian Gafton <gafton@redhat.com>
414 - fix KERN_SECURELVL compile problem
415
416 * Tue Aug 31 1999 Cristian Gafton <gafton@redhat.com>
417 - added alpha patch from HJLu to fix the osf_sigprocmask interpretation
418
419 * Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
420 - update to 3.99.1.
421
422 * Wed Jun  2 1999 Jeff Johnson <jbj@redhat.com>
423 - add (the other :-) jj's sparc patch.
424
425 * Wed May 26 1999 Jeff Johnson <jbj@redhat.com>
426 - upgrade to 3.99 in order to
427 -    add new 2.2.x open flags (#2955).
428 -    add new 2.2.x syscalls (#2866).
429 - strace 3.1 patches carried along for now.
430
431 * Sun May 16 1999 Jeff Johnson <jbj@redhat.com>
432 - don't rely on (broken!) rpm %%patch (#2735)
433
434 * Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
435 - strip binary
436
437 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
438 - auto rebuild in the new build environment (release 16)
439
440 * Tue Feb  9 1999 Jeff Johnson <jbj@redhat.com>
441 - vfork est arrive!
442
443 * Tue Feb  9 1999 Christopher Blizzard <blizzard@redhat.com>
444 - Add patch to follow clone() syscalls, too.
445
446 * Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
447 - patch to build alpha/sparc with glibc 2.1.
448
449 * Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
450 - patch to build on ARM
451
452 * Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
453 - fix typo (printf, not tprintf).
454
455 * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
456 - fix compile problem on sparc.
457
458 * Tue Aug 18 1998 Cristian Gafton <gafton@redhat.com>
459 - buildroot
460
461 * Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
462 - added the umoven patch from James Youngman <jay@gnu.org>
463 - fixed build problems on newer glibc releases
464
465 * Mon Jun 08 1998 Prospector System <bugs@redhat.com>
466 - translations modified for de, fr, tr