]> granicus.if.org Git - strace/blob - strace.spec
statfs: don't quote f_type macro names
[strace] / strace.spec
1 Summary: Tracks and displays system calls associated with a running process
2 Name: strace
3 Version: 4.11
4 Release: 2%{?dist}
5 License: BSD
6 Group: Development/Debuggers
7 URL: http://sourceforge.net/projects/strace/
8 Source: http://downloads.sourceforge.net/strace/%{name}-%{version}.tar.xz
9 BuildRequires: time
10 %ifarch x86_64
11 # for experimental -k option
12 BuildRequires: libunwind-devel
13 %endif
14 %define strace64_arches ppc64 sparc64
15
16 %description
17 The strace program intercepts and records the system calls called and
18 received by a running process.  Strace can print a record of each
19 system call, its arguments and its return value.  Strace is useful for
20 diagnosing problems and debugging, as well as for instructional
21 purposes.
22
23 Install strace if you need a tool to track the system calls made and
24 received by a process.
25
26 %ifarch %{strace64_arches}
27 %package -n strace64
28 Summary: Tracks and displays system calls associated with a running process.
29 Group: Development/Debuggers
30
31 %description -n strace64
32 The strace program intercepts and records the system calls called and
33 received by a running process.  Strace can print a record of each
34 system call, its arguments and its return value.  Strace is useful for
35 diagnosing problems and debugging, as well as for instructional
36 purposes.
37
38 Install strace if you need a tool to track the system calls made and
39 received by a process.
40
41 This package provides the `strace64' program to trace 64-bit processes.
42 The `strace' program in the `strace' package is for 32-bit processes.
43 %endif
44
45 %prep
46 %setup -q
47
48 %build
49 %configure
50 make %{?_smp_mflags}
51
52 %install
53 make DESTDIR=%{buildroot} install
54
55 # remove unpackaged files from the buildroot
56 rm -f %{buildroot}%{_bindir}/strace-graph
57
58 %define copy64 ln
59 %if 0%{?rhel}
60 %if 0%{?rhel} < 6
61 %endif
62 %define copy64 cp -p
63 %endif
64
65 %ifarch %{strace64_arches}
66 %{copy64} %{buildroot}%{_bindir}/strace %{buildroot}%{_bindir}/strace64
67 %endif
68
69 %check
70 make -k check VERBOSE=1
71
72 %files
73 %doc CREDITS ChangeLog ChangeLog-CVS COPYING NEWS README
74 %{_bindir}/strace
75 %{_bindir}/strace-log-merge
76 %{_mandir}/man1/*
77
78 %ifarch %{strace64_arches}
79 %files -n strace64
80 %{_bindir}/strace64
81 %endif
82
83 %changelog
84 * Wed Dec 23 2015 Dmitry V. Levin <ldv@altlinux.org> - 4.11-2
85 - Enabled experimental -k option on x86_64 (#1170296).
86
87 * Mon Dec 21 2015 Dmitry V. Levin <ldv@altlinux.org> - 4.11-1
88 - New upstream release:
89   + print nanoseconds along with seconds in stat family syscalls (#1251176).
90
91 * Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.10-3
92 - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
93
94 * Mon May 11 2015 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 4.10-2
95 - Backport set of upstream patches to get it buildable on AArch64
96
97 * Fri Mar 06 2015 Dmitry V. Levin <ldv@altlinux.org> - 4.10-1
98 - New upstream release:
99   + enhanced ioctl decoding (#902788).
100
101 * Mon Nov 03 2014 Lubomir Rintel <lkundrak@v3.sk> - 4.9-3
102 - Regenerate ioctl entries with proper kernel headers
103
104 * Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.9-2
105 - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
106
107 * Fri Aug 15 2014 Dmitry V. Levin <ldv@altlinux.org> - 4.9-1
108 - New upstream release:
109   + fixed build when <sys/ptrace.h> and <linux/ptrace.h> conflict (#993384);
110   + updated CLOCK_* constants (#1088455);
111   + enabled ppc64le support (#1122323);
112   + fixed attach to a process on ppc64le (#1129569).
113
114 * Fri Jul 25 2014 Dan HorĂ¡k <dan[at]danny.cz> - 4.8-5
115 - update for ppc64
116
117 * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.8-4
118 - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
119
120 * Fri Dec  6 2013 Peter Robinson <pbrobinson@fedoraproject.org> 4.8-3
121 - Fix FTBFS
122
123 * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.8-2
124 - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
125
126 * Mon Jun 03 2013 Dmitry V. Levin <ldv@altlinux.org> - 4.8-1
127 - New upstream release:
128   + fixed ERESTARTNOINTR leaking to userspace on ancient kernels (#659382);
129   + fixed decoding of *xattr syscalls (#885233);
130   + fixed handling of files with 64-bit inode numbers by 32-bit strace (#912790);
131   + added aarch64 support (#969858).
132
133 * Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.7-3
134 - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
135
136 * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.7-2
137 - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
138
139 * Wed May 02 2012 Dmitry V. Levin <ldv@altlinux.org> 4.7-1
140 - New upstream release.
141   + implemented proper handling of real SIGTRAPs (#162774).
142
143 * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.6-2
144 - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
145
146 * Mon Mar 14 2011 Dmitry V. Levin <ldv@altlinux.org> - 4.6-1
147 - New upstream release.
148   + fixed a corner case in waitpid handling (#663547).
149
150 * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.20-2
151 - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
152
153 * Tue Apr 13 2010 Roland McGrath <roland@redhat.com> - 4.5.20-1
154 - New upstream release, work mostly by Andreas Schwab and Dmitry V. Levin.
155   + fixed potential stack buffer overflow in select decoder (#556678);
156   + fixed FTBFS (#539044).
157
158 * Wed Oct 21 2009 Roland McGrath <roland@redhat.com> - 4.5.19-1
159 - New upstream release, work mostly by Dmitry V. Levin <ldv@altlinux.org>
160   + exit/kill strace with traced process exitcode/signal (#105371);
161   + fixed build on ARM EABI (#507576);
162   + fixed display of 32-bit argv array on 64-bit architectures (#519480);
163   + fixed display of 32-bit fcntl(F_SETLK) on 64-bit architectures (#471169);
164   + fixed several bugs in strings decoder, including potential heap
165     memory corruption (#470529, #478324, #511035).
166
167 * Thu Aug 28 2008 Roland McGrath <roland@redhat.com> - 4.5.18-1
168 - build fix for newer kernel headers (#457291)
169 - fix CLONE_VFORK handling (#455078)
170 - Support new Linux/PPC system call subpage_prot and PROT_SAO flag.
171 - In sigaction system call, display sa_flags value along with SIG_DFL/SIG_IGN.
172
173 * Mon Jul 21 2008 Roland McGrath <roland@redhat.com> - 4.5.17-1
174 - handle O_CLOEXEC, MSG_CMSG_CLOEXEC (#365781)
175 - fix biarch stat64 decoding (#222275)
176 - fix spurious "..." in printing of environment strings (#358241)
177 - improve prctl decoding (#364401)
178 - fix hang wait on exited child with exited child (#354261)
179 - fix biarch fork/vfork (-f) tracing (#447475)
180 - fix biarch printing of negative argument kill (#430585)
181 - fix biarch decoding of error return values (#447587)
182 - fix -f tracing of CLONE_VFORK (#455078)
183 - fix ia64 register clobberation in -f tracing (#453438)
184 - print SO_NODEFER, SA_RESETHAND instead of SA_NOMASK, SA_ONESHOT (#455821)
185 - fix futex argument decoding (#448628, #448629)
186
187 * Fri Aug  3 2007 Roland McGrath <roland@redhat.com> - 4.5.16-1
188 - fix multithread issues (#240962, #240961, #247907)
189 - fix spurious SIGSTOP on early interrupt (#240986)
190 - fix utime for biarch (#247185)
191 - fix -u error message (#247170)
192 - better futex syscall printing (##241467)
193 - fix argv/envp printing with small -s settings, and for biarch
194 - new syscalls: getcpu, eventfd, timerfd, signalfd, epoll_pwait,
195   move_pages, utimensat
196
197 * Tue Jan 16 2007 Roland McGrath <roland@redhat.com> - 4.5.15-1
198 - biarch fixes (#179740, #192193, #171626, #173050, #218433, #218043)
199 - fix -ff -o behavior (#204950, #218435, #193808, #219423)
200 - better quotactl printing (#118696)
201 - *at, inotify*, pselect6, ppoll and unshare syscalls (#178633, #191275)
202 - glibc-2.5 build fixes (#209856)
203 - memory corruption fixes (#200621
204 - fix race in child setup under -f (#180293)
205 - show ipc key values in hex (#198179, #192182)
206 - disallow -c with -ff (#187847)
207 - Resolves: RHBZ #179740, RHBZ #192193, RHBZ #204950, RHBZ #218435
208 - Resolves: RHBZ #193808, RHBZ #219423, RHBZ #171626, RHBZ #173050
209 - Resolves: RHBZ #218433, RHBZ #218043, RHBZ #118696, RHBZ #178633
210 - Resolves: RHBZ #191275, RHBZ #209856, RHBZ #200621, RHBZ #180293
211 - Resolves: RHBZ #198179, RHBZ #198182, RHBZ #187847
212
213 * Mon Nov 20 2006 Jakub Jelinek <jakub@redhat.com> - 4.5.14-4
214 - Fix ia64 syscall decoding (#206768)
215 - Fix build with glibc-2.4.90-33 and up on all arches but ia64
216 - Fix build against 2.6.18+ headers
217
218 * Tue Aug 22 2006 Roland McGrath <roland@redhat.com> - 4.5.14-3
219 - Fix bogus decoding of syscalls >= 300 (#201462, #202620).
220
221 * Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-2
222 - rebuild
223
224 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.2
225 - bump again for long double bug on ppc{,64}
226
227 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.1
228 - rebuilt for new gcc4.1 snapshot and glibc changes
229
230 * Mon Jan 16 2006 Roland McGrath <roland@redhat.com> - 4.5.14-1
231 - Fix biarch decoding of socket syscalls (#174354).
232 - Fix biarch -e support (#173986).
233 - Accept numeric syscalls in -e (#174798).
234 - Fix ipc syscall decoding (#164755).
235 - Improve msgrcv printing (#164757).
236 - Man page updates (#165375).
237 - Improve mount syscall printing (#165377).
238 - Correct printing of restarting syscalls (#165469).
239
240 * Wed Aug  3 2005 Roland McGrath <roland@redhat.com> - 4.5.13-1
241 - Fix setsockopt decoding on 64-bit (#162449).
242 - Fix typos in socket option name strings (#161578).
243 - Display more IPV6 socket options by name (#162450).
244 - Don't display inappropriate syscalls for -e trace=file (#159340).
245 - New selector type -e trace=desc for file-descriptor using calls (#159400).
246 - Fix 32-bit old_mmap syscall decoding on x86-64 (#162467, #164215).
247 - Fix errors detaching from multithreaded process on interrupt (#161919).
248 - Note 4.5.12 fix for crash handling bad signal numbers (#162739).
249
250 * Wed Jun  8 2005 Roland McGrath <roland@redhat.com> - 4.5.12-1
251 - Fix known syscall recognition for IA32 processes on x86-64 (#158934).
252 - Fix bad output for ptrace on x86-64 (#159787).
253 - Fix potential buffer overruns (#151570, #159196).
254 - Make some diagnostics more consistent (#159308).
255 - Update PowerPC system calls.
256 - Better printing for Linux aio system calls.
257 - Don't truncate statfs64 fields to 32 bits in output (#158243).
258 - Cosmetic code cleanups (#159688).
259
260 * Tue Mar 22 2005 Roland McGrath <roland@redhat.com> - 4.5.11-1
261 - Build tweaks.
262 - Note 4.5.10 select fix (#151570).
263
264 * Mon Mar 14 2005 Roland McGrath <roland@redhat.com> - 4.5.10-1
265 - Fix select handling on nonstandard fd_set sizes.
266 - Don't print errors for null file name pointers.
267 - Fix initial execve output with -i (#143365).
268
269 * Fri Feb  4 2005 Roland McGrath <roland@redhat.com> - 4.5.9-2
270 - update ia64 syscall list (#146245)
271 - fix x86_64 syscall argument extraction for 32-bit processes (#146093)
272 - fix -e signal=NAME parsing (#143362)
273 - fix x86_64 exit_group syscall handling
274 - improve socket ioctl printing (#138223)
275 - code cleanups (#143369, #143370)
276 - improve mount flags printing (#141932)
277 - support symbolic printing of x86_64 arch_prctl parameters (#142667)
278 - fix potential crash in getxattr printing
279
280 * Tue Oct 19 2004 Roland McGrath <roland@redhat.com> - 4.5.8-1
281 - fix multithreaded exit handling (#132150, #135254)
282 - fix ioctl name matching (#129808)
283 - print RTC_* ioctl structure contents (#58606)
284 - grok epoll_* syscalls (#134463)
285 - grok new RLIMIT_* values (#133594)
286 - print struct cmsghdr contents for sendmsg (#131689)
287 - fix clock_* and timer_* argument output (#131420)
288
289 * Tue Aug 31 2004 Roland McGrath <roland@redhat.com> - 4.5.7-2
290 - new upstream version, misc fixes and updates (#128091, #129166, #128391, #129378, #130965, #131177)
291
292 * Mon Jul 12 2004 Roland McGrath <roland@redhat.com> 4.5.6-1
293 - new upstream version, updates ioctl lists (#127398), fixes quotactl (#127393), more ioctl decoding (#126917)
294
295 * Sun Jun 27 2004 Roland McGrath <roland@redhat.com> 4.5.5-1
296 - new upstream version, fixes x86-64 biarch support (#126547)
297
298 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> 4.5.4-2
299 - rebuilt
300
301 * Thu Jun  3 2004 Roland McGrath <roland@redhat.com> 4.5.4-0.FC1
302 - rebuilt for FC1 update
303
304 * Thu Jun  3 2004 Roland McGrath <roland@redhat.com> 4.5.4-1
305 - new upstream version, more ioctls (#122257), minor fixes
306
307 * Fri Apr 16 2004 Roland McGrath <roland@redhat.com> 4.5.3-1
308 - new upstream version, mq_* calls (#120701), -p vs NPTL (#120462), more fixes (#118694, #120541, #118685)
309
310 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 4.5.2-1.1
311 - rebuilt
312
313 * Mon Mar  1 2004 Roland McGrath <roland@redhat.com> 4.5.2-1
314 - new upstream version, sched_* calls (#116990), show core flag (#112117)
315
316 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
317 - rebuilt
318
319 * Thu Nov 13 2003 Roland McGrath <roland@redhat.com> 4.5.1-1
320 - new upstream version, more fixes (#108012, #105366, #105359, #105358)
321
322 * Tue Sep 30 2003 Roland McGrath <roland@redhat.com> 4.5-3
323 - revert bogus s390 fix
324
325 * Thu Sep 25 2003 Roland McGrath <roland@redhat.com> 4.5-1.2.1AS
326 - rebuilt for 2.1AS erratum
327
328 * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-2
329 - rebuilt
330
331 * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-1
332 - new upstream version, more fixes (#101499, #104365)
333
334 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-2
335 - rebuilt
336
337 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-1
338 - new upstream version, groks more new system calls, PF_INET6 sockets
339
340 * Tue Jun 10 2003 Roland McGrath <roland@redhat.com> 4.4.98-1
341 - new upstream version, more fixes (#90754, #91085)
342
343 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
344 - rebuilt
345
346 * Sun Mar 30 2003 Roland McGrath <roland@redhat.com> 4.4.96-1
347 - new upstream version, handles yet more 2.5 syscalls, x86_64 & ia64 fixes
348
349 * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com> 4.4.95-2
350 - rebuilt
351
352 * Mon Feb 24 2003 Roland McGrath <roland@redhat.com> 4.4.95-1
353 - new upstream version, fixed getresuid/getresgid (#84959)
354
355 * Wed Feb 19 2003 Roland McGrath <roland@redhat.com> 4.4.94-1
356 - new upstream version, new option -E to set environment variables (#82392)
357
358 * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.4.93-2
359 - rebuilt
360
361 * Tue Jan 21 2003 Roland McGrath <roland@redhat.com> 4.4.93-1
362 - new upstream version, fixes ppc and s390 bugs, adds missing ptrace requests
363
364 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.91-1
365 - new upstream version, fixes -f on x86-64
366
367 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.90-1
368 - new upstream version, fixes all known bugs modulo ia64 and s390 issues
369
370 * Fri Jan 03 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.4-11
371 - add further s390 patch from IBM
372
373 * Wed Nov 27 2002 Tim Powers <timp@redhat.com> 4.4-10
374 - remove unpackaged files from the buildroot
375
376 * Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.4-9.1
377 - Added latest s390(x) patch.
378
379 * Fri Sep 06 2002 Karsten Hopp <karsten@redhat.de> 4.4-9
380 - preliminary x86_64 support with an ugly patch to help
381   debugging. Needs cleanup!
382
383 * Mon Sep  2 2002 Jakub Jelinek <jakub@redhat.com> 4.4-8
384 - newer version of the clone fixing patch (Roland McGrath)
385 - aio syscalls for i386/ia64/ppc (Ben LaHaise)
386
387 * Wed Aug 28 2002 Jakub Jelinek <jakub@redhat.com> 4.4-7
388 - fix strace -f (Roland McGrath, #68994)
389 - handle ?et_thread_area, SA_RESTORER (Ulrich Drepper)
390
391 * Fri Jun 21 2002 Jakub Jelinek <jakub@redhat.com> 4.4-6
392 - handle futexes, *xattr, sendfile64, etc. (Ulrich Drepper)
393 - handle modify_ldt (#66894)
394
395 * Thu May 23 2002 Tim Powers <timp@redhat.com>
396 - automated rebuild
397
398 * Tue Apr 16 2002 Jakub Jelinek <jakub@redhat.com> 4.4-4
399 - fix for the last patch by Jeff Law (#62591)
400
401 * Mon Mar  4 2002 Preston Brown <pbrown@redhat.com> 4.4-3
402 - integrate patch from Jeff Law to eliminate hang tracing threads
403
404 * Sat Feb 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
405 - minor update from debian tar-ball
406
407 * Wed Jan 02 2002 Florian La Roche <Florian.LaRoche@redhat.de>
408 - update to 4.4
409
410 * Sun Jul 22 2001 Florian La Roche <Florian.LaRoche@redhat.de>
411 - disable s390 patches, they are already included
412
413 * Wed Jul 18 2001 Preston Brown <pbrown@redhat.com> 4.3-1
414 - new upstream version.  Seems to have integrated most new syscalls
415 - tracing threaded programs is now functional.
416
417 * Mon Jun 11 2001 Than Ngo <than@redhat.com>
418 - port s390 patches from IBM
419
420 * Wed May 16 2001 Nalin Dahyabhai <nalin@redhat.com>
421 - modify new syscall patch to allocate enough heap space in setgroups32()
422
423 * Wed Feb 14 2001 Jakub Jelinek <jakub@redhat.com>
424 - #include <time.h> in addition to <sys/time.h>
425
426 * Fri Jan 26 2001 Karsten Hopp <karsten@redhat.com>
427 - clean up conflicting patches. This happened only
428   when building on S390
429
430 * Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
431 - update to CVS, reintegrate ia64 support
432
433 * Fri Dec  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
434 - Get S/390 support into the normal package
435
436 * Sat Nov 18 2000 Florian La Roche <Florian.LaRoche@redhat.de>
437 - added S/390 patch from IBM, adapting it to not conflict with
438   IA64 patch
439
440 * Sat Aug 19 2000 Jakub Jelinek <jakub@redhat.com>
441 - doh, actually apply the 2.4 syscalls patch
442 - make it compile with 2.4.0-test7-pre4+ headers, add
443   getdents64 and fcntl64
444
445 * Thu Aug  3 2000 Jakub Jelinek <jakub@redhat.com>
446 - add a bunch of new 2.4 syscalls (#14036)
447
448 * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
449 - automatic rebuild
450 - excludearch ia64
451
452 * Fri Jun  2 2000 Matt Wilson <msw@redhat.com>
453 - use buildinstall for FHS
454
455 * Wed May 24 2000 Jakub Jelinek <jakub@redhat.com>
456 - make things compile on sparc
457 - fix sigreturn on sparc
458
459 * Fri Mar 31 2000 Bill Nottingham <notting@redhat.com>
460 - fix stat64 misdef (#10485)
461
462 * Tue Mar 21 2000 Michael K. Johnson <johnsonm@redhat.com>
463 - added ia64 patch
464
465 * Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
466 - man pages are compressed
467 - version 4.2 (why are we keeping all these patches around?)
468
469 * Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
470 - update to 4.1 (with sparc socketcall patch).
471
472 * Fri Nov 12 1999 Jakub Jelinek <jakub@redhat.com>
473 - fix socketcall on sparc.
474
475 * Thu Sep 02 1999 Cristian Gafton <gafton@redhat.com>
476 - fix KERN_SECURELVL compile problem
477
478 * Tue Aug 31 1999 Cristian Gafton <gafton@redhat.com>
479 - added alpha patch from HJLu to fix the osf_sigprocmask interpretation
480
481 * Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
482 - update to 3.99.1.
483
484 * Wed Jun  2 1999 Jeff Johnson <jbj@redhat.com>
485 - add (the other :-) jj's sparc patch.
486
487 * Wed May 26 1999 Jeff Johnson <jbj@redhat.com>
488 - upgrade to 3.99 in order to
489 -    add new 2.2.x open flags (#2955).
490 -    add new 2.2.x syscalls (#2866).
491 - strace 3.1 patches carried along for now.
492
493 * Sun May 16 1999 Jeff Johnson <jbj@redhat.com>
494 - don't rely on (broken!) rpm %%patch (#2735)
495
496 * Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
497 - strip binary
498
499 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
500 - auto rebuild in the new build environment (release 16)
501
502 * Tue Feb  9 1999 Jeff Johnson <jbj@redhat.com>
503 - vfork est arrive!
504
505 * Tue Feb  9 1999 Christopher Blizzard <blizzard@redhat.com>
506 - Add patch to follow clone() syscalls, too.
507
508 * Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
509 - patch to build alpha/sparc with glibc 2.1.
510
511 * Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
512 - patch to build on ARM
513
514 * Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
515 - fix typo (printf, not tprintf).
516
517 * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
518 - fix compile problem on sparc.
519
520 * Tue Aug 18 1998 Cristian Gafton <gafton@redhat.com>
521 - buildroot
522
523 * Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
524 - added the umoven patch from James Youngman <jay@gnu.org>
525 - fixed build problems on newer glibc releases
526
527 * Mon Jun 08 1998 Prospector System <bugs@redhat.com>
528 - translations modified for de, fr, tr