]> granicus.if.org Git - icinga2/blob - icinga2.spec
spec: Install icinga2.conf by default.
[icinga2] / icinga2.spec
1 Summary: network monitoring application
2 Name: icinga2
3 Version: 0.0.2
4 Release: 1%{?dist}
5 License: GPL
6 Group: Applications/System
7 Source: %{name}-%{version}.tar.gz
8 URL: http://www.icinga.org/
9 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
10
11 BuildRequires: asciidoc
12 BuildRequires: docbook-simple
13 BuildRequires: doxygen
14 BuildRequires: openssl-devel
15 BuildRequires: gcc-c++
16 BuildRequires: libstdc++-devel
17 BuildRequires: libtool-ltdl-devel
18 BuildRequires: boost
19 BuildRequires: boost-devel
20 BuildRequires: boost-test
21
22 %description
23 Icinga is a general-purpose network monitoring application.
24
25 %prep
26 %setup -q -n %{name}-%{version}
27
28 %build
29 %configure
30 make %{?_smp_mflags}
31
32 %install
33 [ "%{buildroot}" != "/" ] && [ -d "%{buildroot}" ] && rm -rf %{buildroot}
34 make install DESTDIR=%{buildroot}
35
36 # dist config
37 mv %{buildroot}%{_sysconfdir}/%{name}/%{name}.conf.dist %{buildroot}%{_sysconfdir}/%{name}/%{name}.conf
38
39 %clean
40 [ "%{buildroot}" != "/" ] && [ -d "%{buildroot}" ] && rm -rf %{buildroot}
41
42 %files
43 %defattr(-,root,root)
44 %{_sysconfdir}/%{name}
45 %config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
46 %attr(755,-,-) %{_sysconfdir}/init.d/%{name}
47 %{_bindir}/%{name}
48 %{_libdir}/%{name}
49 %{_datadir}/doc/%{name}
50 %{_datadir}/%{name}
51 %{_datadir}/%{name}/itl
52 %{_mandir}/man8/%{name}.8.gz
53
54
55
56 %changelog
57 * Sat May 04 2013 Michael Friedrich <michael.friedrich@netways.de> - 0.0.2-1
58 - new initscript in initdir
59 - itl is installed into datadir
60 - man pages in mandir
61 - use name macro to avoid typos
62
63 * Fri Nov 19 2012 Gunnar Beutner <gunnar.beutner@netways.de> - 0.0.1-1
64 - initial version