]> granicus.if.org Git - icinga2/blob - icinga2.spec
spec: Fix rhel/suse conditiations with {pre,post}un.
[icinga2] / icinga2.spec
1 #/******************************************************************************
2 # * Icinga 2                                                                   *
3 # * Copyright (C) 2012-2014 Icinga Development Team (http://www.icinga.org)    *
4 # *                                                                            *
5 # * This program is free software; you can redistribute it and/or              *
6 # * modify it under the terms of the GNU General Public License                *
7 # * as published by the Free Software Foundation; either version 2             *
8 # * of the License, or (at your option) any later version.                     *
9 # *                                                                            *
10 # * This program is distributed in the hope that it will be useful,            *
11 # * but WITHOUT ANY WARRANTY; without even the implied warranty of             *
12 # * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the              *
13 # * GNU General Public License for more details.                               *
14 # *                                                                            *
15 # * You should have received a copy of the GNU General Public License          *
16 # * along with this program; if not, write to the Free Software Foundation     *
17 # * Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.             *
18 # ******************************************************************************/
19
20 %define revision 2.beta2.dev
21
22 %if "%{_vendor}" == "redhat"
23 %define el5_boost_version 141
24 %define el5_boost_libs %{_libdir}/boost%{el5_boost_version}
25 %define el5_boost_includes /usr/include/boost%{el5_boost_version}
26 %define apachename httpd
27 %define apacheconfdir %{_sysconfdir}/httpd/conf.d
28 %define apacheuser apache
29 %define apachegroup apache
30 %endif
31 %if "%{_vendor}" == "suse"
32 # opensuse 13
33 %if 0%{?suse_version} >= 1310
34 %define opensuse_boost_version 1_53_0
35 %else
36 %define opensuse_boost_version 1_49_0
37 %endif
38 %define sles_boost_version 1_54_0
39 %define apachename apache2
40 %define apacheconfdir  %{_sysconfdir}/apache2/conf.d
41 %define apacheuser wwwrun
42 %define apachegroup www
43 %endif
44
45 %define icinga_user icinga
46 %define icinga_group icinga
47 %define icingacmd_group icingacmd
48 %define icingaweb2name icingaweb2
49 %define icingaweb2version 2.0.0
50
51 %define icingaclassicconfdir %{_sysconfdir}/icinga
52
53 %define logmsg logger -t %{name}/rpm
54
55 Summary: Network monitoring application
56 Name: icinga2
57 Version: 2.0.0
58 Release: %{revision}%{?dist}
59 License: GPLv2+
60 Group: Applications/System
61 Source: %{name}-%{version}.tar.gz
62 URL: http://www.icinga.org/
63 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
64
65 Requires: %{name}-bin = %{version}
66 #Requires: %{name}-ido-mysql = %{version}
67 #Requires: %{icingaweb2name} >= %{icingaweb2version}
68
69 %description
70 Meta package for Icinga 2 Core, DB IDO and Web.
71
72 %package bin
73 Summary:      Icinga 2 binaries and libraries
74 Group:        Applications/System
75
76 BuildRequires: openssl-devel
77 BuildRequires: gcc-c++
78 BuildRequires: libstdc++-devel
79 BuildRequires: cmake
80 BuildRequires: flex >= 2.5.35
81 BuildRequires: bison
82 BuildRequires: make
83
84 # redhat
85 %if "%{_vendor}" == "redhat"
86 %if 0%{?el5} || 0%{?rhel} == 5 || "%{?dist}" == ".el5"
87 # el5 requires EPEL
88 BuildRequires: boost%{el5_boost_version}-devel
89 BuildRequires: boost%{el5_boost_version}
90 Requires: boost%{el5_boost_version}-program-options
91 Requires: boost%{el5_boost_version}-system
92 Requires: boost%{el5_boost_version}-test
93 Requires: boost%{el5_boost_version}-thread
94 Requires: boost%{el5_boost_version}-regex
95 %else
96 BuildRequires: boost-devel >= 1.41
97 Requires: boost-program-options >= 1.41
98 Requires: boost-system >= 1.41
99 Requires: boost-test >= 1.41
100 Requires: boost-thread >= 1.41
101 Requires: boost-regex >= 1.41
102 %endif
103 %endif
104 #redhat
105
106 # suse
107 %if "%{_vendor}" == "suse"
108 # sles
109 # note: sles_version macro is not set in SLES11 anymore
110 # note: sles service packs are not under version control
111 %if 0%{?suse_version} == 1110
112 BuildRequires: gcc-fortran
113 BuildRequires: libgfortran43
114 BuildRequires: boost-license%{sles_boost_version}
115 BuildRequires: boost-devel >= 1.41
116 Requires: boost-license%{sles_boost_version}
117 Requires: libboost_program_options%{sles_boost_version}
118 Requires: libboost_system%{sles_boost_version}
119 Requires: libboost_test%{sles_boost_version}
120 Requires: libboost_thread%{sles_boost_version}
121 Requires: libboost_regex%{sles_boost_version}
122 %endif
123 # opensuse
124 %if 0%{?suse_version} >= 1210
125 BuildRequires: boost-devel >= 1.41
126 Requires: libboost_program_options%{opensuse_boost_version}
127 Requires: libboost_system%{opensuse_boost_version}
128 Requires: libboost_test%{opensuse_boost_version}
129 Requires: libboost_thread%{opensuse_boost_version}
130 Requires: libboost_regex%{opensuse_boost_version}
131 %endif
132 %endif
133 # suse
134
135 Requires: %{name}-common = %{version}
136
137 %description bin
138 Icinga 2 is a general-purpose network monitoring application.
139 Provides binaries and libraries for Icinga 2 Core.
140
141 %package common
142 Summary:      Common Icinga 2 configuration
143 Group:        Applications/System
144 %if "%{_vendor}" == "redhat"
145 Requires(pre): shadow-utils
146 Requires(post): shadow-utils
147 %endif
148
149 %description common
150 Provides common directories, uid and gid among Icinga 2 related
151 packages.
152
153
154 %package doc
155 Summary:      Documentation for Icinga 2
156 Group:        Applications/System
157 Requires:     %{name} = %{version}-%{release}
158
159 %description doc
160 Documentation for Icinga 2
161
162
163 %package ido-mysql
164 Summary:      IDO MySQL database backend for Icinga 2
165 Group:        Applications/System
166 %if "%{_vendor}" == "suse"
167 BuildRequires: libmysqlclient-devel
168 %if 0%{?suse_version} >= 1210
169 Requires: libmysqlclient18
170 %else
171 Requires: libmysqlclient15
172 %endif
173 %endif
174 %if "%{_vendor}" == "redhat"
175 # el5 only provides mysql package
176 %if 0%{?el5} || 0%{?rhel} == 5 || "%{?dist}" == ".el5"
177 BuildRequires: mysql
178 %else
179 BuildRequires: mysql-libs
180 BuildRequires: mysql
181 %endif
182 BuildRequires: mysql-devel
183 Requires: mysql
184 %endif
185 Requires: %{name} = %{version}-%{release}
186
187 %description ido-mysql
188 Icinga 2 IDO mysql database backend. Compatible with Icinga 1.x
189 IDOUtils schema >= 1.10
190
191
192 %package ido-pgsql
193 Summary:      IDO PostgreSQL database backend for Icinga 2
194 Group:        Applications/System
195 %if "%{_vendor}" == "suse"
196 BuildRequires: postgresql-libs
197 %endif
198 BuildRequires: postgresql-devel
199 Requires: postgresql-libs
200 Requires: %{name} = %{version}-%{release}
201
202 %description ido-pgsql
203 Icinga 2 IDO PostgreSQL database backend. Compatible with Icinga 1.x
204 IDOUtils schema >= 1.10
205
206
207 %package classicui-config
208 Summary:      Icinga 2 Classic UI Standalone configuration
209 Group:        Applications/System
210 BuildRequires: %{apachename}
211 Requires:     %{apachename}
212 Requires:     %{name} = %{version}-%{release}
213 Provides:     icinga-classicui-config
214 Conflicts:    icinga-gui-config
215
216 %description classicui-config
217 Icinga 1.x Classic UI Standalone configuration with locations
218 for Icinga 2.
219
220
221 %prep
222 %setup -q -n %{name}-%{version}
223
224 %build
225 CMAKE_OPTS="-DCMAKE_INSTALL_PREFIX=/usr \
226          -DCMAKE_INSTALL_SYSCONFDIR=/etc \
227                  -DCMAKE_INSTALL_LOCALSTATEDIR=/var \
228          -DCMAKE_BUILD_TYPE=RelWithDebInfo \
229          -DICINGA2_USER=%{icinga_user} \
230          -DICINGA2_GROUP=%{icinga_group} \
231              -DICINGA2_COMMAND_USER=%{icinga_user} \
232              -DICINGA2_COMMAND_GROUP=%{icingacmd_group}"
233 %if "%{_vendor}" == "redhat"
234 %if 0%{?el5} || 0%{?rhel} == 5 || "%{?dist}" == ".el5"
235 # Boost_VERSION 1.41.0 vs 101400 - disable build tests
236 # details in https://dev.icinga.org/issues/5033
237 CMAKE_OPTS="$CMAKE_OPTS -DBOOST_LIBRARYDIR=/usr/lib/boost141 \
238  -DBOOST_INCLUDEDIR=/usr/include/boost141 \
239  -DBoost_ADDITIONAL_VERSIONS='1.41;1.41.0' \
240  -DBoost_NO_SYSTEM_PATHS=TRUE \
241  -DBUILD_TESTING=FALSE \
242  -DBoost_NO_BOOST_CMAKE=TRUE"
243 %endif
244 %endif
245
246 cmake $CMAKE_OPTS .
247
248 make %{?_smp_mflags}
249
250 %install
251 [ "%{buildroot}" != "/" ] && [ -d "%{buildroot}" ] && rm -rf %{buildroot}
252 make install \
253         DESTDIR="%{buildroot}"
254
255 # install classicui config
256 install -D -m 0644 etc/icinga/icinga-classic.htpasswd %{buildroot}%{icingaclassicconfdir}/passwd
257 install -D -m 0644 etc/icinga/cgi.cfg %{buildroot}%{icingaclassicconfdir}/cgi.cfg
258 install -D -m 0644 etc/icinga/icinga-classic-apache.conf %{buildroot}%{apacheconfdir}/icinga.conf
259
260 # fix plugin path on x64
261 %if "%{_vendor}" != "suse"
262 sed -i 's@PluginDir = .*@PluginDir = "%{_libdir}/nagios/plugins"@' %{buildroot}/%{_sysconfdir}/%{name}/constants.conf
263 %endif
264
265 # remove features-enabled symlinks
266 rm -f %{buildroot}/%{_sysconfdir}/%{name}/features-enabled/*.conf
267
268 %clean
269 [ "%{buildroot}" != "/" ] && [ -d "%{buildroot}" ] && rm -rf %{buildroot}
270
271 %pre common
272 getent group %{icinga_group} >/dev/null || %{_sbindir}/groupadd -r %{icinga_group}
273 getent group %{icingacmd_group} >/dev/null || %{_sbindir}/groupadd -r %{icingacmd_group}
274 getent passwd %{icinga_user} >/dev/null || %{_sbindir}/useradd -c "icinga" -s /sbin/nologin -r -d %{_localstatedir}/spool/%{name} -G %{icingacmd_group} -g %{icinga_group} %{icinga_user}
275 exit 0
276
277 %post
278 # suse
279 %if 0%{?suse_version}
280
281 %{fillup_and_insserv icinga2}
282
283 if [ ${1:-0} -eq 1 ]
284 then
285         # initial installation, enable default features
286         %{_sbindir}/icinga2-enable-feature checker notification mainlog
287 fi
288
289 exit 0
290 %else
291 # rhel
292
293 /sbin/chkconfig --add icinga2
294
295 if [ ${1:-0} -eq 1 ]
296 then
297         # initial installation, enable default features
298         %{_sbindir}/icinga2-enable-feature checker notification mainlog
299 fi
300
301 exit 0
302
303 %endif
304 # suse/rhel
305
306 %postun
307 # suse
308 %if 0%{?suse_version}
309
310 %restart_on_update icinga2
311 %insserv_cleanup
312
313 if [ "$1" = "0" ]; then
314         # deinstallation of the package - remove enabled features
315         rm -rf %{_sysconfdir}/%{name}/features-enabled
316 fi
317
318 exit 0
319
320 %else
321 # rhel
322
323 if [ "$1" -ge  "1" ]; then
324         /sbin/service icinga2 condrestart >/dev/null 2>&1 || :
325 fi
326
327 if [ "$1" = "0" ]; then
328         # deinstallation of the package - remove enabled features
329         rm -rf %{_sysconfdir}/%{name}/features-enabled
330 fi
331
332 exit 0
333 %endif
334 # suse / rhel
335
336 %preun
337 # suse
338 %if 0%{?suse_version}
339
340 %stop_on_removal icinga2
341
342 %else
343 # rhel
344
345 if [ "$1" = "0" ]; then
346         /sbin/service icinga2 stop > /dev/null 2>&1
347         /sbin/chkconfig --del icinga2
348 fi
349
350 %endif
351 # suse / rhel
352
353 %post ido-mysql
354 if [ ${1:-0} -eq 1 ]
355 then
356         # initial installation, enable ido-mysql feature
357         %{_sbindir}/icinga2-enable-feature ido-mysql
358 fi
359
360 exit 0
361
362 %postun ido-mysql
363 if [ "$1" = "0" ]; then
364         # deinstallation of the package - remove feature
365         test -x %{_sbindir}/icinga2-disable-feature && %{_sbindir}/icinga2-disable-feature ido-mysql
366 fi
367
368 exit 0
369
370 %post ido-pgsql
371 if [ ${1:-0} -eq 1 ]
372 then
373         # initial installation, enable ido-pgsql feature
374         %{_sbindir}/icinga2-enable-feature ido-pgsql
375 fi
376
377 exit 0
378
379 %postun ido-pgsql
380 if [ "$1" = "0" ]; then
381         # deinstallation of the package - remove feature
382         test -x %{_sbindir}/icinga2-disable-feature && %{_sbindir}/icinga2-disable-feature ido-pgsql
383 fi
384
385 exit 0
386
387 %post classicui-config
388 if [ ${1:-0} -eq 1 ]
389 then
390         # initial installation, enable features
391         %{_sbindir}/icinga2-enable-feature statusdata compatlog command
392 fi
393
394 exit 0
395
396 %postun classicui-config
397 if [ "$1" = "0" ]; then
398         # deinstallation of the package - remove feature
399         test -x %{_sbindir}/icinga2-disable-feature && %{_sbindir}/icinga2-disable-feature statusdata
400         test -x %{_sbindir}/icinga2-disable-feature && %{_sbindir}/icinga2-disable-feature compatlog
401         test -x %{_sbindir}/icinga2-disable-feature && %{_sbindir}/icinga2-disable-feature command
402 fi
403
404 exit 0
405
406 %files
407
408 %files bin
409 %defattr(-,root,root,-)
410 %doc COPYING COPYING.Exceptions README NEWS AUTHORS ChangeLog
411 %attr(755,-,-) %{_sysconfdir}/init.d/%{name}
412 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}
413 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/conf.d
414 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/conf.d/hosts
415 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/conf.d/hosts/localhost
416 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/features-available
417 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/features-enabled
418 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/scripts
419 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/zones.d
420 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/%{name}.conf
421 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/constants.conf
422 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/zones.conf
423 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/conf.d/*.conf
424 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/conf.d/hosts/*.conf
425 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/conf.d/hosts/localhost/*.conf
426 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/features-available/*.conf
427 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/zones.d/*
428 %config(noreplace) %{_sysconfdir}/%{name}/scripts/*
429 %{_sbindir}/%{name}
430 %{_bindir}/%{name}-build-ca
431 %{_bindir}/%{name}-build-key
432 %{_bindir}/%{name}-sign-key
433 %{_sbindir}/%{name}-enable-feature
434 %{_sbindir}/%{name}-disable-feature
435 %{_sbindir}/%{name}-setup-agent
436 %{_sbindir}/%{name}-discover-agent
437 %{_sbindir}/%{name}-forget-agent
438 %{_sbindir}/%{name}-list-agents
439 %exclude %{_libdir}/%{name}/libdb_ido_mysql*
440 %exclude %{_libdir}/%{name}/libdb_ido_pgsql*
441 %{_libdir}/%{name}
442 %{_datadir}/%{name}
443 %exclude %{_datadir}/%{name}/include
444 %{_mandir}/man8/%{name}.8.gz
445
446 %attr(0755,%{icinga_user},%{icinga_group}) %{_localstatedir}/cache/%{name}
447 %attr(0755,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/log/%{name}
448 %attr(0755,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/log/%{name}/compat
449 %attr(0755,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/log/%{name}/compat/archives
450 %attr(0755,%{icinga_user},%{icinga_group}) %ghost %{_localstatedir}/run/%{name}
451 %attr(0750,%{icinga_user},%{icinga_group}) %{_localstatedir}/lib/%{name}
452
453 %attr(2755,%{icinga_user},%{icingacmd_group}) %ghost %{_localstatedir}/run/icinga2/cmd
454
455 %files common
456 %defattr(-,root,root,-)
457 %doc COPYING COPYING.Exceptions README NEWS AUTHORS ChangeLog tools/syntax
458 %attr(755,-,-) %{_sysconfdir}/logrotate.d/%{name}
459 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/spool/%{name}
460 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/spool/%{name}/perfdata
461 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/spool/%{name}/tmp
462 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_datadir}/%{name}/include
463 %{_datadir}/%{name}/include
464
465 %files doc
466 %defattr(-,root,root,-)
467 %{_datadir}/doc/%{name}
468 %docdir %{_datadir}/doc/%{name}
469
470 %files ido-mysql
471 %defattr(-,root,root,-)
472 %doc components/db_ido_mysql/schema COPYING COPYING.Exceptions README NEWS AUTHORS ChangeLog
473 %{_libdir}/%{name}/libdb_ido_mysql*
474
475 %files ido-pgsql
476 %defattr(-,root,root,-)
477 %doc components/db_ido_pgsql/schema COPYING COPYING.Exceptions README NEWS AUTHORS ChangeLog
478 %{_libdir}/%{name}/libdb_ido_pgsql*
479
480 %files classicui-config
481 %defattr(-,root,root,-)
482 %attr(0751,%{icinga_user},%{icinga_group}) %dir %{icingaclassicconfdir}
483 %config(noreplace) %{icingaclassicconfdir}/cgi.cfg
484 %config(noreplace) %{apacheconfdir}/icinga.conf
485 %config(noreplace) %attr(0640,root,%{apachegroup}) %{icingaclassicconfdir}/passwd
486
487
488 %changelog