]> granicus.if.org Git - icinga2/blob - icinga2.spec
Fix plugin path for SLES.
[icinga2] / icinga2.spec
1 #/******************************************************************************
2 # * Icinga 2                                                                   *
3 # * Copyright (C) 2012-2013 Icinga Development Team (http://www.icinga.org/)   *
4 # *                                                                            *
5 # * This program is free software; you can redistribute it and/or              *
6 # * modify it under the terms of the GNU General Public License                *
7 # * as published by the Free Software Foundation; either version 2             *
8 # * of the License, or (at your option) any later version.                     *
9 # *                                                                            *
10 # * This program is distributed in the hope that it will be useful,            *
11 # * but WITHOUT ANY WARRANTY; without even the implied warranty of             *
12 # * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the              *
13 # * GNU General Public License for more details.                               *
14 # *                                                                            *
15 # * You should have received a copy of the GNU General Public License          *
16 # * along with this program; if not, write to the Free Software Foundation     *
17 # * Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.             *
18 # ******************************************************************************/
19
20 %define revision 1
21
22 %if "%{_vendor}" == "redhat"
23 %define el5_boost_version 141
24 %define el5_boost_libs %{_libdir}/boost%{el5_boost_version}
25 %define el5_boost_includes /usr/include/boost%{el5_boost_version}
26 %define apachename httpd
27 %define apacheconfdir %{_sysconfdir}/httpd/conf.d
28 %define apacheuser apache
29 %define apachegroup apache
30 %endif
31 %if "%{_vendor}" == "suse"
32 %define opensuse_boost_version 1_49_0
33 %define sles_boost_version 1_54_0
34 %define apachename apache2
35 %define apacheconfdir  %{_sysconfdir}/apache2/conf.d
36 %define apacheuser wwwrun
37 %define apachegroup www
38 %endif
39
40 %define icinga_user icinga
41 %define icinga_group icinga
42 %define icingacmd_group icingacmd
43
44 %define icingaclassicconfdir %{_sysconfdir}/icinga
45
46 %define logmsg logger -t %{name}/rpm
47
48 Summary: network monitoring application
49 Name: icinga2
50 Version: 0.0.4
51 Release: %{revision}%{?dist}
52 License: GPLv2+
53 Group: Applications/System
54 Source: %{name}-%{version}.tar.gz
55 URL: http://www.icinga.org/
56 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
57
58 BuildRequires: doxygen
59 BuildRequires: openssl-devel
60 BuildRequires: gcc-c++
61 BuildRequires: libstdc++-devel
62 BuildRequires: cmake
63 BuildRequires: flex
64 BuildRequires: bison
65 BuildRequires: %{apachename}
66
67 # redhat
68 %if "%{_vendor}" == "redhat"
69 %if 0%{?el5} || 0%{?rhel} == 5 || "%{?dist}" == ".el5"
70 # el5 requires EPEL
71 BuildRequires: boost%{el5_boost_version}-devel
72 BuildRequires: boost%{el5_boost_version}
73 Requires: boost%{el5_boost_version}-program-options
74 Requires: boost%{el5_boost_version}-system
75 Requires: boost%{el5_boost_version}-test
76 Requires: boost%{el5_boost_version}-thread
77 Requires: boost%{el5_boost_version}-regex
78 %else
79 BuildRequires: boost-devel >= 1.41
80 Requires: boost-program-options >= 1.41
81 Requires: boost-system >= 1.41
82 Requires: boost-test >= 1.41
83 Requires: boost-thread >= 1.41
84 Requires: boost-regex >= 1.41
85 %endif
86 %endif
87 #redhat
88
89 # suse
90 %if "%{_vendor}" == "suse"
91 # sles
92 # note: sles_version macro is not set in SLES11 anymore
93 # note: sles service packs are not under version control
94 %if 0%{?suse_version} == 1110
95 BuildRequires: gcc-fortran
96 BuildRequires: libgfortran43
97 BuildRequires: boost-license%{sles_boost_version}
98 BuildRequires: boost-devel >= 1.41
99 Requires: boost-license%{sles_boost_version}
100 Requires: libboost_program_options%{sles_boost_version}
101 Requires: libboost_system%{sles_boost_version}
102 Requires: libboost_test%{sles_boost_version}
103 Requires: libboost_thread%{sles_boost_version}
104 Requires: libboost_regex%{sles_boost_version}
105 %endif
106 # opensuse
107 %if 0%{?suse_version} >= 1210
108 BuildRequires: boost-devel >= 1.41
109 Requires: libboost_program_options%{opensuse_boost_version}
110 Requires: libboost_system%{opensuse_boost_version}
111 Requires: libboost_test%{opensuse_boost_version}
112 Requires: libboost_thread%{opensuse_boost_version}
113 Requires: libboost_regex%{opensuse_boost_version}
114 %endif
115 %endif
116 # suse
117
118 Requires: %{name}-common = %{version}
119
120 %description
121 Icinga is a general-purpose network monitoring application.
122
123 %package common
124 Summary:      Common Icinga 2 configuration
125 Group:        Applications/System
126 %if "%{_vendor}" == "redhat"
127 Requires(pre): shadow-utils
128 Requires(post): shadow-utils
129 %endif
130
131 %description common
132 Provides common directories, uid and gid among Icinga 2 related
133 packages.
134
135
136 %package doc
137 Summary:      Documentation for Icinga 2
138 Group:        Applications/System
139 Requires:     %{name} = %{version}-%{release}
140
141 %description doc
142 Documentation for Icinga 2
143
144
145 %package ido-mysql
146 Summary:      IDO MySQL database backend for Icinga 2
147 Group:        Applications/System
148 %if "%{_vendor}" == "suse"
149 BuildRequires: libmysqlclient-devel
150 Requires: libmysqlclient18
151 %endif
152 %if "%{_vendor}" == "redhat"
153 # el5 only provides mysql package
154 %if 0%{?el5} || 0%{?rhel} == 5 || "%{?dist}" == ".el5"
155 BuildRequires: mysql
156 %else
157 BuildRequires: mysql-libs
158 BuildRequires: mysql
159 %endif
160 BuildRequires: mysql-devel
161 Requires: mysql
162 %endif
163 Requires: %{name} = %{version}-%{release}
164
165 %description ido-mysql
166 Icinga 2 IDO mysql database backend. Compatible with Icinga 1.x
167 IDOUtils schema >= 1.10
168
169
170 %package ido-pgsql
171 Summary:      IDO PostgreSQL database backend for Icinga 2
172 Group:        Applications/System
173 %if "%{_vendor}" == "suse"
174 BuildRequires: postgresql-libs
175 %endif
176 %if "%{_vendor}" == "redhat"
177 # el5 only provides mysql package
178 %if 0%{?el5} || 0%{?rhel} == 5 || "%{?dist}" == ".el5"
179 BuildRequires: postgresql84
180 %endif
181 %endif
182 BuildRequires: postgresql-devel
183 Requires: postgresql-libs
184 Requires: %{name} = %{version}-%{release}
185
186 %description ido-pgsql
187 Icinga 2 IDO PostgreSQL database backend. Compatible with Icinga 1.x
188 IDOUtils schema >= 1.10
189
190
191 %package classicui-config
192 Summary:      Icinga 2 Classic UI Standalone configuration
193 Group:        Applications/System
194 Requires:     %{apachename}
195 Requires:     %{name} = %{version}-%{release}
196 Provides:     icinga-classicui-config
197 Conflicts:    icinga-gui-config
198
199 %description classicui-config
200 Icinga 1.x Classic UI Standalone configuration with locations
201 for Icinga 2.
202
203
204 %prep
205 %setup -q -n %{name}-%{version}
206
207 %build
208 CMAKE_OPTS="-DCMAKE_INSTALL_PREFIX=/usr \
209          -DCMAKE_INSTALL_SYSCONFDIR=/etc \
210                  -DCMAKE_INSTALL_LOCALSTATEDIR=/var \
211          -DCMAKE_BUILD_TYPE=RelWithDebInfo \
212          -DICINGA2_USER=%{icinga_user} \
213          -DICINGA2_GROUP=%{icinga_group} \
214              -DICINGA2_COMMAND_USER=%{icinga_user} \
215              -DICINGA2_COMMAND_GROUP=%{icingacmd_group}"
216 %if "%{_vendor}" == "redhat"
217 %if 0%{?el5} || 0%{?rhel} == 5 || "%{?dist}" == ".el5"
218 CMAKE_OPTS="$CMAKE_OPTS -DBOOST_LIBRARYDIR=/usr/lib/boost141 \
219  -DBOOST_INCLUDEDIR=/usr/include/boost141 \
220  -DBoost_ADDITIONAL_VERSIONS='1.41;1.41.0'"
221 %endif
222 %endif
223 cmake $CMAKE_OPTS . 
224
225 make %{?_smp_mflags}
226
227 %install
228 [ "%{buildroot}" != "/" ] && [ -d "%{buildroot}" ] && rm -rf %{buildroot}
229 make install \
230         DESTDIR="%{buildroot}"
231
232 # install classicui config
233 install -D -m 0644 etc/icinga/icinga-classic.htpasswd %{buildroot}%{icingaclassicconfdir}/passwd
234 install -D -m 0644 etc/icinga/cgi.cfg %{buildroot}%{icingaclassicconfdir}/cgi.cfg
235 install -D -m 0644 etc/icinga/icinga-classic-apache.conf %{buildroot}%{apacheconfdir}/icinga.conf
236
237 # fix plugin path on x64
238 %if "%{_vendor}" != "suse"
239 sed -i 's@plugindir = .*@plugindir = "%{_libdir}/nagios/plugins"@' %{buildroot}/%{_sysconfdir}/%{name}/conf.d/macros.conf
240 %endif
241
242 %clean
243 [ "%{buildroot}" != "/" ] && [ -d "%{buildroot}" ] && rm -rf %{buildroot}
244
245 %pre common
246 getent group %{icinga_group} >/dev/null || %{_sbindir}/groupadd -r %{icinga_group}
247 getent group %{icingacmd_group} >/dev/null || %{_sbindir}/groupadd -r %{icingacmd_group}
248 getent passwd %{icinga_user} >/dev/null || %{_sbindir}/useradd -c "icinga" -s /sbin/nologin -r -d %{_localstatedir}/spool/%{name} -G %{icingacmd_group} -g %{icinga_group} %{icinga_user}
249 exit 0
250
251 %post ido-mysql
252 if [ ${1:-0} -eq 1 ]
253 then
254         # initial installation, enable ido-mysql feature
255         %{_sbindir}/icinga2-enable-feature ido-mysql
256 fi
257
258 %postun ido-mysql
259 if [ "$1" = "0" ]; then
260         # deinstallation of the package - remove feature
261         test -x %{_sbindir}/icinga2-disable-feature && %{_sbindir}/icinga2-disable-feature ido-mysql
262 fi
263
264 %post ido-pgsql
265 if [ ${1:-0} -eq 1 ]
266 then
267         # initial installation, enable ido-pgsql feature
268         %{_sbindir}/icinga2-enable-feature ido-pgsql
269 fi
270
271 %postun ido-pgsql
272 if [ "$1" = "0" ]; then
273         # deinstallation of the package - remove feature
274         test -x %{_sbindir}/icinga2-disable-feature && %{_sbindir}/icinga2-disable-feature ido-pgsql
275 fi
276
277 %post classicui-config
278 if [ ${1:-0} -eq 1 ]
279 then
280         # initial installation, enable features
281         %{_sbindir}/icinga2-enable-feature statusdata
282         %{_sbindir}/icinga2-enable-feature compatlog
283         %{_sbindir}/icinga2-enable-feature command
284 fi
285
286 %postun classicui-config
287 if [ "$1" = "0" ]; then
288         # deinstallation of the package - remove feature
289         test -x %{_sbindir}/icinga2-disable-feature && %{_sbindir}/icinga2-disable-feature statusdata
290         test -x %{_sbindir}/icinga2-disable-feature && %{_sbindir}/icinga2-disable-feature compatlog
291         test -x %{_sbindir}/icinga2-disable-feature && %{_sbindir}/icinga2-disable-feature command
292 fi
293
294 %files
295 %defattr(-,root,root,-)
296 %doc COPYING COPYING.Exceptions README NEWS AUTHORS ChangeLog
297 %attr(755,-,-) %{_sysconfdir}/init.d/%{name}
298 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/conf.d
299 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/features-available
300 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/features-enabled
301 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/%{name}.conf
302 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/conf.d/*.conf
303 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/features-available/*.conf
304 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/features-enabled/*.conf
305 %{_sbindir}/%{name}
306 %{_bindir}/%{name}-migrate-config
307 %{_bindir}/%{name}-build-ca
308 %{_bindir}/%{name}-build-key
309 %{_sbindir}/%{name}-enable-feature
310 %{_sbindir}/%{name}-disable-feature
311 %exclude %{_libdir}/%{name}/libdb_ido_mysql*
312 %{_libdir}/%{name}
313 %{_datadir}/%{name}
314 %exclude %{_datadir}/%{name}/itl
315 %{_mandir}/man8/%{name}.8.gz
316
317 %attr(0755,%{icinga_user},%{icinga_group}) %{_localstatedir}/cache/%{name}
318 %attr(0755,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/log/%{name}
319 %attr(0755,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/log/%{name}/compat
320 %attr(0755,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/log/%{name}/compat/archives
321 %attr(0755,%{icinga_user},%{icinga_group}) %{_localstatedir}/run/%{name}
322 %attr(0750,%{icinga_user},%{icinga_group}) %{_localstatedir}/lib/%{name}
323
324 %attr(2755,%{icinga_user},%{icingacmd_group}) %{_localstatedir}/run/icinga2/cmd
325
326 %files common
327 %defattr(-,root,root,-)
328 %doc COPYING COPYING.Exceptions README NEWS AUTHORS ChangeLog
329 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/spool/%{name}
330 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_datadir}/%{name}/itl
331 %{_datadir}/%{name}/itl
332
333 %files doc
334 %defattr(-,root,root,-)
335 %doc COPYING COPYING.Exceptions README NEWS AUTHORS ChangeLog
336 %{_datadir}/doc/%{name}
337 %docdir %{_datadir}/doc/%{name}
338
339 %files ido-mysql
340 %defattr(-,root,root,-)
341 %doc components/db_ido_mysql/schema COPYING COPYING.Exceptions README NEWS AUTHORS ChangeLog
342 %{_libdir}/%{name}/libdb_ido_mysql*
343
344 %files ido-pgsql
345 %defattr(-,root,root,-)
346 %doc components/db_ido_pgsql/schema COPYING COPYING.Exceptions README NEWS AUTHORS ChangeLog
347 %{_libdir}/%{name}/libdb_ido_pgsql*
348
349 %files classicui-config
350 %defattr(-,root,root,-)
351 %config(noreplace) %{icingaclassicconfdir}/cgi.cfg
352 %config(noreplace) %{apacheconfdir}/icinga.conf
353 %config(noreplace) %attr(0640,root,%{apachegroup}) %{icingaclassicconfdir}/passwd
354
355
356 %changelog