]> granicus.if.org Git - icinga2/blob - icinga2.spec
Update icinga2.spec
[icinga2] / icinga2.spec
1 Summary: network monitoring application
2 Name: icinga2
3 Version: 0.0.2
4 Release: 1%{?dist}
5 License: GPL
6 Group: Applications/System
7 Source: %{name}-%{version}.tar.gz
8 URL: http://www.icinga.org/
9 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
10
11 BuildRequires: asciidoc
12 BuildRequires: docbook-simple
13 BuildRequires: doxygen
14 BuildRequires: openssl-devel
15 BuildRequires: gcc-c++
16 BuildRequires: libstdc++-devel
17 BuildRequires: libtool-ltdl-devel
18 BuildRequires: automake
19 BuildRequires: autoconf
20 BuildRequires: libtool
21 BuildRequires: help2man
22 BuildRequires: flex
23 BuildRequires: bison
24
25
26 # TODO: figure out how to handle boost on el5
27 BuildRequires: boost
28 BuildRequires: boost-devel
29 BuildRequires: boost-test
30
31 %description
32 Icinga is a general-purpose network monitoring application.
33
34 %prep
35 %setup -q -n %{name}-%{version}
36
37 %build
38 sh autogen.sh
39 %configure
40 make %{?_smp_mflags}
41
42 %install
43 [ "%{buildroot}" != "/" ] && [ -d "%{buildroot}" ] && rm -rf %{buildroot}
44 make install DESTDIR=%{buildroot}
45
46 # dist config
47 mv %{buildroot}%{_sysconfdir}/%{name}/%{name}.conf.dist %{buildroot}%{_sysconfdir}/%{name}/%{name}.conf
48
49 %clean
50 [ "%{buildroot}" != "/" ] && [ -d "%{buildroot}" ] && rm -rf %{buildroot}
51
52 %files
53 %defattr(-,root,root)
54 %doc README AUTHORS ChangeLog COPYING COPYING.Exceptions
55 %{_sysconfdir}/%{name}
56 %config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
57 %attr(755,-,-) %{_sysconfdir}/init.d/%{name}
58 %{_bindir}/%{name}
59 %{_libdir}/%{name}
60 %{_datadir}/doc/%{name}
61 %{_datadir}/%{name}
62 %{_datadir}/%{name}/itl
63 %{_mandir}/man8/%{name}.8.gz
64
65 %{_localstatedir}/cache/%{name}
66 %{_localstatedir}/log/%{name}
67 %{_localstatedir}/run/%{name}
68 %{_localstatedir}/lib/%{name}
69 %{_localstatedir}/spool/%{name}
70 %{_localstatedir}/spool/%{name}/perfdata
71
72
73
74 %changelog
75 * Sat May 04 2013 Michael Friedrich <michael.friedrich@netways.de> - 0.0.2-1
76 - new initscript in initdir
77 - itl is installed into datadir
78 - man pages in mandir
79 - use name macro to avoid typos
80
81 * Fri Nov 19 2012 Gunnar Beutner <gunnar.beutner@netways.de> - 0.0.1-1
82 - initial version