]> granicus.if.org Git - icinga2/blob - icinga2.spec
Cli: Add blacklist/whitelist commands for agent commands
[icinga2] / icinga2.spec
1 #/******************************************************************************
2 # * Icinga 2                                                                   *
3 # * Copyright (C) 2012-2014 Icinga Development Team (http://www.icinga.org)    *
4 # *                                                                            *
5 # * This program is free software; you can redistribute it and/or              *
6 # * modify it under the terms of the GNU General Public License                *
7 # * as published by the Free Software Foundation; either version 2             *
8 # * of the License, or (at your option) any later version.                     *
9 # *                                                                            *
10 # * This program is distributed in the hope that it will be useful,            *
11 # * but WITHOUT ANY WARRANTY; without even the implied warranty of             *
12 # * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the              *
13 # * GNU General Public License for more details.                               *
14 # *                                                                            *
15 # * You should have received a copy of the GNU General Public License          *
16 # * along with this program; if not, write to the Free Software Foundation     *
17 # * Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.             *
18 # ******************************************************************************/
19
20 %define revision 1
21
22 # make sure that _rundir is working on older systems
23 %if ! %{defined _rundir}
24 %define _rundir %{_localstatedir}/run
25 %endif
26
27 %if "%{_vendor}" == "redhat"
28 %define apachename httpd
29 %define apacheconfdir %{_sysconfdir}/httpd/conf.d
30 %define apacheuser apache
31 %define apachegroup apache
32 %if 0%{?el5}%{?el6}
33 %define use_systemd 0
34 %else
35 # fedora and el>=7
36 %define use_systemd 1
37 %endif
38 %endif
39
40 %if "%{_vendor}" == "suse"
41 %define apachename apache2
42 %define apacheconfdir  %{_sysconfdir}/apache2/conf.d
43 %define apacheuser wwwrun
44 %define apachegroup www
45 %if 0%{?suse_version} >= 1310
46 %define use_systemd 1
47 %else
48 %define use_systemd 0
49 %endif
50 %endif
51
52 %define icinga_user icinga
53 %define icinga_group icinga
54 %define icingacmd_group icingacmd
55 %define icingaweb2name icingaweb2
56 %define icingaweb2version 2.0.0
57
58 %define icingaclassicconfdir %{_sysconfdir}/icinga
59
60 %define logmsg logger -t %{name}/rpm
61
62 Summary: Network monitoring application
63 Name: icinga2
64 Version: 2.1.1
65 Release: %{revision}%{?dist}
66 License: GPL-2.0+
67 Group: Applications/System
68 Source: https://github.com/Icinga/%{name}/archive/v%{version}.tar.gz
69 URL: http://www.icinga.org/
70 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
71 Requires: %{name}-bin = %{version}-%{release}
72
73 %description
74 Meta package for Icinga 2 Core, DB IDO and Web.
75
76 %package bin
77 Summary:      Icinga 2 binaries and libraries
78 Group:        Applications/System
79
80 %if "%{_vendor}" == "suse"
81 PreReq:        permissions
82 Provides:      monitoring_daemon
83 Recommends:    monitoring-plugins
84 %endif
85 BuildRequires: openssl-devel
86 BuildRequires: gcc-c++
87 BuildRequires: libstdc++-devel
88 BuildRequires: cmake
89 BuildRequires: flex >= 2.5.35
90 BuildRequires: bison
91 BuildRequires: make
92
93 %if "%{_vendor}" == "redhat" && (0%{?el5} || 0%{?rhel} == 5 || "%{?dist}" == ".el5")
94 # el5 requires EPEL
95 BuildRequires: boost141-devel
96 %else
97 BuildRequires: boost-devel >= 1.41
98 %endif
99
100 %if 0%{?use_systemd}
101 BuildRequires: systemd
102 Requires: systemd
103 %endif
104
105 Requires: %{name}-common = %{version}-%{release}
106
107 %description bin
108 Icinga 2 is a general-purpose network monitoring application.
109 Provides binaries and libraries for Icinga 2 Core.
110
111 %package common
112 Summary:      Common Icinga 2 configuration
113 Group:        Applications/System
114 %if "%{_vendor}" == "redhat"
115 Requires(pre): shadow-utils
116 Requires(post): shadow-utils
117 %endif
118 %if "%{_vendor}" == "suse"
119 Recommends:   logrotate
120 %endif
121
122 %description common
123 Provides common directories, uid and gid among Icinga 2 related
124 packages.
125
126
127 %package doc
128 Summary:      Documentation for Icinga 2
129 Group:        Applications/System
130 Requires:     %{name} = %{version}-%{release}
131
132 %description doc
133 Provides documentation for Icinga 2.
134
135
136 %package ido-mysql
137 Summary:      IDO MySQL database backend for Icinga 2
138 Group:        Applications/System
139 %if "%{_vendor}" == "suse"
140 BuildRequires: libmysqlclient-devel
141 %endif
142 BuildRequires: mysql-devel
143 Requires: %{name} = %{version}-%{release}
144
145 %description ido-mysql
146 Icinga 2 IDO mysql database backend. Compatible with Icinga 1.x
147 IDOUtils schema >= 1.10
148
149
150 %package ido-pgsql
151 Summary:      IDO PostgreSQL database backend for Icinga 2
152 Group:        Applications/System
153 BuildRequires: postgresql-devel
154 Requires: %{name} = %{version}-%{release}
155
156 %description ido-pgsql
157 Icinga 2 IDO PostgreSQL database backend. Compatible with Icinga 1.x
158 IDOUtils schema >= 1.10
159
160
161 %package classicui-config
162 Summary:      Icinga 2 Classic UI Standalone configuration
163 Group:        Applications/System
164 BuildRequires: %{apachename}
165 Requires:     %{apachename}
166 Requires:     %{name} = %{version}-%{release}
167 %if "%{_vendor}" == "suse"
168 Recommends:   icinga-www
169 %endif
170 Provides:     icinga-classicui-config
171 Conflicts:    icinga-gui-config
172
173 %description classicui-config
174 Icinga 1.x Classic UI Standalone configuration with locations
175 for Icinga 2.
176
177
178 %prep
179 %setup -q -n %{name}-%{version}
180
181 %build
182 CMAKE_OPTS="-DCMAKE_INSTALL_PREFIX=/usr \
183          -DCMAKE_INSTALL_SYSCONFDIR=/etc \
184          -DCMAKE_INSTALL_LOCALSTATEDIR=/var \
185          -DCMAKE_BUILD_TYPE=RelWithDebInfo \
186          -DICINGA2_RUNDIR=%{_rundir} \
187          -DICINGA2_USER=%{icinga_user} \
188          -DICINGA2_GROUP=%{icinga_group} \
189          -DICINGA2_COMMAND_GROUP=%{icingacmd_group} \
190          -DICINGA2_UNITY_BUILD=TRUE"
191 %if "%{_vendor}" == "redhat"
192 %if 0%{?el5} || 0%{?rhel} == 5 || "%{?dist}" == ".el5"
193 # Boost_VERSION 1.41.0 vs 101400 - disable build tests
194 # details in https://dev.icinga.org/issues/5033
195 CMAKE_OPTS="$CMAKE_OPTS -DBOOST_LIBRARYDIR=/usr/lib/boost141 \
196  -DBOOST_INCLUDEDIR=/usr/include/boost141 \
197  -DBoost_ADDITIONAL_VERSIONS='1.41;1.41.0' \
198  -DBoost_NO_SYSTEM_PATHS=TRUE \
199  -DBUILD_TESTING=FALSE \
200  -DBoost_NO_BOOST_CMAKE=TRUE"
201 %endif
202 %endif
203
204 %if "%{_vendor}" != "suse"
205 CMAKE_OPTS="$CMAKE_OPTS -DICINGA2_PLUGINDIR=%{_libdir}/nagios/plugins"
206 %else
207 CMAKE_OPTS="$CMAKE_OPTS -DICINGA2_PLUGINDIR=%{_prefix}/lib/nagios/plugins"
208 %endif
209
210 %if 0%{?use_systemd}
211 CMAKE_OPTS="$CMAKE_OPTS -DUSE_SYSTEMD=ON"
212 %endif
213
214 cmake $CMAKE_OPTS .
215
216 make %{?_smp_mflags}
217
218
219 %install
220 make install \
221         DESTDIR="%{buildroot}"
222
223 # install classicui config
224 install -D -m 0644 etc/icinga/icinga-classic.htpasswd %{buildroot}%{icingaclassicconfdir}/passwd
225 install -D -m 0644 etc/icinga/cgi.cfg %{buildroot}%{icingaclassicconfdir}/cgi.cfg
226 install -D -m 0644 etc/icinga/icinga-classic-apache.conf %{buildroot}%{apacheconfdir}/icinga.conf
227
228 # remove features-enabled symlinks
229 rm -f %{buildroot}/%{_sysconfdir}/%{name}/features-enabled/*.conf
230
231 # enable suse rc links
232 %if "%{_vendor}" == "suse"
233 %if 0%{?use_systemd}
234   ln -sf /usr/sbin/service %{buildroot}%{_sbindir}/rc%{name}
235 %else
236   ln -sf ../../%{_initrddir}/%{name} "%{buildroot}%{_sbindir}/rc%{name}"
237 %endif
238 mkdir -p "%{buildroot}%{_localstatedir}/adm/fillup-templates/"
239 mv "%{buildroot}%{_sysconfdir}/sysconfig/%{name}" "%{buildroot}%{_localstatedir}/adm/fillup-templates/sysconfig.%{name}"
240 %endif
241
242
243 %clean
244 [ "%{buildroot}" != "/" ] && [ -d "%{buildroot}" ] && rm -rf %{buildroot}
245
246 %pre common
247 getent group %{icinga_group} >/dev/null || %{_sbindir}/groupadd -r %{icinga_group}
248 getent group %{icingacmd_group} >/dev/null || %{_sbindir}/groupadd -r %{icingacmd_group}
249 getent passwd %{icinga_user} >/dev/null || %{_sbindir}/useradd -c "icinga" -s /sbin/nologin -r -d %{_localstatedir}/spool/%{name} -G %{icingacmd_group} -g %{icinga_group} %{icinga_user}
250 exit 0
251
252 %if "%{_vendor}" == "suse"
253 %verifyscript bin
254 %verify_permissions -e %{_rundir}/%{name}/cmd
255 %endif
256
257
258 %if "%{_vendor}" == "suse"
259 %if 0%{?use_systemd}
260 %pre bin
261   %service_add_pre %{name}.service
262 %endif
263 %endif
264
265 %post common
266 /usr/share/icinga2/migrate-hosts
267
268 # all restart/feature actions belong to icinga2-bin
269 %post bin
270 # suse
271 %if "%{_vendor}" == "suse"
272 %if 0%{?suse_version} >= 1310
273 %set_permissions %{_rundir}/%{name}/cmd
274 %endif
275 %if 0%{?use_systemd}
276 %fillup_only  %{name}
277 %service_add_post %{name}.service
278 %else
279 %fillup_and_insserv %{name}
280 %endif
281
282 # initial installation, enable default features
283 %{_sbindir}/icinga2 feature enable checker notification mainlog
284
285 exit 0
286
287 %else
288 # rhel
289
290 %if 0%{?use_systemd}
291 %systemd_post %{name}.service
292 %else
293 /sbin/chkconfig --add %{name}
294 %endif
295
296 if [ ${1:-0} -eq 1 ]
297 then
298         # initial installation, enable default features
299         %{_sbindir}/icinga2 feature enable checker notification mainlog
300 fi
301
302 exit 0
303
304 %endif
305 # suse/rhel
306
307 %postun bin
308 # suse
309 %if "%{_vendor}" == "suse"
310 %if 0%{?using_systemd}
311   %service_del_postun %{name}.service
312 %else
313   %restart_on_update %{name}
314   %insserv_cleanup
315 %endif
316
317 %else
318 # rhel
319
320 %if 0%{?use_systemd}
321 %systemd_postun_with_restart %{name}.service
322 %else
323 if [ "$1" -ge  "1" ]; then
324         /sbin/service %{name} condrestart >/dev/null 2>&1 || :
325 fi
326 %endif
327
328 %endif
329 # suse / rhel
330
331 if [ "$1" = "0" ]; then
332         # deinstallation of the package - remove enabled features
333         rm -rf %{_sysconfdir}/%{name}/features-enabled
334 fi
335
336 exit 0
337
338 %preun bin
339 # suse
340 %if "%{_vendor}" == "suse"
341
342 %if 0%{?use_systemd}
343   %service_del_preun %{name}.service
344 %else
345   %stop_on_removal %{name}
346 %endif
347
348 exit 0
349
350 %else
351 # rhel
352
353 %if 0%{?use_systemd}
354 %systemd_preun %{name}.service
355 %else
356 if [ "$1" = "0" ]; then
357         /sbin/service %{name} stop > /dev/null 2>&1 || :
358         /sbin/chkconfig --del %{name} || :
359 fi
360 %endif
361
362 exit 0
363
364 %endif
365 # suse / rhel
366
367 %post ido-mysql
368 if [ ${1:-0} -eq 1 ]
369 then
370         # initial installation, enable ido-mysql feature
371         %{_sbindir}/icinga2 feature enable ido-mysql
372 fi
373
374 exit 0
375
376 %postun ido-mysql
377 if [ "$1" = "0" ]; then
378         # deinstallation of the package - remove feature
379         test -x %{_sbindir}/icinga2 && %{_sbindir}/icinga2 feature disable ido-mysql
380 fi
381
382 exit 0
383
384 %post ido-pgsql
385 if [ ${1:-0} -eq 1 ]
386 then
387         # initial installation, enable ido-pgsql feature
388         %{_sbindir}/icinga2 feature enable ido-pgsql
389 fi
390
391 exit 0
392
393 %postun ido-pgsql
394 if [ "$1" = "0" ]; then
395         # deinstallation of the package - remove feature
396         test -x %{_sbindir}/icinga2 && %{_sbindir}/icinga2 feature disable ido-pgsql
397 fi
398
399 exit 0
400
401 %post classicui-config
402 if [ ${1:-0} -eq 1 ]
403 then
404         # initial installation, enable features
405         %{_sbindir}/icinga2 feature enable statusdata compatlog command
406 fi
407
408 exit 0
409
410 %postun classicui-config
411 if [ "$1" = "0" ]; then
412         # deinstallation of the package - remove feature
413         test -x %{_sbindir}/icinga2 && %{_sbindir}/icinga2 feature disable statusdata
414         test -x %{_sbindir}/icinga2 && %{_sbindir}/icinga2 feature disable compatlog
415         test -x %{_sbindir}/icinga2 && %{_sbindir}/icinga2 feature disable command
416 fi
417
418 exit 0
419
420 %files
421 %defattr(-,root,root,-)
422 %doc COPYING
423
424 %files bin
425 %defattr(-,root,root,-)
426 %doc COPYING COPYING.Exceptions README.md NEWS AUTHORS ChangeLog
427 %if 0%{?use_systemd}
428 %attr(644,root,root) %{_unitdir}/%{name}.service
429 %else
430 %attr(755,root,root) %{_sysconfdir}/init.d/%{name}
431 %endif
432 %if "%{_vendor}" == "suse"
433 %{_sbindir}/rc%{name}
434 %{_localstatedir}/adm/fillup-templates/sysconfig.%{name}
435 %else
436 %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
437 %endif
438 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}
439 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/conf.d
440 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/conf.d/hosts
441 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/conf.d/hosts/localhost
442 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/features-available
443 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/features-enabled
444 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/repository.d
445 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/scripts
446 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/repository.d
447 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/zones.d
448 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/%{name}.conf
449 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/init.conf
450 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/constants.conf
451 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/zones.conf
452 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/conf.d/*.conf
453 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/conf.d/hosts/*.conf
454 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/conf.d/hosts/localhost/*.conf
455 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/features-available/*.conf
456 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/repository.d/*
457 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/zones.d/*
458 %config(noreplace) %{_sysconfdir}/%{name}/scripts/*
459 %{_sbindir}/%{name}
460 %{_sbindir}/%{name}-prepare-dirs
461 %exclude %{_libdir}/%{name}/libdb_ido_mysql*
462 %exclude %{_libdir}/%{name}/libdb_ido_pgsql*
463 %{_libdir}/%{name}
464 %{_datadir}/%{name}
465 %exclude %{_datadir}/%{name}/include
466 %exclude %{_datadir}/%{name}/migrate-hosts
467 %{_mandir}/man8/%{name}.8.gz
468 %{_mandir}/man8/%{name}-prepare-dirs.8.gz
469
470 %attr(0750,%{icinga_user},%{icingacmd_group}) %{_localstatedir}/cache/%{name}
471 %attr(0750,%{icinga_user},%{icingacmd_group}) %dir %{_localstatedir}/log/%{name}
472 %attr(0750,%{icinga_user},%{icingacmd_group}) %dir %{_localstatedir}/log/%{name}/compat
473 %attr(0750,%{icinga_user},%{icingacmd_group}) %dir %{_localstatedir}/log/%{name}/compat/archives
474 %attr(0750,%{icinga_user},%{icinga_group}) %{_localstatedir}/lib/%{name}
475
476 %attr(0750,%{icinga_user},%{icingacmd_group}) %ghost %{_rundir}/%{name}
477 %attr(2750,%{icinga_user},%{icingacmd_group}) %ghost %{_rundir}/%{name}/cmd
478
479 %files common
480 %defattr(-,root,root,-)
481 %doc COPYING COPYING.Exceptions README.md NEWS AUTHORS ChangeLog tools/syntax
482 %attr(0750,%{icinga_user},%{icingacmd_group}) %dir %{_localstatedir}/log/%{name}
483 %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
484 %{_sysconfdir}/bash_completion.d/%{name}
485 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/spool/%{name}
486 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/spool/%{name}/perfdata
487 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/spool/%{name}/tmp
488 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_datadir}/%{name}/include
489 %{_datadir}/%{name}/include
490 %{_datadir}/%{name}/migrate-hosts
491
492 %files doc
493 %defattr(-,root,root,-)
494 %{_datadir}/doc/%{name}
495 %docdir %{_datadir}/doc/%{name}
496
497 %files ido-mysql
498 %defattr(-,root,root,-)
499 %doc COPYING COPYING.Exceptions README.md NEWS AUTHORS ChangeLog
500 %{_libdir}/%{name}/libdb_ido_mysql*
501 %{_datadir}/icinga2-ido-mysql
502
503 %files ido-pgsql
504 %defattr(-,root,root,-)
505 %doc COPYING COPYING.Exceptions README.md NEWS AUTHORS ChangeLog
506 %{_libdir}/%{name}/libdb_ido_pgsql*
507 %{_datadir}/icinga2-ido-pgsql
508
509 %files classicui-config
510 %defattr(-,root,root,-)
511 %attr(0751,%{icinga_user},%{icinga_group}) %dir %{icingaclassicconfdir}
512 %config(noreplace) %{icingaclassicconfdir}/cgi.cfg
513 %config(noreplace) %{apacheconfdir}/icinga.conf
514 %config(noreplace) %attr(0640,root,%{apachegroup}) %{icingaclassicconfdir}/passwd
515
516 %changelog