]> granicus.if.org Git - icinga2/blob - icinga2.spec
Cli: Make sure to create & include 'repository.d'
[icinga2] / icinga2.spec
1 #/******************************************************************************
2 # * Icinga 2                                                                   *
3 # * Copyright (C) 2012-2014 Icinga Development Team (http://www.icinga.org)    *
4 # *                                                                            *
5 # * This program is free software; you can redistribute it and/or              *
6 # * modify it under the terms of the GNU General Public License                *
7 # * as published by the Free Software Foundation; either version 2             *
8 # * of the License, or (at your option) any later version.                     *
9 # *                                                                            *
10 # * This program is distributed in the hope that it will be useful,            *
11 # * but WITHOUT ANY WARRANTY; without even the implied warranty of             *
12 # * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the              *
13 # * GNU General Public License for more details.                               *
14 # *                                                                            *
15 # * You should have received a copy of the GNU General Public License          *
16 # * along with this program; if not, write to the Free Software Foundation     *
17 # * Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.             *
18 # ******************************************************************************/
19
20 %define revision 1
21
22 # make sure that _rundir is working on older systems
23 %if ! %{defined _rundir}
24 %define _rundir %{_localstatedir}/run
25 %endif
26
27 %if "%{_vendor}" == "redhat"
28 %define apachename httpd
29 %define apacheconfdir %{_sysconfdir}/httpd/conf.d
30 %define apacheuser apache
31 %define apachegroup apache
32 %if 0%{?el5}%{?el6}
33 %define use_systemd 0
34 %else
35 # fedora and el>=7
36 %define use_systemd 1
37 %endif
38 %endif
39
40 %if "%{_vendor}" == "suse"
41 %define apachename apache2
42 %define apacheconfdir  %{_sysconfdir}/apache2/conf.d
43 %define apacheuser wwwrun
44 %define apachegroup www
45 %if 0%{?suse_version} >= 1310
46 %define use_systemd 1
47 %else
48 %define use_systemd 0
49 %endif
50 %endif
51
52 %define icinga_user icinga
53 %define icinga_group icinga
54 %define icingacmd_group icingacmd
55 %define icingaweb2name icingaweb2
56 %define icingaweb2version 2.0.0
57
58 %define icingaclassicconfdir %{_sysconfdir}/icinga
59
60 %define logmsg logger -t %{name}/rpm
61
62 Summary: Network monitoring application
63 Name: icinga2
64 Version: 2.1.1
65 Release: %{revision}%{?dist}
66 License: GPL-2.0+
67 Group: Applications/System
68 Source: https://github.com/Icinga/%{name}/archive/v%{version}.tar.gz
69 URL: http://www.icinga.org/
70 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
71 Requires: %{name}-bin = %{version}-%{release}
72
73 %description
74 Meta package for Icinga 2 Core, DB IDO and Web.
75
76 %package bin
77 Summary:      Icinga 2 binaries and libraries
78 Group:        Applications/System
79
80 %if "%{_vendor}" == "suse"
81 PreReq:        permissions
82 Provides:      monitoring_daemon
83 Recommends:    monitoring-plugins
84 %endif
85 BuildRequires: openssl-devel
86 BuildRequires: gcc-c++
87 BuildRequires: libstdc++-devel
88 BuildRequires: cmake
89 BuildRequires: flex >= 2.5.35
90 BuildRequires: bison
91 BuildRequires: make
92
93 %if "%{_vendor}" == "redhat" && (0%{?el5} || 0%{?rhel} == 5 || "%{?dist}" == ".el5")
94 # el5 requires EPEL
95 BuildRequires: boost141-devel
96 %else
97 BuildRequires: boost-devel >= 1.41
98 %endif
99
100 %if 0%{?use_systemd}
101 BuildRequires: systemd
102 Requires: systemd
103 %endif
104
105 Requires: %{name}-common = %{version}-%{release}
106
107 %description bin
108 Icinga 2 is a general-purpose network monitoring application.
109 Provides binaries and libraries for Icinga 2 Core.
110
111 %package common
112 Summary:      Common Icinga 2 configuration
113 Group:        Applications/System
114 %if "%{_vendor}" == "redhat"
115 Requires(pre): shadow-utils
116 Requires(post): shadow-utils
117 %endif
118 %if "%{_vendor}" == "suse"
119 Recommends:   logrotate
120 %endif
121
122 %description common
123 Provides common directories, uid and gid among Icinga 2 related
124 packages.
125
126
127 %package doc
128 Summary:      Documentation for Icinga 2
129 Group:        Applications/System
130 Requires:     %{name} = %{version}-%{release}
131
132 %description doc
133 Provides documentation for Icinga 2.
134
135
136 %package ido-mysql
137 Summary:      IDO MySQL database backend for Icinga 2
138 Group:        Applications/System
139 %if "%{_vendor}" == "suse"
140 BuildRequires: libmysqlclient-devel
141 %endif
142 BuildRequires: mysql-devel
143 Requires: %{name} = %{version}-%{release}
144
145 %description ido-mysql
146 Icinga 2 IDO mysql database backend. Compatible with Icinga 1.x
147 IDOUtils schema >= 1.10
148
149
150 %package ido-pgsql
151 Summary:      IDO PostgreSQL database backend for Icinga 2
152 Group:        Applications/System
153 BuildRequires: postgresql-devel
154 Requires: %{name} = %{version}-%{release}
155
156 %description ido-pgsql
157 Icinga 2 IDO PostgreSQL database backend. Compatible with Icinga 1.x
158 IDOUtils schema >= 1.10
159
160
161 %package classicui-config
162 Summary:      Icinga 2 Classic UI Standalone configuration
163 Group:        Applications/System
164 BuildRequires: %{apachename}
165 Requires:     %{apachename}
166 Requires:     %{name} = %{version}-%{release}
167 %if "%{_vendor}" == "suse"
168 Recommends:   icinga-www
169 %endif
170 Provides:     icinga-classicui-config
171 Conflicts:    icinga-gui-config
172
173 %description classicui-config
174 Icinga 1.x Classic UI Standalone configuration with locations
175 for Icinga 2.
176
177
178 %prep
179 %setup -q -n %{name}-%{version}
180
181 %build
182 CMAKE_OPTS="-DCMAKE_INSTALL_PREFIX=/usr \
183          -DCMAKE_INSTALL_SYSCONFDIR=/etc \
184          -DCMAKE_INSTALL_LOCALSTATEDIR=/var \
185          -DCMAKE_BUILD_TYPE=RelWithDebInfo \
186          -DICINGA2_RUNDIR=%{_rundir} \
187          -DICINGA2_USER=%{icinga_user} \
188          -DICINGA2_GROUP=%{icinga_group} \
189          -DICINGA2_COMMAND_GROUP=%{icingacmd_group} \
190          -DICINGA2_UNITY_BUILD=TRUE"
191 %if "%{_vendor}" == "redhat"
192 %if 0%{?el5} || 0%{?rhel} == 5 || "%{?dist}" == ".el5"
193 # Boost_VERSION 1.41.0 vs 101400 - disable build tests
194 # details in https://dev.icinga.org/issues/5033
195 CMAKE_OPTS="$CMAKE_OPTS -DBOOST_LIBRARYDIR=/usr/lib/boost141 \
196  -DBOOST_INCLUDEDIR=/usr/include/boost141 \
197  -DBoost_ADDITIONAL_VERSIONS='1.41;1.41.0' \
198  -DBoost_NO_SYSTEM_PATHS=TRUE \
199  -DBUILD_TESTING=FALSE \
200  -DBoost_NO_BOOST_CMAKE=TRUE"
201 %endif
202 %endif
203
204 %if "%{_vendor}" != "suse"
205 CMAKE_OPTS="$CMAKE_OPTS -DICINGA2_PLUGINDIR=%{_libdir}/nagios/plugins"
206 %else
207 CMAKE_OPTS="$CMAKE_OPTS -DICINGA2_PLUGINDIR=%{_prefix}/lib/nagios/plugins"
208 %endif
209
210 %if 0%{?use_systemd}
211 CMAKE_OPTS="$CMAKE_OPTS -DUSE_SYSTEMD=ON"
212 %endif
213
214 cmake $CMAKE_OPTS .
215
216 make %{?_smp_mflags}
217
218
219 %install
220 make install \
221         DESTDIR="%{buildroot}"
222
223 # install classicui config
224 install -D -m 0644 etc/icinga/icinga-classic.htpasswd %{buildroot}%{icingaclassicconfdir}/passwd
225 install -D -m 0644 etc/icinga/cgi.cfg %{buildroot}%{icingaclassicconfdir}/cgi.cfg
226 install -D -m 0644 etc/icinga/icinga-classic-apache.conf %{buildroot}%{apacheconfdir}/icinga.conf
227
228 # remove features-enabled symlinks
229 rm -f %{buildroot}/%{_sysconfdir}/%{name}/features-enabled/*.conf
230
231 # enable suse rc links
232 %if "%{_vendor}" == "suse"
233 %if 0%{?use_systemd}
234   ln -sf /usr/sbin/service %{buildroot}%{_sbindir}/rc%{name}
235 %else
236   ln -sf ../../%{_initrddir}/%{name} "%{buildroot}%{_sbindir}/rc%{name}"
237 %endif
238 mkdir -p "%{buildroot}%{_localstatedir}/adm/fillup-templates/"
239 mv "%{buildroot}%{_sysconfdir}/sysconfig/%{name}" "%{buildroot}%{_localstatedir}/adm/fillup-templates/sysconfig.%{name}"
240 %endif
241
242
243 %clean
244 [ "%{buildroot}" != "/" ] && [ -d "%{buildroot}" ] && rm -rf %{buildroot}
245
246 %pre common
247 getent group %{icinga_group} >/dev/null || %{_sbindir}/groupadd -r %{icinga_group}
248 getent group %{icingacmd_group} >/dev/null || %{_sbindir}/groupadd -r %{icingacmd_group}
249 getent passwd %{icinga_user} >/dev/null || %{_sbindir}/useradd -c "icinga" -s /sbin/nologin -r -d %{_localstatedir}/spool/%{name} -G %{icingacmd_group} -g %{icinga_group} %{icinga_user}
250 exit 0
251
252 %if "%{_vendor}" == "suse"
253 %verifyscript bin
254 %verify_permissions -e %{_rundir}/%{name}/cmd
255 %endif
256
257
258 %if "%{_vendor}" == "suse"
259 %if 0%{?use_systemd}
260 %pre bin
261   %service_add_pre %{name}.service
262 %endif
263 %endif
264
265
266 # all restart/feature actions belong to icinga2-bin
267 %post bin
268 # suse
269 %if "%{_vendor}" == "suse"
270 %if 0%{?suse_version} >= 1310
271 %set_permissions %{_rundir}/%{name}/cmd
272 %endif
273 %if 0%{?use_systemd}
274 %fillup_only  %{name}
275 %service_add_post %{name}.service
276 %else
277 %fillup_and_insserv %{name}
278 %endif
279
280 # initial installation, enable default features
281 %{_sbindir}/icinga2 feature enable checker notification mainlog
282
283 exit 0
284
285 %else
286 # rhel
287
288 %if 0%{?use_systemd}
289 %systemd_post %{name}.service
290 %else
291 /sbin/chkconfig --add %{name}
292 %endif
293
294 if [ ${1:-0} -eq 1 ]
295 then
296         # initial installation, enable default features
297         %{_sbindir}/icinga2 feature enable checker notification mainlog
298 fi
299
300 exit 0
301
302 %endif
303 # suse/rhel
304
305 %postun bin
306 # suse
307 %if "%{_vendor}" == "suse"
308 %if 0%{?using_systemd}
309   %service_del_postun %{name}.service
310 %else
311   %restart_on_update %{name}
312   %insserv_cleanup
313 %endif
314
315 %else
316 # rhel
317
318 %if 0%{?use_systemd}
319 %systemd_postun_with_restart %{name}.service
320 %else
321 if [ "$1" -ge  "1" ]; then
322         /sbin/service %{name} condrestart >/dev/null 2>&1 || :
323 fi
324 %endif
325
326 %endif
327 # suse / rhel
328
329 if [ "$1" = "0" ]; then
330         # deinstallation of the package - remove enabled features
331         rm -rf %{_sysconfdir}/%{name}/features-enabled
332 fi
333
334 exit 0
335
336 %preun bin
337 # suse
338 %if "%{_vendor}" == "suse"
339
340 %if 0%{?use_systemd}
341   %service_del_preun %{name}.service
342 %else
343   %stop_on_removal %{name}
344 %endif
345
346 exit 0
347
348 %else
349 # rhel
350
351 %if 0%{?use_systemd}
352 %systemd_preun %{name}.service
353 %else
354 if [ "$1" = "0" ]; then
355         /sbin/service %{name} stop > /dev/null 2>&1 || :
356         /sbin/chkconfig --del %{name} || :
357 fi
358 %endif
359
360 exit 0
361
362 %endif
363 # suse / rhel
364
365 %post ido-mysql
366 if [ ${1:-0} -eq 1 ]
367 then
368         # initial installation, enable ido-mysql feature
369         %{_sbindir}/icinga2 feature enable ido-mysql
370 fi
371
372 exit 0
373
374 %postun ido-mysql
375 if [ "$1" = "0" ]; then
376         # deinstallation of the package - remove feature
377         test -x %{_sbindir}/icinga2 && %{_sbindir}/icinga2 feature disable ido-mysql
378 fi
379
380 exit 0
381
382 %post ido-pgsql
383 if [ ${1:-0} -eq 1 ]
384 then
385         # initial installation, enable ido-pgsql feature
386         %{_sbindir}/icinga2 feature enable ido-pgsql
387 fi
388
389 exit 0
390
391 %postun ido-pgsql
392 if [ "$1" = "0" ]; then
393         # deinstallation of the package - remove feature
394         test -x %{_sbindir}/icinga2 && %{_sbindir}/icinga2 feature disable ido-pgsql
395 fi
396
397 exit 0
398
399 %post classicui-config
400 if [ ${1:-0} -eq 1 ]
401 then
402         # initial installation, enable features
403         %{_sbindir}/icinga2 feature enable statusdata compatlog command
404 fi
405
406 exit 0
407
408 %postun classicui-config
409 if [ "$1" = "0" ]; then
410         # deinstallation of the package - remove feature
411         test -x %{_sbindir}/icinga2 && %{_sbindir}/icinga2 feature disable statusdata
412         test -x %{_sbindir}/icinga2 && %{_sbindir}/icinga2 feature disable compatlog
413         test -x %{_sbindir}/icinga2 && %{_sbindir}/icinga2 feature disable command
414 fi
415
416 exit 0
417
418 %files
419 %defattr(-,root,root,-)
420 %doc COPYING
421
422 %files bin
423 %defattr(-,root,root,-)
424 %doc COPYING COPYING.Exceptions README.md NEWS AUTHORS ChangeLog
425 %if 0%{?use_systemd}
426 %attr(644,root,root) %{_unitdir}/%{name}.service
427 %else
428 %attr(755,root,root) %{_sysconfdir}/init.d/%{name}
429 %endif
430 %if "%{_vendor}" == "suse"
431 %{_sbindir}/rc%{name}
432 %{_localstatedir}/adm/fillup-templates/sysconfig.%{name}
433 %else
434 %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
435 %endif
436 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}
437 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/conf.d
438 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/conf.d/hosts
439 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/conf.d/hosts/localhost
440 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/features-available
441 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/features-enabled
442 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/repository.d
443 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/scripts
444 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/repository.d
445 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/zones.d
446 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/%{name}.conf
447 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/init.conf
448 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/constants.conf
449 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/zones.conf
450 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/conf.d/*.conf
451 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/conf.d/hosts/*.conf
452 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/conf.d/hosts/localhost/*.conf
453 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/features-available/*.conf
454 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/repository.d/*
455 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/zones.d/*
456 %config(noreplace) %{_sysconfdir}/%{name}/scripts/*
457 %{_sbindir}/%{name}
458 %{_sbindir}/%{name}-prepare-dirs
459 %exclude %{_libdir}/%{name}/libdb_ido_mysql*
460 %exclude %{_libdir}/%{name}/libdb_ido_pgsql*
461 %{_libdir}/%{name}
462 %{_datadir}/%{name}
463 %exclude %{_datadir}/%{name}/include
464 %{_mandir}/man8/%{name}.8.gz
465 %{_mandir}/man8/%{name}-prepare-dirs.8.gz
466
467 %attr(0750,%{icinga_user},%{icingacmd_group}) %{_localstatedir}/cache/%{name}
468 %attr(0750,%{icinga_user},%{icingacmd_group}) %dir %{_localstatedir}/log/%{name}
469 %attr(0750,%{icinga_user},%{icingacmd_group}) %dir %{_localstatedir}/log/%{name}/compat
470 %attr(0750,%{icinga_user},%{icingacmd_group}) %dir %{_localstatedir}/log/%{name}/compat/archives
471 %attr(0750,%{icinga_user},%{icinga_group}) %{_localstatedir}/lib/%{name}
472
473 %attr(0750,%{icinga_user},%{icingacmd_group}) %ghost %{_rundir}/%{name}
474 %attr(2750,%{icinga_user},%{icingacmd_group}) %ghost %{_rundir}/%{name}/cmd
475
476 %files common
477 %defattr(-,root,root,-)
478 %doc COPYING COPYING.Exceptions README.md NEWS AUTHORS ChangeLog tools/syntax
479 %attr(0750,%{icinga_user},%{icingacmd_group}) %dir %{_localstatedir}/log/%{name}
480 %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
481 %{_sysconfdir}/bash_completion.d/%{name}
482 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/spool/%{name}
483 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/spool/%{name}/perfdata
484 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/spool/%{name}/tmp
485 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_datadir}/%{name}/include
486 %{_datadir}/%{name}/include
487
488 %files doc
489 %defattr(-,root,root,-)
490 %{_datadir}/doc/%{name}
491 %docdir %{_datadir}/doc/%{name}
492
493 %files ido-mysql
494 %defattr(-,root,root,-)
495 %doc COPYING COPYING.Exceptions README.md NEWS AUTHORS ChangeLog
496 %{_libdir}/%{name}/libdb_ido_mysql*
497 %{_datadir}/icinga2-ido-mysql
498
499 %files ido-pgsql
500 %defattr(-,root,root,-)
501 %doc COPYING COPYING.Exceptions README.md NEWS AUTHORS ChangeLog
502 %{_libdir}/%{name}/libdb_ido_pgsql*
503 %{_datadir}/icinga2-ido-pgsql
504
505 %files classicui-config
506 %defattr(-,root,root,-)
507 %attr(0751,%{icinga_user},%{icinga_group}) %dir %{icingaclassicconfdir}
508 %config(noreplace) %{icingaclassicconfdir}/cgi.cfg
509 %config(noreplace) %{apacheconfdir}/icinga.conf
510 %config(noreplace) %attr(0640,root,%{apachegroup}) %{icingaclassicconfdir}/passwd
511
512 %changelog