]> granicus.if.org Git - icinga2/blob - icinga2.spec
Add 'ignore_soft_states' attribute to Dependency objects
[icinga2] / icinga2.spec
1 #/******************************************************************************
2 # * Icinga 2                                                                   *
3 # * Copyright (C) 2012-2015 Icinga Development Team (http://www.icinga.org)    *
4 # *                                                                            *
5 # * This program is free software; you can redistribute it and/or              *
6 # * modify it under the terms of the GNU General Public License                *
7 # * as published by the Free Software Foundation; either version 2             *
8 # * of the License, or (at your option) any later version.                     *
9 # *                                                                            *
10 # * This program is distributed in the hope that it will be useful,            *
11 # * but WITHOUT ANY WARRANTY; without even the implied warranty of             *
12 # * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the              *
13 # * GNU General Public License for more details.                               *
14 # *                                                                            *
15 # * You should have received a copy of the GNU General Public License          *
16 # * along with this program; if not, write to the Free Software Foundation     *
17 # * Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.             *
18 # ******************************************************************************/
19
20 %define revision 1
21
22 # make sure that _rundir is working on older systems
23 %if ! %{defined _rundir}
24 %define _rundir %{_localstatedir}/run
25 %endif
26
27 %define _libexecdir %{_prefix}/lib/
28
29 %if "%{_vendor}" == "redhat"
30 %define apachename httpd
31 %define apacheconfdir %{_sysconfdir}/httpd/conf.d
32 %define apacheuser apache
33 %define apachegroup apache
34 %if 0%{?el5}%{?el6}
35 %define use_systemd 0
36 %if %(uname -m) != "x86_64"
37 %define march_flag -march=i686
38 %endif
39 %else
40 # fedora and el>=7
41 %define use_systemd 1
42 %endif
43 %endif
44
45 %if "%{_vendor}" == "suse"
46 %define apachename apache2
47 %define apacheconfdir  %{_sysconfdir}/apache2/conf.d
48 %define apacheuser wwwrun
49 %define apachegroup www
50 %if 0%{?suse_version} >= 1310
51 %define use_systemd 1
52 %else
53 %define use_systemd 0
54 %endif
55 %endif
56
57 %define icinga_user icinga
58 %define icinga_group icinga
59 %define icingacmd_group icingacmd
60 %define icingaweb2name icingaweb2
61 %define icingaweb2version 2.0.0
62
63 %define icingaclassicconfdir %{_sysconfdir}/icinga
64
65 %define logmsg logger -t %{name}/rpm
66
67 Summary: Network monitoring application
68 Name: icinga2
69 Version: 2.2.4
70 Release: %{revision}%{?dist}
71 License: GPL-2.0+
72 Group: Applications/System
73 Source: https://github.com/Icinga/%{name}/archive/v%{version}.tar.gz
74 URL: https://www.icinga.org/
75 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
76 Requires: %{name}-bin = %{version}-%{release}
77
78 %description
79 Meta package for Icinga 2 Core, DB IDO and Web.
80
81 %package bin
82 Summary:      Icinga 2 binaries and libraries
83 Group:        Applications/System
84
85 %if "%{_vendor}" == "suse"
86 PreReq:        permissions
87 Provides:      monitoring_daemon
88 Recommends:    monitoring-plugins
89 %if 0%{?suse_version} >= 1310
90 BuildRequires: libyajl-devel
91 %endif
92 %endif
93 BuildRequires: openssl-devel
94 BuildRequires: gcc-c++
95 BuildRequires: libstdc++-devel
96 BuildRequires: cmake
97 BuildRequires: flex >= 2.5.35
98 BuildRequires: bison
99 BuildRequires: make
100
101 %if 0%{?build_icinga_org} && "%{_vendor}" == "redhat" && (0%{?el5} || 0%{?rhel} == 5 || "%{?dist}" == ".el5")
102 # el5 requires packages.icinga.org
103 BuildRequires: boost153-devel
104 %else
105 %if 0%{?build_icinga_org} && "%{_vendor}" == "suse" && 0%{?suse_version} < 1310
106 # sles 11 sp3 requires packages.icinga.org
107 BuildRequires: boost153-devel
108 %else
109 BuildRequires: boost-devel >= 1.41
110 %endif
111 %endif
112
113 %if 0%{?use_systemd}
114 BuildRequires: systemd
115 Requires: systemd
116 %endif
117
118 Requires: %{name}-common = %{version}-%{release}
119
120 %description bin
121 Icinga 2 is a general-purpose network monitoring application.
122 Provides binaries and libraries for Icinga 2 Core.
123
124 %package common
125 Summary:      Common Icinga 2 configuration
126 Group:        Applications/System
127 %if "%{_vendor}" == "redhat"
128 Requires(pre): shadow-utils
129 Requires(post): shadow-utils
130 %endif
131 %if "%{_vendor}" == "suse"
132 Recommends:   logrotate
133 %endif
134
135 %description common
136 Provides common directories, uid and gid among Icinga 2 related
137 packages.
138
139
140 %package doc
141 Summary:      Documentation for Icinga 2
142 Group:        Applications/System
143 Requires:     %{name} = %{version}-%{release}
144
145 %description doc
146 Provides documentation for Icinga 2.
147
148
149 %package ido-mysql
150 Summary:      IDO MySQL database backend for Icinga 2
151 Group:        Applications/System
152 %if "%{_vendor}" == "suse"
153 BuildRequires: libmysqlclient-devel
154 %endif
155 BuildRequires: mysql-devel
156 Requires: %{name} = %{version}-%{release}
157
158 %description ido-mysql
159 Icinga 2 IDO mysql database backend. Compatible with Icinga 1.x
160 IDOUtils schema >= 1.12
161
162
163 %package ido-pgsql
164 Summary:      IDO PostgreSQL database backend for Icinga 2
165 Group:        Applications/System
166 BuildRequires: postgresql-devel
167 Requires: %{name} = %{version}-%{release}
168
169 %description ido-pgsql
170 Icinga 2 IDO PostgreSQL database backend. Compatible with Icinga 1.x
171 IDOUtils schema >= 1.12
172
173
174 %package classicui-config
175 Summary:      Icinga 2 Classic UI Standalone configuration
176 Group:        Applications/System
177 BuildRequires: %{apachename}
178 Requires:     %{apachename}
179 Requires:     %{name} = %{version}-%{release}
180 %if "%{_vendor}" == "suse"
181 Recommends:   icinga-www
182 %endif
183 Provides:     icinga-classicui-config
184 Conflicts:    icinga-gui-config
185
186 %description classicui-config
187 Icinga 1.x Classic UI Standalone configuration with locations
188 for Icinga 2.
189
190
191 %prep
192 %setup -q -n %{name}-%{version}
193
194 %build
195 CMAKE_OPTS="-DCMAKE_INSTALL_PREFIX=/usr \
196          -DCMAKE_INSTALL_SYSCONFDIR=/etc \
197          -DCMAKE_INSTALL_LOCALSTATEDIR=/var \
198          -DCMAKE_BUILD_TYPE=RelWithDebInfo \
199          -DCMAKE_VERBOSE_MAKEFILE=ON \
200          -DBoost_NO_BOOST_CMAKE=ON \
201          -DICINGA2_RUNDIR=%{_rundir} \
202          -DICINGA2_USER=%{icinga_user} \
203          -DICINGA2_GROUP=%{icinga_group} \
204          -DICINGA2_COMMAND_GROUP=%{icingacmd_group} \
205          -DICINGA2_UNITY_BUILD=TRUE"
206 %if "%{_vendor}" == "redhat"
207 %if 0%{?el5} || 0%{?rhel} == 5 || "%{?dist}" == ".el5"
208 # Boost_VERSION 1.41.0 vs 101400 - disable build tests
209 # details in https://dev.icinga.org/issues/5033
210 CMAKE_OPTS="$CMAKE_OPTS -DBOOST_LIBRARYDIR=/usr/lib/boost153 \
211  -DBOOST_INCLUDEDIR=/usr/include/boost153 \
212  -DBoost_ADDITIONAL_VERSIONS='1.53;1.53.0' \
213  -DBoost_NO_SYSTEM_PATHS=TRUE \
214  -DBUILD_TESTING=FALSE \
215  -DBoost_NO_BOOST_CMAKE=TRUE"
216 %endif
217 %endif
218
219 %if "%{_vendor}" != "suse"
220 CMAKE_OPTS="$CMAKE_OPTS -DICINGA2_PLUGINDIR=%{_libdir}/nagios/plugins"
221 %else
222 %if 0%{?suse_version} < 1310
223 CMAKE_OPTS="$CMAKE_OPTS -DBOOST_LIBRARYDIR=/usr/lib/boost153 \
224  -DBOOST_INCLUDEDIR=/usr/include/boost153 \
225  -DBoost_ADDITIONAL_VERSIONS='1.53;1.53.0' \
226  -DBoost_NO_SYSTEM_PATHS=TRUE \
227  -DBUILD_TESTING=FALSE \
228  -DBoost_NO_BOOST_CMAKE=TRUE"
229 %endif
230 CMAKE_OPTS="$CMAKE_OPTS -DICINGA2_PLUGINDIR=%{_prefix}/lib/nagios/plugins"
231 %endif
232
233 %if 0%{?use_systemd}
234 CMAKE_OPTS="$CMAKE_OPTS -DUSE_SYSTEMD=ON"
235 %endif
236
237 cmake $CMAKE_OPTS -DCMAKE_C_FLAGS:STRING="%{optflags} %{?march_flag}" -DCMAKE_CXX_FLAGS:STRING="%{optflags} %{?march_flag}" .
238
239 make %{?_smp_mflags}
240
241
242 %install
243 make install \
244         DESTDIR="%{buildroot}"
245
246 # install classicui config
247 install -D -m 0644 etc/icinga/icinga-classic.htpasswd %{buildroot}%{icingaclassicconfdir}/passwd
248 install -D -m 0644 etc/icinga/cgi.cfg %{buildroot}%{icingaclassicconfdir}/cgi.cfg
249 install -D -m 0644 etc/icinga/icinga-classic-apache.conf %{buildroot}%{apacheconfdir}/icinga.conf
250
251 # remove features-enabled symlinks
252 rm -f %{buildroot}/%{_sysconfdir}/%{name}/features-enabled/*.conf
253
254 # enable suse rc links
255 %if "%{_vendor}" == "suse"
256 %if 0%{?use_systemd}
257   ln -sf /usr/sbin/service %{buildroot}%{_sbindir}/rc%{name}
258 %else
259   ln -sf ../../%{_initrddir}/%{name} "%{buildroot}%{_sbindir}/rc%{name}"
260 %endif
261 mkdir -p "%{buildroot}%{_localstatedir}/adm/fillup-templates/"
262 mv "%{buildroot}%{_sysconfdir}/sysconfig/%{name}" "%{buildroot}%{_localstatedir}/adm/fillup-templates/sysconfig.%{name}"
263 %endif
264
265
266 %clean
267 [ "%{buildroot}" != "/" ] && [ -d "%{buildroot}" ] && rm -rf %{buildroot}
268
269 %pre common
270 getent group %{icinga_group} >/dev/null || %{_sbindir}/groupadd -r %{icinga_group}
271 getent group %{icingacmd_group} >/dev/null || %{_sbindir}/groupadd -r %{icingacmd_group}
272 getent passwd %{icinga_user} >/dev/null || %{_sbindir}/useradd -c "icinga" -s /sbin/nologin -r -d %{_localstatedir}/spool/%{name} -G %{icingacmd_group} -g %{icinga_group} %{icinga_user}
273
274 %if "%{_vendor}" == "suse"
275 %if 0%{?use_systemd}
276   %service_add_pre %{name}.service
277 %endif
278 %endif
279 exit 0
280
281 %if "%{_vendor}" == "suse"
282 %verifyscript bin
283 %verify_permissions -e %{_rundir}/%{name}/cmd
284
285 %if 0%{?suse_version} >= 1310
286 %post bin
287 %set_permissions %{_rundir}/%{name}/cmd
288 %endif
289 %endif
290
291 %post common
292 # suse
293 %if "%{_vendor}" == "suse"
294 %if 0%{?use_systemd}
295 %fillup_only  %{name}
296 %service_add_post %{name}.service
297 %else
298 %fillup_and_insserv %{name}
299 %endif
300
301 # initial installation, enable default features
302 for feature in checker notification mainlog; do
303         ln -sf ../features-available/${feature}.conf %{_sysconfdir}/%{name}/features-enabled/${feature}.conf
304 done
305
306 exit 0
307
308 %else
309 # rhel
310
311 %if 0%{?use_systemd}
312 %systemd_post %{name}.service
313 %else
314 /sbin/chkconfig --add %{name}
315 %endif
316
317 if [ ${1:-0} -eq 1 ]
318 then
319         # initial installation, enable default features
320         for feature in checker notification mainlog; do
321                 ln -sf ../features-available/${feature}.conf %{_sysconfdir}/%{name}/features-enabled/${feature}.conf
322         done
323 fi
324
325 exit 0
326
327 %endif
328 # suse/rhel
329
330 %postun common
331 # suse
332 %if "%{_vendor}" == "suse"
333 %if 0%{?using_systemd}
334   %service_del_postun %{name}.service
335 %else
336   %restart_on_update %{name}
337   %insserv_cleanup
338 %endif
339
340 %else
341 # rhel
342
343 %if 0%{?use_systemd}
344 %systemd_postun_with_restart %{name}.service
345 %else
346 if [ "$1" -ge  "1" ]; then
347         /sbin/service %{name} condrestart >/dev/null 2>&1 || :
348 fi
349 %endif
350
351 %endif
352 # suse / rhel
353
354 if [ "$1" = "0" ]; then
355         # deinstallation of the package - remove enabled features
356         rm -rf %{_sysconfdir}/%{name}/features-enabled
357 fi
358
359 exit 0
360
361 %preun common
362 # suse
363 %if "%{_vendor}" == "suse"
364
365 %if 0%{?use_systemd}
366   %service_del_preun %{name}.service
367 %else
368   %stop_on_removal %{name}
369 %endif
370
371 exit 0
372
373 %else
374 # rhel
375
376 %if 0%{?use_systemd}
377 %systemd_preun %{name}.service
378 %else
379 if [ "$1" = "0" ]; then
380         /sbin/service %{name} stop > /dev/null 2>&1 || :
381         /sbin/chkconfig --del %{name} || :
382 fi
383 %endif
384
385 exit 0
386
387 %endif
388 # suse / rhel
389
390 %post ido-mysql
391 if [ ${1:-0} -eq 1 ]
392 then
393         # initial installation, enable ido-mysql feature
394         ln -sf ../features-available/ido-mysql.conf %{_sysconfdir}/%{name}/features-enabled/ido-mysql.conf
395 fi
396
397 exit 0
398
399 %postun ido-mysql
400 if [ "$1" = "0" ]; then
401         # deinstallation of the package - remove feature
402         rm -f %{_sysconfdir}/%{name}/features-enabled/ido-mysql.conf
403 fi
404
405 exit 0
406
407 %post ido-pgsql
408 if [ ${1:-0} -eq 1 ]
409 then
410         # initial installation, enable ido-pgsql feature
411         ln -sf ../features-available/ido-pgsql.conf %{_sysconfdir}/%{name}/features-enabled/ido-pgsql.conf
412 fi
413
414 exit 0
415
416 %postun ido-pgsql
417 if [ "$1" = "0" ]; then
418         # deinstallation of the package - remove feature
419         rm -f %{_sysconfdir}/%{name}/features-enabled/ido-pgsql.conf
420 fi
421
422 exit 0
423
424 %post classicui-config
425 if [ ${1:-0} -eq 1 ]
426 then
427         # initial installation, enable features
428         for feature in statusdata compatlog command; do
429                 ln -sf ../features-available/${feature}.conf %{_sysconfdir}/%{name}/features-enabled/${feature}.conf
430         done
431 fi
432
433 exit 0
434
435 %postun classicui-config
436 if [ "$1" = "0" ]; then
437         # deinstallation of the package - remove feature
438         for feature in statusdata compatlog command; do
439                 rm -f %{_sysconfdir}/%{name}/features-enabled/${feature}.conf
440         done
441 fi
442
443 exit 0
444
445 %files
446 %defattr(-,root,root,-)
447 %doc COPYING
448
449 %files bin
450 %defattr(-,root,root,-)
451 %doc COPYING COPYING.Exceptions README.md NEWS AUTHORS ChangeLog
452 %{_sbindir}/%{name}
453 %exclude %{_libdir}/%{name}/libdb_ido_mysql*
454 %exclude %{_libdir}/%{name}/libdb_ido_pgsql*
455 %dir %{_libdir}/%{name}
456 %{_libdir}/%{name}/*.so*
457 %{_datadir}/%{name}
458 %exclude %{_datadir}/%{name}/include
459 %{_mandir}/man8/%{name}.8.gz
460
461 %attr(0750,%{icinga_user},%{icingacmd_group}) %{_localstatedir}/cache/%{name}
462 %attr(0750,%{icinga_user},%{icingacmd_group}) %dir %{_localstatedir}/log/%{name}
463 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/log/%{name}/crash
464 %attr(0750,%{icinga_user},%{icingacmd_group}) %dir %{_localstatedir}/log/%{name}/compat
465 %attr(0750,%{icinga_user},%{icingacmd_group}) %dir %{_localstatedir}/log/%{name}/compat/archives
466 %attr(0750,%{icinga_user},%{icinga_group}) %{_localstatedir}/lib/%{name}
467
468 %attr(0750,%{icinga_user},%{icingacmd_group}) %ghost %{_rundir}/%{name}
469 %attr(2750,%{icinga_user},%{icingacmd_group}) %ghost %{_rundir}/%{name}/cmd
470
471 %files common
472 %defattr(-,root,root,-)
473 %doc COPYING COPYING.Exceptions README.md NEWS AUTHORS ChangeLog tools/syntax
474 %attr(0750,%{icinga_user},%{icingacmd_group}) %dir %{_localstatedir}/log/%{name}
475 %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
476 %{_sysconfdir}/bash_completion.d/%{name}
477 %if 0%{?use_systemd}
478 %attr(644,root,root) %{_unitdir}/%{name}.service
479 %else
480 %attr(755,root,root) %{_sysconfdir}/init.d/%{name}
481 %endif
482 %if "%{_vendor}" == "suse"
483 %{_sbindir}/rc%{name}
484 %{_localstatedir}/adm/fillup-templates/sysconfig.%{name}
485 %else
486 %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
487 %endif
488 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}
489 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/conf.d
490 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/features-available
491 %exclude %{_sysconfdir}/%{name}/features-available/ido-*.conf
492 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/features-enabled
493 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/repository.d
494 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/scripts
495 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/repository.d
496 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/zones.d
497 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/%{name}.conf
498 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/init.conf
499 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/constants.conf
500 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/zones.conf
501 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/conf.d/*.conf
502 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/features-available/*.conf
503 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/repository.d/*
504 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/zones.d/*
505 %config(noreplace) %{_sysconfdir}/%{name}/scripts/*
506 %dir %{_libexecdir}/%{name}
507 %{_libexecdir}/%{name}/prepare-dirs
508 %{_libexecdir}/%{name}/safe-reload
509 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/spool/%{name}
510 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/spool/%{name}/perfdata
511 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/spool/%{name}/tmp
512 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_datadir}/%{name}/include
513 %{_datadir}/%{name}/include
514
515 %files doc
516 %defattr(-,root,root,-)
517 %{_datadir}/doc/%{name}
518 %docdir %{_datadir}/doc/%{name}
519
520 %files ido-mysql
521 %defattr(-,root,root,-)
522 %doc COPYING COPYING.Exceptions README.md NEWS AUTHORS ChangeLog
523 %{_sysconfdir}/%{name}/features-available/ido-mysql.conf
524 %{_libdir}/%{name}/libdb_ido_mysql*
525 %{_datadir}/icinga2-ido-mysql
526
527 %files ido-pgsql
528 %defattr(-,root,root,-)
529 %doc COPYING COPYING.Exceptions README.md NEWS AUTHORS ChangeLog
530 %{_sysconfdir}/%{name}/features-available/ido-pgsql.conf
531 %{_libdir}/%{name}/libdb_ido_pgsql*
532 %{_datadir}/icinga2-ido-pgsql
533
534 %files classicui-config
535 %defattr(-,root,root,-)
536 %attr(0751,%{icinga_user},%{icinga_group}) %dir %{icingaclassicconfdir}
537 %config(noreplace) %{icingaclassicconfdir}/cgi.cfg
538 %config(noreplace) %{apacheconfdir}/icinga.conf
539 %config(noreplace) %attr(0640,root,%{apachegroup}) %{icingaclassicconfdir}/passwd
540
541 %changelog