]> granicus.if.org Git - icinga2/blob - icinga2.spec
Use Utility::GetFQDN for the NodeName variable.
[icinga2] / icinga2.spec
1 #/******************************************************************************
2 # * Icinga 2                                                                   *
3 # * Copyright (C) 2012-2014 Icinga Development Team (http://www.icinga.org)    *
4 # *                                                                            *
5 # * This program is free software; you can redistribute it and/or              *
6 # * modify it under the terms of the GNU General Public License                *
7 # * as published by the Free Software Foundation; either version 2             *
8 # * of the License, or (at your option) any later version.                     *
9 # *                                                                            *
10 # * This program is distributed in the hope that it will be useful,            *
11 # * but WITHOUT ANY WARRANTY; without even the implied warranty of             *
12 # * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the              *
13 # * GNU General Public License for more details.                               *
14 # *                                                                            *
15 # * You should have received a copy of the GNU General Public License          *
16 # * along with this program; if not, write to the Free Software Foundation     *
17 # * Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.             *
18 # ******************************************************************************/
19
20 %define revision 1.beta2.dev
21
22 %if "%{_vendor}" == "redhat"
23 %define el5_boost_version 141
24 %define el5_boost_libs %{_libdir}/boost%{el5_boost_version}
25 %define el5_boost_includes /usr/include/boost%{el5_boost_version}
26 %define apachename httpd
27 %define apacheconfdir %{_sysconfdir}/httpd/conf.d
28 %define apacheuser apache
29 %define apachegroup apache
30 %endif
31 %if "%{_vendor}" == "suse"
32 # opensuse 13
33 %if 0%{?suse_version} >= 1310
34 %define opensuse_boost_version 1_53_0
35 %else
36 %define opensuse_boost_version 1_49_0
37 %endif
38 %define sles_boost_version 1_54_0
39 %define apachename apache2
40 %define apacheconfdir  %{_sysconfdir}/apache2/conf.d
41 %define apacheuser wwwrun
42 %define apachegroup www
43 %endif
44
45 %define icinga_user icinga
46 %define icinga_group icinga
47 %define icingacmd_group icingacmd
48 %define icingaweb2name icingaweb2
49 %define icingaweb2version 2.0.0
50
51 %define icingaclassicconfdir %{_sysconfdir}/icinga
52
53 %define logmsg logger -t %{name}/rpm
54
55 Summary: Network monitoring application
56 Name: icinga2
57 Version: 2.0.0
58 Release: %{revision}%{?dist}
59 License: GPLv2+
60 Group: Applications/System
61 Source: %{name}-%{version}.tar.gz
62 URL: http://www.icinga.org/
63 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
64
65 Requires: %{name}-bin = %{version}
66 #Requires: %{name}-ido-mysql = %{version}
67 #Requires: %{icingaweb2name} >= %{icingaweb2version}
68
69 %description
70 Meta package for Icinga 2 Core, DB IDO and Web.
71
72 %package bin
73 Summary:      Icinga 2 binaries and libraries
74 Group:        Applications/System
75
76 BuildRequires: openssl-devel
77 BuildRequires: gcc-c++
78 BuildRequires: libstdc++-devel
79 BuildRequires: cmake
80 BuildRequires: flex >= 2.5.35
81 BuildRequires: bison
82 BuildRequires: make
83
84 # redhat
85 %if "%{_vendor}" == "redhat"
86 %if 0%{?el5} || 0%{?rhel} == 5 || "%{?dist}" == ".el5"
87 # el5 requires EPEL
88 BuildRequires: boost%{el5_boost_version}-devel
89 BuildRequires: boost%{el5_boost_version}
90 Requires: boost%{el5_boost_version}-program-options
91 Requires: boost%{el5_boost_version}-system
92 Requires: boost%{el5_boost_version}-test
93 Requires: boost%{el5_boost_version}-thread
94 Requires: boost%{el5_boost_version}-regex
95 %else
96 BuildRequires: boost-devel >= 1.41
97 Requires: boost-program-options >= 1.41
98 Requires: boost-system >= 1.41
99 Requires: boost-test >= 1.41
100 Requires: boost-thread >= 1.41
101 Requires: boost-regex >= 1.41
102 %endif
103 %endif
104 #redhat
105
106 # suse
107 %if "%{_vendor}" == "suse"
108 # sles
109 # note: sles_version macro is not set in SLES11 anymore
110 # note: sles service packs are not under version control
111 %if 0%{?suse_version} == 1110
112 BuildRequires: gcc-fortran
113 BuildRequires: libgfortran43
114 BuildRequires: boost-license%{sles_boost_version}
115 BuildRequires: boost-devel >= 1.41
116 Requires: boost-license%{sles_boost_version}
117 Requires: libboost_program_options%{sles_boost_version}
118 Requires: libboost_system%{sles_boost_version}
119 Requires: libboost_test%{sles_boost_version}
120 Requires: libboost_thread%{sles_boost_version}
121 Requires: libboost_regex%{sles_boost_version}
122 %endif
123 # opensuse
124 %if 0%{?suse_version} >= 1210
125 BuildRequires: boost-devel >= 1.41
126 Requires: libboost_program_options%{opensuse_boost_version}
127 Requires: libboost_system%{opensuse_boost_version}
128 Requires: libboost_test%{opensuse_boost_version}
129 Requires: libboost_thread%{opensuse_boost_version}
130 Requires: libboost_regex%{opensuse_boost_version}
131 %endif
132 %endif
133 # suse
134
135 Requires: %{name}-common = %{version}
136
137 %description bin
138 Icinga 2 is a general-purpose network monitoring application.
139 Provides binaries and libraries for Icinga 2 Core.
140
141 %package common
142 Summary:      Common Icinga 2 configuration
143 Group:        Applications/System
144 %if "%{_vendor}" == "redhat"
145 Requires(pre): shadow-utils
146 Requires(post): shadow-utils
147 %endif
148
149 %description common
150 Provides common directories, uid and gid among Icinga 2 related
151 packages.
152
153
154 %package doc
155 Summary:      Documentation for Icinga 2
156 Group:        Applications/System
157 Requires:     %{name} = %{version}-%{release}
158
159 %description doc
160 Documentation for Icinga 2
161
162
163 %package ido-mysql
164 Summary:      IDO MySQL database backend for Icinga 2
165 Group:        Applications/System
166 %if "%{_vendor}" == "suse"
167 BuildRequires: libmysqlclient-devel
168 %if 0%{?suse_version} >= 1210
169 Requires: libmysqlclient18
170 %else
171 Requires: libmysqlclient15
172 %endif
173 %endif
174 %if "%{_vendor}" == "redhat"
175 # el5 only provides mysql package
176 %if 0%{?el5} || 0%{?rhel} == 5 || "%{?dist}" == ".el5"
177 BuildRequires: mysql
178 %else
179 BuildRequires: mysql-libs
180 BuildRequires: mysql
181 %endif
182 BuildRequires: mysql-devel
183 Requires: mysql
184 %endif
185 Requires: %{name} = %{version}-%{release}
186
187 %description ido-mysql
188 Icinga 2 IDO mysql database backend. Compatible with Icinga 1.x
189 IDOUtils schema >= 1.10
190
191
192 %package ido-pgsql
193 Summary:      IDO PostgreSQL database backend for Icinga 2
194 Group:        Applications/System
195 %if "%{_vendor}" == "suse"
196 BuildRequires: postgresql-libs
197 %endif
198 BuildRequires: postgresql-devel
199 Requires: postgresql-libs
200 Requires: %{name} = %{version}-%{release}
201
202 %description ido-pgsql
203 Icinga 2 IDO PostgreSQL database backend. Compatible with Icinga 1.x
204 IDOUtils schema >= 1.10
205
206
207 %package classicui-config
208 Summary:      Icinga 2 Classic UI Standalone configuration
209 Group:        Applications/System
210 BuildRequires: %{apachename}
211 Requires:     %{apachename}
212 Requires:     %{name} = %{version}-%{release}
213 Provides:     icinga-classicui-config
214 Conflicts:    icinga-gui-config
215
216 %description classicui-config
217 Icinga 1.x Classic UI Standalone configuration with locations
218 for Icinga 2.
219
220
221 %prep
222 %setup -q -n %{name}-%{version}
223
224 %build
225 CMAKE_OPTS="-DCMAKE_INSTALL_PREFIX=/usr \
226          -DCMAKE_INSTALL_SYSCONFDIR=/etc \
227                  -DCMAKE_INSTALL_LOCALSTATEDIR=/var \
228          -DCMAKE_BUILD_TYPE=RelWithDebInfo \
229          -DICINGA2_USER=%{icinga_user} \
230          -DICINGA2_GROUP=%{icinga_group} \
231              -DICINGA2_COMMAND_USER=%{icinga_user} \
232              -DICINGA2_COMMAND_GROUP=%{icingacmd_group}"
233 %if "%{_vendor}" == "redhat"
234 %if 0%{?el5} || 0%{?rhel} == 5 || "%{?dist}" == ".el5"
235 # Boost_VERSION 1.41.0 vs 101400 - disable build tests
236 # details in https://dev.icinga.org/issues/5033
237 CMAKE_OPTS="$CMAKE_OPTS -DBOOST_LIBRARYDIR=/usr/lib/boost141 \
238  -DBOOST_INCLUDEDIR=/usr/include/boost141 \
239  -DBoost_ADDITIONAL_VERSIONS='1.41;1.41.0' \
240  -DBoost_NO_SYSTEM_PATHS=TRUE \
241  -DBUILD_TESTING=FALSE \
242  -DBoost_NO_BOOST_CMAKE=TRUE"
243 %endif
244 %endif
245
246 cmake $CMAKE_OPTS .
247
248 make %{?_smp_mflags}
249
250 %install
251 [ "%{buildroot}" != "/" ] && [ -d "%{buildroot}" ] && rm -rf %{buildroot}
252 make install \
253         DESTDIR="%{buildroot}"
254
255 # install classicui config
256 install -D -m 0644 etc/icinga/icinga-classic.htpasswd %{buildroot}%{icingaclassicconfdir}/passwd
257 install -D -m 0644 etc/icinga/cgi.cfg %{buildroot}%{icingaclassicconfdir}/cgi.cfg
258 install -D -m 0644 etc/icinga/icinga-classic-apache.conf %{buildroot}%{apacheconfdir}/icinga.conf
259
260 # fix plugin path on x64
261 %if "%{_vendor}" != "suse"
262 sed -i 's@PluginDir = .*@PluginDir = "%{_libdir}/nagios/plugins"@' %{buildroot}/%{_sysconfdir}/%{name}/constants.conf
263 %endif
264
265 # remove features-enabled symlinks
266 rm -f %{buildroot}/%{_sysconfdir}/%{name}/features-enabled/*.conf
267
268 %clean
269 [ "%{buildroot}" != "/" ] && [ -d "%{buildroot}" ] && rm -rf %{buildroot}
270
271 %pre common
272 getent group %{icinga_group} >/dev/null || %{_sbindir}/groupadd -r %{icinga_group}
273 getent group %{icingacmd_group} >/dev/null || %{_sbindir}/groupadd -r %{icingacmd_group}
274 getent passwd %{icinga_user} >/dev/null || %{_sbindir}/useradd -c "icinga" -s /sbin/nologin -r -d %{_localstatedir}/spool/%{name} -G %{icingacmd_group} -g %{icinga_group} %{icinga_user}
275 exit 0
276
277 # suse
278 %if 0%{?suse_version}
279 %post
280 %{fillup_and_insserv icinga2}
281
282 if [ ${1:-0} -eq 1 ]
283 then
284         # initial installation, enable default features
285         %{_sbindir}/icinga2-enable-feature checker notification mainlog
286 fi
287
288 exit 0
289 %postun
290 %restart_on_update icinga2
291 %insserv_cleanup
292
293 if [ "$1" = "0" ]; then
294         # deinstallation of the package - remove enabled features
295         rm -rf %{_sysconfdir}/%{name}/features-enabled
296 fi
297
298 exit 0
299
300 %preun
301 %stop_on_removal icinga2
302
303 # rhel
304 %else
305
306 %post
307 /sbin/chkconfig --add icinga2
308
309 if [ ${1:-0} -eq 1 ]
310 then
311         # initial installation, enable default features
312         %{_sbindir}/icinga2-enable-feature checker notification mainlog
313 fi
314
315 exit 0
316
317 %postun
318 if [ "$1" -ge  "1" ]; then
319         /sbin/service icinga2 condrestart >/dev/null 2>&1 || :
320 fi
321
322 if [ "$1" = "0" ]; then
323         # deinstallation of the package - remove enabled features
324         rm -rf %{_sysconfdir}/%{name}/features-enabled
325 fi
326
327 exit 0
328 %preun
329 if [ "$1" = "0" ]; then
330         /sbin/service icinga2 stop > /dev/null 2>&1
331         /sbin/chkconfig --del icinga2
332 fi
333
334 %endif
335 # suse/rhel
336
337 %post ido-mysql
338 if [ ${1:-0} -eq 1 ]
339 then
340         # initial installation, enable ido-mysql feature
341         %{_sbindir}/icinga2-enable-feature ido-mysql
342 fi
343
344 exit 0
345
346 %postun ido-mysql
347 if [ "$1" = "0" ]; then
348         # deinstallation of the package - remove feature
349         test -x %{_sbindir}/icinga2-disable-feature && %{_sbindir}/icinga2-disable-feature ido-mysql
350 fi
351
352 exit 0
353
354 %post ido-pgsql
355 if [ ${1:-0} -eq 1 ]
356 then
357         # initial installation, enable ido-pgsql feature
358         %{_sbindir}/icinga2-enable-feature ido-pgsql
359 fi
360
361 exit 0
362
363 %postun ido-pgsql
364 if [ "$1" = "0" ]; then
365         # deinstallation of the package - remove feature
366         test -x %{_sbindir}/icinga2-disable-feature && %{_sbindir}/icinga2-disable-feature ido-pgsql
367 fi
368
369 exit 0
370
371 %post classicui-config
372 if [ ${1:-0} -eq 1 ]
373 then
374         # initial installation, enable features
375         %{_sbindir}/icinga2-enable-feature statusdata compatlog command
376 fi
377
378 exit 0
379
380 %postun classicui-config
381 if [ "$1" = "0" ]; then
382         # deinstallation of the package - remove feature
383         test -x %{_sbindir}/icinga2-disable-feature && %{_sbindir}/icinga2-disable-feature statusdata
384         test -x %{_sbindir}/icinga2-disable-feature && %{_sbindir}/icinga2-disable-feature compatlog
385         test -x %{_sbindir}/icinga2-disable-feature && %{_sbindir}/icinga2-disable-feature command
386 fi
387
388 exit 0
389
390 %files
391
392 %files bin
393 %defattr(-,root,root,-)
394 %doc COPYING COPYING.Exceptions README NEWS AUTHORS ChangeLog
395 %attr(755,-,-) %{_sysconfdir}/init.d/%{name}
396 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}
397 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/conf.d
398 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/conf.d/hosts
399 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/conf.d/hosts/localhost
400 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/features-available
401 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/features-enabled
402 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/scripts
403 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/zones.d
404 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/%{name}.conf
405 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/constants.conf
406 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/zones.conf
407 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/conf.d/*.conf
408 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/conf.d/hosts/*.conf
409 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/conf.d/hosts/localhost/*.conf
410 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/features-available/*.conf
411 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/zones.d/*
412 %config(noreplace) %{_sysconfdir}/%{name}/scripts/*
413 %{_sbindir}/%{name}
414 %{_bindir}/%{name}-build-ca
415 %{_bindir}/%{name}-build-key
416 %{_bindir}/%{name}-sign-key
417 %{_sbindir}/%{name}-enable-feature
418 %{_sbindir}/%{name}-disable-feature
419 %{_sbindir}/%{name}-setup-agent
420 %{_sbindir}/%{name}-discover-agent
421 %{_sbindir}/%{name}-forget-agent
422 %{_sbindir}/%{name}-list-agents
423 %exclude %{_libdir}/%{name}/libdb_ido_mysql*
424 %exclude %{_libdir}/%{name}/libdb_ido_pgsql*
425 %{_libdir}/%{name}
426 %{_datadir}/%{name}
427 %exclude %{_datadir}/%{name}/include
428 %{_mandir}/man8/%{name}.8.gz
429
430 %attr(0755,%{icinga_user},%{icinga_group}) %{_localstatedir}/cache/%{name}
431 %attr(0755,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/log/%{name}
432 %attr(0755,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/log/%{name}/compat
433 %attr(0755,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/log/%{name}/compat/archives
434 %attr(0755,%{icinga_user},%{icinga_group}) %ghost %{_localstatedir}/run/%{name}
435 %attr(0750,%{icinga_user},%{icinga_group}) %{_localstatedir}/lib/%{name}
436
437 %attr(2755,%{icinga_user},%{icingacmd_group}) %ghost %{_localstatedir}/run/icinga2/cmd
438
439 %files common
440 %defattr(-,root,root,-)
441 %doc COPYING COPYING.Exceptions README NEWS AUTHORS ChangeLog
442 %attr(755,-,-) %{_sysconfdir}/logrotate.d/%{name}
443 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/spool/%{name}
444 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/spool/%{name}/perfdata
445 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/spool/%{name}/tmp
446 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_datadir}/%{name}/include
447 %{_datadir}/%{name}/include
448
449 %files doc
450 %defattr(-,root,root,-)
451 %{_datadir}/doc/%{name}
452 %docdir %{_datadir}/doc/%{name}
453
454 %files ido-mysql
455 %defattr(-,root,root,-)
456 %doc components/db_ido_mysql/schema COPYING COPYING.Exceptions README NEWS AUTHORS ChangeLog
457 %{_libdir}/%{name}/libdb_ido_mysql*
458
459 %files ido-pgsql
460 %defattr(-,root,root,-)
461 %doc components/db_ido_pgsql/schema COPYING COPYING.Exceptions README NEWS AUTHORS ChangeLog
462 %{_libdir}/%{name}/libdb_ido_pgsql*
463
464 %files classicui-config
465 %defattr(-,root,root,-)
466 %attr(0751,%{icinga_user},%{icinga_group}) %dir %{icingaclassicconfdir}
467 %config(noreplace) %{icingaclassicconfdir}/cgi.cfg
468 %config(noreplace) %{apacheconfdir}/icinga.conf
469 %config(noreplace) %attr(0640,root,%{apachegroup}) %{icingaclassicconfdir}/passwd
470
471
472 %changelog