]> granicus.if.org Git - icinga2/blob - icinga2.spec
Config: Fix IcingaMacros const identifier.
[icinga2] / icinga2.spec
1 #/******************************************************************************
2 # * Icinga 2                                                                   *
3 # * Copyright (C) 2012-2014 Icinga Development Team (http://www.icinga.org)    *
4 # *                                                                            *
5 # * This program is free software; you can redistribute it and/or              *
6 # * modify it under the terms of the GNU General Public License                *
7 # * as published by the Free Software Foundation; either version 2             *
8 # * of the License, or (at your option) any later version.                     *
9 # *                                                                            *
10 # * This program is distributed in the hope that it will be useful,            *
11 # * but WITHOUT ANY WARRANTY; without even the implied warranty of             *
12 # * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the              *
13 # * GNU General Public License for more details.                               *
14 # *                                                                            *
15 # * You should have received a copy of the GNU General Public License          *
16 # * along with this program; if not, write to the Free Software Foundation     *
17 # * Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.             *
18 # ******************************************************************************/
19
20 %define revision 1
21
22 %if "%{_vendor}" == "redhat"
23 %define el5_boost_version 141
24 %define el5_boost_libs %{_libdir}/boost%{el5_boost_version}
25 %define el5_boost_includes /usr/include/boost%{el5_boost_version}
26 %define apachename httpd
27 %define apacheconfdir %{_sysconfdir}/httpd/conf.d
28 %define apacheuser apache
29 %define apachegroup apache
30 %endif
31 %if "%{_vendor}" == "suse"
32 # opensuse 13
33 %if 0%{?suse_version} >= 1310
34 %define opensuse_boost_version 1_53_0
35 %else
36 %define opensuse_boost_version 1_49_0
37 %endif
38 %define sles_boost_version 1_54_0
39 %define apachename apache2
40 %define apacheconfdir  %{_sysconfdir}/apache2/conf.d
41 %define apacheuser wwwrun
42 %define apachegroup www
43 %endif
44
45 %define icinga_user icinga
46 %define icinga_group icinga
47 %define icingacmd_group icingacmd
48 %define icingaweb2name icingaweb2
49 %define icingaweb2version 2.0.0
50
51 %define icingaclassicconfdir %{_sysconfdir}/icinga
52
53 %define logmsg logger -t %{name}/rpm
54
55 Summary: Network monitoring application
56 Name: icinga2
57 Version: 0.0.8
58 Release: %{revision}%{?dist}
59 License: GPLv2+
60 Group: Applications/System
61 Source: %{name}-%{version}.tar.gz
62 URL: http://www.icinga.org/
63 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
64
65 Requires: %{name}-bin = %{version}
66 #Requires: %{name}-ido-mysql = %{version}
67 #Requires: %{icingaweb2name} >= %{icingaweb2version}
68
69 %description
70 Meta package for Icinga 2 Core, DB IDO and Web.
71
72 %package bin
73 Summary:      Icinga 2 binaries and libraries
74 Group:        Applications/System
75
76 BuildRequires: doxygen
77 BuildRequires: openssl-devel
78 BuildRequires: gcc-c++
79 BuildRequires: libstdc++-devel
80 BuildRequires: cmake
81 BuildRequires: flex >= 2.5.35
82 BuildRequires: bison
83
84 # redhat
85 %if "%{_vendor}" == "redhat"
86 %if 0%{?el5} || 0%{?rhel} == 5 || "%{?dist}" == ".el5"
87 # el5 requires EPEL
88 BuildRequires: boost%{el5_boost_version}-devel
89 BuildRequires: boost%{el5_boost_version}
90 Requires: boost%{el5_boost_version}-program-options
91 Requires: boost%{el5_boost_version}-system
92 Requires: boost%{el5_boost_version}-test
93 Requires: boost%{el5_boost_version}-thread
94 Requires: boost%{el5_boost_version}-regex
95 %else
96 BuildRequires: boost-devel >= 1.41
97 Requires: boost-program-options >= 1.41
98 Requires: boost-system >= 1.41
99 Requires: boost-test >= 1.41
100 Requires: boost-thread >= 1.41
101 Requires: boost-regex >= 1.41
102 %endif
103 %endif
104 #redhat
105
106 # suse
107 %if "%{_vendor}" == "suse"
108 # sles
109 # note: sles_version macro is not set in SLES11 anymore
110 # note: sles service packs are not under version control
111 %if 0%{?suse_version} == 1110
112 BuildRequires: gcc-fortran
113 BuildRequires: libgfortran43
114 BuildRequires: boost-license%{sles_boost_version}
115 BuildRequires: boost-devel >= 1.41
116 Requires: boost-license%{sles_boost_version}
117 Requires: libboost_program_options%{sles_boost_version}
118 Requires: libboost_system%{sles_boost_version}
119 Requires: libboost_test%{sles_boost_version}
120 Requires: libboost_thread%{sles_boost_version}
121 Requires: libboost_regex%{sles_boost_version}
122 %endif
123 # opensuse
124 %if 0%{?suse_version} >= 1210
125 BuildRequires: boost-devel >= 1.41
126 Requires: libboost_program_options%{opensuse_boost_version}
127 Requires: libboost_system%{opensuse_boost_version}
128 Requires: libboost_test%{opensuse_boost_version}
129 Requires: libboost_thread%{opensuse_boost_version}
130 Requires: libboost_regex%{opensuse_boost_version}
131 %endif
132 %endif
133 # suse
134
135 Requires: %{name}-common = %{version}
136
137 %description bin
138 Icinga 2 is a general-purpose network monitoring application.
139 Provides binaries and libraries for Icinga 2 Core.
140
141 %package common
142 Summary:      Common Icinga 2 configuration
143 Group:        Applications/System
144 %if "%{_vendor}" == "redhat"
145 Requires(pre): shadow-utils
146 Requires(post): shadow-utils
147 %endif
148
149 %description common
150 Provides common directories, uid and gid among Icinga 2 related
151 packages.
152
153
154 %package doc
155 Summary:      Documentation for Icinga 2
156 Group:        Applications/System
157 Requires:     %{name} = %{version}-%{release}
158
159 %description doc
160 Documentation for Icinga 2
161
162
163 %package ido-mysql
164 Summary:      IDO MySQL database backend for Icinga 2
165 Group:        Applications/System
166 %if "%{_vendor}" == "suse"
167 BuildRequires: libmysqlclient-devel
168 %if 0%{?suse_version} >= 1210
169 Requires: libmysqlclient18
170 %else
171 Requires: libmysqlclient15
172 %endif
173 %endif
174 %if "%{_vendor}" == "redhat"
175 # el5 only provides mysql package
176 %if 0%{?el5} || 0%{?rhel} == 5 || "%{?dist}" == ".el5"
177 BuildRequires: mysql
178 %else
179 BuildRequires: mysql-libs
180 BuildRequires: mysql
181 %endif
182 BuildRequires: mysql-devel
183 Requires: mysql
184 %endif
185 Requires: %{name} = %{version}-%{release}
186
187 %description ido-mysql
188 Icinga 2 IDO mysql database backend. Compatible with Icinga 1.x
189 IDOUtils schema >= 1.10
190
191
192 %package ido-pgsql
193 Summary:      IDO PostgreSQL database backend for Icinga 2
194 Group:        Applications/System
195 %if "%{_vendor}" == "suse"
196 BuildRequires: postgresql-libs
197 %endif
198 %if "%{_vendor}" == "redhat"
199 # el5 only provides mysql package
200 %if 0%{?el5} || 0%{?rhel} == 5 || "%{?dist}" == ".el5"
201 BuildRequires: postgresql84
202 %endif
203 %endif
204 BuildRequires: postgresql-devel
205 Requires: postgresql-libs
206 Requires: %{name} = %{version}-%{release}
207
208 %description ido-pgsql
209 Icinga 2 IDO PostgreSQL database backend. Compatible with Icinga 1.x
210 IDOUtils schema >= 1.10
211
212
213 %package classicui-config
214 Summary:      Icinga 2 Classic UI Standalone configuration
215 Group:        Applications/System
216 BuildRequires: %{apachename}
217 Requires:     %{apachename}
218 Requires:     %{name} = %{version}-%{release}
219 Provides:     icinga-classicui-config
220 Conflicts:    icinga-gui-config
221
222 %description classicui-config
223 Icinga 1.x Classic UI Standalone configuration with locations
224 for Icinga 2.
225
226
227 %prep
228 %setup -q -n %{name}-%{version}
229
230 %build
231 CMAKE_OPTS="-DCMAKE_INSTALL_PREFIX=/usr \
232          -DCMAKE_INSTALL_SYSCONFDIR=/etc \
233                  -DCMAKE_INSTALL_LOCALSTATEDIR=/var \
234          -DCMAKE_BUILD_TYPE=RelWithDebInfo \
235          -DICINGA2_USER=%{icinga_user} \
236          -DICINGA2_GROUP=%{icinga_group} \
237              -DICINGA2_COMMAND_USER=%{icinga_user} \
238              -DICINGA2_COMMAND_GROUP=%{icingacmd_group}"
239 %if "%{_vendor}" == "redhat"
240 %if 0%{?el5} || 0%{?rhel} == 5 || "%{?dist}" == ".el5"
241 # Boost_VERSION 1.41.0 vs 101400 - disable build tests
242 # details in https://dev.icinga.org/issues/5033
243 CMAKE_OPTS="$CMAKE_OPTS -DBOOST_LIBRARYDIR=/usr/lib/boost141 \
244  -DBOOST_INCLUDEDIR=/usr/include/boost141 \
245  -DBoost_ADDITIONAL_VERSIONS='1.41;1.41.0' \
246  -DBoost_NO_SYSTEM_PATHS=TRUE \
247  -DBUILD_TESTING=FALSE \
248  -DBoost_NO_BOOST_CMAKE=TRUE"
249 %endif
250 %endif
251
252 cmake $CMAKE_OPTS .
253
254 make %{?_smp_mflags}
255
256 %install
257 [ "%{buildroot}" != "/" ] && [ -d "%{buildroot}" ] && rm -rf %{buildroot}
258 make install \
259         DESTDIR="%{buildroot}"
260
261 # install classicui config
262 install -D -m 0644 etc/icinga/icinga-classic.htpasswd %{buildroot}%{icingaclassicconfdir}/passwd
263 install -D -m 0644 etc/icinga/cgi.cfg %{buildroot}%{icingaclassicconfdir}/cgi.cfg
264 install -D -m 0644 etc/icinga/icinga-classic-apache.conf %{buildroot}%{apacheconfdir}/icinga.conf
265
266 # fix plugin path on x64
267 %if "%{_vendor}" != "suse"
268 sed -i 's@plugindir = .*@plugindir = "%{_libdir}/nagios/plugins"@' %{buildroot}/%{_sysconfdir}/%{name}/conf.d/macros.conf
269 %endif
270
271 # remove features-enabled symlinks
272 rm -f %{buildroot}/%{_sysconfdir}/%{name}/features-enabled/*.conf
273
274 %clean
275 [ "%{buildroot}" != "/" ] && [ -d "%{buildroot}" ] && rm -rf %{buildroot}
276
277 %pre common
278 getent group %{icinga_group} >/dev/null || %{_sbindir}/groupadd -r %{icinga_group}
279 getent group %{icingacmd_group} >/dev/null || %{_sbindir}/groupadd -r %{icingacmd_group}
280 getent passwd %{icinga_user} >/dev/null || %{_sbindir}/useradd -c "icinga" -s /sbin/nologin -r -d %{_localstatedir}/spool/%{name} -G %{icingacmd_group} -g %{icinga_group} %{icinga_user}
281 exit 0
282
283 # suse
284 %if 0%{?suse_version}
285 %post
286 %{fillup_and_insserv icinga2}
287
288 if [ ${1:-0} -eq 1 ]
289 then
290         # initial installation, enable default features
291         %{_sbindir}/icinga2-enable-feature checker
292         %{_sbindir}/icinga2-enable-feature notification
293         %{_sbindir}/icinga2-enable-feature mainlog
294 fi
295
296 exit 0
297 %postun
298 %restart_on_update icinga2
299 %insserv_cleanup
300
301 if [ "$1" = "0" ]; then
302         # deinstallation of the package - remove enabled features
303         rm -rf %{_sysconfdir}/%{name}/features-enabled
304 fi
305
306 exit 0
307
308 %preun
309 %stop_on_removal icinga2
310
311 # rhel
312 %else
313
314 %post
315 /sbin/chkconfig --add icinga2
316
317 if [ ${1:-0} -eq 1 ]
318 then
319         # initial installation, enable default features
320         %{_sbindir}/icinga2-enable-feature checker
321         %{_sbindir}/icinga2-enable-feature notification
322         %{_sbindir}/icinga2-enable-feature mainlog
323 fi
324
325 exit 0
326
327 %postun
328 if [ "$1" -ge  "1" ]; then
329         /sbin/service icinga2 condrestart >/dev/null 2>&1 || :
330 fi
331
332 if [ "$1" = "0" ]; then
333         # deinstallation of the package - remove enabled features
334         rm -rf %{_sysconfdir}/%{name}/features-enabled
335 fi
336
337 exit 0
338 %preun
339 if [ "$1" = "0" ]; then
340         /sbin/service icinga2 stop > /dev/null 2>&1
341         /sbin/chkconfig --del icinga2
342 fi
343
344 %endif
345 # suse/rhel
346
347 %post ido-mysql
348 if [ ${1:-0} -eq 1 ]
349 then
350         # initial installation, enable ido-mysql feature
351         %{_sbindir}/icinga2-enable-feature ido-mysql
352 fi
353
354 exit 0
355
356 %postun ido-mysql
357 if [ "$1" = "0" ]; then
358         # deinstallation of the package - remove feature
359         test -x %{_sbindir}/icinga2-disable-feature && %{_sbindir}/icinga2-disable-feature ido-mysql
360 fi
361
362 exit 0
363
364 %post ido-pgsql
365 if [ ${1:-0} -eq 1 ]
366 then
367         # initial installation, enable ido-pgsql feature
368         %{_sbindir}/icinga2-enable-feature ido-pgsql
369 fi
370
371 exit 0
372
373 %postun ido-pgsql
374 if [ "$1" = "0" ]; then
375         # deinstallation of the package - remove feature
376         test -x %{_sbindir}/icinga2-disable-feature && %{_sbindir}/icinga2-disable-feature ido-pgsql
377 fi
378
379 exit 0
380
381 %post classicui-config
382 if [ ${1:-0} -eq 1 ]
383 then
384         # initial installation, enable features
385         %{_sbindir}/icinga2-enable-feature statusdata
386         %{_sbindir}/icinga2-enable-feature compatlog
387         %{_sbindir}/icinga2-enable-feature command
388 fi
389
390 exit 0
391
392 %postun classicui-config
393 if [ "$1" = "0" ]; then
394         # deinstallation of the package - remove feature
395         test -x %{_sbindir}/icinga2-disable-feature && %{_sbindir}/icinga2-disable-feature statusdata
396         test -x %{_sbindir}/icinga2-disable-feature && %{_sbindir}/icinga2-disable-feature compatlog
397         test -x %{_sbindir}/icinga2-disable-feature && %{_sbindir}/icinga2-disable-feature command
398 fi
399
400 exit 0
401
402 %files
403
404 %files bin
405 %defattr(-,root,root,-)
406 %doc COPYING COPYING.Exceptions README NEWS AUTHORS ChangeLog
407 %attr(755,-,-) %{_sysconfdir}/init.d/%{name}
408 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}
409 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/conf.d
410 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/features-available
411 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/features-enabled
412 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_sysconfdir}/%{name}/scripts
413 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/%{name}.conf
414 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/conf.d/*.conf
415 %config(noreplace) %attr(0640,%{icinga_user},%{icinga_group}) %{_sysconfdir}/%{name}/features-available/*.conf
416 %config(noreplace) %{_sysconfdir}/%{name}/scripts/*
417 %{_sbindir}/%{name}
418 %{_bindir}/%{name}-migrate-config
419 %{_bindir}/%{name}-build-ca
420 %{_bindir}/%{name}-build-key
421 %{_sbindir}/%{name}-enable-feature
422 %{_sbindir}/%{name}-disable-feature
423 %exclude %{_libdir}/%{name}/libdb_ido_mysql*
424 %exclude %{_libdir}/%{name}/libdb_ido_pgsql*
425 %{_libdir}/%{name}
426 %{_datadir}/%{name}
427 %exclude %{_datadir}/%{name}/itl
428 %{_mandir}/man8/%{name}.8.gz
429
430 %attr(0755,%{icinga_user},%{icinga_group}) %{_localstatedir}/cache/%{name}
431 %attr(0755,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/log/%{name}
432 %attr(0755,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/log/%{name}/compat
433 %attr(0755,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/log/%{name}/compat/archives
434 %attr(0755,%{icinga_user},%{icinga_group}) %ghost %{_localstatedir}/run/%{name}
435 %attr(0750,%{icinga_user},%{icinga_group}) %{_localstatedir}/lib/%{name}
436
437 %attr(2755,%{icinga_user},%{icingacmd_group}) %ghost %{_localstatedir}/run/icinga2/cmd
438
439 %files common
440 %defattr(-,root,root,-)
441 %doc COPYING COPYING.Exceptions README NEWS AUTHORS ChangeLog
442 %attr(755,-,-) %{_sysconfdir}/logrotate.d/%{name}
443 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/spool/%{name}
444 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/spool/%{name}/perfdata
445 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_localstatedir}/spool/%{name}/tmp
446 %attr(0750,%{icinga_user},%{icinga_group}) %dir %{_datadir}/%{name}/itl
447 %{_datadir}/%{name}/itl
448
449 %files doc
450 %defattr(-,root,root,-)
451 %doc COPYING COPYING.Exceptions README NEWS AUTHORS ChangeLog
452 %{_datadir}/doc/%{name}
453 %docdir %{_datadir}/doc/%{name}
454
455 %files ido-mysql
456 %defattr(-,root,root,-)
457 %doc components/db_ido_mysql/schema COPYING COPYING.Exceptions README NEWS AUTHORS ChangeLog
458 %{_libdir}/%{name}/libdb_ido_mysql*
459
460 %files ido-pgsql
461 %defattr(-,root,root,-)
462 %doc components/db_ido_pgsql/schema COPYING COPYING.Exceptions README NEWS AUTHORS ChangeLog
463 %{_libdir}/%{name}/libdb_ido_pgsql*
464
465 %files classicui-config
466 %defattr(-,root,root,-)
467 %attr(0751,%{icinga_user},%{icinga_group}) %dir %{icingaclassicconfdir}
468 %config(noreplace) %{icingaclassicconfdir}/cgi.cfg
469 %config(noreplace) %{apacheconfdir}/icinga.conf
470 %config(noreplace) %attr(0640,root,%{apachegroup}) %{icingaclassicconfdir}/passwd
471
472
473 %changelog