]> granicus.if.org Git - imagemagick/blob - ImageMagick.spec
Accept defined compression-filter=6,7,8,9 to be consistent with -quality option.
[imagemagick] / ImageMagick.spec
1 %global VERSION  6.7.1
2 %global Patchlevel  0
3
4 Name:           ImageMagick
5 Version:        %{VERSION}
6 Release:        %{Patchlevel}
7 Summary:        Use ImageMagick to convert, edit, or compose bitmap images in a variety of formats.  In addition resize, rotate, shear, distort and transform images.
8 Group:          Applications/Multimedia
9 License:        http://www.imagemagick.org/script/license.php
10 Url:            http://www.imagemagick.org/
11 Source0:        ftp://ftp.imagemagick.org/pub/%{name}/%{name}-%{VERSION}-%{Patchlevel}.tar.bz2
12
13 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14 BuildRequires:  bzip2-devel, freetype-devel, libjpeg-devel, libpng-devel
15 BuildRequires:  libtiff-devel, giflib-devel, zlib-devel, perl-devel >= 5.8.1
16 BuildRequires:  ghostscript-devel, djvulibre-devel
17 BuildRequires:  libwmf-devel, jasper-devel, libtool-ltdl-devel
18 BuildRequires:  libX11-devel, libXext-devel, libXt-devel
19 BuildRequires:  lcms-devel, libxml2-devel, librsvg2-devel, OpenEXR-devel
20
21 %description
22 ImageMagick is a software suite to create, edit, and compose bitmap images. It
23 can read, convert and write images in a variety of formats (about 100)
24 including DPX, GIF, JPEG, JPEG-2000, PDF, PhotoCD, PNG, Postscript, SVG,
25 and TIFF. Use ImageMagick to translate, flip, mirror, rotate, scale, shear
26 and transform images, adjust image colors, apply various special effects,
27 or draw text, lines, polygons, ellipses and Bézier curves.
28
29 The functionality of ImageMagick is typically utilized from the command line
30 or you can use the features from programs written in your favorite programming
31 language. Choose from these interfaces: G2F (Ada), MagickCore (C), MagickWand
32 (C), ChMagick (Ch), Magick++ (C++), JMagick (Java), L-Magick (Lisp), nMagick
33 (Neko/haXe), PascalMagick (Pascal), PerlMagick (Perl), MagickWand for PHP
34 (PHP), PythonMagick (Python), RMagick (Ruby), or TclMagick (Tcl/TK). With a
35 language interface, use ImageMagick to modify or create images automagically
36 and dynamically.
37
38 ImageMagick is free software delivered as a ready-to-run binary distribution
39 or as source code that you may freely use, copy, modify, and distribute in
40 both open and proprietary applications. It is distributed under an Apache
41 2.0-style license, approved by the OSI.
42
43 The ImageMagick development process ensures a stable API and ABI. Before
44 each ImageMagick release, we perform a comprehensive security assessment that
45 includes memory and thread error detection to help prevent exploits.ImageMagick
46 is free software delivered as a ready-to-run binary distribution or as source
47 code that you may freely use, copy, modify, and distribute in both open and
48 proprietary applications. It is distributed under an Apache 2.0-style license,
49 approved by the OSI.
50
51
52 %package devel
53 Summary: Library links and header files for ImageMagick application development
54 Group: Development/Libraries
55 Requires: %{name} = %{version}-%{release}
56 Requires: libX11-devel, libXext-devel, libXt-devel
57 Requires: ghostscript-devel
58 Requires: bzip2-devel
59 Requires: freetype-devel
60 Requires: libtiff-devel
61 Requires: libjpeg-devel
62 Requires: lcms-devel
63 Requires: jasper-devel
64 Requires: pkgconfig
65
66 %description devel
67 ImageMagick-devel contains the library links and header files you'll
68 need to develop ImageMagick applications. ImageMagick is an image
69 manipulation program.
70
71 If you want to create applications that will use ImageMagick code or
72 APIs, you need to install ImageMagick-devel as well as ImageMagick.
73 You do not need to install it if you just want to use ImageMagick,
74 however.
75
76
77 %package doc
78 Summary: ImageMagick HTML documentation
79 Group: Documentation
80
81
82 %package djvu
83 Summary: DjVu plugin for ImageMagick
84 Group: Applications/Multimedia
85 Requires: %{name} = %{version}-%{release}
86
87 %description djvu
88 This packages contains a plugin for ImageMagick which makes it possible to
89 save and load DjvU files from ImageMagick and libMagickCore using applications.
90
91
92 %description doc
93 ImageMagick documentation, this package contains usage (for the
94 commandline tools) and API (for the libraries) documentation in HTML format.
95 Note this documentation can also be found on the ImageMagick website:
96 http://www.imagemagick.org/.
97
98
99 %package perl
100 Summary: ImageMagick perl bindings
101 Group: System Environment/Libraries
102 Requires: perl-base
103 Requires: %{name} = %{version}-%{release}
104 Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
105
106
107 %description perl
108 Perl bindings to ImageMagick.
109
110 Install ImageMagick-perl if you want to use any perl scripts that use
111 ImageMagick.
112
113
114 %package c++
115 Summary: ImageMagick Magick++ library (C++ bindings)
116 Group: System Environment/Libraries
117 Requires: %{name} = %{version}-%{release}
118
119 %description c++
120 This package contains the Magick++ library, a C++ binding to the ImageMagick
121 graphics manipulation library.
122
123 Install ImageMagick-c++ if you want to use any applications that use Magick++.
124
125
126 %package c++-devel
127 Summary: C++ bindings for the ImageMagick library
128 Group: Development/Libraries
129 Requires: %{name}-c++ = %{version}-%{release}
130 Requires: %{name}-devel = %{version}-%{release}
131
132 %description c++-devel
133 ImageMagick-devel contains the static libraries and header files you'll
134 need to develop ImageMagick applications using the Magick++ C++ bindings.
135 ImageMagick is an image manipulation program.
136
137 If you want to create applications that will use Magick++ code
138 or APIs, you'll need to install ImageMagick-c++-devel, ImageMagick-devel and
139 ImageMagick.
140
141 You don't need to install it if you just want to use ImageMagick, or if you
142 want to develop/compile applications using the ImageMagick C interface,
143 however.
144
145
146 %prep
147 %setup -q -n %{name}-%{VERSION}-%{Patchlevel}
148 sed -i 's/libltdl.la/libltdl.so/g' configure
149 iconv -f ISO-8859-1 -t UTF-8 README.txt > README.txt.tmp
150 touch -r README.txt README.txt.tmp
151 mv README.txt.tmp README.txt
152 # for %%doc
153 mkdir Magick++/examples
154 cp -p Magick++/demo/*.cpp Magick++/demo/*.miff Magick++/examples
155
156 %build
157 %configure --enable-shared \
158            --disable-static \
159            --with-modules \
160            --with-perl \
161            --with-x \
162            --with-threads \
163            --with-magick_plus_plus \
164            --with-gslib \
165            --with-wmf \
166            --with-lcms \
167            --with-rsvg \
168            --with-xml \
169            --with-perl-options='INSTALLDIRS=vendor' \
170            --without-dps \
171            --without-included-ltdl --with-ltdl-include=%{_includedir} \
172            --with-ltdl-lib=%{_libdir}
173 # Disable rpath
174 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
175 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
176 # Do *NOT* use %%{?_smp_mflags}, this causes PerlMagick to be silently misbuild
177 make
178
179
180 %install
181 rm -rf $RPM_BUILD_ROOT
182
183 make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
184 cp -a www/source $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{VERSION}
185 rm $RPM_BUILD_ROOT%{_libdir}/*.la
186
187 # fix weird perl Magick.so permissions
188 chmod 755 $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Image/Magick/Magick.so
189
190 # perlmagick: fix perl path of demo files
191 %{__perl} -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
192
193 # perlmagick: cleanup various perl tempfiles from the build which get installed
194 find $RPM_BUILD_ROOT -name "*.bs" |xargs rm -f
195 find $RPM_BUILD_ROOT -name ".packlist" |xargs rm -f
196 find $RPM_BUILD_ROOT -name "perllocal.pod" |xargs rm -f
197
198 # perlmagick: build files list
199 echo "%defattr(-,root,root,-)" > perl-pkg-files
200 find $RPM_BUILD_ROOT/%{_libdir}/perl* -type f -print \
201         | sed "s@^$RPM_BUILD_ROOT@@g" > perl-pkg-files 
202 find $RPM_BUILD_ROOT%{perl_vendorarch} -type d -print \
203         | sed "s@^$RPM_BUILD_ROOT@%dir @g" \
204         | grep -v '^%dir %{perl_vendorarch}$' \
205         | grep -v '/auto$' >> perl-pkg-files 
206 if [ -z perl-pkg-files ] ; then
207     echo "ERROR: EMPTY FILE LIST"
208     exit -1
209 fi
210
211 # fix multilib issues
212 %ifarch x86_64 s390x ia64 ppc64 alpha sparc64
213 %define wordsize 64
214 %else
215 %define wordsize 32
216 %endif
217
218 mv $RPM_BUILD_ROOT%{_includedir}/%{name}/magick/magick-config.h \
219    $RPM_BUILD_ROOT%{_includedir}/%{name}/magick/magick-config-%{wordsize}.h
220
221 cat >$RPM_BUILD_ROOT%{_includedir}/%{name}/magick/magick-config.h <<EOF
222 #ifndef IMAGEMAGICK_MULTILIB
223 #define IMAGEMAGICK_MULTILIB
224
225 #include <bits/wordsize.h>
226
227 #if __WORDSIZE == 32
228 # include "magick-config-32.h"
229 #elif __WORDSIZE == 64
230 # include "magick-config-64.h"
231 #else
232 # error "unexpected value for __WORDSIZE macro"
233 #endif
234
235 #endif
236 EOF
237
238 %clean
239 rm -rf $RPM_BUILD_ROOT
240
241
242 %post -p /sbin/ldconfig
243
244 %post c++ -p /sbin/ldconfig
245
246 %postun -p /sbin/ldconfig
247
248 %postun c++ -p /sbin/ldconfig
249
250
251 %files
252 %defattr(-,root,root,-)
253 %doc QuickStart.txt ChangeLog Platforms.txt
254 %doc README.txt LICENSE NOTICE AUTHORS.txt NEWS.txt
255 %{_libdir}/libMagickCore.so.4*
256 %{_libdir}/libMagickWand.so.4*
257 %{_bindir}/[a-z]*
258 %{_sysconfdir}/%{name}
259 %{_libdir}/%{name}-%{VERSION}
260 %{_datadir}/%{name}-%{VERSION}
261 %{_mandir}/man[145]/[a-zA-Z]*
262 %{_mandir}/man1/%{name}.*
263 %exclude %{_libdir}/%{name}-%{VERSION}/modules-Q16/coders/djvu.*
264
265
266 %files devel
267 %defattr(-,root,root,-)
268 %{_bindir}/MagickCore-config
269 %{_bindir}/Magick-config
270 %{_bindir}/MagickWand-config
271 %{_bindir}/Wand-config
272 %{_libdir}/libMagickCore.so
273 %{_libdir}/libMagickWand.so
274 %{_libdir}/pkgconfig/MagickCore.pc
275 %{_libdir}/pkgconfig/ImageMagick.pc
276 %{_libdir}/pkgconfig/MagickWand.pc
277 %{_libdir}/pkgconfig/Wand.pc
278 %dir %{_includedir}/%{name}
279 %{_includedir}/%{name}/magick
280 %{_includedir}/%{name}/wand
281 %{_mandir}/man1/Magick-config.*
282 %{_mandir}/man1/MagickCore-config.*
283 %{_mandir}/man1/Wand-config.*
284 %{_mandir}/man1/MagickWand-config.*
285
286 %files djvu
287 %defattr(-,root,root,-)
288 %{_libdir}/%{name}-%{version}/modules-Q16/coders/djvu.*
289
290 %files doc
291 %defattr(-,root,root,-)
292 %doc %{_datadir}/doc/%{name}-%{VERSION}
293 %doc LICENSE
294
295 %files c++
296 %defattr(-,root,root,-)
297 %doc Magick++/AUTHORS Magick++/ChangeLog Magick++/NEWS Magick++/README
298 %doc www/Magick++/COPYING
299 %{_libdir}/libMagick++.so.4*
300
301 %files c++-devel
302 %defattr(-,root,root,-)
303 %doc Magick++/examples
304 %{_bindir}/Magick++-config
305 %{_includedir}/%{name}/Magick++
306 %{_includedir}/%{name}/Magick++.h
307 %{_libdir}/libMagick++.so
308 %{_libdir}/pkgconfig/Magick++.pc
309 %{_libdir}/pkgconfig/ImageMagick++.pc
310 %{_mandir}/man1/Magick++-config.*
311
312 %files perl -f perl-pkg-files
313 %defattr(-,root,root,-)
314 %{_mandir}/man3/*
315 %doc PerlMagick/demo/ PerlMagick/Changelog PerlMagick/README.txt
316
317
318 %changelog
319 * Sun May 01 2005 Cristy <cristy@mystic.es.dupont.com> 1.0-0
320 -  Port of Redhat's RPM script to support ImageMagick.