PostgreSQL Bugs

Collected from the PG bugs email list.

Bug ID16471
PG Version12.2
OSRed Hat Enterprise Linux Server release 7.6
Opened2020-05-29 15:19:03+00
Reported byMukesh Singh
StatusNew

Body of first available message related to this bug follows.

The following bug has been logged on the website:

Bug reference:      16471
Logged by:          Mukesh Singh
Email address:      (redacted)
PostgreSQL version: 12.2
Operating system:   Red Hat Enterprise Linux Server release 7.6
Description:        

Hello Support Team,

I am unable to install  postgis30_12 because getting some so file dependency
issue. please refer the error details as below.

please help me on urgent basis.

[root@OPEPPA-UQPOSMU1 majix]# yum install postgis30_12
Loaded plugins: product-id, rhnplugin, search-disabled-repos,
subscription-manager
This system is receiving updates from RHN Classic or Red Hat Satellite.
Resolving Dependencies
--> Running transaction check
---> Package postgis30_12.x86_64 0:3.0.1-5.rhel7 will be installed
--> Processing Dependency: gdal30-libs >= 3.0.4 for package:
postgis30_12-3.0.1-5.rhel7.x86_64
--> Processing Dependency: proj70 >= 7.0.1 for package:
postgis30_12-3.0.1-5.rhel7.x86_64
--> Processing Dependency: geos38 >= 3.8.1 for package:
postgis30_12-3.0.1-5.rhel7.x86_64
--> Processing Dependency: SFCGAL for package:
postgis30_12-3.0.1-5.rhel7.x86_64
--> Processing Dependency: libprotobuf-c.so.1(LIBPROTOBUF_C_1.0.0)(64bit)
for package: postgis30_12-3.0.1-5.rhel7.x86_64
--> Processing Dependency: libproj.so.19()(64bit) for package:
postgis30_12-3.0.1-5.rhel7.x86_64
--> Processing Dependency: libgdal.so.26()(64bit) for package:
postgis30_12-3.0.1-5.rhel7.x86_64
--> Processing Dependency: libSFCGAL.so.1()(64bit) for package:
postgis30_12-3.0.1-5.rhel7.x86_64
--> Processing Dependency: libprotobuf-c.so.1()(64bit) for package:
postgis30_12-3.0.1-5.rhel7.x86_64
--> Running transaction check
---> Package SFCGAL.x86_64 0:1.3.1-1.rhel7 will be installed
--> Processing Dependency: CGAL for package: SFCGAL-1.3.1-1.rhel7.x86_64
---> Package SFCGAL-libs.x86_64 0:1.3.1-1.rhel7 will be installed
--> Processing Dependency: libboost_serialization-mt.so.1.53.0()(64bit) for
package: SFCGAL-libs-1.3.1-1.rhel7.x86_64
--> Processing Dependency: libmpfr.so.4()(64bit) for package:
SFCGAL-libs-1.3.1-1.rhel7.x86_64
--> Processing Dependency: libboost_date_time-mt.so.1.53.0()(64bit) for
package: SFCGAL-libs-1.3.1-1.rhel7.x86_64
--> Processing Dependency: libboost_thread-mt.so.1.53.0()(64bit) for
package: SFCGAL-libs-1.3.1-1.rhel7.x86_64
--> Processing Dependency: libboost_system-mt.so.1.53.0()(64bit) for
package: SFCGAL-libs-1.3.1-1.rhel7.x86_64
---> Package postgis30_12.x86_64 0:3.0.1-5.rhel7 will be installed
--> Processing Dependency: gdal30-libs >= 3.0.4 for package:
postgis30_12-3.0.1-5.rhel7.x86_64
--> Processing Dependency: proj70 >= 7.0.1 for package:
postgis30_12-3.0.1-5.rhel7.x86_64
--> Processing Dependency: geos38 >= 3.8.1 for package:
postgis30_12-3.0.1-5.rhel7.x86_64
--> Processing Dependency: libproj.so.19()(64bit) for package:
postgis30_12-3.0.1-5.rhel7.x86_64
--> Processing Dependency: libgdal.so.26()(64bit) for package:
postgis30_12-3.0.1-5.rhel7.x86_64
---> Package protobuf-c.x86_64 0:1.0.2-3.el7 will be installed
--> Running transaction check
---> Package CGAL.x86_64 0:4.7-1.rhel7.1 will be installed
--> Processing Dependency: libGLU.so.1()(64bit) for package:
CGAL-4.7-1.rhel7.1.x86_64
---> Package boost-date-time.x86_64 0:1.53.0-27.el7 will be installed
---> Package boost-serialization.x86_64 0:1.53.0-27.el7 will be installed
---> Package boost-system.x86_64 0:1.53.0-27.el7 will be installed
---> Package boost-thread.x86_64 0:1.53.0-27.el7 will be installed
---> Package mpfr.x86_64 0:3.1.1-4.el7 will be installed
---> Package postgis30_12.x86_64 0:3.0.1-5.rhel7 will be installed
--> Processing Dependency: gdal30-libs >= 3.0.4 for package:
postgis30_12-3.0.1-5.rhel7.x86_64
--> Processing Dependency: proj70 >= 7.0.1 for package:
postgis30_12-3.0.1-5.rhel7.x86_64
--> Processing Dependency: geos38 >= 3.8.1 for package:
postgis30_12-3.0.1-5.rhel7.x86_64
--> Processing Dependency: libproj.so.19()(64bit) for package:
postgis30_12-3.0.1-5.rhel7.x86_64
--> Processing Dependency: libgdal.so.26()(64bit) for package:
postgis30_12-3.0.1-5.rhel7.x86_64
--> Running transaction check
---> Package mesa-libGLU.x86_64 0:9.0.0-4.el7 will be installed
---> Package postgis30_12.x86_64 0:3.0.1-5.rhel7 will be installed
--> Processing Dependency: gdal30-libs >= 3.0.4 for package:
postgis30_12-3.0.1-5.rhel7.x86_64
--> Processing Dependency: proj70 >= 7.0.1 for package:
postgis30_12-3.0.1-5.rhel7.x86_64
--> Processing Dependency: geos38 >= 3.8.1 for package:
postgis30_12-3.0.1-5.rhel7.x86_64
--> Processing Dependency: libproj.so.19()(64bit) for package:
postgis30_12-3.0.1-5.rhel7.x86_64
--> Processing Dependency: libgdal.so.26()(64bit) for package:
postgis30_12-3.0.1-5.rhel7.x86_64
--> Finished Dependency Resolution
Error: Package: postgis30_12-3.0.1-5.rhel7.x86_64
(majix2018-7.6-serv-prd_postgresql12)
           Requires: gdal30-libs >= 3.0.4
Error: Package: postgis30_12-3.0.1-5.rhel7.x86_64
(majix2018-7.6-serv-prd_postgresql12)
           Requires: libproj.so.19()(64bit)
Error: Package: postgis30_12-3.0.1-5.rhel7.x86_64
(majix2018-7.6-serv-prd_postgresql12)
           Requires: proj70 >= 7.0.1
Error: Package: postgis30_12-3.0.1-5.rhel7.x86_64
(majix2018-7.6-serv-prd_postgresql12)
           Requires: geos38 >= 3.8.1
Error: Package: postgis30_12-3.0.1-5.rhel7.x86_64
(majix2018-7.6-serv-prd_postgresql12)
           Requires: libgdal.so.26()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Messages

DateAuthorSubject
2020-05-29 15:19:03+00PG Bug reporting formBUG #16471: Unable to install postgis30_12