PostgreSQL Bugs

Collected from the PG bugs email list.

Bug ID16455
PG Version11.8
OSRedHat/CentOS 7.8 and 7.9
Opened2020-05-21 11:39:07+00
Reported byCesar Jorge Martínez
StatusNew

Body of first available message related to this bug follows.

The following bug has been logged on the website:

Bug reference:      16455
Logged by:          Cesar Jorge Martínez
Email address:      (redacted)
PostgreSQL version: 11.8
Operating system:   RedHat/CentOS 7.8 and 7.9
Description:        

Hi,

The following fails when install python-ldap2pg:

El paquete python-ldap2pg se hace obsoleto con python3-ldap2pg, en su lugar
se está intentando instalar python3-ldap2pg-5.2-2.rhel7.x86_64
Resolviendo dependencias
--> Ejecutando prueba de transacción
---> Paquete python-ldap2pg.x86_64 0:4.18-1.rhel7 debe ser obsoleto
---> Paquete python3-ldap2pg.x86_64 0:5.2-2.rhel7 debe ser obsoleto
--> Procesando dependencias: python3-yaml para el paquete:
python3-ldap2pg-5.2-2.rhel7.x86_64
--> Procesando dependencias: python3-ldap para el paquete:
python3-ldap2pg-5.2-2.rhel7.x86_64
--> Resolución de dependencias finalizada
Error: Paquete: python3-ldap2pg-5.2-2.rhel7.x86_64 (pgdg-common)
           Necesita: python3-ldap
Error: Paquete: python3-ldap2pg-5.2-2.rhel7.x86_64 (pgdg-common)
           Necesita: python3-yaml


I think that this RPMs is for RedHat/CentOS 8.

And the RPM postgresql11-devel fails with:
Error: Paquete: postgresql11-devel-11.8-1PGDG.rhel7.x86_64 (pgdg11)
           Necesita: llvm-toolset-7-clang >= 4.0.1

This rpm llvm-toolset-7-clang if you can add to postgres repositories then
not need to install SCL toolsets. You can add this RPM?

Regards,
Cesar Jorge

Messages

DateAuthorSubject
2020-05-21 11:39:07+00PG Bug reporting formBUG #16455: Broken RPMs python-ldap2pg postgresql11-devel