PostgreSQL Bugs

Collected from the PG bugs email list.

Bug ID16442
PG Version12.3
OSwindows
Opened2020-05-15 22:32:10+00
Reported bySuresh Adapa
StatusNew

Body of first available message related to this bug follows.

The following bug has been logged on the website:

Bug reference:      16442
Logged by:          Suresh Adapa
Email address:      (redacted)
PostgreSQL version: 12.3
Operating system:   windows
Description:        

>terraform init
Initializing modules...

Initializing the backend...

Initializing provider plugins...
- Checking for available provider plugins...

No provider "postgresql" plugins meet the constraint "9.5".

The version constraint is derived from the "version" argument within the
provider "postgresql" block in configuration. Child modules may also apply
provider version constraints. To view the provider versions requested by
each
module in the current configuration, run "terraform providers".

To proceed, the version constraints for this provider must be relaxed by
either adjusting or removing the "version" argument in the provider blocks
throughout the configuration.


Error: no suitable version is available

------
Wondering what is the version that i need to use?
>terraform -v
Terraform v0.12.25
+ provider.aws v2.19.0
+ provider.template v2.1.2

Messages

DateAuthorSubject
2020-05-15 22:32:10+00PG Bug reporting formBUG #16442: terraform provider postgresql 9.0.0/9.4/12.3/current/latest fail
2020-05-16 02:17:33+00"David G(dot) Johnston"Re: BUG #16442: terraform provider postgresql 9.0.0/9.4/12.3/current/latest fail