PostgreSQL Bugs

Collected from the PG bugs email list.

Bug ID16416
PG Version12.2
OSMac os
Opened2020-05-05 06:28:13+00
Reported byRadhakrishnan Rajendran
StatusNew

Body of first available message related to this bug follows.

The following bug has been logged on the website:

Bug reference:      16416
Logged by:          Radhakrishnan Rajendran
Email address:      (redacted)
PostgreSQL version: 12.2
Operating system:   Mac os
Description:        

I am unable to start the Postgres server and whenever I use pg_ctl I am
getting the following error - can some one help me to fix this. I changed
the folder permissions using CHmod and tried running with Sudo -s also but
still the problem exists.

one error I did was, I deleted the Postmaster.pid when the server was
running- post this I am getting this issue when ever I try to start the
server through pg_ctl and another error when I use the pgadmin.

Any suggestions here will be really helpful- thanks.

Using Macos Shell command :

pg_ctl start -D /Library/PostgreSQL/12/data waiting for server to
start....2020-05-05 11:40:04.838 IST [1216] FATAL: data directory
"/Library/PostgreSQL/12/data" has wrong ownership 2020-05-05 11:40:04.838
IST [1216] HINT: The server must be started by the user that owns the data
directory. stopped waiting pg_ctl: could not start server Examine the log
output.

Using pgadmin the error is as follows :

could not connect to server: Connection refused Is the server running on
host "localhost" (::1) and accepting TCP/IP connections on port 5434? could
not connect to server: Connection refused Is the server running on host
"localhost" (127.0.0.1) and accepting TCP/IP connections on port 5434? 

p.s. : I modified the hba.conf and also the postgres.conf files to allow
connection from the local ip

Messages

DateAuthorSubject
2020-05-05 06:28:13+00PG Bug reporting formBUG #16416: unable to start the server with pg_CTL
2020-05-05 08:37:50+00Daniel GustafssonRe: BUG #16416: unable to start the server with pg_CTL
2020-05-06 07:45:00+00Sandeep ThakkarRe: BUG #16416: unable to start the server with pg_CTL