PostgreSQL Bugs

Collected from the PG bugs email list.

Bug ID16394
PG Version11.7
OSRedHat/CentOS 7.7
Opened2020-04-27 10:11:52+00
Reported byCesar Jorge Martínez
StatusNew

Body of first available message related to this bug follows.

The following bug has been logged on the website:

Bug reference:      16394
Logged by:          Cesar Jorge Martínez
Email address:      (redacted)
PostgreSQL version: 11.7
Operating system:   RedHat/CentOS 7.7
Description:        

Hi,

I have conflicting versions in PostgreSQL 11.7 (I don't known other
PostgreSQL versions).

Then, when we update this packages:
yum update postgis30_11 (or postgis25_11)
yum update osm2pgrouting_11
yum update pgrouting_11

Then:
The last package pgrouting_11 requires postgis30_11
The last package  osm2pgrouting_11 requires postgis25_11

Then fails with:
Transaction check error:
  file /usr/pgsql-11/lib/postgis-2.5.so conflicts between attempted installs
of postgis25_11-2.5.4-1.rhel7.x86_64 and postgis30_11-3.0.1-4.rhel7.x86_64
  file /usr/pgsql-11/lib/postgis_topology-2.5.so conflicts between attempted
installs of postgis25_11-2.5.4-1.rhel7.x86_64 and
postgis30_11-3.0.1-4.rhel7.x86_64

Etc.

How to fix this conflicting packages?

Regards,
Cesar Jorge

Messages

DateAuthorSubject
2020-04-27 10:11:52+00PG Bug reporting formBUG #16394: Conflicting package postgis versions 2.5 and 3.0