PostgreSQL Bugs

Collected from the PG bugs email list.

Bug ID16250
PG Version10.5
OSMac
Opened2020-02-07 21:36:50+00
Reported byRandy Strauss
StatusNew

Body of first available message related to this bug follows.

The following bug has been logged on the website:

Bug reference:      16250
Logged by:          Randy Strauss
Email address:      (redacted)
PostgreSQL version: 10.5
Operating system:   Mac
Description:        

The documentation looks identical for 10.5 and 12 with respect to
extensions.

There's no point being able to create a database if one can't add the
extensions one needs.
We need postgis,  postgis_topology,  uuid-ossp,  hstore
How about adding a privilege to control this, instead of forcing the
superuser password to be given out?

I don't know if this is a bug. I don't see it on the FAQ or TODO list...
I don't see a "requires superuser" field in the pg_extension table...

Messages

DateAuthorSubject
2020-02-07 21:36:50+00PG Bug reporting formBUG #16250: As the owner of a database, I can't CREATE EXTENSION postgis;
2020-02-07 22:00:51+00Tom LaneRe: BUG #16250: As the owner of a database, I can't CREATE EXTENSION postgis;