PostgreSQL Bugs

Collected from the PG bugs email list.

Bug ID16225
PG Version11.6
OSOracle Linux 8
Opened2020-01-22 06:49:43+00
Reported byAndrew Roffey
StatusNew

Body of first available message related to this bug follows.

The following bug has been logged on the website:

Bug reference:      16225
Logged by:          Andrew Roffey
Email address:      (redacted)
PostgreSQL version: 11.6
Operating system:   Oracle Linux 8
Description:        

Hello

I noticed that the postgresql10/postgresql11 (etc.) packages were not
showing up on an Oracle Linux 8 installation. On closer inspection I found
that they were not being shown due to conflicting packages in the
ol8_appstream repository (I suspect it is the same for CentOS 8 and RHEL
8).

To reproduce:

$ yum config-manager --enable ol8_appstream && yum info postgresql
postgresql11
-> Shows the PostgreSQL 10.6 packages only from appstream despite PGDG
repository being enabled

$ yum config-manager --disable ol8_appstream && yum info postgresql
postgresql11
-> Shows the PostgreSQL 11 package from the PGDG repository

Expected behaviour would to be able to install postgresql (system-provided
version), postgresql10 and postgresql11, or at  least to use the Appstream
and PostgreSQL repos at the same time

I suspect the "provides" list may be the cause of this:

$ rpm -q --provides postgresql11-11.6-2PGDG.rhel8.x86_64.rpm 2>/dev/null
postgresql >= 11.6-2PGDG.rhel8
postgresql11 = 11.6-2PGDG.rhel8
postgresql11(x86-64) = 11.6-2PGDG.rhel8

For comparison, the python3 package "provides" list in EL7:

$ rpm -q --provides python3-3.6.8-10.0.1.el7.x86_64.rpm 2>/dev/null
python(abi) = 3.6
python(abi) = 3.6
python3 = 3.6.8-10.0.1.el7
python3(x86-64) = 3.6.8-10.0.1.el7
python36 = 3.6.8-10.0.1.el7
python36(x86-64) = 3.6.8-10.0.1.el7

The following packages are unavailable when the appstream repository is
enabled:
postgresql11
postgresql11-contrib
postgresql11-docs
postgresql11-plperl
postgresql11-plpython3
postgresql11-pltcl
postgresql11-server
postgresql11-test
(and so on for postgresql10, ...)

These are the conflicting packages in appstream:
postgresql
postgresql-contrib
postgresql-docs
postgresql-plperl
postgresql-plpython3
postgresql-pltcl
postgresql-server
postgresql-test

Messages

DateAuthorSubject
2020-01-22 06:49:43+00PG Bug reporting formBUG #16225: EL8 - PGDG postgresql* packages conflict with appstream postgresql packages
2020-01-23 21:53:35+00Andrew RoffeyRe: BUG #16225: EL8 - PGDG postgresql* packages conflict with appstream postgresql packages
2020-01-24 09:05:20+00Magnus HaganderRe: BUG #16225: EL8 - PGDG postgresql* packages conflict with appstream postgresql packages