PostgreSQL Bugs

Collected from the PG bugs email list.

Bug ID16198
PG Version9.4.25
OSCentos 7.7.1908
Opened2020-01-08 14:15:09+00
Reported byDavid McKelvie
StatusNew

Body of first available message related to this bug follows.

The following bug has been logged on the website:

Bug reference:      16198
Logged by:          David McKelvie
Email address:      (redacted)
PostgreSQL version: 9.4.25
Operating system:   Centos 7.7.1908
Description:        

We have a Centos7 server (a) that has the following rpms installed

ogdi.x86_64                           3.2.0-4.rhel7                   
@pgdg94  
ogdi41.x86_64                         4.1.0-2.rhel7                   
@pgdg94

postgis24_94.x86_64                   2.4.8-3.rhel7                   
@pgdg94  
postgis24_94-utils.x86_64             2.4.8-3.rhel7                   
@pgdg94

postgresql94.x86_64                   9.4.25-1PGDG.rhel7              
@pgdg94  
postgresql94-contrib.x86_64           9.4.25-1PGDG.rhel7              
@pgdg94  
postgresql94-devel.x86_64             9.4.25-1PGDG.rhel7              
@pgdg94  
postgresql94-libs.x86_64              9.4.25-1PGDG.rhel7              
@pgdg94  
postgresql94-server.x86_64            9.4.25-1PGDG.rhel7              
@pgdg94

and 'CREATE EXTENSION postgis;' works

We are trying to set up a similar server (b) but this time

It looks as if Postgresql have removed ogdi-3.2.0-4.rhel7 from their RPM
repository.

   yum list available | grep ogdi
   ogdi-devel.x86_64                         3.2.0-0.19.beta2.el7          
epel   
   ogdi-odbc.x86_64                          3.2.0-0.19.beta2.el7          
epel   
   ogdi-tcl.x86_64                           3.2.0-0.19.beta2.el7          
epel   
   ogdi41-debuginfo.x86_64                   4.1.0-2.rhel7                 
pgdg94 
   ogdi41-devel.x86_64                       4.1.0-2.rhel7                 
pgdg94 
   ogdi41-odbc.x86_64                        4.1.0-2.rhel7                 
pgdg94 
   ogdi41-tcl.x86_64                         4.1.0-2.rhel7                 
pgdg94 

As a result, yum was fetching ogdi.x86_64 0:3.2.0-0.19.beta2.el7
from epel, and THIS DOES NOT WORK

i.e. in psql
drain_walsall=# create extension postgis;
ERROR:  could not load library "/usr/pgsql-9.4/lib/rtpostgis-2.4.so": \
        /usr/gdal23/lib/libgdal.so.20: \
        undefined symbol: ecs_SetReportErrorFunction

Our work around was to get ogdi-3.2.0-4.rhel7.x86_64.rpm
from postgres/9.6/redhat/rhel-7-x86_64 repo

What would the right way to do this?

Messages

DateAuthorSubject
2020-01-08 14:15:09+00PG Bug reporting formBUG #16198: Create extension postgis fails with incorrect version of ogdi