PostgreSQL Bugs

Collected from the PG bugs email list.

Bug ID16064
PG Version10.10
OSUbuntu 18.04
Opened2019-10-17 17:58:50+00
Reported byYudhveer Kandukuri
StatusNew

Body of first available message related to this bug follows.

The following bug has been logged on the website:

Bug reference:      16064
Logged by:          Yudhveer Kandukuri
Email address:      (redacted)
PostgreSQL version: 10.10
Operating system:   Ubuntu 18.04
Description:        

Can any one please guide me what is the issue with my ldap authentication on
Postgresql 10.10. Here is the Entry for ldap in pg_hba.conf file

host      all           all           XX.XX.XXX.XX/32         ldap 
ldapserver=XX.XX.XXX.XX ldapbasedn="ou=People,dc=internal,dc=com"
ldapbinddn="cn=Tom,ou=People,dc=internal,dc=com" ldapbindpasswd="Test123#"
ldapport=389

I created the same user "Tom" in the Postgres database too . Also created
the User "Tom" other user "svc-ldap" in active directory too.

When I am trying to connect to PostgreSQL server from other remote server,
the authentication is failing with 

psql: FATAL:  no pg_hba.conf entry for host "XXX.XX.XXX.XXX", user "Tom",
database "Tom", SSL off

Messages

DateAuthorSubject
2019-10-17 17:58:50+00PG Bug reporting formBUG #16064: Ldap Authentication failing with pg_hba.conf entry
2019-10-17 21:54:43+00Stephen FrostRe: BUG #16064: Ldap Authentication failing with pg_hba.conf entry
2019-10-17 23:16:32+00Jeff JanesRe: BUG #16064: Ldap Authentication failing with pg_hba.conf entry
2019-10-18 00:34:05+00Yudhveer KandukuriRe: BUG #16064: Ldap Authentication failing with pg_hba.conf entry