PostgreSQL Bugs

Collected from the PG bugs email list.

Bug ID16049
PG Version9.5.19
OSDebian 11
Opened2019-10-11 14:12:49+00
Reported bydeath lock
StatusNew

Body of first available message related to this bug follows.

The following bug has been logged on the website:

Bug reference:      16049
Logged by:          death lock
Email address:      (redacted)
PostgreSQL version: 9.5.19
Operating system:   Debian 11
Description:        

[unknown] LOCATION:  BackendRun, postmaster.c:4300
[unknown] DEBUG:  00000: InitPostgres
[unknown] LOCATION:  InitPostgres, postinit.c:555
[unknown] DEBUG:  00000: my backend ID is 4
[unknown] LOCATION:  SharedInvalBackendInit, sinvaladt.c:324
[unknown] DEBUG:  00000: StartTransaction
[unknown] LOCATION:  ShowTransactionState, xact.c:4975
[unknown] DEBUG:  00000: name: unnamed; blockState:       DEFAULT; state:
INPROGR, xid/subid/cid: 0/1/0, nestlvl: 1, children:
[unknown] LOCATION:  ShowTransactionStateRec, xact.c:5004

# log_connections - application_name MIA
[unknown] LOG:  00000: connection authorized: user=postgres
database=postgres

[unknown] LOCATION:  PerformAuthentication, postinit.c:257
psql DEBUG:  00000: CommitTransaction
psql LOCATION:  ShowTransactionState, xact.c:4975
psql DEBUG:  00000: name: unnamed; blockState:       STARTED; state:
INPROGR, xid/subid/cid: 0/1/0, nestlvl: 1, children:
...
psql DEBUG:  00000: proc_exit(0): 4 callbacks to make
psql LOCATION:  proc_exit_prepare, ipc.c:187

# log_disconnections=on
psql LOG:  00000: disconnection: session time: 0:00:10.280 user=postgres
database=postgres host=[local]

Messages

DateAuthorSubject
2019-10-11 14:12:49+00PG Bug reporting formBUG #16049: log_line_prefix=%a and log_connections - application_name missing
2019-10-11 14:36:54+00Tom LaneRe: BUG #16049: log_line_prefix=%a and log_connections - application_name missing
2019-10-15 12:34:40+00death lockRe: BUG #16049: log_line_prefix=%a and log_connections - application_name missing
2019-10-16 11:42:20+00death lockRe: BUG #16049: log_line_prefix=%a and log_connections - application_name missing
2019-10-17 05:40:57+00Michael PaquierRe: BUG #16049: log_line_prefix=%a and log_connections - application_name missing