PostgreSQL Bugs

Collected from the PG bugs email list.

Bug ID15980
PG Version11.5
OSWindows 10
Opened2019-08-26 23:50:17+00
Reported byEugene Podshivalov
StatusNew

Body of first available message related to this bug follows.

The following bug has been logged on the website:

Bug reference:      15980
Logged by:          Eugene Podshivalov
Email address:      (redacted)
PostgreSQL version: 11.5
Operating system:   Windows 10
Description:        

This bug has already been reported: BUG #15945: error while installing
I just want to provide additional info.

I faced this error when trying to install v11.5 into an existing v11.2 data
directory.
Installing into the default clean directory works fine.

The bitrock installer log says (my existing data directory locale is
Russian_Russia.1251):
I don't know if it matters but pay attention to the last backslash in paths.
Isn't it supposed to be a normal slash?
------------------------
Executing icacls
"C:\Users\Yaugenka\AppData\Local\Temp/postgresql_installer_f12a0bc313"
/inheritance:r
Script exit code: 0

Script output:
 ®Ўа Ў®в ­­л© д ©«:
C:\Users\Yaugenka\AppData\Local\Temp/postgresql_installer_f12a0bc313
“бЇҐи­® ®Ўа Ў®в ­® 1 д ©«®ў; ­Ґ г¤ «®бм ®Ўа Ў®в вм 0 д ©«®ў

Script stderr:
 
Executing icacls
"C:\Users\Yaugenka\AppData\Local\Temp/postgresql_installer_f12a0bc313" /T /Q
/grant "Yaugenka:(OI)(CI)F"
Script exit code: 0

Script output:
 “бЇҐи­® ®Ўа Ў®в ­® 1 д ©«®ў; ­Ґ г¤ «®бм ®Ўа Ў®в вм 0 д ©«®ў

Script stderr:

Executing cscript //NoLogo
"C:\Users\Yaugenka\AppData\Local\Temp\postgresql_installer_f12a0bc313\prerun_checks.vbs"
Script exit code: 0

Script output:
 The scripting host appears to be functional.
------------------------

Messages

DateAuthorSubject
2019-08-26 23:50:17+00PG Bug reporting formBUG #15980: Installation fails with executing icacls error