PostgreSQL Bugs

Collected from the PG bugs email list.

Bug ID15711
PG Version11.2
OSRHEL 7.6
Opened2019-03-21 21:34:30+00
Reported byMichael O'Brien
StatusNew

Body of first available message related to this bug follows.

The following bug has been logged on the website:

Bug reference:      15711
Logged by:          Michael O'Brien
Email address:      (redacted)
PostgreSQL version: 11.2
Operating system:   RHEL 7.6
Description:        

downloaded the rhel7 repo rpm ok:

wget
https://download.postgresql.org/pub/repos/yum/11/redhat/rhel-7-x86_64/pgdg-redhat11-11-2.noarch.rpm
--2019-03-21 11:00:52-- 
https://download.postgresql.org/pub/repos/yum/11/redhat/rhel-7-x86_64/pgdg-redhat11-11-2.noarch.rpm
Resolving download.postgresql.org (download.postgresql.org)...
217.196.149.55, 204.145.124.244, 72.32.157.246, ...
Connecting to download.postgresql.org
(download.postgresql.org)|217.196.149.55|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 4896 (4.8K) [application/x-redhat-package-manager]
Saving to: ‘pgdg-redhat11-11-2.noarch.rpm’

100%[=======================================================>] 4,896      
--.-K/s   in 0s      

2019-03-21 11:00:53 (76.4 MB/s) - ‘pgdg-redhat11-11-2.noarch.rpm’ saved
[4896/4896]

2. Installed the repo ok:

yum install pgdg-redhat11-11-2.noarch.rpm
Loaded plugins: langpacks, product-id, search-disabled-repos,
subscription-manager
Examining pgdg-redhat11-11-2.noarch.rpm: pgdg-redhat11-11-2.noarch
Marking pgdg-redhat11-11-2.noarch.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package pgdg-redhat11.noarch 0:11-2 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=================================================================================================
 Package                Arch            Version        Repository           
               Size
=================================================================================================
Installing:
 pgdg-redhat11          noarch          11-2          
/pgdg-redhat11-11-2.noarch          2.7 k

Transaction Summary
=================================================================================================
Install  1 Package

Total size: 2.7 k
Installed size: 2.7 k
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : pgdg-redhat11-11-2.noarch                                    
                1/1 
  Verifying  : pgdg-redhat11-11-2.noarch                                    
                1/1 

Installed:
  pgdg-redhat11.noarch 0:11-2                                               
                    

3. installed postgresql11-server ok :  ver 11.2-2PGDG.rhel7 no details
provided here

4. pgadmin4 install fails (missing python-blinker and python-flask - have
not been able to find them on the web):

yum install pgadmin4.x86_64
Loaded plugins: langpacks, product-id, search-disabled-repos,
subscription-manager
Resolving Dependencies
--> Running transaction check
---> Package pgadmin4.x86_64 0:4.3-1.rhel7 will be installed
--> Processing Dependency: pgadmin4-web for package:
pgadmin4-4.3-1.rhel7.x86_64
--> Running transaction check
---> Package pgadmin4-web.noarch 0:4.3-1.rhel7 will be installed
--> Processing Dependency: python-speaklater >= 1.3 for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: python-psycopg2 >= 2.7.4 for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: python-crypto >= 2.6.1 for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-pytz >= 2018.3 for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-wtforms >= 2.0.2 for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-werkzeug >= 0.9.6 for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-sshtunnel >= 0.1.3 for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-sqlparse >= 0.2.4 for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-sqlalchemy >= 1.2.5 for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-simplejson >= 3.13.2 for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-passlib >= 1.7.1 for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-markupsafe >= 0.23 for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-jinja2 >= 2.7.3 for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-itsdangerous >= 0.24 for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-flask-wtf >= 0.12 for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-flask-sqlalchemy >= 2.1 for
package: pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-flask-security >= 3.0.0 for
package: pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-flask-principal >= 0.4.0 for
package: pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-flask-paranoid >= 0.1 for
package: pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-flask-migrate >= 2.1.1 for
package: pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-flask-login >= 0.3.2 for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-flask-htmlmin >= 1.2 for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-flask-gravatar >= 0.5.0 for
package: pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-flask-babel >= 0.11.1 for
package: pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-flask >= 0.12.4 for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-dateutil >= 2.7.2 for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-blinker >= 1.3 for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-beautifulsoup4 >= 4.4.1 for
package: pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-backports.csv >= 1.0.5 for
package: pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-babel >= 2.3.4 for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-Flask-Mail >= 0.9.1 for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: python2-psutil for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: python-click for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-flask-babelex for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-python-alembic for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: pgadmin4-docs for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: mod_wsgi for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Processing Dependency: httpd for package:
pgadmin4-web-4.3-1.rhel7.noarch
--> Running transaction check
---> Package httpd.x86_64 0:2.4.6-88.el7 will be installed
--> Processing Dependency: httpd-tools = 2.4.6-88.el7 for package:
httpd-2.4.6-88.el7.x86_64
---> Package mod_wsgi.x86_64 0:3.4-18.el7 will be installed
---> Package pgadmin4-docs.noarch 0:4.3-1.rhel7 will be installed
---> Package pgadmin4-python-Flask-Mail.noarch 0:0.9.1-4.rhel7.1 will be
installed
---> Package pgadmin4-python-alembic.noarch 0:0.9.7-3.rhel7.1 will be
installed
--> Processing Dependency: python-editor for package:
pgadmin4-python-alembic-0.9.7-3.rhel7.1.noarch
---> Package pgadmin4-python-babel.noarch 0:2.3.4-2.rhel7.1 will be
installed
---> Package pgadmin4-python-backports.csv.noarch 1:1.0.5-3.rhel7.1 will be
installed
---> Package pgadmin4-python-beautifulsoup4.noarch 0:4.5.1-3.rhel7.1 will be
installed
---> Package pgadmin4-python-blinker.noarch 0:1.4-3.rhel7.1 will be
installed
---> Package pgadmin4-python-dateutil.noarch 1:2.7.2-1.rhel7.1 will be
installed
---> Package pgadmin4-python-flask.noarch 1:0.12.4-1.rhel7 will be
installed
---> Package pgadmin4-python-flask-babel.noarch 0:0.11.1-4.rhel7.1 will be
installed
---> Package pgadmin4-python-flask-babelex.noarch 0:0.9.3-1.rhel7.1 will be
installed
---> Package pgadmin4-python-flask-gravatar.noarch 0:0.5.0-1.rhel7.1 will be
installed
---> Package pgadmin4-python-flask-htmlmin.noarch 0:1.3.2-1.rhel7.1 will be
installed
--> Processing Dependency: pgadmin4-python-htmlmin for package:
pgadmin4-python-flask-htmlmin-1.3.2-1.rhel7.1.noarch
---> Package pgadmin4-python-flask-login.noarch 0:0.3.2-3.rhel7.1 will be
installed
---> Package pgadmin4-python-flask-migrate.noarch 0:2.1.1-1.rhel7.1 will be
installed
---> Package pgadmin4-python-flask-paranoid.noarch 0:0.2-1.rhel7.1 will be
installed
---> Package pgadmin4-python-flask-principal.noarch 0:0.4.0-14.rhel7.1 will
be installed
--> Processing Dependency: python-flask for package:
pgadmin4-python-flask-principal-0.4.0-14.rhel7.1.noarch
--> Processing Dependency: python-blinker for package:
pgadmin4-python-flask-principal-0.4.0-14.rhel7.1.noarch
---> Package pgadmin4-python-flask-security.noarch 0:3.0.0-1.rhel7.1 will be
installed
---> Package pgadmin4-python-flask-sqlalchemy.noarch 0:2.3.2-1.rhel7 will be
installed
---> Package pgadmin4-python-flask-wtf.noarch 0:0.14.2-1.rhel7 will be
installed
---> Package pgadmin4-python-itsdangerous.noarch 0:0.24-10.rhel7.1 will be
installed
---> Package pgadmin4-python-jinja2.noarch 0:2.8-9.rhel7.1 will be
installed
--> Processing Dependency: python-babel >= 0.8 for package:
pgadmin4-python-jinja2-2.8-9.rhel7.1.noarch
---> Package pgadmin4-python-markupsafe.x86_64 0:0.23-13.rhel7.1 will be
installed
---> Package pgadmin4-python-passlib.noarch 0:1.7.1-1.rhel7.1 will be
installed
---> Package pgadmin4-python-simplejson.x86_64 0:3.13.2-1.rhel7.1 will be
installed
---> Package pgadmin4-python-sqlalchemy.x86_64 0:1.2.5-1.rhel7.1 will be
installed
---> Package pgadmin4-python-sqlparse.noarch 0:0.2.4-1.rhel7.1 will be
installed
---> Package pgadmin4-python-sshtunnel.noarch 0:0.1.3-1.rhel7.1 will be
installed
--> Processing Dependency: python-paramiko for package:
pgadmin4-python-sshtunnel-0.1.3-1.rhel7.1.noarch
---> Package pgadmin4-python-werkzeug.noarch 0:0.11.11-4.rhel7.1 will be
installed
---> Package pgadmin4-python-wtforms.noarch 0:2.1-3.rhel7.1 will be
installed
---> Package pgadmin4-pytz.noarch 0:2018.3-1.rhel7.1 will be installed
---> Package python-psycopg2.x86_64 0:2.7.5-1.rhel7.1 will be installed
---> Package python-speaklater.noarch 0:1.3-1.el7 will be installed
---> Package python2-click.noarch 0:6.7-7.el7 will be installed
---> Package python2-crypto.x86_64 0:2.6.1-13.el7 will be installed
---> Package python2-psutil.x86_64 0:2.2.1-4.el7 will be installed
--> Running transaction check
---> Package httpd-tools.x86_64 0:2.4.6-88.el7 will be installed
---> Package pgadmin4-python-flask-principal.noarch 0:0.4.0-14.rhel7.1 will
be installed
--> Processing Dependency: python-flask for package:
pgadmin4-python-flask-principal-0.4.0-14.rhel7.1.noarch
--> Processing Dependency: python-blinker for package:
pgadmin4-python-flask-principal-0.4.0-14.rhel7.1.noarch
---> Package pgadmin4-python-htmlmin.noarch 0:0.1.12-1.rhel7.1 will be
installed
---> Package python-babel.noarch 0:0.9.6-8.el7 will be installed
---> Package python-editor.noarch 0:0.4-4.el7 will be installed
---> Package python-paramiko.noarch 0:2.1.1-9.el7 will be installed
--> Finished Dependency Resolution
Error: Package: pgadmin4-python-flask-principal-0.4.0-14.rhel7.1.noarch
(pgdg11)
           Requires: python-blinker
Error: Package: pgadmin4-python-flask-principal-0.4.0-14.rhel7.1.noarch
(pgdg11)
           Requires: python-flask
**********************************************************************
Dependency resolving failed due to missing dependencies.
Some repositories on your system are disabled, but yum can enable them
and search for missing dependencies. This will require downloading
metadata for disabled repositories and may take some time and traffic.
**********************************************************************

Enable all repositories and try again? [y/N]: n
Error: Package: pgadmin4-python-flask-principal-0.4.0-14.rhel7.1.noarch
(pgdg11)
           Requires: python-blinker
Error: Package: pgadmin4-python-flask-principal-0.4.0-14.rhel7.1.noarch
(pgdg11)
           Requires: python-flask
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Messages

DateAuthorSubject
2019-03-21 21:34:30+00PG Bug reporting formBUG #15711: pgadmin install fails with missing python-blinker and python-flast packages