PostgreSQL Bugs

Collected from the PG bugs email list.

Bug ID15529
PG Version11.0
OSLinux
Opened2018-11-30 10:17:35+00
Reported bywang yakun
StatusOpen

Body of first available message related to this bug follows.

The following bug has been logged on the website:

Bug reference:      15529
Logged by:          wang yakun
Email address:      (redacted)
PostgreSQL version: 11.0
Operating system:   Linux
Description:        

you wrote:

interval: 
Low Value: -178000000 years
High Value: 178000000 years

in 'Table 8.9. Date/Time Types' in postgresql 11 documention.
However, I can execute this sql:

postgres=# select interval '178000001' year;
    interval
-----------------
 178000001 years
(1 row)

In other words, max value is not 178000000.
****************************************************
I test the exact value is 178956970:

postgres=# select interval '178956970' year;
    interval
-----------------
 178956970 years
(1 row)

postgres=# select interval '178956971' year;
ERROR:  interval out of range
LINE 1: select interval '178956971' year;
                        ^
So, you should wrote 178956970 in postgresql 11 documention.

Messages

DateAuthorSubject
2018-11-30 10:17:35+00=?utf-8?q?PG_Bug_reporting_form?=BUG #15529: interval max value '178000000 years' in doc is not exact. It should 178956970.